Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2072 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Problème de config noyau ?? Kernel panic [Résolu]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de config noyau ?? Kernel panic [Résolu]

n°1074511
trouble_fe​te
Posté le 16-09-2008 à 13:06:16  profilanswer
 

Hello, je viens de réussir (enfin) a installer Gentoo sur mon vieux portable pentium mmx, 32Mo de ram.
Problème, le noyau ne boot pas il me fait un Kernel panic:

Citation :


VFS: Cannot open root device "304" or unknow block(3,4)
Please append a correct "root=" boot option: here are the available partition:
0800     2116800 sda driver:sd
 
    0801         20160      sda1
    0802         254016    sda2
    0803         16096      sda3
    0804         1826496   sda4
0b00          1048575 sr0 driver: sr
Kernel panic - not sincyng:  VFS: Unable to mount root fs on unknow-block(3,4)


 
Et là il y a un autre soucis pour moi, c'est quoi ces partitions sda que le noyau m'indique ?? en plus il semble bien que les tailles annoncées correspondent totalement avec celles du disque dur...mais le livecd détecte le disque comme hd et non sd, ce qui fait que je dois faire le bootloader sur la base de hd je n'ai pas le choix, et donc le fstab qui va avec également...
 
croyez vous que le stage 3 de la 2008.0 détecte les disques différemment du livecd 2907.0 ?? (oui je suis obligé celui de la 2007, vu que celui de la 2008 ne peut booter sur mon portable !)
 
Edit: je me souviens avoir déjà eu le coup du disque dur détecté en sata avec un livecd Gentoo, et en hda avec le stage 3 d'une année différente que j'installais...mais là ce n'est pas tout a fait pareil: il ne peut y avoir de disque dur sata...
 
Je crois que je vais etre contraint de tout réinstaller, mais avec le stage 3 de la Gentoo 2007, vu que le livecd 2007.0, là au moins ce serait cohérent, les 2 détecteront le disque de la même façon...(en l'occurence hda tout les 2...)


Message édité par trouble_fete le 18-09-2008 à 14:41:10

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
mood
Publicité
Posté le 16-09-2008 à 13:06:16  profilanswer
 

n°1074514
Fork Bomb
Obsédé textuel
Posté le 16-09-2008 à 13:19:41  profilanswer
 

hdXY / sdXY, c'est dépendant de la version du noyau.
Depuis telle version, on est passés de la libATA à la libSATA (de tête).
Enfin, je crois que c'est ça...


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1074515
trouble_fe​te
Posté le 16-09-2008 à 13:22:34  profilanswer
 

Fork Bomb a écrit :

hdXY / sdXY, c'est dépendant de la version du noyau.
Depuis telle version, on est passés de la libATA à la libSATA (de tête).
Enfin, je crois que c'est ça...


 
Oui mais alors pourquoi sur mon PC de bureau, mon disque dur sata certe est bien en /dev/sda; par contre mon graveur IDE est bien en /dev/hda lui ?? et j'ai le dernier noyau sur le pc de bureau.
Jcomprends plus rien  :??:


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074517
trouble_fe​te
Posté le 16-09-2008 à 13:26:46  profilanswer
 

Je veux faire booter mon portable help me :'(


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074524
wedgeant
Da penguin inside
Posté le 16-09-2008 à 13:36:39  profilanswer
 

t'as quoi comme option "root=" dans la ligne de grub ? [:noxauror]


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°1074526
trouble_fe​te
Posté le 16-09-2008 à 13:39:21  profilanswer
 

C'est lilo et j'ai mis hda :??:
 
(hda4 pour être précis)


Message édité par trouble_fete le 16-09-2008 à 13:40:21

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074532
trouble_fe​te
Posté le 16-09-2008 à 13:43:01  profilanswer
 

Par contre c'est vrai que je suis pas 100% sur de moi pour la configuration du noyau, c'est un vieux portable et pour le IDE j'ai été obligé de prendre le PCI IDE generic, y a pas de pilote officiel pour mon controleur IDE...


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074533
wedgeant
Da penguin inside
Posté le 16-09-2008 à 13:44:04  profilanswer
 

essaye de remplacer par sda4 [:mrbrelle]


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°1074534
trouble_fe​te
Posté le 16-09-2008 à 13:46:17  profilanswer
 

wedgeant a écrit :

essaye de remplacer par sda4 [:mrbrelle]


 
Ben je peux pas, vu que le livecd détecte en hda, si je mets une partition qui n'existe pas, lilo ne modifie pas le MBR, il affiche juste un message d'erreur...


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074537
trouble_fe​te
Posté le 16-09-2008 à 13:48:07  profilanswer
 

Jcrois que la seule solution est de tout réinstaller :(


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
mood
Publicité
Posté le 16-09-2008 à 13:48:07  profilanswer
 

n°1074538
wedgeant
Da penguin inside
Posté le 16-09-2008 à 13:49:27  profilanswer
 

trouble_fete a écrit :

Ben je peux pas, vu que le livecd détecte en hda, si je mets une partition qui n'existe pas, lilo ne modifie pas le MBR, il affiche juste un message d'erreur...


quand tu boot sur le livecd, tu peux passer des paramètres au début ... essayes d'appuyer sur F1/F2/F3/F... et de voir ce que tu peux faire pour forcer en SCSI :jap:
 
Sinon, ben installe grub à la place de lilo :o


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°1074553
trouble_fe​te
Posté le 16-09-2008 à 14:06:39  profilanswer
 

wedgeant a écrit :


quand tu boot sur le livecd, tu peux passer des paramètres au début ... essayes d'appuyer sur F1/F2/F3/F... et de voir ce que tu peux faire pour forcer en SCSI :jap:
 
Sinon, ben installe grub à la place de lilo :o


 
 
Ok je vais essayer ça, et sache que je n'ai rien contrue grub, je suis juste habitué a lilo, mais si grub peut me permettre de pas tout réinstaller j'en serais enchanté ^^ c'est qu'un bootloader...
 
Sinon il semble que le disque dur de ce portable soit bien un IDE:
 
http://www.bestofmicro.com/p/compa [...] d/S0005270
 
Encore merci !!


Message édité par trouble_fete le 16-09-2008 à 14:07:03

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074556
trouble_fe​te
Posté le 16-09-2008 à 14:13:00  profilanswer
 

Au fait j'ai 2 cartes PCMCIA dans le portable mais je sais pas du tout a quoi elles servent, ni si elles servent d'ailleurs :??:


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074558
trouble_fe​te
Posté le 16-09-2008 à 14:18:00  profilanswer
 

Bon...ça m'ennerve je réinstalle tout :o et je garde lilo, car en fait comme ça je peux garder les fichiers distfiles de lilo, eh oui j'ai pas de reseau sur le portable..(y a même pas de port Ethernet...et un seul port USB qui me sert pr la clé pr transférer les fichiers...)
 
Oui je sais installer Gentoo ss réseau ça va etre folklo mais rassure toi j'ai une astuce: d/l de tout les fichiers grace a portage avec mon pc principal sur la clé usb et je transfère tout ds les distfiles du portable...
 
 
Bref je reprends tout a zero avec cette fois le stage 3 de la Gentoo 2007, pour bien aller avec livecd 2007 niveau détection de disque :o


Message édité par trouble_fete le 16-09-2008 à 14:20:20

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074562
wedgeant
Da penguin inside
Posté le 16-09-2008 à 14:26:35  profilanswer
 

[:cerveau dawa psycho]
 
et tu veux pas essayer une distrib autre que gentoo des fois ? [:noxauror]


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°1074564
trouble_fe​te
Posté le 16-09-2008 à 14:28:22  profilanswer
 

Ben j'ai trouvé que 2 livecd qui acceptent de booter sur ce vieux portable, a cause des 32Mo de ram, l'autre c'est DSL mais DSL me dit pas trop :??:


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074565
wedgeant
Da penguin inside
Posté le 16-09-2008 à 14:29:46  profilanswer
 

DSL c'est bien pour un vieux laptop, petite distrib légère et rapide, y'a juste quelques bidouilles pour franciser le tout mais je pense que ça sera bien mieux adapté qu'une gentoo amha [:cosmoschtroumpf]
 
Tu as essayé fluxbuntu sinon ? [:opus dei]


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°1074567
trouble_fe​te
Posté le 16-09-2008 à 14:31:00  profilanswer
 

Non jconnaissais pas fluxbuntu tient, mais j'aime tellement Gentoo :(


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074570
wedgeant
Da penguin inside
Posté le 16-09-2008 à 14:36:07  profilanswer
 

bah oui m'enfin faut s'adapter au matos quand même un tantinet quoi [:neriki]


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°1074572
trouble_fe​te
Posté le 16-09-2008 à 14:36:40  profilanswer
 

:whistle:


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074573
trouble_fe​te
Posté le 16-09-2008 à 14:37:25  profilanswer
 

Tu vas rire (ou pas ^^) le noyau bien optimiser met 3 bonnes heures a se compiler, mdr


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074575
wedgeant
Da penguin inside
Posté le 16-09-2008 à 14:39:02  profilanswer
 

trouble_fete a écrit :

Tu vas rire (ou pas ^^) le noyau bien optimiser met 3 bonnes heures a se compiler, mdr


et la planète !!!! :fou:
 
en taule les polluteurs [:sarko]


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°1074576
trouble_fe​te
Posté le 16-09-2008 à 14:40:31  profilanswer
 

wedgeant a écrit :


et la planète !!!! :fou:
 
en taule les polluteurs [:sarko]


 
Mais non ça va ce portable consomme bien moins que mon PC de bureau a moniteur CRT
 
...si ça peut te rassurer  :whistle:  :bounce:


Message édité par trouble_fete le 16-09-2008 à 14:40:57

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074623
trouble_fe​te
Posté le 16-09-2008 à 16:53:17  profilanswer
 

Et merde ça change rien...en fait le problème c'est que au boot le noyau "raccorde" le disque dur ata a du scsi, j'ai eu le temps de lire au boot c'est indiqué "scsci direct attach: ata" ou truc du genre...
 
je suis donc nické vu que aucun livecd bootant sur ce portable n'est d'accord avec ça, eux trouve plutot que c'est de l'ATA ! comment faire ?
 
edit: meme dsl passera pas, vu qu'a l'install il va considérer le disque en /dev/hda alors qu'au boot ce sera /dev/sda ! c'est vraiment n'importe quoi  :??:


Message édité par trouble_fete le 16-09-2008 à 16:57:59

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074943
trouble_fe​te
Posté le 17-09-2008 à 18:17:21  profilanswer
 

Je crois que j'ai un peu avancé, cette fois le noyau va jusque dans la section Interactive ! celle ou on peut appuyer sur I pour valider ou non au fur et a mesure, je crois que tu dois savoir ce dont je parle.
 
Bref...ça marche toujours pas, a un moment ça dit qu'il n'y a pas de partition root, il la trouve pas :D  
 
Pour info j'en suis arrivé a cette "amélioration" en ajoutant "des trucs" dans la configuration du noyau...genre des pilotes ata génériques, le support de l'émulation SCSI...  
 
Bref j'essaye de faire de mon mieux mais c'est pas payant  :(
 
Edit: là j'ai encore ajouté "des trucs", mais j'en ai aussi retiré pas mal, genre tout ce qui concerne le multimedia, V4L toussa, ainsi que le support du reseau...(de toute façon il a pas de moyens d'accer a un reseau quel qu'il soit alors...) si je retire pas un max de trucs ça prends un temps infini a compiler ...


Message édité par trouble_fete le 17-09-2008 à 18:19:50

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1074983
trouble_fe​te
Posté le 18-09-2008 à 00:10:48  profilanswer
 

J'ai tout bien fait ça j'en suis certain, j'ai installé Gentoo un nombre incalculable de fois...
Mais là ce portable Pentium 1 (Pentium mmx) résiste terriblement !
 
Voila les parties qui beuguent au démarrage, apres "Press I to enter interactive boot mode"
 
juste après "Starting udevd ...":
 

Citation :

udevd[1027]: init_udevd_socket: error getting socket: Function not implemented
error initializing udevd socket
udevd[1027]: main: error initializing udevd socket


Puis juste après "Pupolating /dev with existing devices through uevents ...":
 

Citation :

Letting udev process events ...   [!!!]


 
Puis juste après "Checking root filesystem ..."
 

Citation :

ext2fs_check_if_mount: Aucun fichier ou répertoire de ce type lors de la détermination à savoir si /dev/hda4 est monté.
fsck.ext3: Aucun fichier ou répertoire de ce type lors de la tentative d'ouverture de /dev/hda4:
Le superbloc n'a pu etre lu ou ne contient pas un système de fichiers ext2 correct. Si le périphérique est valide et qu'il contient réellement un système de fichiers ext2 (et non pas de type swap, ufs ou autre), alors le superbloc est corrompu, et vous pourriez tenter d'executer e2fsck avec un autre superbloc:
    e2fsck -b 8193 <périphérique>
 
* Filesystem couldn't be fixed :(
Give root password for maintenance
(or type Control-D to continue):


 
Apres "(or type Control-D to continue):" c'est un prompt...
 
Alors, pensez vous que mon portable soit définitivement incompatible avec Linux  :( sachant que le livecd Gentoo ou DSL boot pourtant...et le chroot sur le livecd Gentoo n'a rien trouvé a redire, la Gentoo est installé correctement pourtant :(
 
A noter cepdendant que j'ai laissé /dev/hda3 tranquille car c'est une partition spéciale avec un morceaux de BIOS...ce qui fait que ma partition root se retrouve en /dev/hda4 sur le livecd Gentoo pour le formatage, l'installation et le chroot, qui se sont tous passés sans encombre.
Je suis completement perdu...


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1075047
l4nkou
Dr House Fan
Posté le 18-09-2008 à 10:22:05  profilanswer
 

si tu tiens vraiment a avoir une gentoo sur ton pentium 1,
je pense qu'il faudrait que sur ta machine perso, qui dispose de plus de puissance, installer une gentoo x86.
utiliser un stage3-x86-2008.0.tar.bz2 par exemple,et recompiler l'ensemble du systeme avec les bons CFLAGS compatible PI ( emerge -e word && emerge -e world ).
Une fois ceci réalisé, booter sur ton portable avec le livecd de ton choix, et faire un rsync over ssh, se chrooter ,et installer grub ;)


Message édité par l4nkou le 18-09-2008 à 10:24:30

---------------
Les avis, c'est comme les anus, tout le monde en a un.
n°1075118
trouble_fe​te
Posté le 18-09-2008 à 12:29:29  profilanswer
 

Ok mais pourquoi udev puisque apparemment le problème vient de lui, me fait chier comme ça sur ce portable :??:
En plus là avec le stage 3 x86 je suis en 486 ! donc largement compatible avec le Pentium 1 :??:
Et j'ai pas de reseau sur le portable (ya pas de carte reseau)


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1075140
trouble_fe​te
Posté le 18-09-2008 à 13:44:55  profilanswer
 

AAHHH:

Citation :

udevd[1027]: init_udevd_socket: error getting socket: Function not implemented


 
J'ai fait une recherche avec ça sur google et il semble que ce soit lié à:
 

Citation :

<*> Unix domain sockets

dans le noyau.
 
Hors problème: cette option du noyau étant dans

Citation :

  • Networking support

Ben moi j'avais plus <*> Unix domain sockets vu que j'ai désactivé [*] Networking support ! en effet je me suis dit comme je n'ai de reseau, je vais gagner du temps de compilation vu que le portable est très très lent...


Du coup là je recompile le noyau avec <*> Unix domain sockets !
 
Je verrais ce que ça donnera mais cette fois j'ai des chances que ce soit bon ! réponse dans 3 heures environ, c'est a dire le temps que le noyau soit compilé  :bounce:
 
Edit: si ça marche, voila un PC ou j'éviterais totalement de casser une Gentoo  :whistle:


Message édité par trouble_fete le 18-09-2008 à 13:53:52

---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
n°1075169
trouble_fe​te
Posté le 18-09-2008 à 14:39:21  profilanswer
 

Youpi ça venait bien de là, ça y est j'ai Gentoo sur mon Pentium premier du nom sur mon portable de 1998  :bounce:


---------------
Tyan Tiger 200T, SDR PC 133, 1*256Mo, Bi-Tualatin 1,4Ghz, disque Maxtor 6Y080L0 IDE 80Go, FX 5200 en format PCI, modem/routeur DSL-524T, le tout sous Gentoo
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Problème de config noyau ?? Kernel panic [Résolu]

 

Sujets relatifs
ds le noyau, pentium mmx ou pentium m ?? [Résolu]chroot = Illegal instruction [Résolu]
Problème avec ffmpeg pour encoder des imagesCherche livecd Linux 32Mo ram, avec mount et tar ! [Résolu]
[RESOLU]Mise à jour Dédié Ubuntu (OS, PHP, MySQL, Postfix ...)probleme de config DNS dynamique Ubuntu 8.4
PROBLEME : Configuration Internet sur Ubuntu (v.8.04)problème desinstallation ubuntu et récupération vista
Plus de sujets relatifs à : Problème de config noyau ?? Kernel panic [Résolu]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR