Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
572 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Debian] Problème de lancement du serveur X

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Debian] Problème de lancement du serveur X

n°863282
jordel
Elven Powaaa
Posté le 16-11-2006 à 10:45:26  profilanswer
 

Bonjour à tous,
 
Je dispose d'un Compaq Presario 702 EA (un portable old school) que je souhaite utiliser pour me familiariser au monde Linux...
 
J'ai donc télécharger dans l'ordre : FC4, Debian 3.1 et Kubuntu...
FC4 et Kubuntu se lançant toujours avec des problèmes d'interface graphique (je ne voyait jamais rien à l'écran)... j'ai donc tenté d'installer la Debian...
 
Tout se passe bien jusque l'install et la config de ma carte video et de GDM...
On me demande les fréquences de mon écran, les caract de ma carte et enfin j'ai le choix entre plusieurs pilotes. Disposant d'une carte VIA ProSavage KN133 - AGP 4x, je choisis naturellement (ai-je fait une erreur) le pilote VIA (avec hésitation quand même).
 
Le PC télécharge et installe les composants choisis... puis il redémarre.
 
Et là, il m'insulte en me disant qu'il ne peut pas lancer le serveur X et que je dois le relancer quand j'aurai bien configuré tout cela (il me dit pas ça comme ça... mais à peu près) ;)
Je me connecte donc en mode console... mais je ne sais pas quoi faire... il me parle de GDM mais je ne sais pas où trouver les infos et modifier la config !!!
 
Après quelques recherches sans résultat probant, je me tourne vers vous et votre savoir !!!
 
Merci d'avance pour vos réponses et votre indulgence envers un newbie de Linux :)
 

mood
Publicité
Posté le 16-11-2006 à 10:45:26  profilanswer
 

n°863285
wedgeant
Da penguin inside
Posté le 16-11-2006 à 11:00:11  profilanswer
 

Salut :)
 
Essayes d'utiliser le pilote vesa au lieu de via.  
Si tu sais faire, édites le fichier /etc/X11/xorg.conf en mode console (avec emacs, vi ou ed).
Sinon, réinstalles en choisissant vesa comme driver


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°863291
jordel
Elven Powaaa
Posté le 16-11-2006 à 11:25:07  profilanswer
 

Hello,
 
Haaaa il faut modifier le xorg.conf !!!
 
Je cherchais absolument à modifier un fichier .conf du répertoire GDM.
J'ai parcouru les 3 fichiers .conf afin de trouver la solution mais sans trouver... ça ne m'étonne plus maintenant :D
 
Merci, je teste ça et je vous tiens au courant !

n°863339
jordel
Elven Powaaa
Posté le 16-11-2006 à 14:11:26  profilanswer
 

Après quelques recherches... il s'avère que je ne trouve pas de xorg.conf sur ma machine !!!
 
Y'a t il un autre fichier de config ???
 
Merci d'avance.

n°863342
wedgeant
Da penguin inside
Posté le 16-11-2006 à 14:18:07  profilanswer
 

xf86config sinon ...
Que donne

ls -l /etc/X11/


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°863508
jordel
Elven Powaaa
Posté le 16-11-2006 à 22:11:56  profilanswer
 

J'ai modifié le pilote dans le fichier "XF86config-4" et j'ai pu démarrer le serveur graphique :)
 
Mais bon, je n'arrive pas à régler la résolution de mon écran... le maxi est du 800x600 au lieu du 1024x768... snifff

n°863511
dchost99
Posté le 16-11-2006 à 22:18:50  profilanswer
 

tape en console :
dpkg reconfigure xserver-xfree86
 
tu mets vesa, et 1024 ...

n°863582
jordel
Elven Powaaa
Posté le 17-11-2006 à 10:25:32  profilanswer
 

Merci m'sieur... Je vais tester cela :)
 
Y'a pas à dire... y'est vraiment chouette ce forum !!!

n°863713
jordel
Elven Powaaa
Posté le 17-11-2006 à 17:02:17  profilanswer
 

Re...
 
J'ai bien reconfiguré avec "dpkg-reconfigure xserver-xfree86" en lançant un terminal sous KDE mais aucun changement sur l'affichage... même après reboot, il ne me propose qu'au maxi 800x600...
 
Bizarre non ?


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Debian] Problème de lancement du serveur X

 

Sujets relatifs
problème divers joomla + serveur mail + ssl +routage pcFirefox 2 : problème recherche directe "j'ai de la chance"
Mandriva 2007 : Probleme serveur X avec carte Intel 846Gproblème de périphérique midi ubuntu dell latitude
Probleme de connection à ESX 3.0serveur de messagrie soous linux
Question sur serveur DNS .probleme pour tout formater
Plus de sujets relatifs à : [Debian] Problème de lancement du serveur X


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR