Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1747 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Debian] Mise à jour

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Debian] Mise à jour

n°633847
arrau
Ludwig von 54
Posté le 09-02-2005 à 20:48:01  profilanswer
 

Bonjour,
 
j'ai installé une debian (testing) par le net il y a 3-4 mois et je ne m'en suis pas servi pendant longtemps.
Hier, j'ai remis tout à jour en faisant apt-get update puis apt-get dist-upgrade.
Est-ce suffisant? (sécurité...)
 
Autrement, si je veux mettre à jour le noyau, est-ce que je suis obligé de tout réinstaller?
 
Merci.

mood
Publicité
Posté le 09-02-2005 à 20:48:01  profilanswer
 

n°633849
mikala
Souviens toi du 5 Novembre...
Posté le 09-02-2005 à 20:53:51  profilanswer
 

logiquement pour mettre a jour c'est apt-get update et apt-get upgrade .
pour la Sarge il est cependant recommandé d'utiliser aptitude dorénavant .
Enfin pour installer un noyau il faut donc utiliser
apt-get/aptitude install kernel-image-xxx

n°633863
arrau
Ludwig von 54
Posté le 09-02-2005 à 21:41:20  profilanswer
 

Et il faudra que je désinstalle l'ancienne version ou c'est écrasé?

n°633865
mikala
Souviens toi du 5 Novembre...
Posté le 09-02-2005 à 21:49:27  profilanswer
 

il vaut mieux a mon avis garder l'ancien kernel au cas  ou.

n°648585
gaby7
Posté le 12-03-2005 à 11:29:15  profilanswer
 

Lors d'un apt-get install kernel-image ...., le systeme se base sur quel .config pour installer le nouveau noyau ?  :??:

n°648589
mikala
Souviens toi du 5 Novembre...
Posté le 12-03-2005 à 11:33:44  profilanswer
 

sur le .config fait par debian .


---------------
Intermittent du GNU
n°648598
gaby7
Posté le 12-03-2005 à 11:52:55  profilanswer
 

Thx :jap:  
C'est ce qu'il me semblait, il install beaucoup de chose à mon gout.
Je me contenterais d'utiliser mon .config perso la prochaine fois, m'enfin bon, c'est toujours bien de tester  :whistle:  

n°648605
mikala
Souviens toi du 5 Novembre...
Posté le 12-03-2005 à 12:01:50  profilanswer
 

bah dans ce cas il suffit de créer son propre kernel et si tu veux utiliser un paquet debian make-kpkg est ton ami .


---------------
Intermittent du GNU
n°648622
nodus
Posté le 12-03-2005 à 12:21:08  profilanswer
 

Il existe sur debian une procédure automatique de compilation du kernel comme sous gentoo avec genkernel ?
 
En fait j'aimerais mettre à jour le driver orinoco et apparemment il faut les sources du noyau, est il necessaire que je recompile mon kernel ?

n°648628
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 12-03-2005 à 12:53:52  profilanswer
 

automatique ?
 
pour inclure des pilotes tiers il faut en effet recompiler le kernel


---------------
uptime is for lousy system administrators what Viagra is for impotent people - mes unixeries - github me
mood
Publicité
Posté le 12-03-2005 à 12:53:52  profilanswer
 

n°648942
Jar Jar
Intaigriste
Posté le 12-03-2005 à 23:40:21  profilanswer
 

black_lord a écrit :

automatique ?
 
pour inclure des pilotes tiers il faut en effet recompiler le kernel

NON ! JAMAIS !
 
Bordel de merde. À quoi ils servent les paquets kernel-headers à ton avis ?
 
Si les modules tiers sont débianisés, un petit coup de module-assistant auto-install ou de make-kpkg modules_image, suivant le cas. Sinon, il faut faire un lien nommé linux dans /usr/src, pointant vers la bonne version des headers, et compiler à la main.

n°648943
Jar Jar
Intaigriste
Posté le 12-03-2005 à 23:41:53  profilanswer
 

En plus pour orinoco ce n'est pas nécessaire, vu que le module est déjà dans le noyau. À moins que tu ne veuilles le driver Host AP, qui est dans hostap-source et géré par module-assistant.


Message édité par Jar Jar le 12-03-2005 à 23:43:05
n°648958
nodus
Posté le 13-03-2005 à 09:17:38  profilanswer
 

C'est juste pour avoir le mode scanning pour ma carte wifi, car le driver inclus dans le 2.6.8 est la version 0.13e qui n'inclue pas le mode scanning. Il faut soit patcher soit mettre à jour le driver.

n°649023
arrau
Ludwig von 54
Posté le 13-03-2005 à 12:28:25  profilanswer
 

Donc pour mettre à jour mon noyau, il faut juste faire un aptitude install kernel-image-*** ?
 
Quelle est actuellement le nom du paquet kernel-image-** le plus récent pour une architecture i386?

n°649028
crt
Posté le 13-03-2005 à 12:34:16  profilanswer
 

En fonction de ton processeur, choisis l'une des images suivantes :
 
kernel-image-2.6.10-1-386 - Linux kernel image for version 2.6.10 on 386.
kernel-image-2.6.10-1-686 - Linux kernel image for version 2.6.10 on PPro/Celeron/PII/PIII/P4.
kernel-image-2.6.10-1-686-smp - Linux kernel image for version 2.6.10 on PPro/Celeron/PII/PIII/P4 SMP.
kernel-image-2.6.10-1-k7 - Linux kernel image for version 2.6.10 on AMD K7.
kernel-image-2.6.10-1-k7-smp - Linux kernel image for version 2.6.10 on AMD K7 SMP.
kernel-image-2.6.10-9-amd64-generic - Linux kernel image for version 2.6.10 on generic x86_64 systems
kernel-image-2.6.10-9-amd64-k8 - Linux kernel image for version 2.6.10 on AMD64 systems
kernel-image-2.6.10-9-amd64-k8-smp - Linux kernel image for version 2.6.10 on AMD64 SMP systems
kernel-image-2.6.10-9-em64t-p4 - Linux kernel image for version 2.6.10 on Intel EM64T systems
kernel-image-2.6.10-9-em64t-p4-smp - Linux kernel image for version 2.6.10 on Intel EM64T SMP systems
 
smp = pour les systèmes multiprocesseurs


Message édité par crt le 13-03-2005 à 12:35:47
n°649029
nodus
Posté le 13-03-2005 à 12:37:49  profilanswer
 

Marrant, je n'ai que ça :??: (en 2.6 les plus récents) , peut être parce que je suis sous sarge.
 
i   kernel-image-2.6.5-1-686        - Linux kernel image for version 2.6.5 on P
v   kernel-image-2.6.8-1-386        -
v   kernel-image-2.6.8-1-686        -
v   kernel-image-2.6.8-1-686-smp    -
v   kernel-image-2.6.8-1-k7         -
v   kernel-image-2.6.8-1-k7-smp     -
p   kernel-image-2.6.8-10-amd64-gen - Linux kernel image for version 2.6.8 on g
p   kernel-image-2.6.8-10-amd64-k8  - Linux kernel image for version 2.6.8 on A
p   kernel-image-2.6.8-10-amd64-k8- - Linux kernel image for version 2.6.8 on A
p   kernel-image-2.6.8-10-em64t-p4  - Linux kernel image for version 2.6.8 on I
p   kernel-image-2.6.8-10-em64t-p4- - Linux kernel image for version 2.6.8 on I
p   kernel-image-2.6.8-2-386        - Linux kernel image for version 2.6.8 on 3
id  kernel-image-2.6.8-2-686        - Linux kernel image for version 2.6.8 on P
p   kernel-image-2.6.8-2-686-smp    - Linux kernel image for version 2.6.8 on P
p   kernel-image-2.6.8-2-k7         - Linux kernel image for version 2.6.8 on A
p   kernel-image-2.6.8-2-k7-smp

n°649032
crt
Posté le 13-03-2005 à 12:39:30  profilanswer
 

Effectivement, l'équipe debian maintient un kernel 2.6.8 à jour pour la release de sarge

n°649036
crt
Posté le 13-03-2005 à 12:47:21  profilanswer
 

nodus a écrit :

C'est juste pour avoir le mode scanning pour ma carte wifi, car le driver inclus dans le 2.6.8 est la version 0.13e qui n'inclue pas le mode scanning. Il faut soit patcher soit mettre à jour le driver.


 
Tu as une carte Wifi orinoco, n'est-ce pas ?  ;)  
 
Pour mettre le dernier driver (qui supporte le scanning), il suffit de compiler le module sur les sources. Pas besoin donc de compiler un noyau à la main. Il faut donc :
 
1) avoir les sources du noyau utilisé
2) les configurer
3) télécharger le dernier driver orinoco 0.15rc2
4) le compiler et installer le nouveau module
 
Si tu ne sais pas comment réaliser l'une de ses étapes... dis-moi


Message édité par crt le 13-03-2005 à 12:51:40
n°649038
arrau
Ludwig von 54
Posté le 13-03-2005 à 12:50:29  profilanswer
 

Merci.

n°649039
crt
Posté le 13-03-2005 à 12:54:04  profilanswer
 


 
Donc tu as bien pris kernel-image-2.6.10-1-k7 ?

n°649046
Jar Jar
Intaigriste
Posté le 13-03-2005 à 13:06:31  profilanswer
 

crt a écrit :

1) avoir les sources du noyau utilisé
2) les configurer
3) télécharger le dernier driver orinoco 0.15rc2
4) le compiler et installer le nouveau module

Non, non et non ! À la place de 1 et 2, tu installes le paquet kernel-headers correspondant au noyau installé et tu crées le bon lien /usr/src/linux.

n°649049
nodus
Posté le 13-03-2005 à 13:12:15  profilanswer
 

crt a écrit :

Tu as une carte Wifi orinoco, n'est-ce pas ?  ;)  
 
Pour mettre le dernier driver (qui supporte le scanning), il suffit de compiler le module sur les sources. Pas besoin donc de compiler un noyau à la main. Il faut donc :
 
1) avoir les sources du noyau utilisé
2) les configurer
3) télécharger le dernier driver orinoco 0.15rc2
4) le compiler et installer le nouveau module
 
Si tu ne sais pas comment réaliser l'une de ses étapes... dis-moi


 
C'est une dell truemobile 1150 (prism2) qui marche avec les drivers orinoco. J'ai installé la dernière version du driver mais apparemment je ne peux avoir le monitor mode. Peut être à cause du firmware. De toute façon je devrais avoir une orinoco gold cette semaine donc j'en reparlerais à ce moment. Sinon j'ai aussi patché les sources du module avec le patch dragorn.  
 
Vu que c'est pour un projet d'études je pense faire un tuto pour cela. Le projet et de faire un programme de cartographie de réseaux wifi avec le rayonnement des points d'accés sur un plan bidimensionel. Sous GPL bien sur :D  
 
En tout cas merci pour ton aide :)
 
EDIT:
 
orinoco 0.15rc2STA (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
orinoco_cs 0.15rc2STA (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
eth1: Hardware identity 0005:0004:0005:0000
eth1: Station identity  001f:0001:0008:000a
eth1: Firmware determined as Lucent/Agere 8.10
eth1: Ad-hoc demo mode supported
eth1: IEEE standard IBSS ad-hoc mode supported
eth1: WEP supported, 104-bit key
eth1: MAC address 00:02:2D:BA:89:85
eth1: Station name "HERMES I"
eth1: ready
eth1: index 0x01: Vcc 3.3, irq 7, io 0x0100-0x013f
 
# iwpriv eth1
eth1      Available private ioctl :
          force_reset      (8BE0) : set   0       & get   0
          card_reset       (8BE1) : set   0       & get   0
          set_port3        (8BE2) : set   1 int   & get   0
          get_port3        (8BE3) : set   0       & get   1 int
          set_preamble     (8BE4) : set   1 int   & get   0
          get_preamble     (8BE5) : set   0       & get   1 int
          set_ibssport     (8BE6) : set   1 int   & get   0
          get_ibssport     (8BE7) : set   0       & get   1 int
          get_rid          (8BE9) : set   0       & get 1024 byte
 
 :cry:


Message édité par nodus le 13-03-2005 à 13:19:31
n°649058
crt
Posté le 13-03-2005 à 13:26:44  profilanswer
 

Le patch pour le monitoring sur le 0.13, je n'ai jamais rien obtenu de très probant avec, mais bon c'etait il y a longtemps.
 
Hormis cela, il me semble que le 10.15rc2 ne rajoute rien dans iwpriv il me semble qu 'il me sufisait de faire un iwconfig eth1 mode scanning et puis ca roulait... Mais c'est à vérifier
 
Une localisation bidimensionelle, ca à l'air bien sympathique comme projet. Petite question par curiosité : Tu penses utiliser une ou deux carte wifi ensemble pour ta cartographie ?


Message édité par crt le 13-03-2005 à 13:28:58
n°649109
nodus
Posté le 13-03-2005 à 14:35:47  profilanswer
 

En fait iwpriv me permet de savoir si la carte supporte le monitor mode, je vais essayer de retrouver le champ.
 
Pour le projet je compte n'utiliser qu'une carte wifi. De toute façon le soft ne sera pas dépendant du hardware, il suffira que le système puisse scanner pour l'utiliser :jap:

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [Debian] Mise à jour

 

Sujets relatifs
animation flash+freeze complet+debian[suse ] mise à jour de la 9.0 vers 9.2
Debian sur un portable Sony VAIO VGN-B1XP : problèmes RESOLUS[debian] Problème pour faire marcher webcam creative notebook
[Debian] Upgrade et mise a jour[IPTABLES] installation/mise à jour packages debian
[Debian "Woody"] Mise à jour automatisée (apt-get update ...)[debian] Mise a jour du noyau
question mise a jour debian?[debian] pbe mise à jour
Plus de sujets relatifs à : [Debian] Mise à jour


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR