Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1593 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  [Slackware] Absence de couleur dans xterm

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Slackware] Absence de couleur dans xterm

n°185444
le passant
Posté le 07-11-2002 à 18:22:52  profilanswer
 

Et ce uniquement quand je suis en su, ce qui me dérange beaucoup car les couleurs c'est très pratique et je suis quasiment toujours en su !!!
 
En effet, je travaille sur une machine distante (enfin sans aucune interface utilisateur), et je m'y connecte par l'intermédiaire d'un utilisateur lambda.
(J'ai enfin réussi à installer et faire fonctionner OpenSSH).
 
Je suis sous une Slackware 8.1 et quand on travaille en su : plus de couleur  :kaola: .
 
Y a t'il un moyen de s'en sortir ???
 
Le passant.

mood
Publicité
Posté le 07-11-2002 à 18:22:52  profilanswer
 

n°185474
kuroineko
je mamgerais bien un truc la..
Posté le 07-11-2002 à 19:34:42  profilanswer
 

Le passant a écrit a écrit :

Et ce uniquement quand je suis en su, ce qui me dérange beaucoup car les couleurs c'est très pratique et je suis quasiment toujours en su !!!
 
En effet, je travaille sur une machine distante (enfin sans aucune interface utilisateur), et je m'y connecte par l'intermédiaire d'un utilisateur lambda.
(J'ai enfin réussi à installer et faire fonctionner OpenSSH).
 
Je suis sous une Slackware 8.1 et quand on travaille en su : plus de couleur  :kaola: .
 
Y a t'il un moyen de s'en sortir ???
 
Le passant.




 
moi c'est pareil mais uniquement en console distante, mais j'avais jamais fait attention que j'avais plus de couleurs quand je me connecte depuis l'exterieur....
 
ps : DESOLE mais je sais pas t'aider...
 
console locale couleur
su local couleur (sauf pour root)
su depuis une machine distante sans couleur (j'autorise pas le root distant)....


Message édité par kuroineko le 07-11-2002 à 19:37:28

---------------
[:kuroineko] Francois.P tel: (+33)617230820 http://www.ifrance.com/fpussault  fpussault@caramail.com
n°185652
le passant
Posté le 07-11-2002 à 22:52:51  profilanswer
 

C'est a n'y rien comprendre !!!
 
Depuis, j'ai essayé en local, c'est pareil, même pour un su depuis root vers autre utilisateur.
 
Me reste à tester su entre deux utilisateurs (et pas de root), mais c'est po ça qui va faire avancer la chose.
 
Visiblement, on n'a plus qu'a désespérer :(.
 
Le passant.

n°185738
unk00
Posté le 08-11-2002 à 09:32:59  profilanswer
 


 Oui, c'est normal : en tapant simplement
   #> su
le /etc/profile n'est pas exécuté (c'est là que "dircolors" -pour configurer la coloration- est appelé)
 Donc, soit il faut l'exécuter après le "su":  
   $> source /etc/profile
 
 soit (et c'est le plus simple) il faut ajouter "-" :
   #> su -
 
extrait de "man su"
 


SYNOPSIS
     su [-] [username [args]]
 
DESCRIPTION
  .... The optional argument - may be used to provide an environment similiar to what the user would expect had the user logged in directly.  
 

 

n°185764
le passant
Posté le 08-11-2002 à 11:55:57  profilanswer
 

Ouaihhhh !!!!!
 
Je t'adore unk00 !!!!
 
Oups, on va se calmer !!
 
Le passant.

n°185972
kuroineko
je mamgerais bien un truc la..
Posté le 08-11-2002 à 20:31:18  profilanswer
 

unk00 a écrit a écrit :

 
 Oui, c'est normal : en tapant simplement
   #> su
le /etc/profile n'est pas exécuté (c'est là que "dircolors" -pour configurer la coloration- est appelé)
 Donc, soit il faut l'exécuter après le "su":  
   $> source /etc/profile
 
 soit (et c'est le plus simple) il faut ajouter "-" :
   #> su -
 
extrait de "man su"
 


SYNOPSIS
     su [-] [username [args]]
 
DESCRIPTION
  .... The optional argument - may be used to provide an environment similiar to what the user would expect had the user logged in directly.  
 

 
 




 
ah ben oui.....
forcement....
j'y avais pourtant pas pense....
 
en faisant rsh -l titi.users "./$HOME/.profile ; . /etc/profile "
 
ca passe mais bon rsh c'est bien en reseau local mais sinon en securite c pas top...


---------------
[:kuroineko] Francois.P tel: (+33)617230820 http://www.ifrance.com/fpussault  fpussault@caramail.com

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  [Slackware] Absence de couleur dans xterm

 

Sujets relatifs
[slackware 8.1] install & premiere impression ....Slackware ou Mandrake
gnomemeeting & slackwareinstallation Slackware et lilo qui marche po !!!!
Slackware et sambaInstallation slackware: que faire comme partitions ??
[slackware 8.1] script avant démarrage XJe viens de d/l slackware-8.1-install.iso je fais koi maintenant???
[Slackware] Problèmes lors de l'install [Résolus_surprise inside]Raaaaa Slackware boot anormal
Plus de sujets relatifs à : [Slackware] Absence de couleur dans xterm


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR