Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1996 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  [résolu] RedHat 8 - Problèmes souris

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[résolu] RedHat 8 - Problèmes souris

n°182995
antp
Super Administrateur
Champion des excuses bidons
Posté le 02-11-2002 à 17:53:40  profilanswer
 

edit: voir plus bas
====================
 
C'est une install toute fraîche
 
il me dit:


xf86OpenSerial: Cannot open device /dev/mouse
   Device or resource busy.
Mouse1: cannot open input device
PreInit failed for input device "Mouse1"
No core pointer


 
la souris est une souris à roulette Microsoft toute simple, branchée sur le port PS/2 (cf config second PC dans mon profil, sauf que j'ai mis une TNT2 à la place de la Kyro2, pour Linux)
pendant toute l'install elle fonctionnait, puis au premier boot ça marche plus :/
 
j'ai déjà viré un lien de type S??gpm dans le dossier /etc/rc.d/rc5.d, suivant un conseil de Kadreg, mais ça marche toujours pas :/
 
PS: je suis assez newbie pour ce qui est de la config sous linux :D


Message édité par antp le 04-11-2002 à 23:03:32

---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
mood
Publicité
Posté le 02-11-2002 à 17:53:40  profilanswer
 

n°183043
kazekami
J'aime pas les gens
Posté le 02-11-2002 à 20:12:44  profilanswer
 

t'as koi comme protocole pour ta souris (c indiké dans ton fichier /etc/X11/XF86Xonfig) ?
 
et /dev/mouse il pointe vers koi (ls -l /dev/mouse pour savoir) ?
 
a priori moi j'mettrais ImPS/2 en protocole, et /dev/mouse doit pointer vers /dev/psaux


---------------
Self Destruction Might Be The Answer - http://www.kazekami.org
n°183046
antp
Super Administrateur
Champion des excuses bidons
Posté le 02-11-2002 à 20:44:39  profilanswer
 


Identifier  "Mouse1"
Driver      "mouse"
Option "Protocol"   "PS/2"
Option "Device"     "/dev/mouse"


 
avant de refaire la config (via xf86config) j'avais IMPS/2
 
/dev/mouse pointe vers psaux


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183051
antp
Super Administrateur
Champion des excuses bidons
Posté le 02-11-2002 à 21:17:38  profilanswer
 

j'ai essayé en mettant "IMPS/2" et en mettant directement "/dev/psaux" mais ça marche pas mieux :/
 
comment savoir ce qui utilise la recource ?


Message édité par antp le 02-11-2002 à 21:17:43

---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183054
kadreg
profil: Utilisateur
Posté le 02-11-2002 à 21:51:17  profilanswer
 

antp a écrit a écrit :

 
comment savoir ce qui utilise la recource ?




 
lsof /dev/psaux


---------------
brisez les rêves des gens, il en restera toujours quelque chose...  -- laissez moi troller sur discu !
n°183056
antp
Super Administrateur
Champion des excuses bidons
Posté le 02-11-2002 à 21:55:50  profilanswer
 

il revient direct au prompt


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183232
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2002 à 15:54:54  profilanswer
 

nan :mad:
j'hésite entre réinstaller la Mandrake 8 et tout virer :D

n°183301
BMOTheKill​er
Posté le 03-11-2002 à 18:42:42  profilanswer
 

sous rh 8.0, à l'install il y a "2 souris" d'installer, une en mouse0 (/dev/psaux) et une mouse1 (/dev/input/psaux) si je me souviens bien, sur les 3 install sur 3 machines différentes j'ai eu ça à chaque fois sans problème, mais peut-être que chez toi ça en pose un.... regarde de ce côté peut-être

n°183309
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2002 à 19:03:05  profilanswer
 

justement dans la config de xfree y a rien d'autre concernant la souris on dirait... :/

n°183350
Kristoph
Posté le 03-11-2002 à 20:35:15  profilanswer
 

Attention avec lsof, si c'est un lien en général le resultat est "vide" comme ca.
 
Si tu utilise devfs ce qui me semble etre le cas, /dev/psaux doit justement etre un lien alors teste lsof sur le vrai fichier.

mood
Publicité
Posté le 03-11-2002 à 20:35:15  profilanswer
 

n°183352
Kristoph
Posté le 03-11-2002 à 20:37:47  profilanswer
 

PS : Je parierais pour un bloquage de la souris par gpm.

n°183359
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2002 à 20:52:24  profilanswer
 

C'est peut-être bien gpm, mais il me semble que j'ai déjà désactivé ça
il n'est plus dans la liste des process...

n°183366
Kristoph
Posté le 03-11-2002 à 21:03:24  profilanswer
 

Dans ce cas, fais le truc avec lsof pour trouver quel process bloque la souris :D. Si la réponse est vide alors je ne comprends pas le message d'erreur de X

n°183369
gm_superst​ar
Appelez-moi Super
Posté le 03-11-2002 à 21:09:08  profilanswer
 

Au fait c'est quoi ta souris ? (interface & modèle)
 
 
Cela dit, chez moi un lsof /dev/psaux me renvoit bien quelque chose :

COMMAND  PID USER   FD   TYPE DEVICE SIZE NODE NAME
X       1106 root   27u   CHR   10,1        86 /dev/misc/psaux


 
Bien que ce soit un lien vers /dev/misc/psaux


---------------
Incongru : une FAQ abandonnée sur les Standards du Web - FAQ périmée de blabla@Prog
n°183370
Kristoph
Posté le 03-11-2002 à 21:13:02  profilanswer
 

Tiens, c'est vrai ca. J'aurais jure :/
 
Dans ce cas, je ne vois pas ce que peut etre le problème dsl.

n°183383
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2002 à 21:45:44  profilanswer
 

gm_superstar a écrit a écrit :

Au fait c'est quoi ta souris ? (interface & modèle)
 




 
Microsoft Wheelmouse (j'avais dit intellimouse mais c'est pas ça :o) :
http://www.activewin.com/reviews/hardware/mice/cordless/images/mouse.jpg
 
sur port PS/2
marche sous Windows, XOSL, pendant l'install de la Red Hat, ...

n°183385
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2002 à 21:46:34  profilanswer
 

vais essayer de connecter une souris série toute bête :/

n°183392
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2002 à 21:53:56  profilanswer
 

j'ai mis une souris série.... maintenant le clavier ne réagit plus mais X démarre :/

n°183400
Kristoph
Posté le 03-11-2002 à 21:59:11  profilanswer
 

??? Comment le fait de mettre une souris serie peut-il bloquer le fonctionnement du clavier ? Et ca bloque sous X seulement ou aussi en console ?
 
Au fait, le PS/2 c'est pas fait pour les branchements/débranchements à chaud ;) Faudra peut-etre rebooter ou même éteindre puis redémarer

n°183405
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2002 à 22:01:44  profilanswer
 

j'éteins à chaque changement, j'ai déjà un jour grillé un port ps/2 et une souris avec des changements à chaud ;)
 
en fait quand je mets la souris série, j'ai un genre d'assistant de fin d'install de redhat, mais le clavier ne réagit pas et la souris ne bouge pas :/
(même pas moyen de faire un appel à une console :/)
 
pour le lsof /dev/psaux, il me met bel et bien rien
et ça ne semble pas être juste un lien

n°183406
gm_superst​ar
Appelez-moi Super
Posté le 03-11-2002 à 22:01:59  profilanswer
 

Normalement c'est IMPS/2 le protocole pour cette souris :/


---------------
Incongru : une FAQ abandonnée sur les Standards du Web - FAQ périmée de blabla@Prog
n°183553
gm_superst​ar
Appelez-moi Super
Posté le 04-11-2002 à 12:46:08  profilanswer
 
n°183568
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 13:19:55  profilanswer
 

ok je testerai ça ce soir... si j'ai le courage :D


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183945
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 22:15:29  profilanswer
 

suite à ce post : http://www.xfree86.org/pipermail/n [...] 17482.html
j'ai tenté de changer en /dev/gpmdata mais ça existe pas apparemment.
Par contre si je lance gpm il me dit lui aussi que le /dev/mouse est busy :heink:


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183957
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 22:26:19  profilanswer
 

oué j'ai peut-être trouvé \0/
http://groups.google.com/groups?hl [...] %40dev.nul
si je fais un cat /proc/interrupts j'ai eth0 en 12
donc le resource busy c'est peut-être l'IRQ et non le port qui est occupé :o
La dernière fois que j'avais un conflit d'IRQ c'était avec Windows 95... comment on fait avec Linux ? :D


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183966
gm_superst​ar
Appelez-moi Super
Posté le 04-11-2002 à 22:37:06  profilanswer
 

Qu'est qu'elle fout en IRQ 12 ta carte réseau ?  
 
Normalement la souris à une IRQ qu'elle ne partage jamais.
 
 
Pour être sûr que c'est ça, arrête le réseau (service "network" ) et décharge le module de la carte réseau (modprobe -r <le_module> ) puis essaye de relancer X.


---------------
Incongru : une FAQ abandonnée sur les Standards du Web - FAQ périmée de blabla@Prog
n°183968
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 22:38:00  profilanswer
 

ouéééé en mettant "PNP OS" sur "no" dans le BIOS ça marche ! ...  
sauf que la souris marche pas :heink: elle bouge pas.
Bon par contre X démarre... spa très pratique quand même un linux sans souris :D
 
je suppose qu'avec pnp os = no c'est le BIOS qui choisit les IRQ.
ici il a mis la carte réseau e, IRQ5
 
en fait maintenant l'IRQ 12 apparait pas dans la liste...
bon comment je fais marcher cette souris ? :/


Message édité par antp le 04-11-2002 à 22:39:40

---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183973
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 22:43:32  profilanswer
 

Je tape ce post avec Lynx :D Au moins le ré0eseau fonctionne...
Par contre c'est pas top niveau lisibilitée :/

n°183980
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 22:51:16  profilanswer
 

je veux une souris qui fonctionne  [:sisicaivrai]


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183986
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 23:01:46  profilanswer
 

j'ai remis la souris en IMPS/2 sur /dev/psaux, ça marche enfin [:yaisse]
 
Merci à tous pour votre aide :)


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183988
antp
Super Administrateur
Champion des excuses bidons
Posté le 04-11-2002 à 23:03:49  profilanswer
 

J'étais en train de le faire :p
j'ai aussi édité le titre du topic


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°183992
gm_superst​ar
Appelez-moi Super
Posté le 04-11-2002 à 23:11:36  profilanswer
 

\o/ Ouééééé
 
 
 
 
 
(hum, cela dit avant de commencer toute bonne installation de Linux il faut mettre PnP OS à No :ange:... même pour Windows c'est conseillé !)


---------------
Incongru : une FAQ abandonnée sur les Standards du Web - FAQ périmée de blabla@Prog
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Débats

  [résolu] RedHat 8 - Problèmes souris

 

Sujets relatifs
Connection speedtouch ADSL auto au démarrage linux (redhat 8)mise à jour Mandrake et RedHat
Redhat 8.0 et touche alt-grMandrake et redhat [mega-noob inside]
pb install redhat 8.0[woody] collections de problemes , ca continue
Souris USB a chaud (sur un portable)Redhat 8 VS Mandrake 9: Résumé final
[mega newb inside] pb avec RedHatRedHat 8 et upgrade noyau 2.4.19 - suite : PB avec cartes GForce ???
Plus de sujets relatifs à : [résolu] RedHat 8 - Problèmes souris


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR