Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1909 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Codes et scripts

  [resolu] Script démarrant automatiquement (init.d)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[resolu] Script démarrant automatiquement (init.d)

n°843747
guepe
J'ai du noir sur la truffe ?
Posté le 17-09-2006 à 02:24:59  profilanswer
 

J'ai cree un petit script qui detecte si mon portable est branche sur secteur ou pas, et en fonction definis le mode de fonctionnement de ma carte graphique grace a une ptitte commande de aticonfig.
J'ai donc un script sh, et un fichier dans init.d qui ressemble a ca :  
 

Code :
  1. #!/bin/sh
  2. set -e
  3. . /lib/lsb/init-functions
  4. case "$1" in
  5. start)
  6.  [ ! -d "/var" ] && sudo mkdir /var
  7.  [ ! -d "/var/run" ] && sudo mkdir /var/run
  8.  log_begin_msg "Démarrage du gestionnaire des frequences CG pour aticonfig"
  9.  /sbin/gest-ati-freq.sh &
  10.  log_end_msg $? "Impossible de démarrer le gestionnaire des fréquences CG pour aticonfig"
  11.  echo $! > /var/run/gest-ati-freq.pid
  12. ;;
  13. stop)
  14.  log_begin_msg "Arrêt du gestionnaire des frequences CG pour aticonfig"
  15.  kill -9 `cat /var/run/gest-ati-freq.pid`
  16.  log_end_msg $? "Impossible d arrêter le gestionnaire des fréquences CG pour aticonfig"
  17.  echo '' > /var/run/gest-ati-freq.pid
  18.  exit 0
  19. ;;
  20. esac


 
Tout marche pour le mieux... si je le lance manuellement (/etc/init.d/gest-ati-freq start) : le stop marche tres bien aussi
 
Malheureusement, au demarrage mon daemon est lance, mais semble inactif, il ne met pas la config comme il faut
Je dois donc au demarrage, faire un stop, puis un start, et tout rentre dans l'ordre....
 
Qu'est-ce que j'ai loupe ????
 
Merci beaucoup !


Message édité par guepe le 20-09-2006 à 04:12:37

---------------
Un blog qu'il est bien
mood
Publicité
Posté le 17-09-2006 à 02:24:59  profilanswer
 

n°843748
Fork Bomb
Obsédé textuel
Posté le 17-09-2006 à 02:53:57  profilanswer
 

Peut-etre virer les "sudo" ?


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°843749
guepe
J'ai du noir sur la truffe ?
Posté le 17-09-2006 à 03:08:03  profilanswer
 

Bon effectivement c'etait bete ces sudo...
Mais malheureusement cela ne change rien... Au demarrage, le daemon est la, mais il ne reagit pas.. un stop, un start et hop tout va bien !!
 
Grrrr....
 
Je me demandais : utilisant aticonfig, il faut que le driver ati soit deja charge pour que le script fonctionne, peut etre que ce n'est pas le cas???? et qu'ensuite, bah je sais pas il plante tout en restant actif???
 
Voila le script :  
 

Code :
  1. #gest-ati-freq.sh
  2. #by HMS_Rose
  3. echo "Gestionnaire pour aticonfig des frequences CG"
  4. while [ 0 ]; do
  5. etat=$(cat /proc/acpi/ac_adapter/AC/state | reverse | cut -d ' ' -f 1 | reverse | tr -d "\n" )
  6. pwstate=$(aticonfig --list-powerstates | grep '*' | cut -d ' ' -f 2)
  7. if [ "$etat" != "off-line" ]; then
  8.  if [ "$pwstate" == "1:" ]; then
  9.   aticonfig --set-powerstate=2
  10.  fi
  11. else
  12.  if [ "$pwstate" == "2:" ]; then
  13.   aticonfig --set-powerstate=1
  14.  fi
  15. fi
  16. sleep 1
  17. done


---------------
Un blog qu'il est bien
n°844195
Dark_Schne​ider
Close the World, Open the Net
Posté le 18-09-2006 à 20:22:03  profilanswer
 

tu pourrais améliorer les entêtes pour chkconfig : http://www.linux-wizard.net/howto. [...] y=services


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°844218
ratur
Posté le 18-09-2006 à 21:36:23  profilanswer
 

selon moi, aticonfig --set-powerstate=1 ne fonctionne que si un serveur X est lancé.

n°844224
guepe
J'ai du noir sur la truffe ?
Posté le 18-09-2006 à 21:44:04  profilanswer
 

Citation :

selon moi, aticonfig --set-powerstate=1 ne fonctionne que si un serveur X est lancé.


 
Quelle solution pourrait-t-on trouver ??? Comment faire demarrer un script une fois X lance ?? (ou une fois un user logge par exemple)
 
Je vais voir chkconfig, merci !!


---------------
Un blog qu'il est bien
n°844232
Dark_Schne​ider
Close the World, Open the Net
Posté le 18-09-2006 à 21:57:47  profilanswer
 

pour lancer un script au lancement de X : /etc/X11/xinit.d/


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°844238
guepe
J'ai du noir sur la truffe ?
Posté le 18-09-2006 à 22:14:05  profilanswer
 

Citation :

pour lancer un script au lancement de X : /etc/X11/xinit.d/


 
Si je met mon script de demarrage dans ce repertoire ca va se lancer??? Il faut pas utiliser une commande style update-rc.d ?? (ou chkconfig pour d'autres distrib)
 
Je vais faire une recherche google... Merci en tout cas !


---------------
Un blog qu'il est bien
n°844248
guepe
J'ai du noir sur la truffe ?
Posté le 18-09-2006 à 22:58:52  profilanswer
 

J'ai mis mon script dans /etc/X11/xinit.d : apres redemarrage cela ne fonctionnai pas...
Bizarrement, j'ai mis mon script dans Xsession.d, ca plantait mon demarrage de session... je l'ai enleve en me loggant sur la session failsafe, supprime le script a cet endroit, puis me suis reloggue en normal... bah maintenant ca marche impec !!!!
Je suis content, merci pour tout !!


---------------
Un blog qu'il est bien
n°844256
guepe
J'ai du noir sur la truffe ?
Posté le 18-09-2006 à 23:31:58  profilanswer
 

Bon en fait ca marche pas.. j'ai reboote, le script ne demarre pas
J'ai essaye de le mettre en init3 avec un id de 99, soit apres usplash et acpi... je pense que X11 est lance a ce moment... mais nope, rien a faire... c'est d'autant plus rageant que le script marche lui.... :pfff:  
 
Quelqu'un aurait une brillante idee??? comment faire marcher un script inscrit dans xinit.d par exemple ??


---------------
Un blog qu'il est bien
mood
Publicité
Posté le 18-09-2006 à 23:31:58  profilanswer
 

n°844270
guepe
J'ai du noir sur la truffe ?
Posté le 19-09-2006 à 02:15:37  profilanswer
 

Voila le resultat de la commande ps -aux apres le login :  
 

Code :
  1. ps -aux | grep gest
  2. Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
  3. root      4614  0.0  0.0   2696   844 ?        S    19:29   0:01 /bin/sh /etc/rc2.d/S99gest-ati-freq start
  4. guepe    31040  0.0  0.0   2924   804 pts/0    R+   20:10   0:00 grep gest


 
Pour moi tout va bien ??  
Ah oui, je precise que j'ai configure le script pour qu'il demarre en init 1 2 3 4 5 en S99... je pense que c'est bon???
 
Bah, a bientot pour un nouvel episode !!!  :(


---------------
Un blog qu'il est bien
n°844517
guepe
J'ai du noir sur la truffe ?
Posté le 20-09-2006 à 04:12:16  profilanswer
 

Voila la fin d'un long feuilleton..
J'ai simplement mis le script en demarrage de ma session gnome via Systeme->preferences->sessions onglet programmes au demarrage.. j'ai ajoute le chemin vers mon script, nickel !!!!
 
Pour quelqu'un qui serait interesse ;-)


---------------
Un blog qu'il est bien

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Codes et scripts

  [resolu] Script démarrant automatiquement (init.d)

 

Sujets relatifs
[RESOLU]Debian - Xorg - Nvidia - bi écran[RESOLU] phpmyadmin+mysql
Installer Firefox 2.0 b2 pour Ubuntu avec ses dictionnaires (résolu)[Résolu]Mandiva 2006 et NVIDIA CK804 : pas de basses ???
[Résolu] XChat Autojoin keyAide sur création de sous dossier avec droit par script
[Résolu] [SSH] Server Refused Our KeyScript démarrage adsl
Heure du pc & Ubuntu [resolu]Installation de log / script
Plus de sujets relatifs à : [resolu] Script démarrant automatiquement (init.d)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR