Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1456 connectés 

  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  Problème initialisation récepteur I.R. rs232 hollywood+

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème initialisation récepteur I.R. rs232 hollywood+

n°9641061
madcat
Posté le 25-10-2015 à 17:05:36  profilanswer
 

Je dois me servir temporairement d'un récepteur ir realmagic hollywood+ (oui ça date !).
 
Ca fonctionne impecc sauf un soucis assez gênant: je suis obligé de démarrer le pc avec le récepteur débranché du port série car sinon le port com associé est inaccessible, et donc l'appli sensée se servir du récepteur IR (girder en l'occurrence) ne peut pas y accéder.
 
Ca ne vient pas de l'appli girder, le problème est le même avec pc remote control, ou encore avec le soft serial watcher qui permet de sniffer ces ports. Lui me dit que le port ne peut pas être ouvert car il est utilisé ou bloqué par une autre appli.
 
J'ai vérifié avec process explorer qui ne me donne aucun processus qui utiliserait ce port com.
 
Le soucis devrait donc venir soit de windows 7, soit de la carte mère lors de l'initialisation au boot du port série avec le récepteur IR branché dessus (et alimenté par lui).
 
Qu'est-ce que je pourrais tenter pour remédier au problème ? Changer le numéro de port com ne donne rien et je n'ai pas vu grand chose dans le bios qui pourrait aider. Reste la solution de mettre un interrupteur au niveau du branchement sur le port série qui rendrait juste le branchement à chaud un peu moins pénible, ou éventuellement un circuit électronique qui se chargerait de faire le branchement automatiquement en le temporisant jusqu'au démarrage de win7 (mais faut le faire).
 
Le mieux serait d'arriver à comprendre pourquoi le port série se retrouve inaccessible si je boot avec le récepteur IR branché. L'OS ne semble pourtant pas faire de détection erronée du récepteur IR (pas de détection comme un souris/clavier par exemple, dont le driver windows pourrait bloquer l'accès au port com ensuite).
 
La CM est une asus P35DS3P rev 1.1


Message édité par madcat le 25-10-2015 à 17:47:45

---------------
" Mais putaaain... Mais les gars qu'est-ce qu'ils font quoi, ils développent un jeu quoi ils essayent leur truc là ? ils essayent ? ils s'voyent voyent pas qu'c'est d'la merde !? "
mood
Publicité
Posté le 25-10-2015 à 17:05:36  profilanswer
 

n°9641437
aesebu
Posté le 26-10-2015 à 09:21:08  profilanswer
 

Il faudrait peut-être déjà installer le driver pour le chipset si ce n'est déjà fait.  
 
Après, voir peut-être au niveau des IRQ, est-ce que le port Com est partagé avec un autre périphérique?

n°9642253
madcat
Posté le 26-10-2015 à 23:44:55  profilanswer
 

J'avais regardé ces 2 points déjà, le driver du chipset est installé et l'IRQ n'est pas partagé.
 
Je vais vérifier s'il y aurait un driver plus récent pour le chipset, l'OS ayant été installé il n'y a pas longtemps possible que je n'ai pas remis la dernière version.


---------------
" Mais putaaain... Mais les gars qu'est-ce qu'ils font quoi, ils développent un jeu quoi ils essayent leur truc là ? ils essayent ? ils s'voyent voyent pas qu'c'est d'la merde !? "
n°9642398
aesebu
Posté le 27-10-2015 à 09:36:04  profilanswer
 

En fait les ports série sont géré par un circuit IT8718 qui est relié sur le chipset ICH9R. C'est bête, car ce circuit possède un port IR pour une télécommande TV, mais il n'y a pas de connecteur pour.  
 
Je suis tombé sur un driver pour le IT8718, mais j'ai l'impression que c'est pour une carte contrôleur à base de ce circuit.

n°9642630
madcat
Posté le 27-10-2015 à 13:29:14  profilanswer
 

Alors j'ai mis à jour les pilotes intel ICH9R justement, ça m'a màj les pilotes de contrôleur sata et bus smb mais je suppose qu'il n'est pas en lien avec le port com (?)

 

Et sinon j'ai aussi testé les 4 IRQ assignables manuellement au port com dans le bios (ainsi que le mode auto) mais le problème persiste :(

 

Ca ne fonctionne que si j'allume le pc avec le récepteur IR débranché. Si j'allume avec le récepteur branché et que j'attends d'être sous windows pour débrancher-rebrancher, le port com reste inaccessible.

 

Je vais regarder si j'ai le dernier bios mais je pense que oui. Mais pas sûr que le soucis vienne de la CM, ça pourrait être win7 ? Je vais vérifier mais je crois que ça fait pareil sur mon nouveau PC à base d'I7. Si c'est le cas alors ça serait plutôt un soucis avec windows.


Message édité par madcat le 27-10-2015 à 13:30:21

---------------
" Mais putaaain... Mais les gars qu'est-ce qu'ils font quoi, ils développent un jeu quoi ils essayent leur truc là ? ils essayent ? ils s'voyent voyent pas qu'c'est d'la merde !? "
n°9645240
madcat
Posté le 29-10-2015 à 23:36:27  profilanswer
 

Solution mise en oeuvre actuellement: arrêter le PC en mode S3.
Ca fera le job jusqu'à réception de la future télécommande.


---------------
" Mais putaaain... Mais les gars qu'est-ce qu'ils font quoi, ils développent un jeu quoi ils essayent leur truc là ? ils essayent ? ils s'voyent voyent pas qu'c'est d'la merde !? "

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  Problème initialisation récepteur I.R. rs232 hollywood+

 

Sujets relatifs
Problème utilisation mémoireProblème après formatage [Résolu]
Problème aléatoire de micro-freezeProblème disque dur non reconnu nouveau pc
LDLC problème/litige SAV carte graphique !!![Résolu] NVIDIA QUADRO K1200 | ZALMAN H1 : Problème montage ?
Problème sur mon nouveaux pc[HELP] Problème avec Ati Saphire 7950 Vapor X
[Probleme] r9 290 impossible de voir l ecranGTX 970 Probleme Ventilateurs
Plus de sujets relatifs à : Problème initialisation récepteur I.R. rs232 hollywood+


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR