Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1938 connectés 

  FORUM HardWare.fr
  Hardware
  Disque dur

  [RESOLU] Disque Dur Spinpoint F1 : 0 Mb dans le BIOS et Partition RAW

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[RESOLU] Disque Dur Spinpoint F1 : 0 Mb dans le BIOS et Partition RAW

n°6672203
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 15:52:58  profilanswer
 

Bonjour,
 
Tout d'abord ma config: Q6700, P5K Premium, 4Gb Crucial ballistix, HD4870 Sapphire, OS sur un disque SSD, Spinpoint F1 1To pour les data.
Tout fonctionnait a merveille jusqu'a avant hier. Partitions NTFS pour le disque Samsung.
 
Jusqu'a aujourd'hui j'avais un gentil disque dur d'1 To pour les data qui n'avait pas d'OS dessus, je l'ai mi dans mon HTPC : E7200, GA-G33M-DS2R, 2Gb Crucial, Spinpoint T166 500Gb, HD3850. Toujours SANS OS.
 
Je reboot le HTPC et là le disque sous windows est en format RAW...Super !
Je vais voir dans le BIOS en redemarrant, le Spinpoint F1 1To est reconnu, mais affiché comme ayant 0 octets ds le BIOS (F4 pas le dernier) de la gigabyte !! ARG !
 
Je re-déplace le HD sur la P5K Premium et là, tout pareil, le BIOS de la P5K me l'affiche comme étant bel et bien un Samsung F1 mais 0Mb !!
En retournant sous windows, toujours en RAW le HD...
 
Je lance un GetDataBack, il me trouve une partition FAT16 de 8Gb ...Toujours avec le bon nom de HD mais fausse capacité...Pareil pour TestDisk qui me détecte que 8Gb (7.8G en octets).
Sachant que ce n'est pas la bonne taille, je n'ai pas formaté of course.
 
Donc:
 
1/ Primo, j'imagine que pour ESPERER recup des data, faut deja que le BIOS le detecte correctement...Une idée ?
2/ Pour tjrs ESPERER recup qque chose, il faut que TestDisk et GetDataBack NTFS détectent aussi la bonne taille (induite par le BIOS j'imagine ?)
 
Need some SERIOUS Help les gens :D
merci !


Message édité par BOD13 le 03-11-2008 à 20:13:47

---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
mood
Publicité
Posté le 02-11-2008 à 15:52:58  profilanswer
 

n°6672226
Power Nabo​t
Verticalement désavantagé.
Posté le 02-11-2008 à 16:02:38  profilanswer
 

Essaye en bootant depuis une distribution Linux voire si ça ne changerais pas quelque chose, ou depuis UBCD ;)


---------------
Encore une victoire de canard !
n°6672256
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 16:16:53  profilanswer
 

Le probleme c'est que meme testDisk qui est basé sur du linux, m'affiche:
 
Disk/dev/sda : 8455 Mb / Samsung HD103UJ
 
Soit 8GB...au lieu d'un pti Tera... :(
 
[EDIT] l'utilitaire ESTOOL fournit par Samsung pour un diagnostic des disques durs, me trouve un disque de 31MB (le BIOS de la DS2R aussi a trouve cette taille avant de m'afficher 0 la fois suivante). Cet utilitaire bootable sous DOS m'a indique un " BAD SECTORS" et me recommande d'utilser ERASE HD que je n'ai pas fait bien entendu...


Message édité par BOD13 le 02-11-2008 à 17:05:26

---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6672353
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 17:05:30  profilanswer
 

up !
Pour apporter de l'eau au moulin de la detresse ;)
 
http://liamclarke.free.fr/gestion_disk_WinXP.JPG
 
C'est le disque 0, le disque 1 est un RAID de SSD
 
La gestion des disques de Windows, tout comme TestDisk et GetDataBack NTFS me trouve que 8Gb...


Message édité par BOD13 le 02-11-2008 à 17:21:30

---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6672449
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 18:05:18  profilanswer
 

MAJ-
 
TestDisk screen :
 
http://liamclarke.free.fr/testdisk_wrong_size.JPG
 
8Gb seulement...


Message édité par BOD13 le 02-11-2008 à 18:05:58

---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6672504
Profil sup​primé
Posté le 02-11-2008 à 18:38:38  answer
 

limitation à 8go => vérifie si le disque est en mode LBA dans le bios de la mobo.

n°6672607
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 19:17:27  profilanswer
 

Il est en AUTO et les autres options disponibles sont juste "DISABLED" pour le LBA.
 
Par contre, petit update : avec PTEDIT, le code "Type" est 04 => FAT16 <32Mb partition.
 
D'ou pendant un reboot sur la GA-DS2R la taille du disque à 32Mb ds le BIOS et de même sous le soft ESTOOL de Samsung (ss DOS) pour le diagnostic de HD.
 
Je l'avais fait il y a longtemps, mais en changeant le type de partition on n'altère pas les données ds PTEDIT ? Si je mets NTFS (code "07" ) au lieu de "04" erroné de toute façon !


Message édité par BOD13 le 02-11-2008 à 19:23:44

---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6672651
Power Nabo​t
Verticalement désavantagé.
Posté le 02-11-2008 à 19:34:58  profilanswer
 

Même après un formatage, si tu ne réécris pas dessus, des logiciels de récupération de données te permettrons de retrouver celles-ci ;)


---------------
Encore une victoire de canard !
n°6672673
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 19:42:11  profilanswer
 

je vais surement me lancer dans la remise en ordre de l'amorce, MBR ou MFT si necessaire par la suite. AU moins je pourrais dire que j'ai tenté ce qu'il y avait à tenter ;)


---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6672871
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 21:05:22  profilanswer
 

qqun sait utiliser HDAT2 pour changer le "maximum LBA sectors" ?


---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
mood
Publicité
Posté le 02-11-2008 à 21:05:22  profilanswer
 

n°6673106
BOD13
Pog Me Thon!
Posté le 02-11-2008 à 23:19:33  profilanswer
 

Bon HDAT2 m'a permis a l'aide de la commande "SET MAX ADRESS" de faire apparaitre les 900Go restant du disque, une limite etait apparu à 32Mb (le cache), par contre ils sont en "non assignés" sous windows.
 
Je vais tenter de récup les données maintenant que la partition est visible...
 
Premier gros update du probleme ;) youpi ^^


---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6673376
BOD13
Pog Me Thon!
Posté le 03-11-2008 à 09:42:13  profilanswer
 

Saga terminée ;)
 
Combo gagnant:
 
1/ HDAT2 : pour remettre la "Max cluster address" a 1To avec "set Max address" => on retrouve les 900Go restants ds le gestionnaire de disque et ds le BIOS bien entendu
 
2/ TestDisk:  On a la bonne taille de disque à présent , donc on lance un TestDisk qui retrouve les partitions dans les 900Gb "non alloués" pour repecher les données
 
Voilà, si çà peut aider des gens qui ont/auront le meme probleme, un petit feedback coute rien :D


Message édité par BOD13 le 03-11-2008 à 09:42:23

---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6674229
Power Nabo​t
Verticalement désavantagé.
Posté le 03-11-2008 à 16:05:04  profilanswer
 

Merci en tout cas :jap:
Un petit [Résolu] devant ton titre pour indiquer à d'autres que la solution se trouve dans le topic ?


---------------
Encore une victoire de canard !
n°6674856
BOD13
Pog Me Thon!
Posté le 03-11-2008 à 20:11:40  profilanswer
 

ok j'update çà !


---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°6743200
BOD13
Pog Me Thon!
Posté le 15-12-2008 à 17:15:58  profilanswer
 

Je mets juste à jour:
 
HDAT2: version utilisée v4.53 (et pas la 4.52 de l'Ultimate Boot CD 4.1.1 qui ne marchait pas pour mon disque d'1TB!)
 
TestDisk: version 6.10 windows, partition "Intel-PC" a selectionner, puis "Analyse".
 
A noter qu'il faut checker dans le BIOS et dans la gestion des disques, la taille de la partition RAW apres la manip HDAT2. Il faut que la partition soit de la taille CORRECTE du disque.
 
Voilà, j'espere que c'est assez complet pour aider les gens ds ce meme cas de figure ! :D


Message édité par BOD13 le 15-12-2008 à 17:16:34

---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°7653812
itsigo
Posté le 11-11-2010 à 22:52:19  profilanswer
 

même si c'est un vieux topic, effectivement j'ai réussi à remettre la partition en marche avec hdat2, un disque dur de 1 to qui avais le même problème mentionner plus haut.
 
Sur le 1er écran entrer "1" (fonction CD only)
- Sur le 2e écran entrer "hdat2" Pour les claviers français azerty ce sera "hdqt2"  
- sélectionner set max
- ensuite vous arriver sur deux choix
 1) le lba de votre disque dur pour moi c'était lba : 1953525168
 2) le deuxième était lba : 0
- sélectionné le premier choix et puis appuyer sur "inser"  
 
et le tour et jouer.
ça aidera ceux qui n'y connaissent pas grand chose
je l'ai fait avec la dernière version sans problème.


Message édité par itsigo le 11-11-2010 à 22:53:11

---------------
[marque d'alimentation de merde à éviter: Heden, Advance, Lc power, xilence,SHAI,mad-x,Top lite,E-tech ou autre marque chinoise.]  [marque recommandé : Akasa, Antec, Be quiet, Cooler Master, Corsair, Enermax, Evga, Fsp Fortron, Lepa, Seasonic, Zalman]
n°7673269
BOD13
Pog Me Thon!
Posté le 25-11-2010 à 15:39:12  profilanswer
 

cool de voir qu'un de mes vieux topoc aide encore :D


---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !
n°7817263
lafouine75
Posté le 03-03-2011 à 11:26:40  profilanswer
 

Bonjour,
Il m'arrive la même bricole avec un disque hitachi 7k1000. Je m’apprêtais à le jeter quand je suis tombé sur ce topic :).
Je testerais ce soir.
Par curiosité qu'est ce qui a pu provoquer ce problème?  
Peut on considérer que le disque est fiable après opération ou bien s'agit il simplement d'une méthode pour récupérer ses données? Ce qui est déjà pas mal :)
Pour ceux qui ont testé Bod13 et Itsigo vos disques fonctionnent il toujours?
 
Merci d'avance et je vous fais un retour ce soir :)
 
Super topic


Message édité par lafouine75 le 03-03-2011 à 11:27:41
n°7818380
lafouine75
Posté le 04-03-2011 à 01:18:53  profilanswer
 

Ca y est j'ai trouvé un moment pour tester et cela a fonctionné :D
Je vais m'empressé de sauvegarder mon tera.
 
Merci beaucoup
 
Juste pour information je suis sous windows 7 ultimate 64 et je n'ai eu qu'a utiliser hdat2 en version 4.8.1 pour retrouver la capacité du disque.  
Windows a fait le reste. Partition reconnu de suite sans testdisk
 
Encore merci pour ce tuto :)

n°7927780
BOD13
Pog Me Thon!
Posté le 04-06-2011 à 13:34:21  profilanswer
 

cool que çà serve encore ;) lol
 
Comme quoi, laisser une petite analyse avec la résolution du probleme "grave" de perte de disque est toujours une bonne idée :D


---------------
Éire go Brágh || 2009-2011-2012 HCUP Champions !

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Disque dur

  [RESOLU] Disque Dur Spinpoint F1 : 0 Mb dans le BIOS et Partition RAW

 

Sujets relatifs
Probleme Boot avec Disque dure ExterneDisque dur externe 3.5 Verbatim USB 2 500GB et bloc défectueux
[Résolu] Cable non approprié (VGA)[auto-résolu] gros problème HD...HELP
limitations bios NF325-A7Memtest Erreur [RESOLU]
Impossible de rentrer dans le BIOSDisque dur plein (miniscule mémoire)
Problème Samsung SpinPoint M6S ?[RESOLU]Problemes stabilité windows/jeux/winrar/firefox...
Plus de sujets relatifs à : [RESOLU] Disque Dur Spinpoint F1 : 0 Mb dans le BIOS et Partition RAW


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR