Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1868 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Télécom

  Cohabitation des ip phones SIP et SCCP sur Cisco 3945

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Cohabitation des ip phones SIP et SCCP sur Cisco 3945

n°143056
tombko
Posté le 02-11-2016 à 18:27:00  profilanswer
 

Bonjour,  
 
Espérant vous trouver en pleine forme, je viens vous demander de l'aide pour la configuration d'un ajout d'une vingtaine d'ip phone SPA-525G2 et d'une dizaine de CP-8841 sur un CISCO 3945 déjà en production avec deux centaines de ip phone 7911.  
Les ip phone 7911 fonctionne en SCCP tandis que les autres modèles à ajouter (SPA-525G2 et CP-8841) fonctionnent en SIP.  
j'ai deja chargé leurs firmwares, mais ils n'arrivent toujours pas à obtenir d'adresse ip.  
 
Je vous remercie d'avance !

mood
Publicité
Posté le 02-11-2016 à 18:27:00  profilanswer
 

n°143063
campesinos
Posté le 03-11-2016 à 10:16:41  profilanswer
 

Faudra être un peu plus précis quand même.
Tes postes SIP sont sur un VLAN dédié ? Ou se trouve ton DHCP ? Sur quel VLAN ? Comment as-tu chargé leur firmware ?...

n°143065
tombko
Posté le 03-11-2016 à 12:15:33  profilanswer
 

Je vous remercie Campesinos d'avoir réagis aussi vite. Je vous précise comment j'ai procéder:
 - Les ip phone SCCP 7911 sont deployés sur le Flash0 et actuellement cette flash0 n'a plus d'espace libre pour héberger d'autre fichier. J'ai insérré  
une autre memoire flash de 256 MB pareille que celle qui se trouve dans le slot 0. Actuellement les deux memoire font 512 MB.
 - Les ip phones SIP de modèles SPA-525G2 et CP-8841 ont leur fichier firmware copiés dans le flash1.
 - Les téléphones SCCP et SIP sont tous dans le même Vlan 15 et leur passerelle est 192.168.5.254/24.
 - Pour copier les firmwares, j'utilise en mode privilégié la commande copy tftp: flash1: ensuite adresse tftp et enfin je copie le nom des firmware un à un à partir de l'application TFTP.
Les firmware pour SPA-525G2 sont:
  - spa525g-7-4-9a.bin
  - spa525g-7-4-9a-bt.bin
 
Les firmware pour CP-8841 sont:
  - fbi88xx.10-3-1-9-3PCC.sbn
  - kern88xx.10-3-1-9-3PCC.sbn
  - rootfs88xx.10-3-1-9-3PCC.sbn
  - sb288xx.10-3-1-9-3PCC.sbn
  - sip88xx.10-3-1-9-3PCC.loads
  - vc488xx.10-3-1-9-3PCC.sbn
Ce sont les fichiers que j'ai copier dans le flash pour SPA-525G et pour CP-8841
  Mais, dans les config, je n'ai pas pu préciser le type de mes téléphone car il n'y avait ni le type 525G2, ni le type 8841. Les ip phones SCCP et SIP  
s’adressent tous à la passerelle 192.168.5.254 pour des infos d'adresse ip et d'autre fichiers contenus dans la mémoire flash.
Voilà un peu comment j'ai procéder, je vous suis disponible pour toute autre précision.
 
Je vous REMERCIE !

n°143067
campesinos
Posté le 03-11-2016 à 16:24:34  profilanswer
 

Ca me semble un peu compliqué et fastidieux cette méthode pour mettre les firmwares, mais passons.
Le problème le plus urgent (de ce que je comprends) c'est de régler ton soucis de dhcp.
Le serveur dhcp est où et qui tient ce rôle (serveur dhcp windows, cisco, ipbx)? dans quel VLAN est-il ? Si autre vlan, un agent relaie est configuré ? Tes postes sccp sont en dhcp ? Ils obtiennent des ip ?

n°143068
tombko
Posté le 03-11-2016 à 17:18:27  profilanswer
 

Le serveur DHCP est le ipbx lui même qui n'est autre que le Cisco 3945. il est le seul à tout gérer. Les telephone SCCP et SIP sont tous dans le même Vlan et s'adresse à une même adresse pour  
récupérer les adresses ip et les firmware. Les telephones existant SCCP fonctionne sans problème mais les SIP pas encore.
 
Merci !

n°143073
campesinos
Posté le 04-11-2016 à 06:04:04  profilanswer
 

Ok, donc tout ce petit monde étant dans le même VLAN tes postes SIP ne devraient pas avoir de problème pour obtenir une IP.
Ton scope dhcp est-il assez large ?
Que disent les logs ? Normalement tu dois voir les demandes de bail avec les mac address correpondante
Tes postes SIP sont-ils configurés en IP dynamique ? Vérifies les paramètres directement sur les postes.
Il faut savoir ce que font tes postes quand ils démarrent, donc au pire tu mets en place en mirroring du port d'un poste sip et tu captures le traffic (tcpdump, wireshark...) pour voir les requêtes dhcp.
.

n°143084
tombko
Posté le 04-11-2016 à 14:27:17  profilanswer
 

J'ai encore une cinquantaine d'adresses ip disponible et les log n'affichent rien de  
nouveau concernant les SIP. Les postes SIP sont bien en DHCP. J'ai essayé de les  
mettre manuellement dans le vlan 15, mais toujours pas de reponse de la part de DHCP.
 
Je peux toute fois vous faire un show running et vous l'envoyez pour que puissiez mieux  
discerner mon problème ?
 
Je vous REMERCIE !

n°143085
campesinos
Posté le 04-11-2016 à 14:36:31  profilanswer
 

Tu peux toujours balancer ta conf mais il te faudra comprendre pourquoi ton dhcp n'attribue pas d'IP, c'est forcément indiqué dans les logs, sinon tu fais une capture de trame pour voir ce qu'il se passe.

n°143091
tombko
Posté le 04-11-2016 à 15:58:51  profilanswer
 


Router_CME#sh run
Building configuration...
 
 
Current configuration : 53167 bytes
!
! Last configuration change at 12:54:41 UTC Fri Nov 4 2016 by root
! NVRAM config last updated at 10:41:58 UTC Wed Nov 2 2016 by root
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router_CME
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
enable secret 5 $1$zO0s$8VWr9II/ISslnF7VivF9j.
!
no aaa new-model
network-clock-participate wic 0
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.5.1 192.168.65.10
ip dhcp excluded-address 192.168.5.254
!
ip dhcp pool IP-PHONES
 network 192.168.5.0 255.255.255.0
 default-router 192.168.5.253
 option 150 ip 192.168.5.253
 lease 7
!
!
!
no ip domain lookup
ip domain name BMS-SA.LOCAL
ip name-server 192.168.4.50
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
isdn switch-type primary-net5
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-797832819
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-797832819
 revocation-check none
 rsakeypair TP-self-signed-797832819
!
!
crypto pki certificate chain TP-self-signed-797832819
 certificate self-signed 01
  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D
  DC296582 19811B82 3F3CF7BD CF
        quit
voice-card 0
!
voice service voip
 ip address trusted list
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 modem passthrough nse codec g711ulaw
 h323
  no h225 timeout keepalive
 sip
  registrar server
  asymmetric payload full
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729br8
 codec preference 4 g729r8
!
!
!
!
voice register pool-type  exi
!
voice register global
 mode  cme
 source-address 192.168.5.254 port 5060
 bandwidth video tias-modifier 512000 negotiate end-to-end
 max-dn 100
 max-pool 50
 load E20 spa525g-7-4-9a-bt.bin
 timezone 22
 time-format 24
 date-format D/M/Y
 tftp-path flash:
 create profile sync 008524392504846A
 network-locale FR
 camera
 video
!
voice register dn  1
 number 1188
 label ADG
!
voice register dn  2
 number 1199
 label DTC
!
voice register pool  1
 busy-trigger-per-button 2
 id mac 547C.6942.48C6
 number 1 dn 1
 dtmf-relay sip-kpml
 codec g711ulaw
 camera
 video
 transfer max-length 4
!
!
!
!
!
license udi pid C3900-SPE150/K9 sn FOC191689K4
hw-module pvdm 0/0
!
!
!
username root privilege 15 password 7 1510061F172338747965
username ablosam privilege 15 password 7 06540E321C1F5F390804
!
redundancy
!
!
controller E1 0/0/0
 framing NO-CRC4
 pri-group timeslots 1-31
!
ip ssh version 2
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.15
 description CONNECT TO DIS-TEL GigabitEthernet0/48
 encapsulation dot1Q 15
 ip address 192.168.5.254 255.255.255.0
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.168.5.254
!
interface GigabitEthernet0/0.99
 encapsulation dot1Q 99 native
 ip address 192.168.99.51 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:15
 description Appel Exterieur
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn incoming-voice voice
 isdn sending-complete
 no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!
ip route 192.168.1.0 255.255.255.0 192.168.99.1
ip route 192.168.4.0 255.255.255.0 192.168.99.100
ip route 192.168.61.0 255.255.255.0 192.168.99.1
!
!
nls resp-timeout 1
cpd cr-id 1
!
tftp-server flash Analog1.raw
tftp-server flash Analog2.raw
tftp-server flash AreYouThere.raw
tftp-server flash AreYouThereF.raw
tftp-server flash Bass.raw
tftp-server flash CallBack.raw
tftp-server flash Chime.raw
tftp-server flash Classic1.raw
tftp-server flash Classic2.raw
tftp-server flash ClockShop.raw
tftp-server flash DistinctiveRingList.xml
tftp-server flash Drums1.raw
tftp-server flash Drums2.raw
tftp-server flash FilmScore.raw
tftp-server flash HarpSynth.raw
tftp-server flash Jamaica.raw
tftp-server flash KotoEffect.raw
tftp-server flash MusicBox.raw
tftp-server flash Piano1.raw
tftp-server flash Piano2.raw
tftp-server flash Pop.raw
tftp-server flash Pulse1.raw
tftp-server flash Ring1.raw
tftp-server flash Ring2.raw
tftp-server flash Ring3.raw
tftp-server flash Ring4.raw
tftp-server flash Ring5.raw
tftp-server flash Ring6.raw
tftp-server flash Ring7.raw
tftp-server flash RingList.xml
tftp-server flash Sax1.raw
tftp-server flash Sax2.raw
tftp-server flash apps11.9-2-1TH1-13.sbn
tftp-server flash cnu11.9-2-1TH1-13.sbn
tftp-server flash cvm11sccp.9-2-1TH1-13.sbn
tftp-server flash dsp11.9-2-1TH1-13.sbn
tftp-server flash jar11sccp.9-2-1TH1-13.sbn
tftp-server flash SCCP11.9-2-1S.loads
tftp-server flash term06.default.loads
tftp-server flash term11.default.loads
tftp-server flash:7921-dictionary.xml
tftp-server flash:7921-font.dat
tftp-server flash:7921-kate.utf-8.xml
tftp-server flash:7921-kate.xml
tftp-server flash:be-sccp.jar
tftp-server flash:CME-locale-fr_FR-French-8.6.2.4.tar.cfg
tftp-server flash:g3-tones.xml
tftp-server flash:gd-sip.jar
tftp-server flash:gp-sccp.jar
tftp-server flash:ipc-sccp.jar
tftp-server flash:mk-sccp.jar
tftp-server flash:rp-sccp.jar
tftp-server flash:rtl-sccp.jar
tftp-server flash:tags_file
tftp-server flash:tc-sccp.jar
tftp-server flash:td-sccp.jar
tftp-server flash:utf8_tags_file
tftp-server flash:7921-dictionary.xml alias 7921-dictionary.xml
tftp-server flash:7921-font.dat alias 7921-font.dat
tftp-server flash:7921-kate.utf-8.xml alias 7921-kate.utf-8.xml
tftp-server flash:7921-kate.xml alias 7921-kate.xml
tftp-server flash:be-sccp.jar alias be-sccp.jar
tftp-server flash:CME-locale-fr_FR-French-8.6.2.4.tar.cfg alias CME-locale-fr_FR-French-8.6.2.4.tar.cfg
tftp-server flash:g3-tones.xml alias g3-tones.xml
tftp-server flash:gd-sip.jar alias gd-sip.jar
tftp-server flash:gp-sccp.jar alias gp-sccp.jar
tftp-server flash:ipc-sccp.jar alias ipc-sccp.jar
tftp-server flash:mk-sccp.jar alias mk-sccp.jar
tftp-server flash:rp-sccp.jar alias rp-sccp.jar
tftp-server flash:rtl-sccp.jar alias rtl-sccp.jar
tftp-server flash:tags_file alias tags_file
tftp-server flash:tc-sccp.jar alias tc-sccp.jar
tftp-server flash:td-sccp.jar alias td-sccp.jar
tftp-server flash:utf8_tags_file alias utf8_tags_file
tftp-server flash:apps42.9-4-2ES9.sbn
tftp-server flash:cnu42.9-4-2ES9.sbn
tftp-server flash:cvm42sccp.9-4-2ES9.sbn
tftp-server flash:dsp42.9-4-2ES9.sbn
tftp-server flash:jar42sccp.9-4-2ES9.sbn
tftp-server flash:SCCP42.9-4-2SR1-1S.loads
tftp-server flash:term42.default.loads
tftp-server flash:term62.default.loads
!
control-plane
!
!
voice-port 0/0/0:15
 cptone FR
 description T2 SOTELMA
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer cor custom
 name Fixe
 name Mobile
 name Local
 name International
!
!
dial-peer cor list AppelFixe
 member Fixe
 member Local
!
dial-peer cor list AppelMobile
 member Fixe
 member Mobile
 member Local
!
dial-peer cor list AppelFull
 member Fixe
 member Mobile
 member Local
 member International
!
dial-peer cor list AppelLocal
 member Local
!
!
dial-peer voice 2 pots
 corlist outgoing AppelMobile
 tone ringback alert-no-PI
 description Appel Mobile
 destination-pattern 0[4-9].......
 progress_ind alert enable 8
 incoming called-number .
 fax rate voice
 direct-inward-dial
 port 0/0/0:15
 forward-digits 8
!
dial-peer voice 3 pots
 corlist outgoing AppelFull
 tone ringback alert-no-PI
 description AppelFull
 destination-pattern 000.+T
 progress_ind alert enable 8
 incoming called-number .
 direct-inward-dial
 port 0/0/0:15
 prefix 00
!
dial-peer voice 4 pots
 corlist outgoing AppelLocal
 tone ringback alert-no-PI
 description Appel Local
 destination-pattern [0-7]...
 incoming called-number .
 direct-inward-dial
 forward-digits 4
!
dial-peer voice 1 pots
 corlist outgoing AppelFixe
 tone ringback alert-no-PI
 description Appel National
 destination-pattern 2.......
 progress_ind alert enable 8
 incoming called-number .
 direct-inward-dial
 port 0/0/0:15
 forward-digits 8
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 conference transfer-pattern
 no auto-reg-ephone
 max-ephones 365
 max-dn 900
 ip source-address 192.168.65.253 port 2000
 timeouts ringing 30
 system message BMS TELEPHONE SERVICE
 url services http://192.168.5.254/voiceview/common/login.do
 url authentication http://192.168.5.254/CCMCIP/authenticate.asp
 cnf-file location flash:
 user-locale FR
 network-locale FR
 load 7911 term11.default.loads
 time-zone 22
 time-format 24
 date-format dd-mm-yy
 dialplan-pattern 1 2070.... extension-length 4
 max-conferences 154 gain -6
 multicast moh 239.10.10.11 port 2000
 web admin system name admin password cisco
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp 7960 Nov 01 2016 19:30:57
!
!
ephone-dn  1  dual-line
 number 8888
 label TOTO
 name TOTO
 corlist incoming AppelLocal
 hold-alert 30 originator
!
!
ephone-dn  2  dual-line
 number 9999
 label TOUTOU
 name TOUTOU
 corlist incoming AppelFull
 hold-alert 30 originator
!
!
!
ephone  1
 mac-address C062.6BD3.70E5
 type 7911
 button  1:1
!
!
!
ephone  2
 mac-address 001D.70FA.BB78
 type 7911
 button  1:2
!

n°143094
tombko
Posté le 05-11-2016 à 14:06:53  profilanswer
 

Bonjour campesinos,
 
Le problème d'adresse ip est résolu. le poste SIP a bel et bien une adresse IP de la même plage que  
les postes SCCP. Juste une mauvaise manipulation du poste. Je vous remercie de m'avoir aider.
  Le présent problème reste toujours que les postes SIP ne sont toujours pas opérationnel car ils n'arrivent  
toujours pas à charger leurs firmwares de la mémoire flash.
Je vous remercie !

mood
Publicité
Posté le 05-11-2016 à 14:06:53  profilanswer
 

n°143100
campesinos
Posté le 07-11-2016 à 12:09:19  profilanswer
 

Bonne nouvelle déjà.  :D

n°143101
tombko
Posté le 07-11-2016 à 12:11:13  profilanswer
 

ah oui, la suite m'intrigue jusqu'à présent. Merci pour tout !

n°143169
tombko
Posté le 09-11-2016 à 11:32:42  profilanswer
 

Excusez moi, mais je suis toujours en attente d'aide pour pouvoir rendre opérationnel mes ip phone SIP (SPA-525G2 et CP-8841)
 
Je vous remercie d'avance !


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Télécom

  Cohabitation des ip phones SIP et SCCP sur Cisco 3945

 

Sujets relatifs
CISCO création username et privilègesCisco authentication line con 0
Ouvrages de référence Cisco & Windows ServerTDR sur switch Cisco et probleme de CRC et Error Input
switch Cisco- erreur: impossible de définir '' avec 'Activer', erreurCreation interface vlan SWITCH 3850 CISCO
Plus de sujets relatifs à : Cohabitation des ip phones SIP et SCCP sur Cisco 3945



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR