Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1714 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Management du SI

  [Résolue] OCS - Remonté impossible

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolue] OCS - Remonté impossible

n°167271
haraxus
Posté le 02-01-2020 à 12:17:20  profilanswer
 

Bonjour,
 
J'ai monté une Debian 10 avec OCS Inventory afin de faire un inventaire de parc.
 
Lorsque que j'effectue la remonté des agents sur Windows j'ai ceci comme erreur :  
 

Code :
  1. ==============================================================================
  2. Starting OCS Inventory NG Agent on Thursday, January 02, 2020 11:56:55.
  3. AGENT => Running OCS Inventory NG Agent Version 2.6.0.0
  4. AGENT => Using OCS Inventory NG FrameWork Version 2.6.0.0
  5. AGENT => Loading plug-in(s)
  6. DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files\OCS Inventory Agent\plugins>
  7. DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
  8. AGENT => Using network connection with Communication Server
  9. COM PROVIDER => Loading Communication Provider <C:\Program Files\OCS Inventory Agent\ComHTTP.dll>
  10. AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.6.0.0>
  11. AGENT => Sending getLabel request
  12. COM SERVER => Initializing cURL library for getFile
  13. COM SERVER => Using cURL without server authentication
  14. COM SERVER => Disabling cURL proxy support
  15. COM SERVER => Disabling cURL SSL server validation support
  16. COM SERVER => Sending fileGet request to URL <http://192.168.1.5:3306/ocsinventory/deploy/label>
  17. WARNING *** COM SERVER => Failed to send HTTP Get request <Couldn't connect to server>
  18. COM SERVER => Cleaning cURL library
  19. AGENT => Failed to retrieve Label <Couldn't connect to server>
  20. AGENT => Sending Prolog
  21. DID_CHECK => Read DeviceID <PC-NEAU-2020-01-02-08-56-02> and MACs <00:FF:12:B3:23:3164:80:99:E1:03:790A:00:27:00:00:0C70:5A:0F:83:26:2800:FF:9C:F0:32:CE00:FF:BF:87:6E:D400:FF:EF:F9:A1:0100:15:5D:15:18:57> in file <ocsinventory.dat>
  22. COM SERVER => Initializing cURL library for sendRequest
  23. COM SERVER => Using cURL without server authentication
  24. COM SERVER => Disabling cURL proxy support
  25. COM SERVER => Disabling cURL SSL server validation support
  26. COM SERVER => Sending HTTP Post request to URL <http://192.168.1.5:3306/ocsinventory>
  27. WARNING *** COM SERVER => Failed to send HTTP Post request <Couldn't connect to server>
  28. COM SERVER => Cleaning cURL library
  29. ================= TRACE START ===============
  30. ================= TRACE STOP ===============
  31. ERROR *** AGENT => Failed to send Prolog <Couldn't connect to server>
  32. AGENT => Unloading communication provider
  33. AGENT => Unloading plug-in(s)
  34. AGENT => Execution duration: 00:00:43.


 
 
Voici les fichiers de conf :  
 
Z-ocsinventory-server.conf :
 
  # Master Database settings
  # Replace localhost by hostname or ip of MySQL server for WRITE
  PerlSetEnv OCS_DB_HOST localhost
  # Replace 3306 by port where running MySQL server, generally 3306
  PerlSetEnv OCS_DB_PORT 3306
  # Name of database
  PerlSetEnv OCS_DB_NAME OCS
  PerlSetEnv OCS_DB_LOCAL OCS
  # User allowed to connect to database
  PerlSetEnv OCS_DB_USER Test
  # Password for user
  PerlSetVar OCS_DB_PWD test123
 

dbconfig.inc.php :

 
<?php
define("DB_NAME", "OCS" );
define("SERVER_READ","localhost" );
define("SERVER_WRITE","localhost" );
define("COMPTE_BASE","test" );
define("PSWD_BASE","test123" );
?>
 
 
 
- Le compte test a bien les droits sur la BDD (MariaDB)
- Mes services MYSQL et APACHE 2 ont bien été reboot
- Les pare-feu sont désactivé sur les postes agent
- Je ping très bien le serveur OCS depuis mes postes agent
 
 
Voici le .ini des agents Windows :  
 
 
[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=2
Local=
NoSoftware=0
HKCU=0
NoTAG=0
IpDisc=
[HTTP]
Server=http://192.168.1.5:3306/ocsinventory
SSL=0
CaBundle=cacert.pem
AuthRequired=0
User=
Pwd=
ProxyType=0
Proxy=
ProxyPort=0
ProxyAuthRequired=0
ProxyUser=
ProxyPwd=
[OCS Inventory Service]
TTO_WAIT=1380
INVENTORY_ON_STARTUP=0
 
 
J'ai pas mal cherché sur le net et je n'ai pas trouvé de solution miracle pour le moment  :sweat:  
 
Si quelqu'un à une idée ou a déjà rencontré le soucis je suis preneur  :hello:


Message édité par haraxus le 03-01-2020 à 08:56:58
mood
Publicité
Posté le 02-01-2020 à 12:17:20  profilanswer
 

n°167279
roondar
Posté le 03-01-2020 à 00:41:03  profilanswer
 

Ton url http://192.168.1.5:3306/ocsinventory n'est sûrement pas bonne, le port devrait être 80 et non 3306 qui est pour mysql


Message édité par roondar le 03-01-2020 à 00:41:32
n°167281
skoizer
tripoux et tête de veau
Posté le 03-01-2020 à 08:48:36  profilanswer
 

j'ai regardé sur mes clients
c'est bien par défaut le port 80
Server=http://leserveurOCS.domaine.fr/ocsinventory


---------------
je veux tout, tout de suite, et gratuitement ! miladiou !
n°167282
haraxus
Posté le 03-01-2020 à 08:56:07  profilanswer
 

Bonjour,
 
Merci pour vos réponses , le problème venait simplement du port en effet mais pas seulement :)  
 
J'ai ensuite eu une erreur 500 , j'avais indiqué dans le Z-ocsinventory-server.conf "OCS" en maj alors que dans MariaDB celui-ci était en minuscule.
 
Merci encore :D


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Management du SI

  [Résolue] OCS - Remonté impossible

 

Sujets relatifs
Impossible de telecharger un kb WSUSRedirection internet explorer impossible afficher la page
Remonté alertes AlienVault / ELKla remonté automatique des noms des équipement avec Shinken
Lien Vlan qui "remonte" pasimpossible de contacter un contrôleur de domaine active directory pour
Connexion FTP avec filezilla impossible 
Plus de sujets relatifs à : [Résolue] OCS - Remonté impossible


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR