Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1889 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  [résolu] Déploiement imprimantes via GPO Preferences capricieux

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[résolu] Déploiement imprimantes via GPO Preferences capricieux

n°105185
i'm philou
Posté le 16-01-2013 à 22:12:04  profilanswer
 

Salut all
 
J'essaie de déployer des imprimantes via les GPOs préférences sur deux serveurs TSE (2008 R2 SP1 et 2008 32 bits SP2).
Ben, c'est ok sur le 2008 R2 mais pas sur l'autre.
 
Contexte :
les 2 serveurs sont dans la meme UO
Un ensemble de GPOs s'appliquent sur ces 2 serveurs sans distinction dont celle qui monte les imprimantes.
les imprimantes montés sont du genre "\\serveurX\copieur..."
les pilotes 32 bits de ces imprimantes sont bien installés sur le 2008 32 bits.
le meme utilisateur monte ses imprimantes sur le 2008 R2 mais pas sur l'autre.
AD 2008 R2, niveau fonctionnel idem.
 
Des idees ?  :)


Message édité par i'm philou le 02-02-2013 à 21:23:01
mood
Publicité
Posté le 16-01-2013 à 22:12:04  profilanswer
 

n°105200
Je@nb
Modérateur
Kindly give dime
Posté le 17-01-2013 à 10:17:40  profilanswer
 

Regarde les logs :)

n°105246
i'm philou
Posté le 18-01-2013 à 14:37:03  profilanswer
 

Rien dans l'obs d'évènements.
 
J'ai vu par contre, en cherchant sur le net qu'on pouvait activer un suivi de l'application des GPP.
Pour info, c'est un paramètre machine modfiable par GPO (Machine\Modele Administration\systeme\strategie de groupe\journalisation et suivi)
Il suffit de choisir ce que l'on veut auditer (mapp, imprimantes..)
 
je regarde et je reviens commenter.

n°105247
akizan
Eye Sca Zi
Posté le 18-01-2013 à 14:43:13  profilanswer
 

Tu utilises PushPrinterConnections.exe ? Car si oui tu as possibilité d'avoir un log qui donne pas mal d'aide.

n°105248
Je@nb
Modérateur
Kindly give dime
Posté le 18-01-2013 à 15:15:28  profilanswer
 

De tête PushPrinterConnections c'est pas pour les GPP

n°105754
i'm philou
Posté le 28-01-2013 à 19:29:04  profilanswer
 

Exact.
Rien dans les logs, je désespère...

n°105758
i'm philou
Posté le 28-01-2013 à 19:43:23  profilanswer
 

et si il me manquait un .net framework ?
parce que j'en ai aucun sur le serveur en question...
 

n°105775
i'm philou
Posté le 29-01-2013 à 10:51:12  profilanswer
 

Avec le Framework 4, c'est pas mieux...
 
Je précise le contexte : La GPP s'applique bien, donc c'est pas un problème d'application de GPOs. D'ailleurs, l'ouverture de session en mode verbose m'affiche bien "Group Policy Printers" mais ca passe tres vite, trop vite...comme s'il manquait quelque chose, un pré requis qui empeche le montage des imprimantes.
 
 
 

n°105781
Je@nb
Modérateur
Kindly give dime
Posté le 29-01-2013 à 11:40:35  profilanswer
 

Si tu installes l'imprimante à la main ça marche ou pas ?

n°105782
boobaka
Posté le 29-01-2013 à 11:43:49  profilanswer
 

J'ai été, egalement, confronté a quelques soucis sur le déploiement via GPP ..
Tu peux jouer sur l'option ciblage dans l'onglet commun ( de la partie imprimante de ta GPP).


---------------
www.google.fr  
mood
Publicité
Posté le 29-01-2013 à 11:43:49  profilanswer
 

n°105785
i'm philou
Posté le 29-01-2013 à 12:19:21  profilanswer
 

Hello
 
Je peux sans problème monter les imprimantes à la main.
les imprimantes mappées s'installent aussi
Je joue déjà sur l'option cliblage afin de ne monter que les imprimantes qui correspondent au plan d'adressage du poste client.
 


Message édité par i'm philou le 29-01-2013 à 12:20:19
n°105786
Je@nb
Modérateur
Kindly give dime
Posté le 29-01-2013 à 12:24:31  profilanswer
 

Tu as activé les logs pour débugger tes GPP ?
http://blogs.technet.com/b/askds/a [...] -rsat.aspx

n°105787
i'm philou
Posté le 29-01-2013 à 12:28:24  profilanswer
 

J'en parle plus haut  :D  et non, rien de particulier dans les logs.

n°105788
Je@nb
Modérateur
Kindly give dime
Posté le 29-01-2013 à 12:30:38  profilanswer
 

même si pas d'erreurs ils disent quoi ? :D

n°105825
i'm philou
Posté le 29-01-2013 à 17:18:16  profilanswer
 

sur celui ou c'est pas ok :
2013-01-29 12:35:12.277 [pid=0x3d4,tid=0x1554]         ( X ) GPO_INFO_FLAG_NOCHANGES - No changes were detected to the Group Policy Objects
2013-01-29 12:35:12.293 [pid=0x3d4,tid=0x1554] WMI namespace : No (0x00000000)
 
2013-01-29 12:35:12.324 [pid=0x3d4,tid=0x1554] GPH : C:\ProgramData\Microsoft\Group Policy\History\{AA367A2C-91F5-40C9-8FC8-1E40572D8373}\S-1-5-21-3172862664-821996187-3003522585-6644\Preferences\Printers\Printers.xml
2013-01-29 12:35:12.324 [pid=0x3d4,tid=0x1554] GPT : \\domaine.local\SysVol\domaine.local\Policies\{AA367A2C-91F5-40C9-8FC8-1E40572D8373}\User\Preferences\Printers\Printers.xml
2013-01-29 12:35:12.324 [pid=0x3d4,tid=0x1554] GPH data file : C:\ProgramData\Microsoft\Group Policy\History\{AA367A2C-91F5-40C9-8FC8-1E40572D8373}\S-1-5-21-3172862664-821996187-3003522585-6644\Preferences\Printers\Printers.xml
2013-01-29 12:35:12.386 [pid=0x3d4,tid=0x1554] GPE data file : \\domaine.local\SysVol\domaine.local\Policies\{AA367A2C-91F5-40C9-8FC8-1E40572D8373}\User\Preferences\Printers\Printers.xml

 
2013-01-29 12:35:12.402 [pid=0x3d4,tid=0x1554] Starting filter [AND FilterTerminal].
2013-01-29 12:35:12.402 [pid=0x3d4,tid=0x1554] Starting filter [OR FilterTerminal].
2013-01-29 12:35:12.402 [pid=0x3d4,tid=0x1554] Starting filter [OR FilterTerminal].
2013-01-29 12:35:12.402 [pid=0x3d4,tid=0x1554] Starting filter [OR FilterTerminal].
2013-01-29 12:35:12.402 [pid=0x3d4,tid=0x1554] Starting filter [OR FilterTerminal].
...
 
 
sur celui ou c'est ok :  
2013-01-29 12:35:12.277 [pid=0x3d4,tid=0x1554]         (  ) GPO_INFO_FLAG_NOCHANGES - No changes were detected to the Group Policy Objects
2013-01-29 14:17:47.822 [pid=0x344,tid=0x2a48] WMI namespace : Yes (0x05d1d380)
 
je n'ai pas ce qui est en italique plus haut
 
2013-01-29 14:17:47.869 [pid=0x344,tid=0x2a48] RunOnce value created [SUCCEEDED(S_FALSE)]
2013-01-29 14:17:47.869 [pid=0x344,tid=0x2a48] Starting filter [AND FilterTerminal].
2013-01-29 14:17:49.959 [pid=0x344,tid=0x2a48] RunOnce value created [SUCCEEDED(S_FALSE)]
2013-01-29 14:17:49.975 [pid=0x344,tid=0x2a48] Starting filter [OR FilterTerminal].
2013-01-29 14:17:49.975 [pid=0x344,tid=0x2a48] Starting filter [OR FilterTerminal].
...


Message édité par i'm philou le 29-01-2013 à 17:20:13
n°105827
i'm philou
Posté le 29-01-2013 à 17:21:11  profilanswer
 

En gras les differences, j'ai beau chercher partout sur le net, je trouve pas !  :(
J'ai essayé ce qui est noté ici (suppression des xml) http://support.microsoft.com/kb/979731/en-us?fr=1 sans succès


Message édité par i'm philou le 29-01-2013 à 17:25:31
n°105829
Je@nb
Modérateur
Kindly give dime
Posté le 29-01-2013 à 17:36:52  profilanswer
 

Regarde le fichier Printers.xml dans ton programdata, essaie de supprimer le contenu du dossier History
 
J'ai trouvé ça aussi http://support.microsoft.com/kb/973772/en-us
 
C'est lequel de log que tu regardes ? On dirait le log des gpo machines

n°105842
i'm philou
Posté le 29-01-2013 à 23:25:56  profilanswer
 

Le log est dans C:\ProgramData\GroupPolicy\Preference\Trace
 
Je viens de supprimer le dossier History présent dans "C:\ProgramData\Microsoft\GroupPolicy"  =>  tjs pareil
 
 

n°105850
i'm philou
Posté le 30-01-2013 à 09:40:16  profilanswer
 

Bon, au bout d'un moment, il fallait bien la faire celle là !  :pt1cable:  
A force de bricoler, j'ai malencontreusement détruit ma GPP en supprimant le "printers.xml" dans le dossier sysvol !
 
Du coup, je me suis repaluché les 38 imprimantes à redéclarer dans la GPP...ce qui m'a permis de voir en cours de route que les imprimantes finissaient bien par monter sur le serveur RDS 2008 32 bits tant que je ne mettais pas de ciblage !. De plus, si je suis admin ou utilisateur lambda, il ne se passe pas la meme chose.
 
Je fais des tests et je reviens...


Message édité par i'm philou le 31-01-2013 à 12:55:58
n°105947
i'm philou
Posté le 31-01-2013 à 12:19:47  profilanswer
 

:pfff:  pénible !
 
Alors, si les imprimantes sont "ciblées", je ne les vois pas du tout sur le serveur 2008 32 bits SP2. Si j'enleve le ciblage, elles apparaissent toutes dans une session Admin mais il m'en manque quelques unes dans une session User, pourtant meme GPP pour tout le monde et rien de particulier sur l'imprimante sur le serveur d'impression !   :pt1cable:  
 
Aucun problème sur le 2008 R2 SP1
 
 :sarcastic:


Message édité par i'm philou le 31-01-2013 à 13:16:24
n°105969
Je@nb
Modérateur
Kindly give dime
Posté le 31-01-2013 à 16:17:33  profilanswer
 

Upgrade en R2 :D

n°105977
i'm philou
Posté le 31-01-2013 à 18:31:45  profilanswer
 

Bah, on peut pas, ces serveurs sont des serveurs d'applis et nous avons notre logiciel de compta/RH qui n'est pas compatible 64 bits.
 :cry:  
Je vais bien finir par trouver...  :fou:  
 
 

n°105980
i'm philou
Posté le 31-01-2013 à 23:26:14  profilanswer
 

Bon, on avance.
Primo, j'avais pas de traces dans l'observateur d'évènements car la signalisation des erreurs et des avertissement du spouleur étaient désactivées !
 
A part ça, J'ai résolu un des problèmes, à savoir les imprimantes qui montent pas dès que le ciblage est activé.
http://support.microsoft.com/kb/976033/fr => correctif KB974825 pour Vista/2008
 
Maintenant, les imprimantes "même ciblées"sont bien là dans la session...mais seulement dans une session admin !
Les utilisateurs qui tentent de monter les imprimantes génèrent un event 4098 dans l'observateur d'evenements indiquant un accès refusé  "event id 4098 (0x80070005 Access is denied"
Je verrais ça demain...


Message édité par i'm philou le 03-02-2013 à 20:28:55
n°105986
nebulios
Posté le 01-02-2013 à 09:46:22  profilanswer
 

Tu as créé les GPO à partir de quelle machine ? Mais sinon oui il est possible que la seule solution soit de passer en 2008 R2 :/

n°105988
Je@nb
Modérateur
Kindly give dime
Posté le 01-02-2013 à 09:54:07  profilanswer
 

Qd tu la montes manuellement avec un compte standard ça marche ?
Le point and print (plus en tête le terme) est activé ?

n°105992
i'm philou
Posté le 01-02-2013 à 11:19:36  profilanswer
 

Ca semble incroyable d'avoir autant de problème !  :pfff:  
 
Les GPP sont issus d'un AD 2008 R2 SP1 niveau fonctionnel 2008 R2
J'ai pas précisé jusqu'a maintenant mais mon serveur d'impression est un 2008 R2 SP1
Sur les serveur RDS, le "restriction pointer & imprimer" est désactivé via GPO (partie machines & partie users.)
 
Je pense que j'avais deux problèmes. Un probleme de ciblage resolu par le patch cité plus haut et j'ai un problème de droits visiblement pour les users. Je n'arrive effectivement pas à les installer manuellement depuis une session user sur le RDS 2008.


Message édité par i'm philou le 01-02-2013 à 11:20:05
n°105993
nebulios
Posté le 01-02-2013 à 11:25:32  profilanswer
 

Il y a justement eu des changements là-dessus entre 2008 R1 et R2, c'est peut-être la cause de ton problème.

n°105996
i'm philou
Posté le 01-02-2013 à 12:04:29  profilanswer
 

Test :
 
Paramétrage GPP :  
=> ciblage - terminal serveur - adresse ip du client
=> GPP en mode "remplacer" et case "supprimer quand plus utilisé..." cochée.
 
Sur les 38 imprimantes que monte la GPO, 11 concerne mon user X (9 par ciblage + 2 non ciblées)
 
Suppression du profil de X sur le serveur 2008 puis ouverture de session :
Sur les 9 ciblées, 2 seulement montent.
Sur les 2 non ciblées, 1 seule monte.
 
les 8 qui montent pas => erreur 4098 dans l'observateurs d'evenements.
 
Toutes les imprimantes sont crées pareil !   :pt1cable:

n°106015
Je@nb
Modérateur
Kindly give dime
Posté le 01-02-2013 à 18:20:13  profilanswer
 

C'est quoi comme drivers ?

n°106038
i'm philou
Posté le 02-02-2013 à 16:49:09  profilanswer
 

Sharp MX3610N, MX5112N, MXC310...tout en PCL6
 
J'ai fait les choses suivantes :
 
Sur le DC, désactivation de la GPP
Sur le 2008 SP2 : suppression profil user X, suppressions pilotes, imprimantes, port et ménage dans la BDR
Ouverture de session user X, lancement d'un script VB qui lance 21 imprimantes = > les pilotes semblent s'installer mais seulement 2 imprimantes apparaissent  :pfff:  
 
Ouverture de session admin :
rsop.msc => le paramètre "restrictions pointer & cliquer" au niveau machine apparaît dans les paramètres de registres supplémentaires un peu comme si je n'avais pas le bon adm  :heink:  
 
Au passage, je précise que l'UAC est désactivé, cela peut t-il poser problème ?
 
 

n°106039
i'm philou
Posté le 02-02-2013 à 18:19:20  profilanswer
 

Je pense avoir ciblé le problème.
Je crois pas avoir le paramètre machine "restrictions pointer & imprimer" sur désactivé sur mon serveur 2008 vu que je n'ai pas l'ADM correspondant. Du coup, je dois avoir une demande d’élévation de droits au montage de l'imprimante, élévation interdite par l'UAC désactivé.
 
Il me faut rajouter l'adm correspondant. Seulement, sur 2008, je n'ai que des admx et la GPO ne semble pas en vouloir quand je veux rajouter un modèle alors on fait comment ?
 

n°106040
Je@nb
Modérateur
Kindly give dime
Posté le 02-02-2013 à 18:39:34  profilanswer
 

pas besoin d'adm, c'est dans un admx par défaut donc dispo de base (pas en tête où)

n°106042
i'm philou
Posté le 02-02-2013 à 20:10:40  profilanswer
 

Sauf que je fais les GPOs sur un AD 2008 R2 SP1 et que visiblement, dans ce cas là, le 2008 Sp2 ne sait pas gérer le paramètre "Pointer & imprimer"
 

n°106043
i'm philou
Posté le 02-02-2013 à 21:16:20  profilanswer
 

Bon, on dérive du sujet original qui était le problème des GPP associé au ciblage corrigé avec le correctif KB974825 récupérable ici http://support.microsoft.com/kb/976033/fr
Je tague ce topic en resolu et j'en ouvre un autre sur le problème du montage des imprimantes en tant qu'utilisateur lambda.


Message édité par i'm philou le 03-02-2013 à 20:33:21
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  [résolu] Déploiement imprimantes via GPO Preferences capricieux

 

Sujets relatifs
Windows 8 et net use via GPO logon scriptGPO Pour taches partagées Outlook ?
XP : Modifier un parametre IE via GPO ou RegeditDeploiement Windows 7 WDS + MDT
Deploiement Windows 7 Embedded via MDTDéploiement Firefox en entreprise
GPO Affichage de comptabilitéGPO - desactiver "user sttings" sur une machine
déploiement d'un serveur 2003 
Plus de sujets relatifs à : [résolu] Déploiement imprimantes via GPO Preferences capricieux


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR