Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1842 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  39  40  41  42  43  44  45  46  47
Auteur Sujet :

Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.

n°436461
ypc
Posté le 26-10-2009 à 18:55:28  profilanswer
 

Reprise du message précédent :
Je n'ai pas non plus répondu à la vote. Le fond du problème est la compréhension des 2 modes tun / tap ou encore bridge / route.
Biensûr, je peux moi même faire la configure, mais ce n'est pas l'object de ce forum.
Ces notions sont détaillées dams le premier post, il n'est pas nécessaire que je les reprennes.


---------------
Galerie photo : http://sebouvard.free.fr
mood
Publicité
Posté le 26-10-2009 à 18:55:28  profilanswer
 

n°436701
guigs91
Posté le 28-10-2009 à 17:13:26  profilanswer
 

il ne se passe rien quand je double clique est-ce normal?

n°436787
bubblegum
Posté le 29-10-2009 à 09:56:36  profilanswer
 

Quelqu'un a teste sous seven pour le client ?

n°436788
don_619
amateratsu
Posté le 29-10-2009 à 09:57:47  profilanswer
 

re-bonjour a tous!
Je m'en sort pas encore :cry: ,un coup de pouce sera toujours la bienvenue!
 :hello:

n°436789
guigs91
Posté le 29-10-2009 à 10:12:41  profilanswer
 

Re en fait la c'est mon build-dh qui ne fonctionne pas le curseur clignote mais pas de ...... il ne se passe rien sur le topic j'ai vu quelqu'un qui avais le meme probleme mais personne lui a repondu,quelqu'un peux m'aider?

n°436793
don_619
amateratsu
Posté le 29-10-2009 à 11:13:39  profilanswer
 

:cry:  :cry: il n'y a pas de solution  :cry:  :cry:  il n'y a que des problemes

n°436806
ypc
Posté le 29-10-2009 à 12:33:59  profilanswer
 

Quelles sont les ping qui ne marchent pas? Quelles sont les IP pingué? Quelles sont les IP du client? Qelles sont les IP du serveurs?
ipconfig des hotes et fichiers de conf pourraient aider.


---------------
Galerie photo : http://sebouvard.free.fr
n°436811
don_619
amateratsu
Posté le 29-10-2009 à 13:07:10  profilanswer
 

le schema:
|client XP|<-----------------> [<routeur cisco 2600>]<------------------->|serveur Ubuntu|
                                               255.255.255.252
                                          (eth0/1)          (eth0/0)
192.168.11.2                                                                                        192.168.10.2
192.168.11.1                                                                                        192.168.10.1        
255.255.255.252                                                                                   255.255.255.252
 
10.10.0.6                                                                                                10.10.0.1
(pas trop bien compris,ca doit pas etre entre 10.10.0.1 jusqu'a 10.10.0.4 par hasard?)
 
ping sans lancer openVPN:
192.168.11.2 vers 192.168.11.1
192.168.11.2 vers 192.168.10.2 et vice versa
 
ping(depuis le client,puis le serveur) en lançant openVPN:
rien n'arrive a part la même machine qui pingue.
 
le log sur le client:

Spoiler :


Thu Oct 29 12:05:45 2009 OpenVPN 2.1_rc20 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Oct  1 2009
Thu Oct 29 12:05:45 2009 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Oct 29 12:05:45 2009 LZO compression initialized
Thu Oct 29 12:05:45 2009 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Thu Oct 29 12:05:45 2009 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Thu Oct 29 12:05:45 2009 Local Options hash (VER=V4): '41690919'
Thu Oct 29 12:05:45 2009 Expected Remote Options hash (VER=V4): '530fdded'
Thu Oct 29 12:05:45 2009 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Oct 29 12:05:45 2009 UDPv4 link local: [undef]
Thu Oct 29 12:05:45 2009 UDPv4 link remote: 192.168.10.2:1194
Thu Oct 29 12:05:45 2009 TLS: Initial packet from 192.168.10.2:1194, sid=a388f2de 96606f30
Thu Oct 29 12:05:50 2009 VERIFY OK: depth=1, /C=mg/ST=tana/L=tana/O=bfv/OU=bfv/CN=server/emailAddress=bfv@bfv.sg
Thu Oct 29 12:05:50 2009 VERIFY OK: nsCertType=SERVER
Thu Oct 29 12:05:50 2009 VERIFY OK: depth=0, /C=mg/ST=tana/L=tana/O=bfv/OU=bfv/CN=server/emailAddress=bfv@bfv.sg
Thu Oct 29 12:06:08 2009 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Thu Oct 29 12:06:08 2009 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Oct 29 12:06:08 2009 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Thu Oct 29 12:06:08 2009 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Oct 29 12:06:08 2009 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Thu Oct 29 12:06:08 2009 [server] Peer Connection Initiated with 192.168.10.2:1194
Thu Oct 29 12:06:10 2009 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Thu Oct 29 12:06:10 2009 PUSH: Received control message: 'PUSH_REPLY,route 192.168.10.0 255.255.255.0,route 10.10.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.10.0.6 10.10.0.5'
Thu Oct 29 12:06:10 2009 OPTIONS IMPORT: timers and/or timeouts modified
Thu Oct 29 12:06:10 2009 OPTIONS IMPORT: --ifconfig/up options modified
Thu Oct 29 12:06:10 2009 OPTIONS IMPORT: route options modified
Thu Oct 29 12:06:10 2009 ROUTE default_gateway=192.168.11.1
Thu Oct 29 12:06:10 2009 TAP-WIN32 device [Connexion au réseau local 4] opened: \\.\Global\{256EAFE0-0D8A-492F-AC91-11F1CF2ADE34}.tap
Thu Oct 29 12:06:10 2009 TAP-Win32 Driver Version 9.6  
Thu Oct 29 12:06:10 2009 TAP-Win32 MTU=1500
Thu Oct 29 12:06:10 2009 Notified TAP-Win32 driver to set a DHCP IP/netmask of 10.10.0.6/255.255.255.252 on interface {256EAFE0-0D8A-492F-AC91-11F1CF2ADE34} [DHCP-serv: 10.10.0.5, lease-time: 31536000]
Thu Oct 29 12:06:10 2009 NOTE: FlushIpNetTable failed on interface [4] {256EAFE0-0D8A-492F-AC91-11F1CF2ADE34} (status=259) : Aucune donnée n'est disponible.  
Thu Oct 29 12:06:15 2009 TEST ROUTES: 2/2 succeeded len=2 ret=1 a=0 u/d=up
Thu Oct 29 12:06:15 2009 C:\WINDOWS\system32\route.exe ADD 192.168.10.0 MASK 255.255.255.0 10.10.0.5
Thu Oct 29 12:06:15 2009 Route addition via IPAPI succeeded [adaptive]
Thu Oct 29 12:06:15 2009 C:\WINDOWS\system32\route.exe ADD 10.10.0.1 MASK 255.255.255.255 10.10.0.5
Thu Oct 29 12:06:15 2009 Route addition via IPAPI succeeded [adaptive]
Thu Oct 29 12:06:15 2009 Initialization Sequence Completed


 
J'ai pas bien compris ce que fait le 10.10.0.5,on dirait une passerelle mais j'arrive pas a pinguer vers lui.
 
le fichier config du client:

Spoiler :


##############################################
# Sample client-side OpenVPN 2.0 config file #
# for connecting to multi-client server.     #
#                                            #
# This configuration can be used by multiple #
# clients, however each client should have   #
# its own cert and key files.                #
#                                            #
# On Windows, you might want to rename this  #
# file so it has a .ovpn extension           #
##############################################
 
# Specify that we are a client and that we
# will be pulling certain config file directives
# from the server.
client
 
# Use the same setting as you are using on
# the server.
# On most systems, the VPN will not function
# unless you partially or fully disable
# the firewall for the TUN/TAP interface.
;dev tap
dev tun
 
# Windows needs the TAP-Win32 adapter name
# from the Network Connections panel
# if you have more than one.  On XP SP2,
# you may need to disable the firewall
# for the TAP adapter.
;dev-node MyTap
 
# Are we connecting to a TCP or
# UDP server?  Use the same setting as
# on the server.
;proto tcp
proto udp
 
# The hostname/IP and port of the server.
# You can have multiple remote entries
# to load balance between the servers.
remote 192.168.10.2 1194
;remote my-server-2 1194
 
# Choose a random host from the remote
# list for load-balancing.  Otherwise
# try hosts in the order specified.
;remote-random
 
# Keep trying indefinitely to resolve the
# host name of the OpenVPN server.  Very useful
# on machines which are not permanently connected
# to the internet such as laptops.
resolv-retry infinite
 
# Most clients don't need to bind to
# a specific local port number.
nobind
 
# Downgrade privileges after initialization (non-Windows only)
;user nobody
;group nobody
 
# Try to preserve some state across restarts.
persist-key
persist-tun
 
# If you are connecting through an
# HTTP proxy to reach the actual OpenVPN
# server, put the proxy server/IP and
# port number here.  See the man page
# if your proxy server requires
# authentication.
;http-proxy-retry # retry on connection failures
;http-proxy [proxy server] [proxy port #]
 
# Wireless networks often produce a lot
# of duplicate packets.  Set this flag
# to silence duplicate packet warnings.
;mute-replay-warnings
 
# SSL/TLS parms.
# See the server config file for more
# description.  It's best to use
# a separate .crt/.key file pair
# for each client.  A single ca
# file can be used for all clients.
ca ca.crt
cert client.crt
key client.key
 
# Verify server certificate by checking
# that the certicate has the nsCertType
# field set to "server".  This is an
# important precaution to protect against
# a potential attack discussed here:
#  http://openvpn.net/howto.html#mitm
#
# To use this feature, you will need to generate
# your server certificates with the nsCertType
# field set to "server".  The build-key-server
# script in the easy-rsa folder will do this.
ns-cert-type server
 
# If a tls-auth key is used on the server
# then every client must also have the key.
;tls-auth ta.key 1
 
# Select a cryptographic cipher.
# If the cipher option is used on the server
# then you must also specify it here.
;cipher x
 
# Enable compression on the VPN link.
# Don't enable this unless it is also
# enabled in the server config file.
comp-lzo
 
# Set log file verbosity.
verb 3
 
# Silence repeating messages
;mute 20
 


 
j'ai pas decommenté cette ligne "tls-auth ta.key 1" car j'ai pas generé ta.key(j'en ai pas besoin pour le moment)  
 
sur le serveur:
 

Spoiler :


 
mode server
 
port 1194
 
proto udp
 
;dev tap
dev tun
 
 
;dev-node MyTap
 
ca /usr/share/doc/openvpn/examples/easy-rsa/2.0/keys/ca.crt
cert /usr/share/doc/openvpn/examples/easy-rsa/2.0/keys/server.crt
key /usr/share/doc/openvpn/examples/easy-rsa/2.0/keys/server.key  # This file should be kept secret
 
 
dh /usr/share/doc/openvpn/examples/easy-rsa/2.0/keys/dh1024.pem
 
server 10.10.0.0 255.255.255.0
 
 
ifconfig-pool-persist ipp.txt
 
 
;server-bridge 10.8.0.4 255.255.255.0 10.8.0.50 10.8.0.100
 
 
;server-bridge
 
push "route 192.168.10.0 255.255.255.0"
;push "route 192.168.20.0 255.255.255.0"
 
 
 
;client-config-dir ccd
;route 192.168.40.128 255.255.255.248
 
;client-config-dir ccd
;route 10.9.0.0 255.255.255.252
 
 
;learn-address ./script
 
;push "redirect-gateway def1 bypass-dhcp"
 
 
;push "dhcp-option DNS 208.67.222.222"
;push "dhcp-option DNS 208.67.220.220"
 
 
;client-to-client
 
 
;duplicate-cn
 
 
keepalive 10 120
 
;tls-auth ta.key 0 # This file is secret
 
;cipher BF-CBC        # Blowfish (default)
;cipher AES-128-CBC   # AES
;cipher DES-EDE3-CBC  # Triple-DES
 
comp-lzo
 
;max-clients 100
 
 
;user nobody
;group nogroup
 
 
persist-key
persist-tun
 
 
status openvpn-status.log
 
log         openvpn.log
log-append  openvpn.log
 
 
verb 3
 
;mute 20
 


 

n°436823
ypc
Posté le 29-10-2009 à 14:03:48  profilanswer
 

La directive push "route 192.168.10.0 255.255.255.0"  ne colle pas avec 192.168.10 /30
 
Une fois le VPN monté les 10 se ping le serveur ping le client avec 10.0.0.6


---------------
Galerie photo : http://sebouvard.free.fr
n°436829
don_619
amateratsu
Posté le 29-10-2009 à 14:29:45  profilanswer
 

euhhh...waif :sweat:!
En clair je dois changer quoi en quoi pourque ca marche??

mood
Publicité
Posté le 29-10-2009 à 14:29:45  profilanswer
 

n°436831
don_619
amateratsu
Posté le 29-10-2009 à 14:35:54  profilanswer
 

j'ai deja commenté cette ligne(dans le tuto c'est commenté) mais ca ne change pas grand chose

n°436870
ypc
Posté le 29-10-2009 à 17:39:58  profilanswer
 

Une fois le VPN monté les 10 se ping le serveur ping le client avec 10.0.0.6


---------------
Galerie photo : http://sebouvard.free.fr
n°436931
don_619
amateratsu
Posté le 30-10-2009 à 05:40:39  profilanswer
 

Desolé mais ca ping pas chez moi!
Le serveur marche tres bien,le client s'allume en vert mais le ping:"délai d'attente depassé"
j'arrive même pas à pinger ce 10.10.0.5 :sweat:

 

La directive push "route 192.168.10.0 255.255.255.0",je dois changer en quoi au juste?

 

J'avoue,je suis à cour d'idée :pfff:

 

A l'aide!!! :bounce:


Message édité par don_619 le 30-10-2009 à 05:42:35
n°437217
don_619
amateratsu
Posté le 01-11-2009 à 16:44:15  profilanswer
 

:bounce: un coup de main!!!!

n°437475
don_619
amateratsu
Posté le 03-11-2009 à 14:21:02  profilanswer
 

PROBLEME RESOLU GRACE AU CIEL :o !
Je ne sais pas comment mais après avoir changer la table de routage du client vers la machine serveur,ca marchais :sweat: .mais le plus incroyable c'est que maintenant ça marche toujours,même en remettant la table de routage par defaut qui n'a pas marché avant  :lol: .
Rien a voir avec le mode bridge(tap) ou le tun.
 

n°438090
The_chosen​_one
There can only be one !
Posté le 08-11-2009 à 17:29:09  profilanswer
 

Bonjour,
 
Est-ce qu'il est possible de ne pas chiffrer le canal du vpn ? (pour des raisons de consommation cpu sur un téléphone portable)
 
Merci.

n°438115
ypc
Posté le 08-11-2009 à 19:19:28  profilanswer
 

Oui, c'est possible, mais d'expérience, avec ou sans, cela ne change rien. Les problèmes de lenteur sont insoluble et lié au réseau sans fils. Le problème, c'est les temps de latences importants sur ce type de réseau aux il faut ajouter les temps de latences dû au VPN.
 
J'ai essayé d'optimiser cela sans grand résultat. Les débits bons mais les latences importantes d'où l'impression de lenteur. Le chiffrement et la tailles des paquets influent peu ou pas.


---------------
Galerie photo : http://sebouvard.free.fr
n°438148
The_chosen​_one
There can only be one !
Posté le 08-11-2009 à 23:21:44  profilanswer
 

Je parlais plutôt en terme de consommation électrique (calculs liés au chiffrement et à la compression)

n°438161
ypc
Posté le 09-11-2009 à 07:17:09  profilanswer
 

-complzo pour la compession et pour le chiffrement de mémoire -vi, sur le client ET le serveur.


---------------
Galerie photo : http://sebouvard.free.fr
n°438238
M4xl4M3n4c​3
Posté le 09-11-2009 à 16:20:45  profilanswer
 

bubblegum a écrit :

Quelqu'un a teste sous seven pour le client ?


 
Testé avec le client sous seven et connexion 3g.
Fonctionne au poil.  :jap:


Message édité par M4xl4M3n4c3 le 09-11-2009 à 16:21:18
n°438247
The_chosen​_one
There can only be one !
Posté le 09-11-2009 à 17:43:20  profilanswer
 

Bon, alors j'ai fait :
coté serveur :

#comp-lzo #désactivation de la compression
cipher none #pas de chiffrement


coté client :
pareil
 
Ca fonctionne, mais le problème, c'est que du coup je peux plus monter de tunnel chiffré.
En gros, si je comprend bien, le serveur ne pas gérer à la fois des clients sans chiffrement et d'autres avec... qqun peut me confirmer ça ?

n°438262
ypc
Posté le 09-11-2009 à 18:34:47  profilanswer
 

exact


---------------
Galerie photo : http://sebouvard.free.fr
n°438265
The_chosen​_one
There can only be one !
Posté le 09-11-2009 à 18:54:47  profilanswer
 

C'est gênant et pas vraiment logique...
 
edit:
Bon du coup j'ai monté 2 instances, juste en copiant le fichier de conf et en modifiant les params de chiffrement et de compression.
Pour ceux qui chercherait pdt 1h pourquoi ça marche pas, n'oubliez pas non plus de changer le réseau de votre deuxième instance afin de ne pas avoir les 2 instances sur le même réseau et donc planter les routes.


Message édité par The_chosen_one le 09-11-2009 à 23:31:11
n°438462
yon137
Posté le 11-11-2009 à 14:07:52  profilanswer
 

salut,
 
Voici mon problème.
J'ai bien sûr suivi le tuto et je veux essayer sur un réseau ad hoc sans fil.
Pc server : 192.168.1.2
Pc client  : 192.168.1.1
 
Dans cette config ca fonctionne bien en revanche je cherche à le faire fonctionner avec la config suivante:
 
PC1 server windows xp en connexion orange 3G
PC2 client  sous vista avec connexion Freewifi.
Et bien là ca ne fonctionne pas j'ai un timeout.
Je pense que c'est freewifi qui ne laisse pas passer openvpn...
 
De plus question: une fois le vpn monté on peut faire passer ce que l'on veut en application???
En fait j'aimerai balancer un flux audio ou video par vlc ou shoutcast dans le vpn est ce possible????
 
Merci pour votre aide.
 
Qu'en pensez vous????


Message édité par yon137 le 11-11-2009 à 18:39:19
n°438486
yon137
Posté le 11-11-2009 à 18:39:41  profilanswer
 

up:)

n°438488
yon137
Posté le 11-11-2009 à 19:21:56  profilanswer
 

voila ce que j'obtiens lorsque j'essaie avec d'un cote 3g et de l'autre Freewifi
 
Wed Nov 11 19:01:26 2009 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
Wed Nov 11 19:01:26 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Wed Nov 11 19:01:26 2009 LZO compression initialized
Wed Nov 11 19:01:26 2009 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Wed Nov 11 19:01:26 2009 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Wed Nov 11 19:01:26 2009 Local Options hash (VER=V4): '41690919'
Wed Nov 11 19:01:26 2009 Expected Remote Options hash (VER=V4): '530fdded'
Wed Nov 11 19:01:26 2009 UDPv4 link local: [undef]
Wed Nov 11 19:01:26 2009 UDPv4 link remote: 217.167.241.199:1194
Wed Nov 11 19:02:25 2009 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Wed Nov 11 19:02:25 2009 TLS Error: TLS handshake failed
Wed Nov 11 19:02:25 2009 TCP/UDP: Closing socket
Wed Nov 11 19:02:25 2009 SIGUSR1[soft,tls-error] received, process restarting
Wed Nov 11 19:02:25 2009 Restart pause, 2 second(s)
 

n°438505
ypc
Posté le 11-11-2009 à 21:53:01  profilanswer
 

En TCP sur le port 443 cela fonctionnera mieux.


---------------
Galerie photo : http://sebouvard.free.fr
n°438512
yon137
Posté le 11-11-2009 à 22:50:32  profilanswer
 

merci pour la réponse je vais essayer ça.
 
Par contre j'ai fait une autre expérience pour tester la diffusion de flux dans le vpn:
Réseau ad hoc sans fil entre PC1(192.168.1.1) et PC2(192.168.1.2)
Le server openvpn est sur PC1(10.8.0.1)
Le client sur PC2(10.8.0.6)
 
Le vpn fonctionne.
Maintenant la diffusion de flux avec Vlc.
Dans le sens server  vers client la diffusion fonctionne.
En revanche dans le sens client vers serveur beh rien...
 
Pour être sûr que cela ne vienne pas du vlc ou autre j'ai testé sur la diffusion dans les deux sens avec les ips 192 et par contre là ca fonctionne bien.
Donc je n'arrive pas à diffuser dans le vpn du client vers le server.
 
Une idée?

n°438514
yon137
Posté le 11-11-2009 à 23:00:30  profilanswer
 

Quand server et client en tcp 443 j'obtiens un fail :
Wed Nov 11 22:57:43 2009 TCP: connect to mondyndns*** failed, will try again in 5 seconds

n°438537
ypc
Posté le 12-11-2009 à 10:33:45  profilanswer
 

Faut peut-être ouvrir et router le port en question et configurer le FW en conséquence.


---------------
Galerie photo : http://sebouvard.free.fr
n°438539
yon137
Posté le 12-11-2009 à 10:41:51  profilanswer
 

ok ca fonctionne entre de la 3g et de l'adsl.
Merci pour tout:)

n°438629
yon137
Posté le 12-11-2009 à 22:34:51  profilanswer
 

Sinon dernière question:
Server openvpn sur windows 2003
Client openvpn sur Xp
Je souhaite faire passer un flux via windows media encoder du client vers windows media services sur le server.
 
windows media encoder ne permet que d'envoyer le flux vers le serveur sous la forme http://ipserveur:8080
 
Que va t-il se passer lorsque je tenterai d'envoyer le flux au serveur vpn actif??
Cela pose t-il problème ou est ce que le flux va passer normalement via openvpn (ce que je souhaite)??
N'hesitez pas si vous voyez déjà des difficultes à venir avant que je me lance.
 
Merci


Message édité par yon137 le 12-11-2009 à 22:35:27
n°440141
adrien8255
Posté le 24-11-2009 à 17:21:03  profilanswer
 

Bonjour, j'ai un ptit problème avec open VPN :
 
LAN 192.168.0.0
Passerrelle 192.168.0.1
IP serveur 192.168.0.52
IP virtuel serveur 10.8.0.1
 
Enfaite openvpn se connecte bien mais je peux pas pinger les IP 10.8.x.x depuis le serveur ni depuis le client.
 
Enfaite j'aimerais que tout le traffic passe par le VPN  
server.conf

Spoiler :

port 443
proto tcp
dev tun
 
ca ca.crt
cert server.crt
key server.key  
dh dh1024.pem
 
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
 
push "redirect-gateway"
keepalive 10 120
 
cipher AES-128-CBC  
 
comp-lzo
 
persist-key
persist-tun
 
status openvpn-status.log
verb 3
route-method exe  
route-delay 2  
 
route 192.168.0.0 255.255.255.0  
push "route 192.168.0.0 255.255.255.0"


 
client  

Spoiler :

client
dev tun
proto tcp
remote /dyndns/ 443
nobind
persist-key
persist-tun
 
mute-replay-warnings
ca ca.crt
cert macbook.crt
key macbook.key
;ns-cert-type server
cipher AES-128-CBC
comp-lzo
verb 3
mute 20
route-method exe  
route-delay 2  


 
Merci d'avance pour votre aide

n°440472
DrDooM
Posté le 27-11-2009 à 11:22:02  profilanswer
 

hop un nouveau problème avec OpenVPN, j'ai un serveur Debian qui fait tourner le serveur OpenVPN et 2 postes clients sous Seven qui se connectent à ce serveur.
Pas de souci de ping avec le serveur mais impossible pour les 2 clients de se pinger entre eux, pourtant j'ai bien ajouté client-to-client, des idées?


---------------
Désigné membre du camp du mal par sylphide pinklady :pt1cable:
n°440817
beretta93
Posté le 29-11-2009 à 21:07:54  profilanswer
 

Salut à tous,
 
Voilà j'ai un problème. J'essaye depuis plusieurs jours de monter un VPN depuis mon réseau local avec un serveur OpenVPN intégré à un routeur flashé sous DD-WRT v24 SP2 VPN vers mon PC portable qui se connecte en 3G via modem 3G intégré avec une puce illimythics (donc passe par le Wap).
 
En gros, ça donne :
 
Réseau local (192.168.1.xx) <= Routeur (Lan : 192.168.1.1/Wan : 192.168.0.14 / VPN : 192.168.2.0) <= Box NC (Lan : 192.168.0.1 / Wan : 213.245.xx.xx) <= Proxy WAP SFR (195.115.25.129) <= Client OpenVPN en 3G
 
J'ai suivi plusieurs tuto, jusqu'à arriver à une configuration proche du potable, mais je bloque à une étape. Voici le log de mon client VPN :
 

Citation :

Sun Nov 29 20:12:39 2009 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Sun Nov 29 20:12:39 2009 Re-using SSL/TLS context
Sun Nov 29 20:12:39 2009 Control Channel MTU parms [ L:1543 D:140 EF:40 EB:0 ET:0 EL:0 ]
Sun Nov 29 20:12:39 2009 Data Channel MTU parms [ L:1543 D:1450 EF:43 EB:4 ET:0 EL:0 ]
Sun Nov 29 20:12:39 2009 Local Options hash (VER=V4): 'db02a8f8'
Sun Nov 29 20:12:39 2009 Expected Remote Options hash (VER=V4): '7e068940'
Sun Nov 29 20:12:39 2009 Attempting to establish TCP connection with 195.115.25.129:8080
Sun Nov 29 20:12:39 2009 TCP connection established with 195.115.25.129:8080
Sun Nov 29 20:12:39 2009 Send to HTTP proxy: 'CONNECT 213.245.xx.xx:443 HTTP/1.0'
Sun Nov 29 20:12:40 2009 HTTP proxy returned: 'HTTP/1.0 200 Connection established'
Sun Nov 29 20:12:42 2009 TCPv4_CLIENT link local: [undef]
Sun Nov 29 20:12:42 2009 TCPv4_CLIENT link remote: 195.115.25.129:8080
Sun Nov 29 20:13:32 2009 Connection reset, restarting [0]
Sun Nov 29 20:13:32 2009 TCP/UDP: Closing socket
Sun Nov 29 20:13:32 2009 SIGUSR1[soft,connection-reset] received, process restarting
Sun Nov 29 20:13:32 2009 Restart pause, 5 second(s)
Sun Nov 29 20:13:37 2009 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Sun Nov 29 20:13:37 2009 Re-using SSL/TLS context
Sun Nov 29 20:13:37 2009 Control Channel MTU parms [ L:1543 D:140 EF:40 EB:0 ET:0 EL:0 ]
Sun Nov 29 20:13:37 2009 Data Channel MTU parms [ L:1543 D:1450 EF:43 EB:4 ET:0 EL:0 ]
Sun Nov 29 20:13:37 2009 Local Options hash (VER=V4): 'db02a8f8'
Sun Nov 29 20:13:37 2009 Expected Remote Options hash (VER=V4): '7e068940'
Sun Nov 29 20:13:37 2009 Attempting to establish TCP connection with 195.115.25.129:8080
Sun Nov 29 20:13:37 2009 TCP connection established with 195.115.25.129:8080
Sun Nov 29 20:13:37 2009 Send to HTTP proxy: 'CONNECT 213.245.xx.xx:443 HTTP/1.0'
Sun Nov 29 20:13:38 2009 HTTP proxy returned: 'HTTP/1.0 200 Connection established'
Sun Nov 29 20:13:40 2009 TCPv4_CLIENT link local: [undef]
Sun Nov 29 20:13:40 2009 TCPv4_CLIENT link remote: 195.115.25.129:8080
Sun Nov 29 20:13:58 2009 TCP/UDP: Closing socket
Sun Nov 29 20:13:58 2009 SIGTERM[hard,] received, process exiting


 
Et pour plus de facilité à comprendre ma configuration, j'ai fait des captures de toute ma config :  
 
La configuration du Daemon OpenVPN sur mon routeur :  
 
http://img69.imageshack.us/img69/9774/capturevpndaemon1.jpg
http://img341.imageshack.us/img341/237/capturevpndaemon2.jpg
 
La config server :
 
http://img341.imageshack.us/img341/1213/capturevpnserveurconfig.jpg
 
La redirection du port 443 de ma box vers mon routeur :
 
http://img81.imageshack.us/img81/831/capturencrouteur.jpg
 
La commande Firewall sur le routeur :
 
http://img524.imageshack.us/img524/3396/capturecommandfirewall.jpg
 
Et enfin ma configuration côté client :
 

Citation :

remote 213.245.xx.xx
port 443
 
client  
dev tun0  
proto tcp
resolv-retry infinite  
nobind  
persist-key  
persist-tun
http-proxy 195.115.25.129 8080
ca ca.crt  
cert client.crt  
key client.key
verb 3


 
Donc voilà, j'aimerais savoir à quel moment ça cloche.  
 
Ce que j'aimerais faire, c'est tout d'abord :
 
1) réussir à créer le réseau VPN afin de me servir de ma connexion 3G sans restriction de port, et dans un second temps
 
2) reparamétrer la connexion VPN en mode bridge, pour que je puisse me connecter à distance et avoir une IP 192.168.1.xx, afin d'accéder aux fichiers partagés des PC de mon groupe résidentiel (idéalement).
 
Un peu d'aide me serait vraiment utile. Je suis un pur profane et je configure uniquement à l'aide des tutos de DD-WRT Wiki et de ce que je peux choper sur le net. Donc ne vous étonnez pas si vous voyez des abbérations dans ma configuration. :D
 
Merci à tous; :jap:


Message édité par beretta93 le 30-11-2009 à 14:28:08

---------------
>>>FEED<<<
n°441449
mbsofts
Posté le 05-12-2009 à 15:39:16  profilanswer
 

bonjour,
bravo pour ce tutoriel.
Mais j'ai un souci au niveau du client lors de la connexion, voici le fichier log :
 

Code :
  1. Sat Dec 05 15:32:23 2009 OpenVPN 2.1_rc22 Win32-MSVC++ [SSL] [LZO2] built on Nov 29 2009
  2. Sat Dec 05 15:32:24 2009 Using Windows Connection Manager with destination '{B2AD7D1D-2C4B-494B-B324-42EEC882B71B}' resolving to provider guid {B2AD7D1D-2C4B-494B-B324-42EEC882B71B} (exclusive)
  3. Sat Dec 05 15:32:24 2009 Cannot acquire Windows Connection Manager provider, error 0x00000028
  4. Sat Dec 05 15:32:24 2009 Exiting


 
quelqu'un peut-il m'aider ?
 
niveau hardware j'ai un PC sans firewall avec le serveur OpenVPN d'installer dessus.
Ce PC est sur une connexion FREE avec routeur activé et port 443 TCP et UDP redirigé sur le 443 du pc en question (je pense que c bon !?)
J'ai un HTC DIamond chez SFR. Le serveur met bien les 2 icones vertes, c coté HTC Diamond que ca démarre pas (message affiché "Le serveur ne reponds pas au ping. Continuer ?" )
 
merci de votre aide

n°441500
ypc
Posté le 06-12-2009 à 10:36:05  profilanswer
 

Modifier les options dans l'onglet connexion de openvpn sur le diamond. Je sais plus laquelle, mais c'est là. Désactiver ou activer exclusive ou sélectionner la connexion dans la liste. Ca tourne autour de ça.


---------------
Galerie photo : http://sebouvard.free.fr
n°442130
exeral
Posté le 11-12-2009 à 02:20:54  profilanswer
 

Euuh dites !
 
comment tester son VPN ? il faudrait que j'ai accès à une autre IP d'internet (que celle où est moi et mon serveur vpn) pour vérifier que tout y marche, que je vois bien tout le monde
 
soit j'attends 4 jours quand je serais revenu à mon logement "bis"
soit j'attend un ami capable d'installer un client vpn
:s pas très pratique pour tester ^^

n°443292
Groody
Utilisez MES smileys §
Posté le 23-12-2009 à 09:23:12  profilanswer
 

LightKyle a écrit :

Petite question de noob qui patauge un peu.  [:o_doc]  
J'ai voulu tester OpenVPN Access Server, l'appliance VM toute faite. Le machin me génère un .ovpn tout en un visiblement, avec une partie certificat dedans & des parties clé, sous la forme de chaine de caractères.


 
?
Une machine virtuelle ?
 
 
J'avais déjà installé et utilisé OpenVPN il y'a quelques années.
Je dois m'en remettre un en place. Je partais pour l'installer sur un 2003 server en machine virtuelle, mais si il existe un serveur (os+openVPN) complètement adapté/dédié ce serait sûrement mieux.
 
 
J'ai regardé sur le net, ce n'est "qu"une" interface web de gestion d'OpenVPN, à installer sur un Linux déjà en place.
Ton message m'a donné de faux espoirs :'(
:o


---------------
Vidéo Concorde Air France | www.kiva.org
n°443321
Groody
Utilisez MES smileys §
Posté le 23-12-2009 à 15:25:16  profilanswer
 

Ca y est, ça coince...
 
 
Dans le tuto :

Citation :

Vous l'enregistrez sous « sign-req.bat » dans /easy-rsa. Le fichier « client1.csr » doit être copié dans /easy-rsa/keys.


 
Sauf que j'ai déjà un Client1.csr dans le dossier KEYS côté serveur.
Une idée ? [:canaille]


---------------
Vidéo Concorde Air France | www.kiva.org
n°443323
Groody
Utilisez MES smileys §
Posté le 23-12-2009 à 15:33:14  profilanswer
 

Ah zut, sûrement parceque j'avais lancé une "Génération locale des clés" avant de faire une "Génération de la clé et d'une demande de certificat signé"


---------------
Vidéo Concorde Air France | www.kiva.org
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  39  40  41  42  43  44  45  46  47

Aller à :
Ajouter une réponse
 

Sujets relatifs
*** Réseau domestique et partage de connexion Internet 
Plus de sujets relatifs à : Réseau privé virtuel sous Windows - OpenVPN - Tutoriels.


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR