Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1736 connectés 

 


 

Utilisez-vous fun_plug pour étendre les possiblités de votre NAS ?
Sondage à 5 choix possibles.




Attention si vous cliquez sur "voir les résultats" vous ne pourrez plus voter
Les invités peuvent voter

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  34  35  36  ..  152  153  154  155  156  157
Auteur Sujet :

[Nas] D-Link ShareCenter DNS-320/DNS-320L et DNS-325

n°562819
le_candide
Posté le 30-01-2012 à 12:51:37  profilanswer
 

Reprise du message précédent :

themanson a écrit :

Je pense savoir pour les fichiers a 0ko, ça a peut être déjà été dit,  
mais si on utilise un copieur externe (genre supercopier) le CIFS est très mal géré,  
donc (chez moi en tout cas) 1 fichier sur 3 est a 0ko,
même en déplacement (plutôt gênant vu qu'on a plus le fichier de l'autre coté)


Effectivement j'utilise supercopier, et j'ai perdu qq. Go sur un simple déplacement  :sweat:  
Du coup tu confirmes mes doutes, et le firmware 2.02 n'est pas en cause...
Bref ne pas utiliser supercopier pour copier/déplacer des fichiers sur le NAS

mood
Publicité
Posté le 30-01-2012 à 12:51:37  profilanswer
 

n°562833
themanson
Posté le 30-01-2012 à 13:41:00  profilanswer
 

 
 
Si tu peux le rajouter en FP, ça éviterait beaucoup de crises de nerfs ^^
 
Visiblement ultracopier marcherais bien, a tester

n°562835
lasolution
A perdu son pseudo de 2005
Posté le 30-01-2012 à 13:47:41  profilanswer
 

le_candide a écrit :


je m'en doutais  ;)  
pour commencer il faudrait regarder du côté des logs du NAS  :??:  (déjà sur l'interface web admin...)


 
C'est fait j'ai tout configurer ...
mais c'est bon ce que j'ai fais dans l'interface free ?
c'est ce qu'il faut faire ?

n°562836
themanson
Posté le 30-01-2012 à 13:51:58  profilanswer
 

 
Essai a l'instant, sur une 200n de musique (flac/mp3) et une 20n d'episodes, pas une erreur ;)
 
Donc Ultracopier c'est le bien
 

n°562838
le_candide
Posté le 30-01-2012 à 13:56:47  profilanswer
 

themanson a écrit :

Si tu peux le rajouter en FP, ça éviterait beaucoup de crises de nerfs ^^
Visiblement ultracopier marcherais bien, a tester


C'est noté, (je compte faire un gros rafraichissement, si ma femme me laisse tranquille  :) ...)

n°562839
le_candide
Posté le 30-01-2012 à 14:00:53  profilanswer
 

lasolution a écrit :


 
C'est fait j'ai tout configurer ...
mais c'est bon ce que j'ai fais dans l'interface free ?
c'est ce qu'il faut faire ?


as-tu installé FFP ?
si oui, il faut ajouter aussi le port 81.

n°562846
lasolution
A perdu son pseudo de 2005
Posté le 30-01-2012 à 14:34:02  profilanswer
 

le_candide a écrit :


as-tu installé FFP ?
si oui, il faut ajouter aussi le port 81.


 
Non je n'ai rien installé dessus,
juste fait l'installation normal avec le cd rom fournis

n°562847
le_candide
Posté le 30-01-2012 à 14:36:55  profilanswer
 

lasolution a écrit :

Non je n'ai rien installé dessus,
juste fait l'installation normal avec le cd rom fournis


 :hello: ,
A mon avis c'est le serveur intégré à la freebox V6 qui entre en conflit avec celui du NAS...
change le port de celui de la freebox et ca devrait rouler (détail en MP).

n°562864
le_candide
Posté le 30-01-2012 à 16:39:39  profilanswer
 

Marmotte_73 a écrit :

Bonjour,  
 
Mais je n'arrive ps à trouver les bons répertoires pour qu'il me prenne lighttpd_portmod.conf  
 
Pour info, les processus lighttpd qui tournent au démarrage sont localisés ici  
 
root      1742  1373  0 00:14 ?        00:00:00 /usr/sbin/lighttpd -D -m /usr/local/lib -f /etc/lighttpd/lighttpd.conf  
root      1373     1  0 00:14 ?        00:00:00 /usr/sbin/lighttpd-angel -D -m /usr/local/lib -f /etc/lighttpd.conf  
 
Je n'y connais pas grand chose en linux et çà se limite à du bidouillage, si quelqu'un a des pistes pour m'aider... je suis preneur.


j'ai peut-être une piste : copier et adapter le contenu de /ffp/start/kickwebs_dns320.sh directement dans /mnt/HD/HD_a2/fun_plug
comme ça ce sera fait avant l'appel au chroot (qui a plus de limitations).
(nota si ça marche dans l'environement chrooté, il suffit de rajouter ta commande dans /boot/linuxrc)

Message cité 1 fois
Message édité par le_candide le 30-01-2012 à 16:46:27
n°562867
Lafee14
Posté le 30-01-2012 à 18:04:57  profilanswer
 

tpicard65 a écrit :


si ta page d'accueil de ton site c'est monsite.php oui
sinon directement sur l'adresse dyndns ça doit afficher ton site


 
Ca fonctionne toujours pas, aussi bien avec ip qu'avec dyndns  :fou:  
Et le dyndns fonctionner bien avant l'instal de { funplug, php, lighttpd, openssl }
Je comprends rien  :pfff:  , faut bien laisser le service ssh en route ?
 
Edit  
Est-ce que l'on peut savoir si le service dyndns est actif sur le Nas ?

 
Edit  
Et comment se connecter à l'interface du Nas ? car je n'y arrive plus ? depuis les installes ?

J'ai réussi en ssl port 443 ;)  
 
Merci pour votre aide


Message édité par Lafee14 le 30-01-2012 à 21:48:45
mood
Publicité
Posté le 30-01-2012 à 18:04:57  profilanswer
 

n°562883
lasolution
A perdu son pseudo de 2005
Posté le 30-01-2012 à 19:38:15  profilanswer
 

le_candide a écrit :


 :hello: ,
A mon avis c'est le serveur intégré à la freebox V6 qui entre en conflit avec celui du NAS...
change le port de celui de la freebox et ca devrait rouler (détail en MP).


 
 
c'est fait quand je suis en local chez moi en tapant l'ip de ma freebox j'atteind bien le serveur mais de l'exterieur impossible   :fou:  :fou:  :pfff:

n°562886
Theutheu
Posté le 30-01-2012 à 20:08:33  profilanswer
 

http://www.comptoir-hardware.com/b [...] tml#ragots
 
Bon plan: NAS D-Link + 2 x 2To Caviar Green à 192,90€ (MAJ)
 
 


---------------
Je sais, on ne me remerciera jamais assez ... | | | http://www.fun-fairplay.org
n°562893
le_candide
Posté le 30-01-2012 à 20:41:58  profilanswer
 

lasolution a écrit :

C'est fait quand je suis en local chez moi en tapant l'ip de ma freebox j'atteind bien le serveur mais de l'exterieur impossible   :fou:  :fou:  :pfff:


bin, fait l'inverse alors, translate des ports plus élevés vers ton nas (ce qui d’ailleurs est plus prudent),
par exemple dans l'interface de ton routeur :
 
 56555:udp vers 192.168.0.32:80:udp
 56555:tcp vers 192.168.0.32:80:tcp
puis tu y accède de l’extérieur via :
http://ip_fixe_free_chez_toi:56555
(détail en MP)

Message cité 1 fois
Message édité par le_candide le 30-01-2012 à 20:43:05
n°562905
lasolution
A perdu son pseudo de 2005
Posté le 30-01-2012 à 21:35:59  profilanswer
 

le_candide a écrit :


bin, fait l'inverse alors, translate des ports plus élevés vers ton nas (ce qui d’ailleurs est plus prudent),
par exemple dans l'interface de ton routeur :
 
 56555:udp vers 192.168.0.32:80:udp
 56555:tcp vers 192.168.0.32:80:tcp
puis tu y accède de l’extérieur via :
http://ip_fixe_free_chez_toi:56555
(détail en MP)


 
 
Merci pour ton aide ça a marché  :bounce:  :bounce:  :bounce:

n°562906
lasolution
A perdu son pseudo de 2005
Posté le 30-01-2012 à 21:37:32  profilanswer
 

Sinon une question mon ami peu telecharger les fichiers qu'à 100ko/s maxi c'est normale ou ya moyen d'augmenter ?

n°562908
garath_
Posté le 30-01-2012 à 21:42:24  profilanswer
 

Télécharger avec quoi?


---------------
SFBA Report - HFR Links Preview - Parrainage Mint Energie
n°562909
lasolution
A perdu son pseudo de 2005
Posté le 30-01-2012 à 21:43:38  profilanswer
 

de chez lui sur mon serveur en ftp

n°562910
garath_
Posté le 30-01-2012 à 21:46:02  profilanswer
 

ah ok.
C'est ton débit d'upload qui bride, en adsl c'est inévitable...
100ko/s c'est peu, mais je ne sais pas si on peut vraiment augmenter ça.


---------------
SFBA Report - HFR Links Preview - Parrainage Mint Energie
n°562911
lasolution
A perdu son pseudo de 2005
Posté le 30-01-2012 à 21:48:28  profilanswer
 

vous faites comment vous ?
du coup ya pas moyen d'avoir mieux alors :'(

n°562912
Lafee14
Posté le 30-01-2012 à 21:53:31  profilanswer
 

Lorsque j'essai d'accéder à mon site en Php par mon dyndns, j'obtiens une erreur 404
 
Box Orange, paramètre peut-être ???
 
http://tracesgps.dyndns-web.com:80/Accueil.php
 
Auriez-vous une idée de ce qui va pas ?

n°562913
garath_
Posté le 30-01-2012 à 21:57:55  profilanswer
 

Essaye d'abord avec ton ip plutot qu'avec dyndns pour s'assurer que l'accès depuis l'exterieur fonctionne.
Tu peux nous montrer comment tu as redirigé les ports dans ta box?


Message édité par garath_ le 30-01-2012 à 21:58:12

---------------
SFBA Report - HFR Links Preview - Parrainage Mint Energie
n°562914
Lafee14
Posté le 30-01-2012 à 22:09:58  profilanswer
 

Edit


Message édité par Lafee14 le 02-02-2012 à 12:40:39
n°562916
garath_
Posté le 30-01-2012 à 22:12:47  profilanswer
 

Ok donc en local, sur http://192.168.1.36:80 tu tombes sur ton site?
Et sur http://192.168.1.36:81 sur l'interface d'administration c'est ça?


---------------
SFBA Report - HFR Links Preview - Parrainage Mint Energie
n°562917
Lafee14
Posté le 30-01-2012 à 22:16:06  profilanswer
 

Oui, site web ok en local, extérieur ???
Par contre impossible de me connecter à mon interface ! EDIT : j'arrive à l'interface mais lorsque je rentre mon code, ça échou !


Message édité par Lafee14 le 30-01-2012 à 22:21:15
n°562919
garath_
Posté le 30-01-2012 à 22:20:31  profilanswer
 

php est correctement installé? T'as bien suivi le tuto?
T'as executé le script kickwebdns320.sh ?


Message édité par garath_ le 30-01-2012 à 22:21:20

---------------
SFBA Report - HFR Links Preview - Parrainage Mint Energie
n°562921
Lafee14
Posté le 30-01-2012 à 22:23:16  profilanswer
 

Oui, ça fait près de 10 fois que je le fait car j'arrive toujours au même problème
 
Tout comme dans le tuto, il manque le "curl.tgz"
 
Mais sinon je pense que c'est bien installé car j'arrive à avoir la fiche info.php !

n°562922
garath_
Posté le 30-01-2012 à 22:25:03  profilanswer
 

Quand tu cliques sur les 2 adresses que j'ai donnée plus haut, ça donne bien le résultat attendu (à part l'interface d'administartion?)
L'adresse ip du nas est bien 192.168.1.36 ?


---------------
SFBA Report - HFR Links Preview - Parrainage Mint Energie
n°562923
Lafee14
Posté le 30-01-2012 à 22:27:22  profilanswer
 

Oui sauf que je tombe sur le info.php et monsite est Accueil.php mais sinon Oui c'est bien ça
Oui pour l'interface  EDIT : mais je n'arrive pas a me connecter !
Edit : Oui l'adresse du Nas est bien 192.168.1.36


Message édité par Lafee14 le 30-01-2012 à 22:34:36
n°562927
garath_
Posté le 30-01-2012 à 22:50:31  profilanswer
 

Ben c'est normal déjà , par défaut lighttpd va rechercher une page qui s'appelle index.php.
Tu peux modifier ça dans lighttpd.conf pour qu'il recherche aussi accueil.php


---------------
SFBA Report - HFR Links Preview - Parrainage Mint Energie
n°562933
Marmotte_7​3
Posté le 30-01-2012 à 23:43:20  profilanswer
 

le_candide a écrit :


j'ai peut-être une piste : copier et adapter le contenu de /ffp/start/kickwebs_dns320.sh directement dans /mnt/HD/HD_a2/fun_plug
comme ça ce sera fait avant l'appel au chroot (qui a plus de limitations).
(nota si ça marche dans l'environement chrooté, il suffit de rajouter ta commande dans /boot/linuxrc)


 
J'y ai effectivement pensé....
Sauf que je n'arrive pas à trouver  comment stopper lighttpd et le relancer en ligne de commande....
Il seraient localisés ici...
root      1742  1373  0 00:14 ?        00:00:00 /usr/sbin/lighttpd -D -m /usr/local/lib -f /etc/lighttpd/lighttpd.conf  
root      1373     1  0 00:14 ?        00:00:00 /usr/sbin/lighttpd-angel -D -m /usr/local/lib -f /etc/lighttpd.conf  
 
Mais comment les stopper et les redémarrer depuis putty....  j'obtiens :
-bash: /usr/sbin/lighttpd: Aucun fichier ou dossier de ce type
 
J'avais rusé en rebootant manuellement le nas mais après il ne me trouvait pas le lighttpd.conf que j'avais redéfini sur 81...
 

n°562938
chaced
Posté le 31-01-2012 à 00:14:50  profilanswer
 

kill -3 piddelighttpd ?

 

C'est quoi le gestionnaire de daemon ? service ou init.d ?

Message cité 1 fois
Message édité par chaced le 31-01-2012 à 00:16:43

---------------
CPU-Z | Timespy | Mes bd
n°562939
Marmotte_7​3
Posté le 31-01-2012 à 00:47:39  profilanswer
 

chaced a écrit :

kill -3 piddelighttpd ?
 
C'est quoi le gestionnaire de daemon ? service ou init.d ?


 
Aucune idée justement...  :??:  
Comment savoir ?

n°562942
le_candide
Posté le 31-01-2012 à 01:34:15  profilanswer
 

voici un moyen plus rapide pour installer une debian squeeze sur votre nas en appliquant toutes
les corrections mentionnées ici (le pinning est paramétré, mais dans le fichier sources.lst, les testing/unstable/experimentals sont en commentaire, en effet c'est plutôt réservé au "audacieux" )
 
 
Installation Debian Squeeze Chrooté (alternative à FFP)  
A. installation fichiers
Téléchargez directement sur //ip_nas/Volume_1 les fichiers :


puis redémarrer le NAS ce qui exécutera le script d'installation.  
Au bout de 5 minutes le NAS boot une seconde fois.
Consulter alors le fichier //ip_nas/Volume_1/ffp.log qui doit ressembler à ceci :

[30/01/2012 23:12] installation reussie ;-) , reboot en cours  ...
 
[30/01/2012 23:13] ------ Debut Demarrage DEBIAN DNS-320/325 ------
Starting periodic command scheduler: cron.
[30/01/2012 23:14] ------ Fin Demarrage DEBIAN DNS-320/325 ------

Se connecter alors via Putty avec les paramètres suivants :  
Host name : Ip NAS / connection type : SSH
avec login : root    /  password : dlink
Modifiez le mot de passe via la commande :

passwd


B. Mise à jour de la distribution ...
en exécutant les commandes suivantes

aptitude update
aptitude install deb-multimedia-keyring  
aptitude update
aptitude upgrade

(répondre "Yes" aux différentes questions)
 
C. "Francisation" de l'installation...
... en installant le paquet locales via les commandes suivantes :

aptitude install locales
dpkg-reconfigure locales

Sélectionnez (avec la touche espace) : fr_FR ISO-8859-1 ;  fr_FR UTF8.UTF8 ;  fr_FR@euro ISO-8859-15
mettez par défaut : fr_FR UTF8.UTF8
 
D. synchroniser heure ...(optionnel)
exécuter la commande suivante :  

aptitude install ntpdate


puis pour que le nas soit mis à l'heure à chaque redémarrage, ajouter dans le fichier :
 /boot/linuxrc la ligne :

/usr/sbin/ntpdate fr.pool.ntp.org

Message cité 4 fois
Message édité par le_candide le 14-08-2014 à 12:47:10
n°562945
le_candide
Posté le 31-01-2012 à 02:11:03  profilanswer
 

Bonjour,
comme je suis en train de mettre à jour le premier post, pour ceux qui seraient perdu,
je remet l'original dans ce post :

http://reho.st/up.nas-tweaks.net/2010/12/DNS-320-500x443.jpg
 
Sommaire
1. Installation de fun_plug
2. Installation de squeeze une alternative à funplug
   2.1 Installation de twonkyserver
   2.2 Installation de sabnzbd
   2.3 Installation de mediatomb
   2.4 installation de minidlna (alternative à mediatomb)
3. Mise à jour de mediatomb sous fun_plug
 
 
1. Tutoriel d'initiation à Fun-Plug pour le NAS D-Link DNS-320
Plutôt que de faire un premier post (très) lourd, je vous propose de télécharger le tuto au format pdf avec les fichiers nécessaires.
Pour simplifier funplug est système de plugin qui vous permettra d'entendre les capacités de votre NAS pour y ajouter des fonctionnalités supplémentaires.
Tout cela est très bien décrit dans le tuto que je vous invite à consulter.
 
Télécharger: Fun-plug-DNS320FR-v1.1a
mot de passe: hardware.fr
 
Miroir: http://www.alerte-bonne-affaire.fr [...] -v1-1a.zip
 
 
auteur : ULI (http://nas-tweaks.net/author/uli/)
traduction : GARATH_  
adaptation/correction : ECK0  
 
version du document : 1.1 fr (révision A)  
date de publication : 2011.08.09 (y-m-d)
 
Merci à ECK0 pour ce super document. ;)
 
 
2. Voici un tutoriel qui synthétise toutes les manipulations à faire pour installer squeeze ainsi que twonkyserver:
Merci à florent33700.
 
L'installation de squeeze permet d'obtenir un environnement chrooté et donc plus sûr.  
ffp n'étant pas chrooté, il y a une faille ...  
En effet, en passant via le sftp, les utilisateurs (ayant un compte créé via l'interface de gestion du NAS) peuvent parcourir toute l'architecture du disque et donc accéder aux fichiers qui ne leur sont pas autorisés.  
 
La faille est cependant limitée à vos utilisateurs de votre NAS, mais il convient de faire attention.
 
 
Vous trouverez les fichiers nécessaires à cette adresse : http://www.megaupload.com/?d=Q7TTJRUG

 
- déposer fun_plug + fun_plug.tgz dans Volume_1
- redémarrer le NAS
- déposer fun_plug.debian + squeeze.tar.gz ( à télécharger ici : http://www.megaupload.com/?d=5823T7NX  ) dans Volume_1
- se connecter en telnet sur le NAS et taper les commandes suivantes :
 # cd /mnt/HD/HD_a2
 # gunzip squeeze.tar.gz
 # tar -xf squeeze.tar
- supprimer le fichier fun_plug et squeeze.tar et renommer fun_plug.debian en fun_plug
- redémarrer le NAS
- se connecter en ssh sur le NAS avec comme id : root et mdp:dlink
-lancer la commande suivante afin de changer le mot de passe root :
 #passwd
 
 
2.1 Tutoriel installation twonkyserver :
 
Avant tout, il est nécessaire d'installer unzip et killall :
 #aptitude install unzip
 #aptitude install psmisc sysvinit-utils
 
Ensuite, taper les commandes suivantes (c'est une adaptation du tutoriel proposé par garath_ pour squeeze):
 #mkdir -p /usr/local/twonkymedia/data
 #cd /usr/local/twonkymedia
 #wget http://www.twonkyforum.com/downloa [...] 6.0.37.zip
 #unzip twonkymedia-kurobox-pro-*.zip
 #rm nassetup.exe nas-installer nas-uninstaller install.nas twonkymedia-kurobox-pro-*.zip
 #chmod +x /usr/local/twonkymedia/twonkymedia
 #chmod +x /usr/local/twonkymedia/twonkymediaserver
 #chmod +x /usr/local/twonkymedia/plugins/*
 #chmod +x /usr/local/twonkymedia/cgi-bin/*
 
Copier le script twonkymedia.sh dans /etc/init.d/
Le rendre exécutable :
 #chmod +x /etc/init.d/twonkymedia.sh
 
Afin que twonky se lance au démarrage du NAS ajouter cette ligne dans le fichier /boot/linuxrc :
 #/etc/init.d/twonkymedia.sh start
 
A SAVOIR :
Le script twonkymedia.sh crée un historique dans le fichier log.txt situé dans Volume_1.
 
 
INFORMATION :
Pour désinstaller ffp et squeeze remplacer le fichier "fun_plug" situé dans Volume_1 par "Désinstallation de ffp et squeeze" (fourni)
 
 
 
2.2Installation de saznbd
Merci à le_candide
 
L'installation est valable uniquement pour une debian, pour que ça tourne sur FFP, il faudrait suivre un tuto pour installer python et le reste (peut être via optware).
 
Voici en résumé le tuto applicable sur une debian chrootée ("je cite" ) :

Citation :


Toutes les commandes vont êtres effectués depuis Putty en ligne de commande. Ensuite pour configurer SABnzbd ça se passera depuis l’explorateur Internet.
 
Pour commencer, j’ai ajouté les sources de SABnzbd dans mon fichier source de Debian:
 
nano /etc/apt/sources.list
 
puis à la fin du fichier j’ai ajouté:
 
#SABnzbd
deb http://ppa.launchpad.net/jcfp/ppa/ubuntu lucid main
 
J’ai aussi ajouté:
 
non-free après deb http://ftp.fr.debian.org/debian/ squeeze main
 
pour installer unrar par la suite.
 
Ensuite il faut ajouter les clés avec la commande:
 
apt-key adv --keyserver hkp://keyserver.ubuntu.com:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
 
Comme toujours après avoir modifier le fichier sources.list, il faut rafraichir:
 
aptitude update
 
Maintenant nous pouvons lancer l’installation de SABnzbd:
 
aptitude install sabnzbdplus
 
Puis celle de Unrar pour décompresser automatiquement les fichiers compressés:
 
aptitude install unrar
 
Nous voilà avec SABnzbd sur le serveur, mais il faut maintenant le lancer:
 
/etc/init.d/sabnzbdplus start
 
Voila, maintenant il suffit d’ouvrir son navigateur Internet et de tapper l’adressse:
 
http://IP_du_serveur:8080/sabnzbd/
 


 
 
2.3 Installation de mediatomb sous squeeze
merci à le_candide
 
a. Ajuster les devices /dev/random & /dev/null dans l'environnement chrooté :
   sous windows, avec par exemple notepad++, ouvrir le fichier //volume_1/fun_plug
   Après la ligne "mount --bind /dev $DISTDIR/dev" ajouter les instructions suivantes  :
      mknod -m 0444 $DISTDIR/dev/random c 1 8
      chmod 666 $DISTDIR/dev/null

 
b. Elargir la liste des packages installable :
   sous putty exécuter la commande suivante :
      nano /etc/apt/sources.list
   puis modifier la ligne :
      deb http://ftp.fr.debian.org/debian/ squeeze main
   en :
      deb http://ftp.fr.debian.org/debian/ squeeze main non-free
   (faire ctrl+X pour quitter l'éditeur nano)
 
c. Installer le package mediatomb ...
   ... en exécutant la commande suivante (sous putty):
   aptitude install mediatomb-common mediatomb-daemon
 
d. Paramétrer et ré-exécuter le service/daemon...
   ... en exécutant les commandes suivantes (sous putty):
      sed -i '/ui enabled/s/no/yes/' /etc/mediatomb/config.xml
      /etc/init.d/mediatomb restart

   le paramétrage s'effectue ensuite sur votre navigateur internet favori en spécifiant l'adresse suivante:
      http:"ip_de_votre_nas":49152
   (nota, contrairement à FFP, le fichier config.xml se trouve sur /etc/mediatomb/config.xml)
 
e. (optionnel) Paramétrer le démarrage automatique de mediatomb...
   ... en exécutant la commande suivante (sous putty):
      nano /root/linuxrc
   et ajouter à la fin du fichier la ligne suivante :
      /etc/init.d/mediatomb restart
 
 
 
2.4 Installation de minidlna sous squeeze
merci à nono87410
 
source: http://www.galipe.net/articles/min [...] lna-leger/
 
On installe d’abord les dépendances requises pour la compilation:
 
aptitude install build-essential libexif-dev libjpeg-dev libid3tag0-dev libflac-dev libvorbis-dev libsqlite3-dev libavformat-dev libuuid1

Ensuite on rafraîchi les bibliotheques dev par un update  
aptitude update
aptitude upgrade
 
 
Puis on va se placer dans le dossier temporaire:
cd /tmp/
?
On télécharge le fichier des sources (ici la dernière version en date était la 1.0.22):
Wget http://downloads.sourceforge.net/p [...] 1.0.22_src .tar.gz
?puis l'on décompresse l'archive:
tar -xzvf minidlna_1.0.22_src.tar.gz
?On se met dans le dossier des sources décompressées "minidlna_1.0.22":
cd minidlna_1.0.22
?Et on lance un "make"
make
?Il n'y a plus qu'à copier les fichiers obtenus aux bons endroits:
cp minidlna /usr/sbin/
cp minidlna.conf /etc/
cat linux/minidlna.init.d.script > /etc/init.d/minidlna
chmod +X /etc/init.d/minidlna
chmod 755 /etc/init.d/minidlna

?Voilà, vous n'avez plus qu'à faire les réglages de vos préférences (dossier où sont stockés vos medias, port d'écoute, pochettes d'albums, etc...) dans le /etc/minidlna.conf  
le chemin de mon dossier MEDIA qui contient les dossiers FILMS,MUSIQUE et  PHOTOS est   /mnt/HD/HD_a2/MEDIA
donc dans le fichier /etc/minidlna.conf voila ce que ça donne
 
# port for HTTP (descriptions, SOAP, media transfer) traffic
port=8200
 
# network interfaces to serve, comma delimited
#network_interface=eth0
 
# set this to the directory you want scanned.
# * if have multiple directories, you can have multiple media_dir= lines
# * if you want to restrict a media_dir to a specific content type, you
#   can prepend the type, followed by a comma, to the directory:
#   + "A" for audio  (eg. media_dir=A,/home/jmaggard/Music)
#   + "V" for video  (eg. media_dir=V,/home/jmaggard/Videos)
#   + "P" for images (eg. media_dir=P,/home/jmaggard/Pictures)
 
media_dir=V,/mnt/HD/HD_a2/MEDIA/FILMS
media_dir=A,/mnt/HD/HD_a2/MEDIA/MUSIQUE
media_dir=P,/mnt/HD/HD_a2/MEDIA/PHOTOS

 
pour éditer /etc/minidlna.conf
 
nano /etc/minidlna.conf
 
ensuite lancer minidlna par:
/etc/init.d/minidlna start
 
pour  ajouter  à votre séquence de boot  un démarrage automatique de minidlna editer avec nano
nano /boot/linuxrc
 
et ajouter a la fin du fichier
 
/etc/init.d/minidlna start
 
Le problème des fichiers de playlist:?Lors du scan il a passé ~ 2 minutes d'analyse par fichier m3u qu'il a trouvé, s'il en trouve tout un tas l'indexation ne finira jamais...
Comme je n'ai aucune utilité des fichiers m3u, ni pls, je les ai effacé de ma bibliothèque en me rendant dans le dossier où sont stockés mes medias et en utilisant ces commandes:
find . -name "*.m3u" -exec rm '{}' \;
find . -name "*.M3U" -exec rm '{}' \;
find . -name "*.pls" -exec rm '{}' \;
find . -name "*.PLS" -exec rm '{}' \;

Le cache de MiniDLNA mis dans le répertoire /tmp:?Par défaut MiniDLNA génère ses fichiers de cache (base de données, etc...) dans le dossier temporaire /tmp/ qui dégage à chaque reboot (ça veut dire rescanner tout à chaque démarrage de la machine).?Une option est disponible depuis des récentes version pour stocker ces données ailleurs (au choix de l'utilisateur).?Il suffit de renseigner la variable "db_dir" dans le fichier de configuration, /etc/minidlna.conf
db_dir=/var/cache/minidlna
 
pour ceux que ça interresse aussi j'ai installer airplayer sur mon iphone et je me connecte a mon serveur minidlna en 3G depuis n'importe ou ( bon c'est ok pour la musique mais pour la video il vos mieux etre en wifi)
pour cela configurer le routage de port en tcp vers l'adresse ip de votre nas sur le port 8200
ensuite dans airplayer rentrer " http://l'adresse ip exterieur du nas:8200/rootDesc.xml" et hop voila le serveur  
attention!!!! minidlna n'a pas de protection par mot de passe donc en ouvrant le port 8200 vous exposez votre serveur sur le net
 
 
MAJ de mediatomb pour funplug dans le 2ème post!

Message cité 1 fois
Message édité par le_candide le 03-02-2015 à 16:04:33
n°562954
Lafee14
Posté le 31-01-2012 à 09:13:49  profilanswer
 

garath_ a écrit :

Ben c'est normal déjà , par défaut lighttpd va rechercher une page qui s'appelle index.php.
Tu peux modifier ça dans lighttpd.conf pour qu'il recherche aussi accueil.php


 
Oui, mais ce qui me parait bizarre, j'arrive bien a avoir aussi bien le info.php ainsi que tout mon site web (toutes les pages sont en .php), mais que chez moi !
Et toujours rien de l'extérieur
 
Je modifierai Lighttpd ce soir en rentrant du taf, j'y ajouterai Accueil.php ! Mais ce sera sans conviction  :heink:
 
 
Et est-ce que le Dyndns doit être obligatoirement en .org, car actuellement je suis en .com  :??:


Message édité par Lafee14 le 31-01-2012 à 12:39:05
n°562955
sito59
Posté le 31-01-2012 à 09:19:44  profilanswer
 

le_candide a écrit :

Bonjour,
comme je suis en train de mettre à jour le premier post, pour ceux qui seraient perdu,
je remet l'original dans ce post :

http://hfr-rehost.net/http://up.na [...] 00x443.jpg
...
MAJ de mediatomb pour funplug dans le 2ème post!


 
 :jap:  
Au-delà de l'installation de divers logiciels sur le DNS-320, je suggère la création d'une petite section dédiée aux firwares (versions / installation des MAJ)...

n°562958
le_candide
Posté le 31-01-2012 à 09:26:32  profilanswer
 

sito59 a écrit :


 
 :jap:  
Au-delà de l'installation de divers logiciels sur le DNS-320, je suggère la création d'une petite section dédiée aux firwares (versions / installation des MAJ)...


ça roule !
j'ai aussi dans les tiroirs : les débits 320/325, comment changer/ajouter des HD sans soucis, une partie hardware (montage wake-on lan, montage cable pour JTAG, remplacement ventillateur)
et bien entendu je reste ouvert à toute proposition  ;)


Message édité par le_candide le 31-01-2012 à 09:27:38
n°562961
lasolution
A perdu son pseudo de 2005
Posté le 31-01-2012 à 09:54:16  profilanswer
 

Bonjour,
question débile mais ça rapporte quoi de faire tout ça ?
c'est uniquement pour ceux qui veulent heberger un site web ?

n°562962
Marmotte_7​3
Posté le 31-01-2012 à 10:02:21  profilanswer
 

le_candide a écrit :

voici un moyen plus rapide pour installer une debian squeeze sur votre nas en appliquant toutes
les corrections mentionnées...


 
Pas de souci pour l'installation de Squeeze, çà fonctionne sur le dns-320
En revanche l'installation d'apache et le passage de lighttpd sur le port 81.... quelqu'un a t'il déjà essayé ?
 
A
root@NAS:~#  /etc/init.d/apache2 start  
 
J'obtiens ceci...  
apache2: Could not reliably determine the server's fully qualified domain name, using 192.168.1.16 for ServerName  
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80  
no listening sockets available, shutting down  
 
Si j'ai bien compris c'est parce qu'il y a lighttpd qui prend déjà la place  
 
lighthttpd est utilisé sur le port 8à pour l'accès à l'interface d’administration du nas  
 
Effectivement la commande renvoie  
 
root@NAS:~# netstat -tulpn| grep :80  
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN                      1742/lighttpd  
 
J'ai essayé de changer la conf de lighttpd en passant le port en 81  
 
A priori ? la conf serait ici  
/mnt/root/etc/lighttpd/lighttpd.conf  
 
Mais quand je redémarre le nas (au passage impossible de trouver l'appli pur faire un restart) ..., bref en redémarrant le nas, la conf repasse en 80...  
 
Il me faudrait apparemment faire un script du genre de celui indiqué ici pour ffp, équivalent au kickwebs_dns320.sh  
 
http://dns323.kood.org/dns-320#cha [...] on_utility  
 
Mais je n'arrive ps à trouver les bons répertoires pour qu'il me prenne lighttpd_portmod.conf  
 
Pour info, les processus lighttpd qui tournent au démarrage sont localisés ici  
 
root      1742  1373  0 00:14 ?        00:00:00 /usr/sbin/lighttpd -D -m /usr/local/lib -f /etc/lighttpd/lighttpd.conf  
root      1373     1  0 00:14 ?        00:00:00 /usr/sbin/lighttpd-angel -D -m /usr/local/lib -f /etc/lighttpd.conf  
 
Je n'y connais pas grand chose en linux et çà se limite à du bidouillage, si quelqu'un a des pistes pour m'aider... je suis preneur.

n°562963
le_candide
Posté le 31-01-2012 à 10:15:22  profilanswer
 

[DEBIAN SQUEEZE] TUTO : comment changer le port par défaut de l'interface admin du dlink (et ainsi pouvoir installer un serveur woueb)
(source : http://dns323.kood.org/dns-320 )
 
sous putty/client ssh exécuter les commandes suivantes :

cp -p /mnt/root/etc/lighttpd/lighttpd.conf /etc/lighttpd_portmod.conf
nano /etc/lighttpd_portmod.conf

sous nano trouver la ligne ci-dessous et la modifier avec le port souhaité (exemple 8888) :
server.port = 8888
 
directement dans //ip_nas/volume_1/fun_plug, avant l'appel au chroot ajouter les lignes suivantes :

#>> Debut changement du port pour le webui
echo "killing  lighttpd-angel"
kill -9 `pidof lighttpd-angel`
echo "killing  lighttpd"
kill -9 `pidof lighttpd`
echo "redemarrage lighttpd-angel sur un port different"
/usr/sbin/lighttpd-angel -D -m /usr/local/lib -f /mnt/HD/HD_a2/squeeze/etc/lighttpd_portmod.conf &
##<< Fin changement du port pour le webui

redemarrer le NAS et vérifier que le contenu du fichier //ip_nas/ffp.log contient bien les lignes :

killing  lighttpd-angel
killing  lighttpd
redemarrage lighttpd-angel sur un port different

puis se connecter sur l'interface woueb admin dlink en deux fois

  • 1ere fois pour le login (user/mot de passe) : http://ip_du_nas:8888/web/login.html
  • une fois connecté il faut retaper le lien : http://ip_du_nas:8888/web/home.html

Message cité 1 fois
Message édité par le_candide le 20-02-2012 à 23:39:44
n°562964
chaced
Posté le 31-01-2012 à 10:21:10  profilanswer
 

Marmotte_73 a écrit :


 
Aucune idée justement...  :??:  
Comment savoir ?


 
si il y a le repertoire /etc/init.d c'est que c'est init.d :D
 
/etc/init.d/lighttpd restart


---------------
CPU-Z | Timespy | Mes bd
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  34  35  36  ..  152  153  154  155  156  157

Aller à :
Ajouter une réponse
 

Sujets relatifs
Débit ultra lent sur NAS Memup Mediadisk LNXconstruction Nas perso fait main ....
NAS vide après changement de BoxServeur d'impression WiFi TP-LINK TL-WPS510U Installation ?
Nas Netgear Duo: Syslog possible?aide sur choix NAS
DLink DNS 320 - Raid 1Propagation DNS, bancal depuis 3 jours
internet avec wireless + NAS avec lan = internet lentNAS : Synology DS110j ou D-Link DNS-320 ?
Plus de sujets relatifs à : [Nas] D-Link ShareCenter DNS-320/DNS-320L et DNS-325


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR