Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2010 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  nouvelles images passent plus sur site page perso ( non résolu )

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

nouvelles images passent plus sur site page perso ( non résolu )

n°903686
sagamore
Posté le 10-01-2016 à 21:49:25  profilanswer
 

Bonjour.
 
Bon je vais essayer de faire simple.
Je ne suis pas informaticien de formation.
Grace à openclassroom j'ai appris HTML CSS3 et même php Mysql.
J'ai écris mes 2 sites (laborieusement, mais bon.................).
Je suis chez orange en page perso donc uniquement HTML5 et CSS3 possible ( pas grave j'ai écris aussi mes 2 sites en php qui tournent sur mon PC ( dual boot Seven / Ubuntu ) en serveur local ).
J'ai décider de mettre à jour mon premier site : http://daniel-aquarelles.pagesperso-orange.fr/
 
J'ai donc ajouté des photos de taille différentes ( 160x120 ans Navigation ans mes motifs préférés ) et 640x480 ou 480x640 une fois que l'on a choisi un motif ( Bastides , Corse , Normandie par exemple ).
 
Je travaille sous Seven 64 bits , Filezzila 3.141 , VSO image resizer 4.0.3.6
 
Coté code je n'ai pas de soucis.
C 'est coté " image " que ça queutte. Les nouvelles photo réduites en résolution et en taille ne passent pas. Ce sont pourtant des .jpg.
Par exemple la photo " Bretagne " dans la page " Navigation dans mes motifs préférés " n'est pas visible.
Quand je clique droit " examiner l'élément " sur le minuscule icone au desssus de Bretagne ( dans l'onglet  Navigation dans mes motifs préférés )  j'obtiens çà :
                             <div>                          
                     <a href="bretagne.html">
                                  <img src="images/daniel_aquarelles/Bretagnemini.jpg" /></a>
                                  <p>Bretagne</p>        
                             </div>
Et quand je clique sur la ligne <img src="images/daniel_aquarelles/Bretagnemini.jpg" /></a> , il me dit " impossible de charger l'image " ou 24x24.
 
Quand je remplace les nouvelles images qui semblent  "défectueuses" par des anciennes ( de même tailles bien sur en changeant juste le nom ) ça marche.
Ces images "défectueuses"  s'ouvrent sans problème avec la visionneuse de photo windows.
 
J'ai bien vérifié :
 - les extensions ( .jpg et pas .JPG ou autres extensions ).
 - les poids à qq ko prés.
 - les tailles ( résolutions 640x480 ou 160x120 ).  
 - les droits d'accés 0644 et proprio groupe 33 33
 
Merci de votre aide.


Message édité par sagamore le 12-01-2016 à 22:14:41
mood
Publicité
Posté le 10-01-2016 à 21:49:25  profilanswer
 

n°903719
splinter_f​ive0
Posté le 11-01-2016 à 08:25:57  profilanswer
 

Bonjour,
 
et en changeant le nom de l'image qui pose probleme  ? en la nommant exactement à l'identique de l'ancienne image par exemple ?

n°903731
sagamore
Posté le 11-01-2016 à 09:46:41  profilanswer
 

Je l'ai fait, j'ai copié l'icone cliquable de Bernay et l'ai renommé Bretagne. Ca marche.
 
J'utilisai un clavier sans fil, je vais faire un essai avec un clavier filaire et une photo prise sur la carte de mon APN ( donc pas encore renommée ).
Sinon je n'ai plus d'idée.

n°903732
slr56
Tout problème a sa solution.
Posté le 11-01-2016 à 09:52:23  profilanswer
 

Bonjour,
 
Les serveurs web (notamment OVH) sont sensibles à la casse.
 
Si votre fichier s'appelle "Bretagnemini.jpg".  Dans le fichier html qui fait appel à ce fichier il faut exactement la même syntaxe (majuscule, minuscule) Il en est de même pour les dossiers dans le chemin indiqué.
 
Ensuite, est ce que le chemin relatif est correct ? C'est à dire le positionnement de la photo dans l'arborescence par rapport au à la page html censée l'affichée?


---------------
Configurations type du moment : https://forum.hardware.fr/hfr/Hardw [...] 1331_1.htm  https://www.jouannetphotographe.com
n°903737
sagamore
Posté le 11-01-2016 à 10:35:45  profilanswer
 

Je regarde de suite.
Merci.
Mais le fichier photo qui est bon lorsqu'il est dans mon dossier " miseàjour" dans mon PC, je le charge avec Filezila sur le serveur d'orange dans mon espace page perso. Donc pas de soucis ?

n°903738
sagamore
Posté le 11-01-2016 à 10:40:09  profilanswer
 

J'ai utilisé un clavier filaire. Ca marche !
Et pourtant je suis certain de n'avoir pas fait d'erreur dans le nom de mes fichiers photo. Je mets çà ( lâchement ) sur le dos du clavier sans fil ( que j'avais déjà mis de coté quand j'avais fait beaucoup de console sous Linux ).
 
Vous avez déjà rencontré des soucis avec un clavier filaire ?
 
Résolu.
 
Merci de votre aide.


Message édité par sagamore le 11-01-2016 à 10:41:34
n°903774
splinter_f​ive0
Posté le 11-01-2016 à 13:36:39  profilanswer
 

Personnellement non mais le principal c'est que ton soucis soit résolu ^^

n°904046
sagamore
Posté le 12-01-2016 à 22:38:29  profilanswer
 

Bon en fin de compte rien n'est résolu.
J'ai renommé des photos prélevées dans une carte mémoire.
Aujourd'hui je viens d'avoir le même problème. Une photo dans mon album Albi ( la première ) n'apparait pas. Quand je clique droit dessus " examiner l'élément " dans l'inspecteur jai le code HTML et en cliquant sur image/Abi/photo1.jpg l'image ne s'affiche pas. J'obtiens un carré blanc dans lequel est marqué 24x24.
Lors de mes recherches en cliquant sur l'onglet console ( juste aprés inspecteur ) j'ai eu un une ligne disant : corrupt-or-truncated.
Et j'ai trouvé ça : http://www.developpez.net/forums/d [...] truncated/
J'ai a peu prés compris que ma photo était corrompue et qu'il fallait que je la refasse en utilisant une source " neuve " ma carte mémoire d'APN.
Le soucis c'est que ça marchait bien avant la mise à jour de Firefox .
Le pôvre clavier filaire.....n'y était pour rien.


Message édité par sagamore le 12-01-2016 à 22:40:23
n°904057
sagamore
Posté le 13-01-2016 à 09:57:46  profilanswer
 

Comment expliquer qu'une photo modifiée ( en résolution et en Ko ) visible avec tous les programmes imaginables sur mon PC, soit une fois " installée " sur le serveur d'orange ( dans mon espace réservé en page perso ) corrompue ou tronquée ?
Est ce Filezilla qui " modifie " ma photo ?
Est-elle " modifiée " lors de son arrivée sur le serveur d'Orange ?
Autre question  : pourquoi lorsqu'à partir de Filezilla, quand je télécharge une de mes photos ( se trouvant sur mon espace personnel d'Orange ) j'obtiens sur mon PC une photo inexploitable ( alors qu'elle était bonne sur mon site ?
Seules les photos sont " esquintées ", pas les fichiers en HTML , CSS ou PHP ?


Message édité par sagamore le 13-01-2016 à 09:58:59

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  nouvelles images passent plus sur site page perso ( non résolu )

 

Sujets relatifs
Noob cherchant à créer un petit site + quelques boîtes mail.Un NAS perso ou du commerce...
ce site ne fournit pasInfecté ? Ou juste un site obsolète ?
Installer un routeur perso derrière une Livebox fibre orange ?Harcelé de pubs à chaque chargement de page !
Cloud et vpn site to siteQuel CM (socket FM2) pour undervolté un A10-5800K
stocker ses fichiers en ligne sur son site, des avis ? 
Plus de sujets relatifs à : nouvelles images passent plus sur site page perso ( non résolu )


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR