Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1066 connectés 

  FORUM HardWare.fr
  Windows & Software

  Serveur FTP avec Switch + Modem ST510v4 en uplink - help

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Serveur FTP avec Switch + Modem ST510v4 en uplink - help

n°2254667
stefexster
Posté le 12-12-2005 à 18:25:15  profilanswer
 

Bonjour à tous,
 
Voilà mon problème est apparemment simple à régler. J'ai fais ma petite recherche sur le forum et j'ai trouvé presque la même réponse, à la différence près : je n'ai pas un routeur MAIS un MODEM ETHERNET SPEEDTOUCH 510 v4 (Version 1 Port Ethernet) relié en UPLINK sur un SWITCH 10Mb 3COM !!
 
Ca change tout apparemment ! Car j'ai procédé comme expliqué dans un autre topic (à savoir celui ci : http://forum.hardware.fr/hardwaref [...] 3951-1.htm ) et mon problème n'est toujours pas résolu.
 
Je m'explique :  
J'ai TYPSOFT FTP Serveur, un soft qui fait office de Serveur FTP avec gestion d'utilisateurs, droits, etc...
 
Je crée donc le SERVEUR avec un PORT = 69 (j'ai pris 69, vous verrez pourquoi par la suite .... il faut savoir que par défaut, il est mis à 21).
 
Mon adresse IP LOCALE sur le réseau de mon PC de bureau est : 10.0.0.1  
L'IP LOCALE du modem ST510v4 sur le réseau est : 10.0.0.138 (qui est également et forcément, ma passerelle internet !).
 
Pour donner un exemple, mon adresse IP sur INTERNET à l'heure actuelle est : 81.240.223.216
 
Donc par conséquent, vu qu'il y a 2 PC connectés sur mon LAN, je dois ATTRIBUER un PORT LOCAL à mon PC de bureau !  
Je dois le paramétrer dans les règles NAT de mon modem ...
 
Voici ce que je mets :  
 
IP locale : 10.0.0.1
Port interne : 69
IP Distante : 0.0.0.0 (ce qui signifie , valable pour toutes !!)
Port Distant : 69
 
Et lorsque quelqu'un essaye de se connecter à mon PC de bureau en tappant :  
 
FTP://81.240.223.216:69/
 
Dans le Monitoring de mon programme TYPSOFT FTP Serveur , je vois ceci :  
 
[17:54:39] - Serveur démarré
[17:54:39] - Port FTP : 69
[17:55:08] - [120] Connecté à 80.200.186.160. Collecte du Nom d'Utilisateur.
[17:55:08] - [120] Utilisateur ANONYMOUS [80.200.186.160] connecté
[17:55:08] - [120] ANONYMOUS : Répertoire en Cours : C:\Documents and Settings\xxxx\Bureau\Test\
 
Dans mon infos des utilisateurs, je vois l'utilisateur et son IP avec son temps de connexion !
 
Le seul ennui c'est que lui, l'explorateur cherche à afficher le contenu du dossier root partagé, et n'affiche rien !  
Et il n'arrive à rien downloader sur moi !  
 
J'ai désactivé Firewall de XP et Firewall SyGate ! Tout passe !  
 
Et pourtant ...  
 
Une explication ?


Message édité par stefexster le 14-12-2005 à 08:22:13

---------------
Stéphane L.
mood
Publicité
Posté le 12-12-2005 à 18:25:15  profilanswer
 

n°2255279
fievel
Posté le 13-12-2005 à 05:32:09  profilanswer
 

:hello:
 
Cela doit être le probème d'une cnx active ou passive Un peut de lecture ;)
 
Rappel des ports par défaut :
 

ftp-data         20/tcp    File Transfer [Default Data]
ftp-data         20/udp    File Transfer [Default Data]
ftp              21/tcp    File Transfer [Control]
ftp              21/udp    File Transfer [Control]


 
Essaye de d'ouvrir les ports 50000 à 50100 pour le mode passif, voir si ça fonctionne...
 
:jap:


---------------
StatsBOINC
n°2256226
stefexster
Posté le 13-12-2005 à 21:57:13  profilanswer
 

Salut Fievel,
 
Tout d'abord MERCI d'avoir pris le temps de me répondre.  :)  
 
Bon, alors j'ai testé .... mais ca ne change rien ... ca fait toujours la même chose :(
 
[21:41:45] - Serveur démarré
[21:41:45] - Port FTP : 50000
[21:56:08] - [1] Connecté à 10.0.0.1. Collecte du Nom d'Utilisateur.
[21:56:11] - [2] Connecté à 10.0.0.1. Collecte du Nom d'Utilisateur.
[21:56:17] - [3] Connecté à 10.0.0.1. Collecte du Nom d'Utilisateur.
 
 
et puis timeout :/


---------------
Stéphane L.
n°2256354
fievel
Posté le 13-12-2005 à 23:07:53  profilanswer
 

:hello:
 
[:ab614]
 
Bon on c mal compris ^^ :ange: dans un premier il serait bien de tester avec les ports par défaut, donc sur ton routeur tu ouvres ceci :
 
21 > TCP
20 > UDP
50000 à 50100 > TCP/UDP
 
:jap:


Message édité par fievel le 13-12-2005 à 23:08:05

---------------
StatsBOINC
n°2256568
stefexster
Posté le 14-12-2005 à 08:19:14  profilanswer
 

Je ne comprends pas ce que tu veux dire par "ouvrir les ports".  
Je rappelle que c'est un MODEM Ethernet, et non un routeur, cela joue aussi. Le modem est prévu pour faire fonctionner 1 PC, et certaines options de réglages telles qu'un routeur dispose, ne sont malheureusement pas présentes.  
 
Si je teste la connexion via :  FTP://mon.adresse.ip.internet:21/ cela se connecte tout de suite, mais j'ai un dossier/fichier qui apparait portant ce nom : .: Permission denied
Je n'ai ni les droits pour créer un dossier dans ce root, ni aucune autre possibilité.  
Si je teste la connexion via : FTP://mon.adresse.ip.internet:50099/ par exemple, j'ai un message disant qu'il est impossible d'établir une connexion.
 
Je n'ai pas de menu, dans la configuration du modem Ethernet SpeedTouch 510 v4 (version 1Port Ethernet) qui me permette d'ouvrir une plage de ports sur telle ou telle adresse IP.  
 
Je pense que le problème vient surement de là.  :ouch:  
 
Merci encore pour le temps que tu me consacre.  ;)


Message édité par stefexster le 14-12-2005 à 08:21:55

---------------
Stéphane L.
n°2257834
fievel
Posté le 15-12-2005 à 08:33:45  profilanswer
 

:hello:
 
ouSp! c moi qui est mal lu :pt1cable: tu as un modem ! ça va être dur d'ouvrir des ports en effet! ;) l'idéal serait de tester en live, donne moi ton MSN en MP. :jap:


---------------
StatsBOINC

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software

  Serveur FTP avec Switch + Modem ST510v4 en uplink - help

 

Sujets relatifs
Drivers modemModem TRC et routeur wifi
routeur ou switch ?modem adsl urgent !!!
Cherche Modem/Routeur ADSL WiFi +TéléphoneNAT modéré avec WIFI club internet = PB, HELP
Help! Fichier System Perdu Ou Endommagé sur XP SP2Celeron 333MHz en serveur PHP/MySQL : faisable ou pas ?
Droits utilisateurs serveur 2003ISA serveur cache !!
Plus de sujets relatifs à : Serveur FTP avec Switch + Modem ST510v4 en uplink - help


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR