Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1704 connectés 

 



Dernière réponse
Sujet : IIS 6 : utilisation de l'authentification intégrée à Windows
man2 Oui tout était bien paramétré dans IIS.
 
En fait il fallait indiquer sur chaque poste client dans les options de IE qu'il faut utiliser l'authentification intégrée à Windows, paramètre qui est inactif par défaut.
Je l'ai appliqué maintenant par GPO, mais il subsiste un problème : je veux utiliser ce parametre uniquement pour la zone intranet afin de ne pas générer de probleme de sécurité sur la zone internet. Le problème c'est que je n'arrive pas à ajouter le site à la zone intranet par GPO. C'est théoriquement possible, j'ai activé la fonction concernée mais le serveur me dit que ma syntaxe n'est pas bonne (ou que mes fichiers .adm ne sont pas à jour, ce qui parait ridicule). Pourtant j'ai mis http://monsite.com en nom de valeur, et 1 en valeur, ce qui est considéré comme la chose à faire dans l'aide, sur le site de Microsoft, ainsi que sur tous les istes web que j'ai trouvé et qui en parlent...
 
EDIT : Finalement ca fonctionne, Windows me donnait en fait un message d'erreur qui ne concernait pas ce point...  [:aless]

Votre réponse
Nom d'utilisateur    Pour poster, vous devez être inscrit sur ce forum .... si ce n'est pas le cas, cliquez ici !
Le ton de votre message                        
                       
Votre réponse


[b][i][u][strike][spoiler][fixed][cpp][url][email][img][*]   
 
   [quote]
 

Options

 
Vous avez perdu votre mot de passe ?


Vue Rapide de la discussion
man2 Oui tout était bien paramétré dans IIS.
 
En fait il fallait indiquer sur chaque poste client dans les options de IE qu'il faut utiliser l'authentification intégrée à Windows, paramètre qui est inactif par défaut.
Je l'ai appliqué maintenant par GPO, mais il subsiste un problème : je veux utiliser ce parametre uniquement pour la zone intranet afin de ne pas générer de probleme de sécurité sur la zone internet. Le problème c'est que je n'arrive pas à ajouter le site à la zone intranet par GPO. C'est théoriquement possible, j'ai activé la fonction concernée mais le serveur me dit que ma syntaxe n'est pas bonne (ou que mes fichiers .adm ne sont pas à jour, ce qui parait ridicule). Pourtant j'ai mis http://monsite.com en nom de valeur, et 1 en valeur, ce qui est considéré comme la chose à faire dans l'aide, sur le site de Microsoft, ainsi que sur tous les istes web que j'ai trouvé et qui en parlent...
 
EDIT : Finalement ca fonctionne, Windows me donnait en fait un message d'erreur qui ne concernait pas ce point...  [:aless]
moldar Tu as bien mis une authentification de type "Authentification Digest pour les serveurs de domaine Windows"  en précisant ton domaine ? (onglet sécurité de répertoire)
ninoulilo Bonjour,
J'avais le même souci que toi, pour ma part je voulais accéder au site sans mot de passe ni nom d'utilisateur.
Mais toi est  ce que tu veux absolument qu'il mette leur nom utilisateur du domaine ou qu'on puisse accéder au site sans mot de passe?
 
Enfin moi ce que j'ai fait, j'ai tout réinstallé, et même formater et maintenant ca marche, j'avais du faire une mauvaise manip.
Bon courage
man2 Merci pour ta réponse.
 
J'ai remplacé le msftpsvc par w3svc, qui est le service pour le web.
la commande s'éxécute correctement :  
 
C:\Inetpub\AdminScripts>cscript adsutil.vbs set w3svc/DefaultLogonDomain domain
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. Tous droits réservés.
 
DefaultLogonDomain              : (STRING) "domain"
 
mais ca ne change rien : je dois toujours spécifier le domaine lorsque j'essaie de me connecter   :??:  
 
Il y a quelque chose qui m'echappe...  
 
moldar Ca ne va pas répondre directement à ta question, mais pour définir le domaine par défaut pour les sites FTP, il faut faire comme ça :
 

Code :
  1. cd /d %systemdrive%\inetpub\adminscripts
  2. cscript adsutil.vbs set msftpsvc/DefaultLogonDomain nom_domaine avec nom_domaine le domaine active directory


 
Donc pour les sites Web, la syntaxe doit être assez proche...

man2 Salut à tous,
 
J'ai configuré un site web sous IIS 6 et Windows 2003 Server et tout fonctionne bien. Pour gérer les droits d'accès, je veux utiliser l'authentification intégré à Windows, afin de ne pas obliger les utilisateurs à taper un nom et un mot de passe. J'ai donc activé l'option correspondante dans les propriétés du site dans IIS.
Le serveur et les postes qui doivent accéder sont tous intégrés dans un domaine Windows 2000.  
Le problème, c'est que pour accéder au site, il faut systématiquement entrer un nom et un mot de passe. A la limite, ca passe encore, mais il faut entrer en plus le nom complet (user@domaine.lan ou DOMAINE\User) et le mot de passe. Etant donné que toutes les machines sont sur le même domaine, j'ai du mal à comprendre pourquoi ca me réclame le nom de domaine (si je le met pas, ca marque MACHINE_LOCALE\user dans l'emplacement du nom). Comme l'accès marche,  en utilisant le meme compte utilisé pour l'ouverture de session du client, ca n'est pas une histoire d'autorisations.
Bref, comment configurer IIS (ou le client ?) pour qu'il utilise correctement l'authentification intégrée à Windows ? Au moins ne pas avoir à taper le domaine, comme pour l'ouverture d'une session "normale" sur le domaine, car les utilisateurs ne vont jamais s'y faire...
 
Merci pour votre aide !
 

Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR