Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1714 connectés 

  FORUM HardWare.fr
  Programmation

  [PHP] problème include ...

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[PHP] problème include ...

n°13753
funwebmax
Posté le 11-02-2001 à 16:21:22  profilanswer
 

j'ai un problème bizarre.
hier j'ai formaté .... et j'ai réinstallé le PHP mais maintenant, tous mes fichiers include merde .
 
tous mon site est fais de fichier include car les liens sont "index.php?page=blabla"
 
c'est pas le script qui merde car ça marchait avant ...
 
c'est koi a votre avis, merci .... je comprends rien...

mood
Publicité
Posté le 11-02-2001 à 16:21:22  profilanswer
 

n°13779
Roswell_
Posté le 11-02-2001 à 20:56:17  profilanswer
 

je sais pas du tout, je suppose que tes liens ne sont pas en absolue sinon ça marcherait pas sur ton site.
 
Essaie de faire des include les plus simples possibles pour voir si la fonction marche toujours.
 
sinon il y à des équivalent mais qui sont peut être juste des alias. virtual() si je me souvient bien...


---------------
http://www.cheata.net le site qui vous donne la banane!
n°13838
funwebmax
Posté le 12-02-2001 à 11:40:11  profilanswer
 

la fonction include() marche tjs.
 
je comprends pas, ça marche sur mon site et pas en local ...
 
roswell_> c'est koi les liens en absolue ...
 
et c'est koi les alias.
merci A+

n°13843
omega2
Posté le 12-02-2001 à 12:00:36  profilanswer
 

funwebmax a écrit a écrit :

la fonction include() marche tjs.
 
je comprends pas, ça marche sur mon site et pas en local ...
 
roswell_> c'est koi les liens en absolue ...
 
et c'est koi les alias.
merci A+




En absolue, ca veut dire que t'as mis le chemin complet du fichier (depuis la racine du disque).
En relatif, ca veut dire que t'as mis le chemin du fichier en fonction de sa position par rapport au fichier de départ.
Un alias, c'est un nom constant qui remplace une partie d'un chemin d'ccés au fichier (un peu comme une variable que tu ne peux modifier).
 
Pour ton problème, je pense que c'est le chemin d'include par défault qui n'est pas le même après ta réinstallation qu'avant. Du coup, il ne trouve plus les fichiers qu'il a besoin.

n°13848
funwebmax
Posté le 12-02-2001 à 13:00:55  profilanswer
 

comment je fais pour changer le chemin d'include par défault ...

n°13851
zeltron
Posté le 12-02-2001 à 13:44:47  profilanswer
 

Il faut modifier le fichier de config de PHP.

n°13853
funwebmax
Posté le 12-02-2001 à 14:23:55  profilanswer
 

zeltron a écrit a écrit :

Il faut modifier le fichier de config de PHP.




 
c'est Php.ini, je suppose ...
 
a la ligne include_path
ya rien d'ecrit, faut mettre koi
merci

n°13875
funwebmax
Posté le 12-02-2001 à 15:55:49  profilanswer
 

je vais essayer de m'expliquer mieux.
 
sur la page index.php, j'ai ce script
 
<?php  
if (empty($page)) {$page=accueil;}
$url=$page.".php";  
include("$url" );  
?>
 
et sur cette page, les liens sont de la forme index.php?page=blabla
 
normalement ça devraient ouvrir  blabla.php
mais en fait il m'ouvre tjs accueil.php
voila, ce ki est encore pus bizarre, c'est que sur forez, ça marche très bien.
ya kan local que ça merde ....

n°13965
funwebmax
Posté le 12-02-2001 à 22:46:43  profilanswer
 

personne ne sait ?  :(  :??:

n°13990
Sh@rdar
Ex-PhPéteur
Posté le 13-02-2001 à 08:19:20  profilanswer
 

J'ai eu exactement le même problème suite à une réinstallation.
C'est clairement un pb avec ton php3.ini mais je sais plus lequel
sinon file ton mail je te ferai suivre mon fichier ..
 
@+


---------------
La musique c'est comme la bouffe, tu te souviens du restaurant dans lequel t'as bien mangé 20 ans plus tôt, mais pas du sandwich d'il y a 5 minutes :o - Plugin pour winamp ©Harkonnen : http://harko.free.fr/soft
mood
Publicité
Posté le 13-02-2001 à 08:19:20  profilanswer
 

n°14008
Roswell_
Posté le 13-02-2001 à 10:14:10  profilanswer
 

Bah, moi j'ai rien non plus dans le path du include, sorry


---------------
http://www.cheata.net le site qui vous donne la banane!
n°14010
funwebmax
Posté le 13-02-2001 à 10:18:35  profilanswer
 

Sh@rdar a écrit a écrit :

J'ai eu exactement le même problème suite à une réinstallation.
C'est clairement un pb avec ton php3.ini mais je sais plus lequel
sinon file ton mail je te ferai suivre mon fichier ..
 
@+




 
c'est bizarre ...
sh@dar, envoie ton php.ini STP
webmaster@funwebmax.com
je te remercie

n°14012
Lord II
PIB2000
Posté le 13-02-2001 à 10:23:14  profilanswer
 

funwebmax a écrit a écrit :

je vais essayer de m'expliquer mieux.
 
sur la page index.php, j'ai ce script
 
<?php  
if (empty($page)) {$page=accueil;}
$url=$page.".php";  
include("$url" );  
?>
 
et sur cette page, les liens sont de la forme index.php?page=blabla
 
normalement ça devraient ouvrir  blabla.php
mais en fait il m'ouvre tjs accueil.php
voila, ce ki est encore pus bizarre, c'est que sur forez, ça marche très bien.
ya kan local que ça merde ....




 
Justement moi je suis sur forez et j'ai un pb d'include egalement. Je m'explique :  
Suite aux nombreux problemes chez multumania, j'ai déplacé mon site sur forez mais voilà il y a un gros probleme d'include. J'ai des includes poitant en relatif sur des fichiers ( ../../include/top.php par exemple). Chez multi ca marche mais chez forez il me fait une erreur, si quelqu'un avait la solution c a m'arrangerait bien, merci d'avance


---------------
La bave du crapaud n'empèche pas la caravane de passer .

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation

  [PHP] problème include ...

 

Sujets relatifs
configuration pour PHPFormulaire HTML (PHP?)
Erreur fonction PHP strpos[PHP] tronquer un long mot dans une chaine...
ASP CFML PHP : petit sondage !problème de saisie de chaines de caractères en JAVA
probleme sur liste chainéePetit probleme de cookies en ASP...
[PhotoS] Petit problème de Layer ..PHP Fonction Mail... Config ??
Plus de sujets relatifs à : [PHP] problème include ...


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR