Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1135 connectés 

  FORUM HardWare.fr
  Programmation

  [HTML] j'ai un pb avec un tableau...

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[HTML] j'ai un pb avec un tableau...

n°93160
Roco
Posté le 24-01-2002 à 21:57:46  profilanswer
 

Bonjour!
 
Voilà j'ai un vieux problème avec une page html.
 
http://eric.ledonge.free.fr/archiv [...] ndex2.html
 
En fait, dans la 3eme et la 5eme lignes, j'ai une barre en jpeg d'une largeur de 1 pixel. Et bien qu'ayant spécifié que je veux que ces cellules mesurent 1 pixel de largeur : IE, Netscape et Mozilla refusent absolument de me mettre une cellule de 1 pixel... résultat la cellule est énorme et la mise en page est foutu!
 
Sous Opéra, ça marche nickel, la cellule fait bien 1 pixel de largeur...
 
D'habitude quand ça marche sous IE ça marche partout et là c'est la contraire...
 
Aidez-moi à corriger mon erreur!!!
 
Merci

mood
Publicité
Posté le 24-01-2002 à 21:57:46  profilanswer
 

n°93240
Suri
Darksurious
Posté le 25-01-2002 à 00:55:57  profilanswer
 

Code :
  1. <!-- TROISIEME LIGNE DU TABLEAU : ESPACE ENTRE LE LOGO ET LE MENU -->
  2.  <tr width="780" height="18">
  3.   <td>
  4.    <table cellpadding="0" cellspacing="0" align="left" width="100%" border="0">
  5.     <tr>
  6.      <td>
  7.       <img src="images/pixel.gif" width="1" height="1" alt="" border="0" />
  8.      </td>
  9.     </tr>
  10.    </table>
  11.   </td>
  12.  </tr>


 
 
ya comme un truc bizarre....:D


---------------
Suri.morkitu.org : Balades au coeur de la ville...
n°93262
Roco
Posté le 25-01-2002 à 07:46:43  profilanswer
 

Non ça c'est normal... Cette partie est l'espace séparant le logo de la barre haute du menu.
 
Ce sont les 4 et 6 eme lignes en fait qui me posent problème (je m'étais mal exprimé dsl).
 
Elles ont une taille de cellule de 780*1 pixel pour que ma ptite barre haute du menu qui mesure 780*1 rentre parfaitement, et là sous IE et Netscape, ces cellules st bcp trop grandes...(pourtant les cellpading et cellspacing sont à 0.
 
Need Help!

n°93264
youdontcar​e
Posté le 25-01-2002 à 08:32:06  profilanswer
 

pourquoi ne pas utiliser <hr> ? <hr size='1' color='black'> ...
 
ton code me semble bien compliqué pour un truc pareil ...

n°93319
Suri
Darksurious
Posté le 25-01-2002 à 12:19:40  profilanswer
 

youdontcare a écrit a écrit :

 
ton code me semble bien compliqué pour un truc pareil ...  




 
c clair, ya ptet pas besoin d'inbriquer autant de tableaux hein....:sarcastic:

n°93442
Roco
Posté le 25-01-2002 à 17:45:19  profilanswer
 

c bon j'ai trouvé...
 
la balise <img> était trop loin de la balise <td>... c'est la première fois ke jvois ce bug!


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation

  [HTML] j'ai un pb avec un tableau...

 

Sujets relatifs
[html]tableau[html] bordures dans un tableau
[HTML] % dans un tableau[html] image de fond d'un tableau
tableau html et requete php/mysql(html) cadres & tableau ??
[html] tableau + images + lien => le truc alakhon ! HELP WANTED !![HTML] disposition dans un tableau
[ HTML ] SVP , j'ai un gros problème avec un tableau :(((((Tableau HTML
Plus de sujets relatifs à : [HTML] j'ai un pb avec un tableau...


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR