Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
673 connectés 

  FORUM HardWare.fr
  Programmation
  Java

  Eclipse, SVN, EJB (probleme)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Eclipse, SVN, EJB (probleme)

n°1938232
discmat
Posté le 06-11-2009 à 09:47:04  profilanswer
 

Salut à tous,
Voila on travaille à plusieurs sur un projet. nous utilisons donc l'IDE Eclipse Galileo avec un plugin qui fournit des connecteurs SVN.
Le logiciel consiste en une architecture 3 tiers. Il y a donc deux projets (client serveur).
Lorsque j'importe le projet serveur depuis le SVN, il me reste a ajouter les librairies (hibernaite et d'autres) par un clique droit : ajout de librairies : je vais les chercher dans le dossier téléchargé via le SVN. Le serveur marche !!
 
Par contre, pour le client c'est une autre histoire. Je télécharge les fichier via SVN (file : project : Team : from SVN...tout comme pour le serveur...).
Mais l'ordonnancement des fichiers est différents/étrange. Je n'ai plus le package "default-package". Il faut donc que je rajoute des noms de package et refasse les lients.
ex : dossier1.dossier2 deviens : dossier0.dossier1.dossier2.
Ça semble compliquer mais bref, c est difficile à expliquer. Et il est hors de question de retoucher des définitions de fichiers qui rendraient ces derniers erronés pour mes collègues.
 
A savoir, que si j'utilise un logiciel SVN (genre tortoise SVN), que je télécharge les fichiers et les ouvre avec Eclipse, tout marche bien ,seulement je n'ai plus accès aux actions/commandes SVN dans le logiciel vu que le projet n'est pas definit en tant qu'import via SVN...
 
Bref, si vous avez déjà eu une expérience similaire et avez une idée, faites m'en part.
 
Merci
Bonne journée.
 
PS : nous avons tous récupéré le même dossier Eclipse (même version, plugin...), nous avons la même version de JBoss....


Message édité par discmat le 06-11-2009 à 09:47:57
mood
Publicité
Posté le 06-11-2009 à 09:47:04  profilanswer
 

n°1938705
el muchach​o
Comfortably Numb
Posté le 08-11-2009 à 10:04:55  profilanswer
 

Vous avez mis tous les fichiers du projet sous SVN ? J'ai l'impression que non.
Et sinon, j'espère que vos classes ne sont pas sous default-package, c'est totalement interdit, surtout avec un serveur d'applis.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Java

  Eclipse, SVN, EJB (probleme)

 

Sujets relatifs
Problème rapidité de mise en pauseProblème fichier de configuration hibernate
Probleme d'écriture pour un client (JAVA)[SVN] Merge de branche ?
probléme d'insertion de caractères accentués dans un xml via phpprobléme d'insertion de caractères accentués dans un xml via php
Problème placement JButtonproblème affichage sous IE
Texte dynamique + masque = probleme[Offset] problème
Plus de sujets relatifs à : Eclipse, SVN, EJB (probleme)


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR