Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1068 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Problème encodage d'un site

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème encodage d'un site

n°1426538
Sebastien
Posté le 17-08-2006 à 12:11:52  profilanswer
 

Voil j'ai mis en place un petit site via Joomla et j'ai un problème d'encodage avec tous les titres
 
Quand je passe sur http://web-sniffer.net pour voir ce que me dis mon header j'ai
 

Citation :


HTTP Request Header
 
GET /hunter/ HTTP/1.1[CRLF]
 
Connection: close[CRLF]
Accept-Encoding: gzip[CRLF]
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5[CRLF]
Accept-Language: fr,en-us;q=0.7,en;q=0.3[CRLF]
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7[CRLF]
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6 Web-Sniffer/1.0.24[CRLF]
Referer: http://web-sniffer.net/[CRLF]
[CRLF]


 
La tout parait correctement on va dire
 
par contre quand il me fait le tableau recapitulatif j'ai  

Citation :


HTTP Response Header
Name Value Delim
HTTP Status Code: HTTP/1.1 200 OK
Date: Thu, 17 Aug 2006 10:05:01 GMT CRLF
Server: Apache/2.0.55 (Debian) PHP/5.1.1 CRLF
X-Powered-By: PHP/5.1.1 CRLF
Set-Cookie: 81c5a1757000ee427a5300f35a4423a0=-; path=/ CRLF
Expires: Mon, 26 Jul 1997 05:00:00 GMT CRLF
Last-Modified: Thu, 17 Aug 2006 10:05:01 GMT CRLF
Cache-Control: no-store, no-cache, must-revalidate CRLF
Cache-Control: post-check=0, pre-check=0 CRLF
Pragma: no-cache CRLF
Connection: close CRLF
Transfer-Encoding: chunked CRLF
Content-Type: text/html; charset=windows-1251 CRLF


 
Quelqu'un comprend pourquoi je suis passé en cyrillique ??
 
Le début de la page (parties interressantes):

Citation :


<?xml version="1.0" encoding="iso-8859-15"?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />


Message édité par Sebastien le 17-08-2006 à 12:14:20
mood
Publicité
Posté le 17-08-2006 à 12:11:52  profilanswer
 

n°1426541
Sebastien
Posté le 17-08-2006 à 12:17:10  profilanswer
 

Je viens de voir que dans mon apache j'ai pas de AddDefaultCharset ca viendrait de la ?

n°1426557
mIRROR
Chevreuillobolchévik
Posté le 17-08-2006 à 12:45:14  profilanswer
 

j ai remarqué que le prolog xml foutait souvent la merde
la tu n en as pas besoin t es en text/html
essaie de le virer pour voir  
(je dis ca sans conviction mais bon...)

n°1427637
gebruik
Posté le 19-08-2006 à 11:05:49  profilanswer
 

Je confirme, c'est ça qui semble poser problème.
D'ailleurs, c'est quoi cette nouvelle tendance ? Elle ne sert pas à grand chose la déclaration xml...

n°1427653
mIRROR
Chevreuillobolchévik
Posté le 19-08-2006 à 12:07:39  profilanswer
 

je crois qu elle est obligatoire en xhtml1.1 mais bon
par contre j avais pas vu mais t as pas le meme charset dans ton prolog et ton meta ...

n°1427767
Sebastien
Posté le 19-08-2006 à 18:18:28  profilanswer
 

J'ai retrouvé le problème dans un fichier à la con, j'avais le charset 1251, je sais pas trop comment il est arrivé la et pourquoi il s'appliquait qu'à la tete du client, mais enfin bon ca remarche.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Problème encodage d'un site

 

Sujets relatifs
[VBA] Probleme copie after + ...quotes dans requête pose problème
Probleme de socket ? ou de mise en place dans un fichier ?Probleme avec mon code source pour les sockets
Probleme mise à la ligne javascriptprobleme script vbs
Le code html de mon site apparait sur google[RESOLU][CSS] Problème de float
affichage d'un swf: firefox ok, IE probleme !Problème d'impression de page web
Plus de sujets relatifs à : Problème encodage d'un site


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR