Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
853 connectés 

  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  Problème POO et execution de fonction

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème POO et execution de fonction

n°2032392
athenaa
Posté le 26-10-2010 à 18:28:58  profilanswer
 

Salut,
 
J'ai un problème assez pénible et j'imagine super débile, ça fait un moment que je n'ai pas fais de POO en AS3 et donc je n'arrive même plus à faire la base de la base.
 
J'ai créée mon fichier flash qui contient mon objet tout beau tout jolie (ou pas) et j'ai le fichier as3 où  je déclare ma classe et ma fonction constructeur. Mais il ne veut pas exécuter ma fonction constructeur alors que j'ai instancié mon objet ...
 
Normalement le constructeur est appelée dès la création d'un objet non? alors pourquoi il veut pas l'executer :cry:  
 
Je suis sûre que c'est une bête erreur d'un truc que j'ai oublié ... En tout cas ça marche si je mets mon objet dessiné directement sur la scène mais dans ce cas là je ne sais pas créer le nombre d'objet que je souhaite, ce qui n'est pas le but  [:poooop]  
 
mon fichier: http://www.megaupload.com/?d=SO72E0X4
 
merci d'avance  :jap:

mood
Publicité
Posté le 26-10-2010 à 18:28:58  profilanswer
 

n°2032410
athenaa
Posté le 26-10-2010 à 19:52:35  profilanswer
 

ça marche si je met instanciation de l'objet dans la premiere image du fla  [:jean-guitou] mais je préfère l'avoir dans l'AS  :o  
 
Pourquoi ça ne va pas  :heink: j'ai peut-être oublier l'import de quelquechose  :heink:

n°2034044
Zedlefou
In cabbage we trust !
Posté le 04-11-2010 à 17:32:28  profilanswer
 

Tu l'as fais avec quel version de Flash ? J'arrive pas à l'ouvrir ...


---------------
Jeu de simulation Boursière - Version BETA - https://www.facebook.com/wildstocks
n°2036914
abais
Posté le 18-11-2010 à 15:18:31  profilanswer
 

Oula chayri...

 

Il est peut-etre trop tard pour te répondre, mais je le fais...

 

Il y a un debordement de pile pour la simple raison que tu instancies un Vaisseau() dans ta déclaration de class Vaisseau... C'est un beau cercle vicieux non ? =)


Message édité par abais le 18-11-2010 à 15:22:02

---------------
Le membre ci-contre n'est pas responsable du message ci-dessus.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  Problème POO et execution de fonction

 

Sujets relatifs
Problème de requêteProbleme sur sed
jQuery : problème .append() et $.each()Fonction ok sous ie6 mais ne fonctionne pas sous firefox
Probleme avec balise <img/>bug en exécution
Problème de décalage et de compatibilitéProblème pour modifier le span
Problème taille popup selon navigateurs 
Plus de sujets relatifs à : Problème POO et execution de fonction


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR