Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
967 connectés 

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[mdk10] Samba

n°572549
gorben
Posté le 14-10-2004 à 15:53:05  profilanswer
 

Salut tout le monde!
 
Bon... avant tout, je voudrais dire que j'ai fais bcp de recherche sur ce forum et sur le net pour resoudre mon probleme mais que j'y arrive pas.
 
J'ai 2 pc, l'un sous xpSP1, l'autre (serveur) sous mandrake 10.
Je voudrais partager ma connexion internet entre mes 2 pc ainsi que certains dossier, notament /mnt/win_e qui est en FAT 32.
 
Pour le partage de la connexion, pas de probleme, j'ai tout reussi a faire.
 
Pour le partage des dossiers avec samba impossible...
deja, en interface graphique il ne veut pas que je partage autre chose que mon /home en "clic droit/partage".  
Je ne comprends pas non plus comment bien configurer swat. j'ai suivi les tutos de lea-linux et de ze-linux en autre.  
 
En gros, je comprends rien... je ne sais pas si mon serveur samba deconne, si mes partages sont pourris, si c'est windows qui voit rien.
 
Je ne comprends pas non plus les droits d'acces que je donne a mon serveur. il me faut creer un "user" sur mdk et le meme sur xp? ca veut dire que si je partage mon pc avec 10 pc (ce qui ne sera pas le cas) je devrais avoir 10 comptes sur mdk alors que je suis le seul a l'utiliser?
 
pas de moyen autre qu'en ligne de commande de configurer simplement samba pour lui permettre le partage?  
 
Comment je dois faire sous win pour voir mon serveur? y'a des trucs particuliers a faire? (j'ai trouvé ca nulle part)  
 
Samaba n'est pas un peu puissant pour le modeste partage que je veux faire?
 
Et pour finir, impossible de laisser a samba les droits de sortir de mon firewall, et si je coupe le firewall, ma connexion ineternet n'est plus partagée...  
 
Bon... ben voila, si qq un peut m'aider (explication ou lien vers un howto clair et simple)ce serait vraiment super sympa  
 
Merci!

mood
Publicité
Posté le 14-10-2004 à 15:53:05  profilanswer
 

n°572585
Dark_Schne​ider
Close the World, Open the Net
Posté le 14-10-2004 à 16:13:40  profilanswer
 

+ c'est normal car le partage via un clic droit ne le permet que pour les dossiers perso de l'utilisateurs ( heureusement sinon cela pourrait constituer un gros pb de sécu ).
 
+ c'est le firewall du partage de connexion qui bloque le partage de fichier.
 
Ajoute les 2 lignes suivantes dans /etc/shorewall/policy :


fw      loc     ACCEPT
loc      fw     ACCEPT


 
ces 2 lignes lui disent d'accepter les connexions du firewall ( fw ) vers le réseau local ( local ) et vice-versa
Ensuite tu relances le firewall :


service shorewall restart


 
tu peux aussi le fraire via l'interface graphqiue ( drakxservices ) : menu -> système -> configuration -> configurez votre ordinateur : système -> services
 
+ pour conf swat, il suffit ... d'installer le package samba-swat ou samba3-swat
 
ensuite tu modifies le fichier /etc/xinetd.d/swat ou /etc/xinetd.d/swat3 afin d'avoir :


disable = no


 
ce qui signifie de ne pas le désactiver, ensuite tu relances xinetd :
[fixed]
service xinetd restart
[fixed]
 
tu peux aussi le faire via l'interface graphique ( configurez votre ordinateur -> système -> services )
 
tu te connectes à swat ( http://127.0.0.1:901 si ma mémoire est bonne ), tu définies un domaine, et les partages ( nom du partage, rep que tu partages, etc ... )
 
il y a aussi un package très bien qui s'apelle ksambaplugin et qui est dispo dans les média contrib. Il fait la même chose que swat mais via le KDE Control center.
 
http://mandrakeuser.org/docs/connect/csamba.html
http://mandrakeuser.org/docs/connect/csamba2.html
http://mandrakeuser.org/docs/connect/csamba3.html
http://www.linux-wizard.net/howto. [...] article=13


Message édité par Dark_Schneider le 14-10-2004 à 16:14:58

---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°572622
gorben
Posté le 14-10-2004 à 16:29:09  profilanswer
 

alors la, je dis merci pour la reponse rapide et complete :)
 
je suis pas devant mon pc la, mais des que je rentre ce soir je teste tout ca!
 
certainement a ce soir ! ;)

n°573519
gorben
Posté le 15-10-2004 à 21:41:58  profilanswer
 


cool ca marche bien, a partir de linux j'arrive a voir mon dossier xp
 
Par contre, a partir de win... rien ne va impossible de me connecter a mon linux. j'ai vu l'ordinateur linux dans favori reseau mais en voulant me connecter il m'a dit que j'avais pas les droits d'acces.  
j'ai redemaré win, et maintenant dans "favoris reseau" il met 5mn a me trouver Mshome et je n'arrive plus a ouvrir Mshome, il me dit qu'il n'a pas trouvé le serveur :??:
probleme de configuration samba ou probleme win?
 
j'ai aussi un truc bizarre, dans swat/status, j'ai

Citation :

version:
3.0.6
 
smbd:
non actif
 
nmbd:
actif
 
winbindd:
non actif


j'ai essayé de couper et redemarrer samba avec  
$ samba stop
puis $ samba start (ou restart, je comprends pas bien la difference entre les deux...)
mais qd je coupe j'ai tout non actif, et je relance mais je reviens a la meme config... c'est ptet pour ca que ca marche pas non?


Message édité par gorben le 15-10-2004 à 23:07:05
n°573620
Dark_Schne​ider
Close the World, Open the Net
Posté le 16-10-2004 à 02:36:11  profilanswer
 

que donne un status ?  
service samba status
 
tu as bien conf le fichier de conf de samba ? essaie la commande testparm pourle vérifier.
 
 
restart = stop + start


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°573694
gorben
Posté le 16-10-2004 à 13:09:56  profilanswer
 

alors pour mon service samba status ca me donne :
 

Citation :


root@localhost toto]# service samba status
Cannot find samba service
Usage: service -[Rfshv] SERVICE ARGUMENTS
        -f|--full-restart:      Do a fullrestart of the service.
        -R|--full-restart-all:  Do a fullrestart of all services currently running.
        -s|--status-all:        Print a status of all services.
        -d|--debug:             Launch with debug.
        -h|--help:              This help.
        -v|--version:           Print version.
 
version 1.14
[root@localhost toto]#


 
avec testparm j'ai :
 

Citation :


[root@localhost toto]# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[pdf-generator]"
Processing section "[/home/toto/test]"
Processing section "[/mnt/win_e]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions


et si je fais "enter" j'ai :  

Citation :


 
# Global parameters
[global]
        workgroup = MSHOME
        netbios name = toto
        server string = Samba
        map to guest = Bad User
        guest account = ftp
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printer admin = @adm
        hosts allow = 192.168.1.250.
 
[homes]
        comment = Home Directories
        read only = No
        browseable = No
 
[printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        guest ok = Yes
        printable = Yes
        print command = lpr-cups -P %p -o raw %s -r   # using client side printer drivers.
        browseable = No
 
[print$]
        path = /var/lib/samba/printers
        write list = @adm, root
        inherit permissions = Yes
        guest ok = Yes
 
[pdf-generator]
        comment = PDF Generator (only valid users)
        path = /var/tmp
        printable = Yes
        print command = /usr/share/samba/scripts/print-pdf %s ~%u //%L/%u %m %I "%J" &
 
[/home/toto/test]
        comment = samba
        path = /home/toto/test
        read only = No
 
[/mnt/win_e]
        path = /documents
        valid users = emy
        admin users = emy
        read list = emy
        write list = emy
        read only = No
[root@localhost toto]#


 
Merci pour restart, j'avais pas bien saisi le truc :)
 
PS : c'etait bien le firewal linux qui me bloquait mon partage la premiere fois...


Message édité par gorben le 16-10-2004 à 14:24:32
n°652282
keld
Posté le 20-03-2005 à 02:34:29  profilanswer
 

Dans la section [home]tu devrai mettre browseable = Yes


Aller à :
Ajouter une réponse
 

Sujets relatifs
[MDK10] Problème d'installation drivers réso et make....permission dossier linux MDK10
[MDK10]Installation Oracle9i[MDK10]problème de compte utilisateur
Accès samba refusé avec Nautilus / Gnome 2.6[urgent] Partage Samba MDK Linux -> Windows XP SP2
[MDK10]dvd shrink sous linux?[SAMBA] 2 sous reseau , Win XP ne passe pas ...
[Repondu] [MDK10] Partage de fichiers[MDK10][Win] Samba
Plus de sujets relatifs à : [mdk10] Samba


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR