Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1125 connectés 

 



Dernière réponse
Sujet : pas de d'activation du réseau eth0 au démarrage sans message [résolu]
nazdul

Mjules a écrit :

vérifie déjà qu'il est bien down et qu'il n'y a pas un autre pb :
ifconfig pour voir les interfaces
 
regarde dans tes logs (/var/log/messages) pour voir ce qui se passe


 
ça marche!! J'ai lancé par hasard un autre service en plus de network: "netplugd" (netplugd is a daemon for managing non-static network interfaces.) ça c'est l'explication qui va avec. et ça marche :bounce:  
 
Merci tout de même pour le temps que tu as conscré à me répondre  :jap:
 
A+


Votre réponse
Nom d'utilisateur    Pour poster, vous devez être inscrit sur ce forum .... si ce n'est pas le cas, cliquez ici !
Le ton de votre message                        
                       
Votre réponse


[b][i][u][strike][spoiler][fixed][cpp][url][email][img][*]   
 
   [quote]
 

Options

 
Vous avez perdu votre mot de passe ?


Vue Rapide de la discussion
nazdul

Mjules a écrit :

vérifie déjà qu'il est bien down et qu'il n'y a pas un autre pb :
ifconfig pour voir les interfaces
 
regarde dans tes logs (/var/log/messages) pour voir ce qui se passe


 
ça marche!! J'ai lancé par hasard un autre service en plus de network: "netplugd" (netplugd is a daemon for managing non-static network interfaces.) ça c'est l'explication qui va avec. et ça marche :bounce:  
 
Merci tout de même pour le temps que tu as conscré à me répondre  :jap:
 
A+

Mjules vérifie déjà qu'il est bien down et qu'il n'y a pas un autre pb :
ifconfig pour voir les interfaces
 
regarde dans tes logs (/var/log/messages) pour voir ce qui se passe
nazdul

Mjules a écrit :

normalement, là ta carte est up


 
ben ouais mais ça ç'est manuellement ça à tjs fonctionné.
 
Je viens de rebooter la machine et j'ai vu dans les messages de boot bringing up network eth0  [OK]
 
et quand je vais dans system settings network il est indiqués inactif et je ne peux pas me connecter à Internet.
 
ç'est à se flinguer, à croire qu'un autre service le fait planter en fin de boot ou quelque chose comme ça, peut-être httpd (apache)? :pt1cable:

Mjules normalement, là ta carte est up
nazdul

Mjules a écrit :

essayes de redémarrer le service network (tu passes root et service network restart)et de voir si il y a un message d'erreur dans les logs :
tu ouvres une console et tu tapes tail -f /var/log/messages pour avoir les logs qui s'affichent en direct


 
Voilà les logs, je vois pas d'accrochage. dans quelle conf est-ce que je peux voir si le service est bien lancé au démarrage?
 
Jun 22 21:21:27 localhost network: Shutting down interface eth0:  succeeded
Jun 22 21:21:27 localhost network: Shutting down loopback interface:  succeeded
Jun 22 21:21:39 localhost sysctl: net.ipv4.ip_forward = 0
Jun 22 21:21:39 localhost sysctl: net.ipv4.conf.default.rp_filter = 1
Jun 22 21:21:39 localhost sysctl: kernel.sysrq = 0
Jun 22 21:21:39 localhost sysctl: kernel.core_uses_pid = 1
Jun 22 21:21:39 localhost network: Setting network parameters:  succeeded
Jun 22 21:21:39 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jun 22 21:21:39 localhost kernel: Disabled Privacy Extensions on device 022db720(lo)
Jun 22 21:21:39 localhost network: Bringing up loopback interface:  succeeded
Jun 22 21:21:40 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jun 22 21:21:40 localhost ifup:
Jun 22 21:21:40 localhost ifup: Determining IP information for eth0...
Jun 22 21:21:40 localhost dhclient: sit0: unknown hardware address type 776
Jun 22 21:21:41 localhost dhclient: sit0: unknown hardware address type 776
Jun 22 21:21:42 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Jun 22 21:21:42 localhost dhclient: DHCPACK from 10.20.1.101
Jun 22 21:21:42 localhost dhclient: bound to 10.20.15.97 -- renewal in 173599 seconds.
Jun 22 21:21:42 localhost ifup:  done.
Jun 22 21:21:42 localhost network: Bringing up interface eth0:  succeeded

Mjules essayes de redémarrer le service network (tu passes root et service network restart)et de voir si il y a un message d'erreur dans les logs :
tu ouvres une console et tu tapes tail -f /var/log/messages pour avoir les logs qui s'affichent en direct
nazdul [citation=508262,0,6][nom]Mjules a écrit[/nom]commence tu lances ton réseau manuellement ?
 
est ce qu'un service network start fonctinne ?
 
peut-être le service network n'est il pas lancé au démarrage : essayes un chkconfig network on
 
sinon sous fedora, ça doit être comme sous redhat et Mandrake, les conf sont dans /etc/sysconfig/network et /etc/sysconfig/network-scripts avec un fichier ifcfg-eth0 dans ton cas
 
tu trouveras la syntaxe pour ce genre de fichier dans /usr/share/doc/initscript-XXXX/sysconfig.txt
 :heink:  
 
Je le lance manuellement dans: System Settings -> Network Device Control
 
Alors voilà le contenu de /etc/sysconfig/network-scripts/ifcfg-eth0
 
# 3Com Corporation|3c905C-TX/TX-M [Tornado]
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Ethernet
USERCTL=yes
PEERDNS=yes
IPV6INIT=yes
DHCP_HOSTNAME=shzbel
 
et voilà pour etc/sysconfig/network
 
NETWORKING=yes
HOSTNAME=shzbel
NISDOMAIN=local
 
tout ça me semble désespérément normal et configuré correctement
 
quand à chkconfig il ne trouve pas la commande??
 
mais il y a un service Network qui fonctionne dans serviceconf(mode graphique) mais il indique ceci:
 
Configured devices:
lo eth0
Currently active devices:
 
alors que eth0 est maintenant en fonction! :pfff:
Mjules commence tu lances ton réseau manuellement ?
 
est ce qu'un service network start fonctinne ?
 
peut-être le service network n'est il pas lancé au démarrage : essayes un chkconfig network on
 
sinon sous fedora, ça doit être comme sous redhat et Mandrake, les conf sont dans /etc/sysconfig/network et /etc/sysconfig/network-scripts avec un fichier ifcfg-eth0 dans ton cas
 
tu trouveras la syntaxe pour ce genre de fichier dans /usr/share/doc/initscript-XXXX/sysconfig.txt
 
 
nazdul Je pateauge et point ne trouve..
j'aimerais bien partir en vacance en sachant que le serveur redémarrera de lui-même après une panne de courant
Quelqu'un à-t-il une solution ??
nazdul /etc/network/interfaces j'ai pas de répertoire ni de fichier de ce nom!? j'ai pas de ifconfig non-plus.
nazdul Merci, je vais essayer
quickman ifconfig
 
/etc/network/interfaces pour le fichier de conf
nazdul Bonjour,
 
J'ai installé un serveur linux pour pour faire tourner un programme
d'inventaire là où je travaille. J'ai une distrib Fedora Core 2 qui
était déjà installée sur la machine. Et j'utillise Apache (module PHP)
et mysql.
 
J'ai branché mon serveur sur le réseau sans en informer le service
informatique qui ne voit pas d'un bon oeil tout ce qui n'est pas
Windows et je ne bénéficie donc pas d'adresse statique.
 
Problème: Le réseau (eth0) ne s'active pas automatiquement au démarrage
de la machine, bien que je l'aie spécifié dans le menu de configuration
réseau. Je n'obtiens aucun message d'erreur et je peux le démarrer
manuellement sans problème une fois la machine bootée.  On dirait qu'il ignore
totalement tout ce que je paramètre en mode graphique. Est-ce que
quelqu'un sait où se trouvent les fichers de config résultants de ce
menu? ou connait une solution au problème?
 
Question2: une commande simple pour trouver l'adresse IP fournie par le
réseau? netstat ne ma la donne pas toujours et ç'est un véritable
charabia. Je l'ai trouvée dans /var/lib/dhcp/ mais ç'est veut dire que je dois l'extraire avec un script.
 
Merci d'avance :jap:

Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR