Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1523 connectés 

 



Dernière réponse
Sujet : Debian Sid : compilation noyau et Lilo = kernel panic
Klaimant au boot dans lilo tu selectionnes un noyeau et tu tapes root=/dev/hda1 et tu valides et tu nous dis :)

Votre réponse
Nom d'utilisateur    Pour poster, vous devez être inscrit sur ce forum .... si ce n'est pas le cas, cliquez ici !
Le ton de votre message                        
                       
Votre réponse


[b][i][u][strike][spoiler][fixed][cpp][url][email][img][*]   
 
   [quote]
 

Options

 
Vous avez perdu votre mot de passe ?


Vue Rapide de la discussion
Klaimant au boot dans lilo tu selectionnes un noyeau et tu tapes root=/dev/hda1 et tu valides et tu nous dis :)
Combi_A_Vendre Tu as vu que dans certains cas tu as root="..." avec des guillemets et des fois sans guillemets  ? Je ne connais pas bien la syntax de lilo, mais ça semble étrange.
Et tu n'as pas de label pour le premier noyau.
Tu n'as pas de messages d'erreur quand tu fais /sbin/lilo ?
 
 
vw
sebast51 Je suis en ext3 et lilo est installé en dur (il est sur hda). Seul les kernels compilés par moi ne veulent pas booter, les kernels précompilés ne posent aucun problèmes.
Riot c quoi ton system de fichier?
tu la bien mis en dur???
sebast51 Lorsque j'installe un noyau précompilé et que je configure Lilo, il n'y a pas de pb. Lorsque je compile un noyau à la sauce Debian, je l'installe, je configure Lilo et j'obtiens ce message lors du boot du noyau concerné :
 
VFS : cannot open rootdevice "301" or unknow-block (3,1)
Please append a correct "root=" boot option
Kernel Panic : VFS: unable to mount rootFS or unknow-block (3,1)
 
Le résultat est le même après compilation d'un 2.4 ou d'un 2.6. Les autres noyaux précompilés n'ont pas ce pb.
Pour compiler le noyau, j'utilise le guide d'ANDESI : http://www.andesi.org/article.php?id=kkernel
 
voici mon Lilo :
boot=/dev/hda
lba32
prompt
timeout=50
root=/dev/hda1
default=2.6.0-test9-1-3
 
image=/boot/vmlinuz-2.4.22-1-k7
 label="2.4.22-1"
 root=/dev/hda1
 read-only
 initrd="/boot/initrd.img-2.4.22-1-k7"
 
image=/boot/vmlinuz-2.4.23-1-k7
 label="2.4.23-1"
 root=/dev/hda1
 read-only
 initrd="/boot/initrd.img-2.4.23-1-k7"
 
image=/boot/vmlinuz-2.6.0-test11
 label="2.6.0-test11"
 root=/dev/hda1
 read-only
 
image="/boot/vmlinuz-2.6.0-test9-1-386"
 label="2.6.0-test9-1-3"
 root="/dev/hda1"
 read-only
 initrd="/boot/initrd.img-2.6.0-test9-1-386"
 
Le noyau compilé est le 2.6.0-test11, les autres noyau sont précompilés et bootent correctement.
si vous avez une idée ?
Merci

Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR