Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1107 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  Problème avec un graveur sous MDK 8.1

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème avec un graveur sous MDK 8.1

n°83844
julouze
May the louze be with you !
Posté le 03-04-2002 à 01:26:11  profilanswer
 

Depuis le temps, je me suis enfin décidé à m'acheter un graveur. J'ai donc entrepris l'installation de la bête cet après-midi. Je possède une mandrake 8.1 et le graveur en question est un Sony qui est reconnu sans problème. Comme c'est un graveur IDE j'ai suivi attentivement les conseils sur le site de Dark (http://perso.wanadoo.fr/linux_wizard/faq_hardware.html). Pour avoir mes deux lecteurs (le graveur et le lecteur CDROM) je les ai émulés tous les deux en SCSI mais le problème c'est que maintenant, quand je veux monter mon lecteur CD il me sort ça:  

Citation :

mount : type fs incorrect, option incorrecte, superbloc incorrect sur /dev/hdc,
       ou trop de systèmes de fichiers montés
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)


Qu'est-ce que je dois faire pour y remédier ?
Voici mon fstab:

Citation :

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom iso9660 ro,nosuid,noauto,exec,user,nodev 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy vfat exec,iocharset=iso8859-1,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

 
et lilo.conf:
 

Citation :

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
vga=normal
default=linux-nonfb
keytable=/boot/fr_CH-latin1.klt
lba32
prompt
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
other=/dev/fd0
 label=floppy
 unsafe
image=/boot/vmlinuz
 label=linux
 root=/dev/hda1
 initrd=/boot/initrd.img
 append=" devfs=mount hdc=ide-scsi hdd=ide-scsi quiet"
 vga=788
 read-only
image=/boot/vmlinuz
 label=linux-nonfb
 root=/dev/hda1
 initrd=/boot/initrd.img
 append=" devfs=mount hdc=ide-scsi hdd=ide-scsi"
 read-only
image=/boot/vmlinuz
 label=failsafe
 root=/dev/hda1
 initrd=/boot/initrd.img
 append=" devfs=mount hdc=ide-scsi hdd=ide-scsi failsafe"
 read-only

 
Et puis j'ai aussi un autre petit problème, koncd m'a l'air bien mieux que Xcdroast c'est pourquoi j'ai essayé de l'installer. Il s'agit de la version 1.0rc2. Il y avait un problème de dépendance envers libpng que j'ai négligé. Le programme se lance bien mais dès que je sauvegarder le setup en root ça plante, je pense que le problème vient cette lib mais dans quel package puis-je trouver libpng.so.3 ?
Merci d'avance, j'en peux plus de ramer.

mood
Publicité
Posté le 03-04-2002 à 01:26:11  profilanswer
 

n°83933
julouze
May the louze be with you !
Posté le 03-04-2002 à 13:17:20  profilanswer
 

up!

n°83935
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-04-2002 à 13:22:31  profilanswer
 

réfléchis ... hdc = IDE secondary master
or ... c'est considéré comme du SCSI now
tu n'as pas suivi si attentivement que cela ...
 

Avant de commencer la gravure, il convient de modifier /etc/fstab. En effet, le lecteur étant émuler en SCSI, son nom de device à changer.
Pour nous y retrouver on va créer un répertoire pour monter le graveur, par exemple /mnt/graveur. Puis tester le device.
Le CDROM IDE est émulé en SCSI donc il faut tester les devices SCSI. Les CDROM SCSI sont nommés scdx (Scsi CD rom). Pour cela on met un CD de donnés dans le graveur ou le lecteur IDE qui a été émuler en SCSI et on essaie les commandes suivantes :
$> mount -t iso9660 /dev/scdx /mnt/graveur
avec x = 0, 1, 2, 3, ....
 
Dès que cela marche, vous avez trouvé le graveur. Souvent c'est /dev/scd0.
 
Ensuite il faut faire votre lien. Faites :
$> ls -l /dev/cdrom*
Prenez le lien qui pointe vers votre ex cdrom IDE et effacer le. Supposons que ce lien est /dev/cdrom, cela donne :
$> rm /dev/cdrom
Ensuite faites le pointer vers le le nouveau lecteur IDE émuler en SCSI :
$> ln -s /dev/scdx /dev/cdrom
Ensuite vous rajouter la ligne suivante dans /etc/fstab :
/dev/cdrom /mnt/cdrom iso9660 ro,nosuid,noauto,exec,user,nodev   0 0
ou
/dev/cdrom /mnt/cdrom auto ro,nosuid,noauto,exec,user,nodev   0 0
Ce cas ne s'applique bien sûr que lorsque le lien vers le lecteur émulé en SCSI s'apelle /dev/cdrom.
Vous pouvez aussi remplacer /mnt/cdrom qui est le point de montage pour accéder au graveur par le nom que vous voulez : /mnt/cdrom1 , /mnt/graveur , ... Bien sûr il ne faut pas oublier de créer le répertoire correspondant.
 


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°83939
monokrome
nocturne
Posté le 03-04-2002 à 13:31:13  profilanswer
 

julouze a écrit a écrit :

Depuis le temps, je me suis enfin décidé à m'acheter un graveur. J'ai donc entrepris l'installation de la bête cet après-midi. Je possède une mandrake 8.1 et le graveur en question est un Sony qui est reconnu sans problème. Comme c'est un graveur IDE j'ai suivi attentivement les conseils sur le site de Dark (http://perso.wanadoo.fr/linux_wizard/faq_hardware.html). Pour avoir mes deux lecteurs (le graveur et le lecteur CDROM) je les ai émulés tous les deux en SCSI mais le problème c'est que maintenant, quand je veux monter mon lecteur CD il me sort ça:  

Citation :

mount : type fs incorrect, option incorrecte, superbloc incorrect sur /dev/hdc,
       ou trop de systèmes de fichiers montés
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)


Qu'est-ce que je dois faire pour y remédier ?
Voici mon fstab:

Citation :

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom iso9660 ro,nosuid,noauto,exec,user,nodev 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy vfat exec,iocharset=iso8859-1,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

 
et lilo.conf:
 

Citation :

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
vga=normal
default=linux-nonfb
keytable=/boot/fr_CH-latin1.klt
lba32
prompt
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
other=/dev/fd0
 label=floppy
 unsafe
image=/boot/vmlinuz
 label=linux
 root=/dev/hda1
 initrd=/boot/initrd.img
 append=" devfs=mount hdc=ide-scsi hdd=ide-scsi quiet"
 vga=788
 read-only
image=/boot/vmlinuz
 label=linux-nonfb
 root=/dev/hda1
 initrd=/boot/initrd.img
 append=" devfs=mount hdc=ide-scsi hdd=ide-scsi"
 read-only
image=/boot/vmlinuz
 label=failsafe
 root=/dev/hda1
 initrd=/boot/initrd.img
 append=" devfs=mount hdc=ide-scsi hdd=ide-scsi failsafe"
 read-only

 
Et puis j'ai aussi un autre petit problème, koncd m'a l'air bien mieux que Xcdroast c'est pourquoi j'ai essayé de l'installer. Il s'agit de la version 1.0rc2. Il y avait un problème de dépendance envers libpng que j'ai négligé. Le programme se lance bien mais dès que je sauvegarder le setup en root ça plante, je pense que le problème vient cette lib mais dans quel package puis-je trouver libpng.so.3 ?
Merci d'avance, j'en peux plus de ramer.  




 
maintenant que ton lecteur ide est émulé en SCSI, e n'est plus par /dev/hdx que tu peut y accéder, mais par /dev/scdx.
Tente de monter tes lecteurs en testant /dev/scd0, scd1, etc jusqu'a ce que tu trouves les bons et ensuite met a jour ton fstab.

n°83950
julouze
May the louze be with you !
Posté le 03-04-2002 à 13:39:50  profilanswer
 

Ok je tente de modifier ça et je vous donne des nouvelles.
Merci beaucoup de m'aider ! :jap:

n°84520
julouze
May the louze be with you !
Posté le 04-04-2002 à 22:49:11  profilanswer
 

Voilà maintenant normalement tout est bon mais quand j'essaie de graver quelque chose avec gcombust voici le message que me sort cdrecord:
** WARNING **: contractions.c 131: popen_rw_unbuffered: execv() returned  
Je comprends pas de quoi ça vient. Mais il y a aussi un truc qui est étrange c'est que quand je clique sur détection SCSI dans les options du graveur je reçois l'erreur suivante:
cdrecord n'a pu reconnaître le graveur séléctionné (soit la configuration SCSI est incorrecte, soit vous n'avez pas les permissions nécessaires) !
Alors que un cdrecord -scanbus me sort ça:
Cdrecord 1.10 (i586-mandrake-linux-gnu) Copyright (C) 1995-2001 Jörg Schilling
Linux sg driver version: 3.1.20
Using libscg version 'schily-0.5'
scsibus0:
        0,0,0     0) 'PIONEER ' 'DVD-ROM DVD-105 ' '1.22' Removable CD-ROM
        0,1,0     1) 'SONY    ' 'CD-RW  CRX175A1 ' '5YS2' Removable CD-ROM
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *

Aidez-moi pleeeeeeeeeeeeeeze !  
Merci!

n°84569
julouze
May the louze be with you !
Posté le 05-04-2002 à 01:32:10  profilanswer
 

up!


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  Problème avec un graveur sous MDK 8.1

 

Sujets relatifs
Problème son: 2 cartes détectées.[Unreal] problème au lancement du serveur
problème compiler différent de l'original[MDK 8.2] Modem ADSL ECI à installer
Probleme de gestion du clavier!Mandrake 8.1 : Problème de boot sur hdb1
[MDK 8.2] Probleme d'ecran .... qui clignote ...Probleme Mysql
Problème gravure isos woody 
Plus de sujets relatifs à : Problème avec un graveur sous MDK 8.1


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR