Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1455 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  Problème de connection à internet en mode graphique

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de connection à internet en mode graphique

n°777459
cornjump
Posté le 31-01-2006 à 16:22:18  profilanswer
 

Bonjour,
 
Je me decide a venir exposer mon problème car cela fait plusieurs semaines que je ne trouve pas de solution.
La connexion internet se fait par un Modem/routeur Dlink DSL-504T configurer en DHCP. 2 des ports ethernet de ce routeur menent directement a des machines. Le 3ème ports ethernet menent a un autre routeur Dlink (DI-604) qui fourni en DHCP l'ip de 2 machines. Le problème que j'énonce intervient sur ces 2 dernières machines (pour les 2 autres, je ne sais pas, elles n'ont pas de system linux d'installé)
 
 
Le problème, que je ne comprends pas est le suivant :  
 
Lorsque je boot sur une distribution linux (noyau 2.6) je peux me connecter à internet sans problème en console ou dans un terminal (gestionnaire de paquet, links, lynx, wget etc...), par contre, si je lance firefox, opera, gaim, xchat ou sylpheed, impossible de charger quoi que ce soit (Pour firefox, il s'arrete a Looking up www.google.fr puis me renvoi un timeout).
J'ai le meme problème si j'utilise un live-cd avec un noyau 2.6, mais si j'utilise un live-cd avec un noyau 2.4 (Damn small Linux), firefox peut charger les pages sans problème.
 
J'ai tenté de supprimer le routeur DI-604 en branchant directement ma machine au DSL-504T, mais le problème reste le meme. J'ai egalement tenté de desactiver le firewall intégré au DSL-504T, sans succes non plus.
 
Je suis donc a la recherche d'idées ou d'hypothèses pour m'aider a resoudre ce souci, car en attendant, je suis sous un windows qui lui n'a aucun souci pour se connecter!!

mood
Publicité
Posté le 31-01-2006 à 16:22:18  profilanswer
 

n°777468
Mjules
Modérateur
Parle dans le vide
Posté le 31-01-2006 à 16:44:45  profilanswer
 

ça serait pas un problème de résolution de noms ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°777474
cornjump
Posté le 31-01-2006 à 17:06:16  profilanswer
 

de memoire mon /etc/resolv.conf ressemble a ceci :  
 
'nameserver 192.168.1.1
search'
 
Cette ip est l'ip du DSL-504T
 
Sous windows, dans les propriétés de la connection au reseau local :  
Passerelle par defaut : 198.168.0.1, qui est l'ip du DI-604
 
Il y a donc, oui, sans doute un problème de DNS
 
 
J'ai déjà essayé de modifier mon /etc/resolv.conf mais dés que je lance  
/etc/rc.d/network restart
le fichier resolv.conf retrouve sa configuration d'origine.
 
Je suis en train de me construire un LFS qui sera bientot fonctionnel (le system boot, mais je ne peux pas me loguer). J'espère que ce linux épuré me permettra de mieux comprendre le problème
 
 

n°777476
freekk91
pouf c'est tout...
Posté le 31-01-2006 à 17:14:09  profilanswer
 

Salut, tu devrais plutôt mettre comme nameserver celui de ton FAI, sinon, effectivement ça foire comme dans ton cas.
C'est un changement du noyau entre le 2.4 et le 2.6, j'ai eu le même pb.
 
Il me semble que si tu laisse comme nameserver ton routeur, la résolution de nom se fait, mais c'est TRES long.
 
Voilà !
Bonne chance!

n°777478
cornjump
Posté le 31-01-2006 à 17:16:25  profilanswer
 

Merci pour ton info Freekk91, mais saurais tu me dire comment modifier mon resolv.conf sans qu'il ne se réinitialise a chaque lancement du network?
 
Et surtout, pourquoi la connection fonctionne-t-elle parfaitement en mode console et pas en mode graphique?


Message édité par cornjump le 31-01-2006 à 17:18:09
n°777479
l0ky
Posté le 31-01-2006 à 17:17:19  profilanswer
 

Normalement il n'y a aucune différence entre les applications graphiques et les applications console pour la résolution DNS.
Le démarrage du serveur X n'impactes pas du tout sur celà.

n°777480
l0ky
Posté le 31-01-2006 à 17:20:05  profilanswer
 

tu as des options dans le /etc/dhclient.conf il me semble pour éviter de prendre les DNS fournit par dhcp.
 
Sinon tu as la solution bourrin d'empecher les modifications de /etc/resolv.conf avec la commande chattr

n°777485
cornjump
Posté le 31-01-2006 à 18:07:13  profilanswer
 

Merci pour toutes ses reponses. Je vais de ce pas regarder le fichier de conf dhcp sous archie et je vous tiens au courant


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  Problème de connection à internet en mode graphique

 

Sujets relatifs
pb Internet Kubuntu5.10whax : probleme avec interface graphique
Redhat problème de login avec useraddDHCP - Breezy - AMD 64 - problème quantique avec le stop
Probleme lancement interface graphique whaxcomment entrée dans le mode priviligé bridge cisco 350
Création de DSN en mode consolecomment déterminer la source d'un problème matériel ?
Plus de sujets relatifs à : Problème de connection à internet en mode graphique


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR