Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1599 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Performances RAID5 logiciel Ubuntu server

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Performances RAID5 logiciel Ubuntu server

n°1010605
Elekaj
Posté le 12-02-2008 à 20:53:30  profilanswer
 

Bonsoir

 

Sur un PC (Shuttle SN41G2VA, avec Athlon XP 2500+ et 512Mo RAM), j'ai installé Ubuntu Server, et monté un RAID 5 (logiciel) avec 3 disques IDE ATA133 de 250Go.

 

Mais voilà, les performances sont franchement minables
15 à 20 Mo/s que se soit en lecture ou écriture.

 

J'aimerais donc savoir si ces performances sont normales, ou si quelques choses ne va pas !!!

 

si je fais un hdparm -t /dev/hdx (disques faisant partie de la grappe RAID 5), j'obtiens un débit de lecture de 75Mo/s à 80Mo/s selon les disques.

 

Est ce que du RAID 0 améliorerait les performances en lecture/écriture ?

 

Cordialement,

 

Elekaj

   



Message édité par Elekaj le 13-02-2008 à 07:48:44
mood
Publicité
Posté le 12-02-2008 à 20:53:30  profilanswer
 

n°1010628
laurent123
Posté le 12-02-2008 à 23:29:33  profilanswer
 

Sous Debian ca marche tres bien.

n°1010638
Nonor_
Ubuntu c'est supaire
Posté le 13-02-2008 à 00:39:01  profilanswer
 

15 à 20 Mo/S avec de l'IDE 133 ? Mais heu.... C'est tout à fait normal....
 
C'est ce que j'ai sur ma machine et mes transferts de fichiers se font à peu près à cette vitesse là... Sans aucun raid...

n°1010656
Elekaj
Posté le 13-02-2008 à 08:00:44  profilanswer
 

Bonjour,
 
Vu que c'est le début, j'ai réinstallé une Debian .... idem, debit de 15/20Mo/s en RAID 5
 
En retirant un disque du RAID, j'obtiens environ 75Mo/s (en lecture et ecriture) sur le disque hors du RAID !!!!
 
J'en conclue que le calcul du RAID écroule les performances !!!!
 

n°1010712
laurent123
Posté le 13-02-2008 à 09:59:47  profilanswer
 

Chez moi ca marche.
 
P4 3 GHz, 1 Go RAM, 4 x 750 Go SATA RAID5 :

Code :
  1. root@samba1:~ # hdparm -tT /dev/sda
  2. /dev/sda:
  3. Timing cached reads:   1726 MB in  2.00 seconds = 862.71 MB/sec
  4. Timing buffered disk reads:  222 MB in  3.03 seconds =  73.37 MB/sec
  5. root@samba1:~ # hdparm -tT /dev/md1
  6. /dev/md1:
  7. Timing cached reads:   1712 MB in  2.00 seconds = 855.62 MB/sec
  8. Timing buffered disk reads:  642 MB in  3.00 seconds = 213.82 MB/sec


 
P3 500 MHz, 128 Mo RAM, 2 x 13,6 Go IDE RAID1 :

Code :
  1. root@test1:~ # hdparm -tT /dev/hda
  2. /dev/hda:
  3. Timing cached reads:   264 MB in  2.00 seconds = 131.73 MB/sec
  4. Timing buffered disk reads:   74 MB in  3.01 seconds =  24.57 MB/sec
  5. root@test1:~ # hdparm -tT /dev/md1
  6. /dev/md1:
  7. Timing cached reads:   264 MB in  2.00 seconds = 131.69 MB/sec
  8. Timing buffered disk reads:   74 MB in  3.01 seconds =  24.59 MB/sec


Message édité par laurent123 le 13-02-2008 à 10:01:22
n°1010870
fighting_f​alcon
Posté le 13-02-2008 à 13:53:01  profilanswer
 

tu as 3 disques IDE, 2 sur une nappe et 1 sur une autre ?
 
parce que ça joue ... la où pour le SATA, il y a un connecteur par disque, en IDE tu peux brancher 2 disques sur un même connecteur et du coup saturer ta bande passante : en théorie, un disque atteint les 80Mo/s, soit 160Mo/s pour 2 disques, soit que l'IDE est limité, en théorie toujours, à 133Mo/s pour les derniers chipsets. Tu me suis ?
 
Je pense que tu as effectivement un problème vu les faibles débits annoncés, mais il est par contre clair que le raid5 te fera perdre un peu, et un raid 0 ne te fera rien gagné si tes disques sont sur la même nappe ...
 
Faudrait savoir exactement comment sont câblés tes disques, quel chipset, si tu utilises le bon driver, si les réglages UDMA sont corrects ...

n°1010920
Elekaj
Posté le 13-02-2008 à 15:46:29  profilanswer
 

Pour les configs, voici les résultats de hdparm -cd /dev/hdx
Le chipset IDE est celui intégré au chipset nForce2 d nVidia (a priori correctement détecté par le système), donc ATA133.
 
HDA = Disque système, IDE1 master  
HDB = Disque grappe RAID, IDE1 slave
HDC = Disque grappe RAID, IDE2 master
HDD = Disque grappe RAID, IDE2 slave
 
Pour les débits, je demande pas à avoir plusieurs centaines de Mo/s. Mais là je trouve que c'est vraiment peu.
 


/dev/hdb:
 IO_support    =  1 (32-bit)
 using_dma     =  1 (on)
 
/dev/hdc:
 IO_support    =  1 (32-bit)
 using_dma     =  1 (on)
 
/dev/hdd:
 IO_support    =  1 (32-bit)
 using_dma     =  1 (on)


 
Quand j'ai réintégré hdd dans le RAID, celui ci s'est reconstruit à 45Mo/s.
Suite à cela, j'obtiens 50Mo/s en écriture, et 90Mo/s en lecture !!!
 
Comme quoi, le fait d'avoir enlevé un disque du RAID et le réintégrer peut résoudre des problèmes  :pt1cable:  
 
Maintenant, je conçois parfaitement que le SATA (même en 150Mo/s) soit plus rapide que l'IDE.

n°1010931
laurent123
Posté le 13-02-2008 à 16:07:32  profilanswer
 

T'a bien attendu que le volume raid soit construit avant de faire tes tests la premiere fois?

n°1011031
Elekaj
Posté le 14-02-2008 à 07:49:44  profilanswer
 

Oui, j'avais bien attendu lol.
 
Mais aujourd'hui, après reboot, les perfs sont revenues vers 20 Mo/s en lecture et vers environ 15Mo en ecriture !!!  :fou:  
Truc marrant : Pendant l'écriture intensive sur le raid avec par ex :

Code :
  1. # dd if=/dev/zero of=/mnt/raid/hdd.dat bs=10M count=100


l'utilisation CPU est d'environ 60% (en moyenne) et oscille entre 50 et 75% grosso modo  :ouch:  
 
Du coup, j'ai testé le RAID 0 logiciel sur 2 disques (les slaves de chaque controlleurs)
Ecriture : 138 Mo/s - Lecture : 90 Mo/s
 
et sur 3 disques
Ecriture : 134 Mo/s - Lecture : 87 Mo/s
 
Et je peux rebooter, les perfs sont au rendez vous !!!
 
Je pense que je vais rester sur du RAID 0!!

n°1011041
fighting_f​alcon
Posté le 14-02-2008 à 08:18:30  profilanswer
 

raid0 / raid5 c'est pas la même utilisation ...
 
perso je comprends un peu tes résultats, même si je trouve qu'il y a quand même une grosse diff ...
avec ton raid 0 tu fais travailler 2 disques mais sur 2 connecteurs différents ...
avec ton raid 5, tu fais travailler 3 disques dont 2 sur le même connecteur => 2 disques se partagent un même connecteur, qui se retrouve être le goulot d'étranglement.
 
regarde aussi le paramétrage UDMA de tes disques, d'un point de vue vitesse. Pour cela, hdparm -i /dev/hdX et regarde les lignes :

Citation :


 PIO modes:  pio0 pio1 pio2 pio3 pio4  
 DMA modes:  mdma0 mdma1 mdma2  
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5  


 
l'étoile indique le mode actuel utilisé, si tu n'es pas en udma5 au moins, il faut reparamétrer ça


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Performances RAID5 logiciel Ubuntu server

 

Sujets relatifs
Question ubuntu[Ubuntu 7.10] TES4 : Oblivion
Triple Boot avec XP, Vista et Ubuntu[DEBIAN] Logiciel introuvable...
Entrée microphone non détecté (ubuntu - realtek alc880)[RESOLU][Dell] 5 partitions préinstallée , dual boot impossible ?
installation ubuntu sur clé U3Messagerie a traver un proxy sous Ubuntu
antivirus sous ubuntu neccessaire ou pas?Tutoriel pour installer un réseau familial Ubuntu
Plus de sujets relatifs à : Performances RAID5 logiciel Ubuntu server


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR