Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
892 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Debian] Apache2 MPM Worker + PHP5

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Debian] Apache2 MPM Worker + PHP5

n°943399
Popop56
56
Posté le 15-08-2007 à 12:36:56  profilanswer
 

Bonjour,
 
Je cherche à installer apache2-mpm-worker (qui d'après ce que j'ai lu est bien plus léger niveau mémoire que prefork) sur mon debian.
Seulement debian n'aime pas trop worker avec php (pour cause mauvaise gestion de module très particuliers), le paquet php5 dépend donc de apache2-prefork.
Je lui ai donc forcer l'install en ne prenant pas en compte les dépendances (dpkg -i --force-depends libapache2-mod-php5*.deb), la tout va bien mais au reload de apache2 j'obtiens cette erreur:

Code :
  1. [crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe.  You need to recompile PHP.


 
Savez vous si il existe un .deb php5 compatible avec apache2 worker ? J'avoue j'ai la flemme de compiler php  :D


---------------
| Tablatures Guitar Pro |
mood
Publicité
Posté le 15-08-2007 à 12:36:56  profilanswer
 

n°943400
Mjules
Modérateur
Parle dans le vide
Posté le 15-08-2007 à 12:39:46  profilanswer
 

de mémoire, php en module ne fonctionne pas avec le mode worker (une histoire de non fonctionnement de thread ou quelque chose comme ça).
 
peut-être en cgi ou fcgi mais sans certitude.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°943410
Popop56
56
Posté le 15-08-2007 à 13:06:12  profilanswer
 

D'après ce que j'ai lu il existe une option lors de la compilation de php. Après apparemment les devs ne conseillent pas de l'utiliser en prod mais en l'utilisant sur un serveur perso pas de problème.


---------------
| Tablatures Guitar Pro |
n°952594
Olivier51
Posté le 11-09-2007 à 20:29:19  profilanswer
 

Exactly, si tu veux utiliser php5 avec Apache MPM worker sur ta debian, tu peux utiliser la package apache-worker, mais tu as a compiler toi meme php5 avec l'option qui va bien.
Attention, toutes les extensions php ne supportent pas le 'fonctionnement' worker (probleme d'acces concurrent), et du coup, tu peux avoir des disfonctionnements dans ton script.

n°952627
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 11-09-2007 à 21:39:53  profilanswer
 

En gros c'est complètement idiot de vouloir faire ça (pour résumer).

n°952634
Popop56
56
Posté le 11-09-2007 à 22:06:29  profilanswer
 

En gros c'est ta remarque qui est idiote :o


---------------
| Tablatures Guitar Pro |
n°952642
SpN
BF4: Joorem
Posté le 11-09-2007 à 22:22:29  profilanswer
 

Pas du tout...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Debian] Apache2 MPM Worker + PHP5

 

Sujets relatifs
Debian installer une appli, permission non accordéelancer automatiquement server X au démarrage debian
KP lors d'install debiancitrix et linux debian
Recherche " Explorateur Windows " Like pour Debianpb htaccess - pb de conf apache2.conf AllowOverride
[Debian] samba ldap et creation d'utilisateurs problèmeApache, SSL et packages Debian Etch
[Debian/Packages] Exécution des programmes en tant que rootDebian etch - GDM - nvidia - Beryl
Plus de sujets relatifs à : [Debian] Apache2 MPM Worker + PHP5


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR