Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
671 connectés 

 


 

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  1420  1421  1422  1423  1424  1425
Auteur Sujet :

[UBUNTU] 19.10 'Eoan Ermine' - Topic dédié

n°1437529
moustacko
Posté le 03-09-2019 à 18:17:34  profilanswer
 

Reprise du message précédent :
Bon désolé je suis encore là avec mes histoires de CG...
On s'approche du dénouement.  
On me propose un Ryzen 5 couplé avec une 1050Ti... La personne me dotant du PC n'a pas la version RX560 chez son fournisseur.
 
Du coup ma question, est-ce qu'on peut facilement désactiver la CG au profit de l'IGP dans toute circonstance sous Ubuntu ?

mood
Publicité
Posté le 03-09-2019 à 18:17:34  profilanswer
 

n°1437530
burn2
ça rox du poney
Posté le 03-09-2019 à 19:19:00  profilanswer
 

C'est un pc portable ou pas?
Il y a fort à parier que ça soit un ryzen sans GPU.


---------------
"C'est vrais qu'un type aussi pénible de jour on serait en droit d'espérer qu'il fasse un break de nuit mais bon …"
n°1437531
moustacko
Posté le 03-09-2019 à 19:38:29  profilanswer
 

Ah merde, la fourbance ! :/
Oui PC portable Asus de la gamme Tuf505.
R5 3550h + 1050 Ti


Message édité par moustacko le 03-09-2019 à 19:39:10
n°1437538
burn2
ça rox du poney
Posté le 03-09-2019 à 23:35:09  profilanswer
 

Ah bah logiquement si y a un igp sur ce cpu.
Mais avec un gpu nvidia il est désactivé je pense cf:
https://www.01net.com/tests/test-as [...] -6267.html


Message édité par burn2 le 03-09-2019 à 23:35:28

---------------
"C'est vrais qu'un type aussi pénible de jour on serait en droit d'espérer qu'il fasse un break de nuit mais bon …"
n°1437709
phœnix
Posté le 08-09-2019 à 13:19:48  profilanswer
 

J'ai eu un gros bug, l'ordi s'est emballé, écran figé, impossible de lancer un terminal pour tuer le processus qui poserait problème, ventilo à fond, ça chauffait un max, j'ai paniqué et coupé le courant :o Au redémarrage ils me disaient qu'il y avait un soucis, j'ai tenté de redémarrer avec une autre version du noyaux, en mode sans échec, je lui ai dit de restaurer les fichiers mais rien, quand j'appuyais sur ctrl+D pour continuer le démarrage il tentait le démarrage puis me redisait pareil. Impossible de le réparer. Bref, ce n'est pas tant le problème mais je me demande s'il y a des solutions dans ce cas.

 


Autre question, car bien sûre c'est tombé la seule fois où j'avais absolument pas le temps de restaurer, heureusement j'ai un autre pc mais je me suis demandé si certains ici avait deux os, pas pour avoir windows mais justement pour ces cas. Ai-je vraiment eu de la chance de ne jamais avoir eu cela jusqu'à là ou au contraire en n'ai-je pas eu que ça m'arrive et donc c'est un peu inutile ?

 


Dernière question et la raison de ce post de base. Maintenant que la méthode choisi pour le chiffrement c'est : on chiffre tout ou on chiffre rien, utilisez-vous une partition séparé pour home et donc ne chiffrez pas (ou autrement) ? Car je trouvais ça bien d'avoir un home propre parfois mais quand ça arrive alors que tu n'as pas envie de tout réinstaller, c'est chiant en fait de devoir remettre les paramètres.

 

Ca m'a fait aussi penser que j'avais la plupart de mes fichiers séparés sur d'autres disques durs, tout ce qui n'est pas en rapport avec le système, les logiciels en faites (documents, photos, scripts, ect.). Et souvent vous parlez de sauvegarder votre home ou une partie (par exemple le profil firefox, là où il y a le plus de choses privés stockés dans sa config pour monsieur et madame tout le monde).

 

Du coup je me demandais est-ce vraiment utile le chiffrement pour un pc fixe personnel (sans être des renseignements intérieur), le faites-vous ? J'ai l'impression qu'on le fait pour faire bien mais qu'en fait beaucoup de documents importants nous les chiffrons pas (par exemple qui chiffre ses clefs usb ?). Et comment organisez-vous vos partitions ?

Message cité 1 fois
Message édité par phœnix le 08-09-2019 à 13:23:39
n°1437710
Mobilis In​ Mobile
Posté le 08-09-2019 à 13:28:18  profilanswer
 

Moi je ne chiffre rien.
Souvent c'est un nid à emmerdes quand le système plante et que l'on veut réinstaller ( il y a de nombreux sujets pour en parler sur le forum Ubuntu )
Je ne sépare pas non plus mon /home, par flemme  :o  
 
Si un jour mon Ubuntu part en carafe, je réinstalle depuis une clé USB en suivant cette méthode :
https://doc.ubuntu-fr.org/reinstallation_ubuntu
Après la réinstallation j'ai juste à remettre les logiciels non présents de base dans la distribution -> tous les paramètres et tous les fichiers de configurations ayant été conservés je n'ai rien d'autre à faire. Même sans /home séparé -> vive la simplicité.
 
A mon avis la meilleure protection de ses données personnelles, on la trouve sur une sauvegarde, sur un support externe donc.
 
Reste le souci des cambriolages ou des incendies, mais bon on va pas sombrer dans le catastrophisme non plus  :o


Message édité par Mobilis In Mobile le 08-09-2019 à 13:40:15
n°1437735
kajoux
Posté le 08-09-2019 à 19:36:52  profilanswer
 

phœnix a écrit :

Dernière question et la raison de ce post de base. Maintenant que la méthode choisi pour le chiffrement c'est : on chiffre tout ou on chiffre rien, utilisez-vous une partition séparé pour home et donc ne chiffrez pas (ou autrement) ? Car je trouvais ça bien d'avoir un home propre parfois mais quand ça arrive alors que tu n'as pas envie de tout réinstaller, c'est chiant en fait de devoir remettre les paramètres.


Pas de partition séparée pour home, mais des sauvegardes régulières. Une unique partition racine chiffrée pour le système, et une partition également chiffrée pour les données. La première est ouverte pendant la première phase de boot par demande interactive de mot de passe, la seconde est ouverte pendant la seconde phase de boot, par lecture du mot de passe dans un fichier stocké sur la première (sous /root), en utilisant le couple /etc/crypttab, /etc/fstab.
 
J'oubliais : il y a aussi une petite partition /boot non chiffrée quand même.


Message édité par kajoux le 08-09-2019 à 19:39:39
n°1437843
jeep05
Posté le 11-09-2019 à 09:55:19  profilanswer
 

Perso partition /home séparée (systeme sur SSD et /home sur HDD)
le /home est chiffré avec donc demande du mdp lors du boot

 

La solution la plus sécurisée est celle décrite par kajoux mais j'ai fait dans la simplicité

 

Pour le moment, aucun soucis, malgré des plantages dû à VirtualBox par exemple qui m'a oblité à quelques RESET sauvages, le système a tjrs re démarré sans soucis. (ubuntu LTS)

Message cité 1 fois
Message édité par jeep05 le 11-09-2019 à 09:56:43

---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°1437847
Mobilis In​ Mobile
Posté le 11-09-2019 à 10:46:05  profilanswer
 

jeep05 a écrit :

Perso partition /home séparée (systeme sur SSD et /home sur HDD)
le /home est chiffré avec donc demande du mdp lors du boot
 
La solution la plus sécurisée est celle décrite par kajoux mais j'ai fait dans la simplicité
 
Pour le moment, aucun soucis, malgré des plantages dû à VirtualBox par exemple qui m'a oblité à quelques RESET sauvages, le système a tjrs re démarré sans soucis. (ubuntu LTS)


 
Tout dépend ce que l'on entend par sécurité.
Si c'est la sécurité dans le sens "mes données ne pourront pas être accessibles à un tiers" alors oui c'est la solution la plus sécurisée.
Si c'est la sécurité dans le sens "mes données seront facilement récupérables en cas de plantage de mon OS" alors déjà j'ai plus de doute.  
Comme je l'ai déjà écrit, je ne compte plus les sujets sur le forum Ubuntu des personnes qui avaient crypté leur OS ou leur /home et qui se retrouve bien embêtées quand le bazar part en carafe.
 
Donc comme à la base je ne suis ni paranoïaque, ni catastrophiste... je ne chiffe rien et je me contente de mes sauvegardes en clair sur des supports externes.
J'ai également des sauvegardes dans le cloud, via Onedrive et Google Drive ( même pas peur qu'ils m'espionnent donc  :o  )
Bon faut dire aussi que je n'ai rien de compromettant ( du genre une photo de moi en tutu de danseuse  :o ) donc ça aide à rester serein  :D

n°1437855
kajoux
Posté le 11-09-2019 à 11:42:40  profilanswer
 

Mobilis In Mobile a écrit :

Tout dépend ce que l'on entend par sécurité.
Si c'est la sécurité dans le sens "mes données ne pourront pas être accessibles à un tiers" alors oui c'est la solution la plus sécurisée.
Si c'est la sécurité dans le sens "mes données seront facilement récupérables en cas de plantage de mon OS" alors déjà j'ai plus de doute.


Généralement, par sécurité, on entend bien la première définition. Mais de toutes façons, je ne vois pas le rapport entre le plantage de l'os et la possibilité ou non de récupérer les données sur une partition chiffrée.

mood
Publicité
Posté le 11-09-2019 à 11:42:40  profilanswer
 

n°1437858
jeep05
Posté le 11-09-2019 à 11:51:45  profilanswer
 

Oui 1ere définition.
Et le chiffrement des données n'empêchent pas d'effectuer des sauvegardes ;-)


---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°1437863
Mobilis In​ Mobile
Posté le 11-09-2019 à 12:19:03  profilanswer
 

kajoux a écrit :


Généralement, par sécurité, on entend bien la première définition. Mais de toutes façons, je ne vois pas le rapport entre le plantage de l'os et la possibilité ou non de récupérer les données sur une partition chiffrée.


Un sujet parmi d'autres ( il y a plein )
https://forum.ubuntu-fr.org/viewtopic.php?id=1993141
Bref pour résumer mon point de vue -> chiffrer c'est bien quand on est un utilisateur avancé, et que l'on sait se dépatouiller en cas de souci. Par contre pour l'utilisateur Lambda c'est une connerie. Et le fait qu'Ubuntu le propose à tous sans avertissement quand on l'installe m'a toujours fait hérisser les poils  :o  
 

jeep05 a écrit :

Oui 1ere définition.
Et le chiffrement des données n'empêchent pas d'effectuer des sauvegardes ;-)


Oui mais c'est bien connu, le système plante toujours avant la sauvegarde  :o  

n°1437866
kajoux
Posté le 11-09-2019 à 12:56:47  profilanswer
 

Mobilis In Mobile a écrit :

Un sujet parmi d'autres ( il y a plein )
https://forum.ubuntu-fr.org/viewtopic.php?id=1993141
Bref pour résumer mon point de vue -> chiffrer c'est bien quand on est un utilisateur avancé, et que l'on sait se dépatouiller en cas de souci. Par contre pour l'utilisateur Lambda c'est une connerie. Et le fait qu'Ubuntu le propose à tous sans avertissement quand on l'installe m'a toujours fait hérisser les poils  :o


Bah ouais mais bon, le gars que tu cites il faut voir un peu ce qu'il fait…
Je pense qu'il y a des "utilisateurs lambda" qui voient quand même un peu mieux ce qu'ils font ou ce qu'il faut faire.
Il a une partition linux à explorer et… il se met sous windows pour le faire.
Il a (apparemment) un chiffrage du home par ecryptfs et… il se demande si il ne pourrait pas booter sur sa partition prétendument chiffrée.
etc.
 
Je n'ai pas tout lu, juste parcouru vite fait, mais là le chiffrement est loin d'être le seul problème.
Après, concernant la pertinence de proposer d'emblée le chiffrement, pour une distribution qui se veut grand public comme ubuntu, c'est vrai que la question mérite sans doute d'être posée.
Mais basiquement, si tu as du contenu chiffré, par quelque moyen que ce soit sous linux, tu branches une clef usb live avec les logiciels de déchiffrement correspondant (typiquement une clef usb live de l'os à partir duquel tu as effectué le chiffrement), et tu déchiffres ton contenu sans aucun problème.
Genre si c'est un conteneur luks, tu ouvres gparted, tu entres ton mot de passe de déchiffrement, et c'est bon : c'est quand même pas sorcier…

n°1437879
jeep05
Posté le 11-09-2019 à 17:12:56  profilanswer
 

D'ailleurs même mon disque de sauvegarde externe est chiffré lol
Bien pratique ce Luks


---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°1437882
Colonel Sn​@ke
Posté le 11-09-2019 à 21:02:08  profilanswer
 

Hello,
Comme il y a quelques mois, j'ai de nouveau des erreurs au boot de ma Ubuntu 19.04 : après la validation dans Grub (je suis en dual boot avec Windows 10), j'ai ce message : "erreur : tentative de lecture ou d'écriture en dehors du disque hd0", suivi d'un kernel panic si j'appuie sur une touche. Le système bootait encore correctement hier et je n'ai fait aucune modification.
Si je lance en mode recovery, ça passe...
Pour le disque sous W10, aucun souci pour démarrer l'OS.  
Quelqu'un aurait une idée de ce qui pourrait expliquer ce souci et comment le résoudre svp ?
 
edit : après avoir rebooté en recovery et avoir pu accéder à ma session, Ubuntu m'a proposé une mise à jour des composants Ubuntu, suite à quoi j'ai pu rebooter plusieurs fois correctement, sans passer par le recovery... J'avoue ne pas bien comprendre...
edit 2 : fausse joie, le problème est revenu... Même en recovery ça ne marchait plus... Puis à la tentative suivante, c'est passé... :pt1cable:


Message édité par Colonel Sn@ke le 11-09-2019 à 21:19:03
n°1437885
PetitJean
Manuela Nicolosi Gang
Posté le 11-09-2019 à 22:51:18  profilanswer
 

19.04 ? ça sent la dernière "windowsation", la pile de mise à jour à effectuer avant extinction. Tu as éteint ton ordinateur comment la première fois ?


---------------
BONJOUR AMIS CITOYENS PATRIOTES !
n°1437886
Colonel Sn​@ke
Posté le 11-09-2019 à 23:00:55  profilanswer
 

De manière tout à fait normale ;)

n°1437888
PetitJean
Manuela Nicolosi Gang
Posté le 11-09-2019 à 23:05:21  profilanswer
 

tu as quelle version du noyau ?
 
également sous 19.04, j'ai ça
 

Linux yannick-Lenovo-G50-30 5.2.0-13-generic #14-Ubuntu SMP Thu Aug 15 15:28:52 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


---------------
BONJOUR AMIS CITOYENS PATRIOTES !
n°1437889
Colonel Sn​@ke
Posté le 11-09-2019 à 23:23:05  profilanswer
 

Maintenant que tu le dis, il est possible que lors de ma session précédente, il m'ait demandé de rebooter pour installer une mise à jour... Je ne l'avais pas fait, j'avais éteint le PC en me disant que le prochain démarrage ferait l'affaire.
Mon noyau est le 5.0.0-27-generic :

Linux Otacon-Lab 5.0.0-27-generic #28-Ubuntu SMP Tue Aug 20 19:53:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


Message édité par Colonel Sn@ke le 11-09-2019 à 23:26:38
n°1437900
jeep05
Posté le 12-09-2019 à 12:58:41  profilanswer
 

J'ai souvent des problèmes pour ouvrir la session ou de verrouillage de session... pas fiable le truc !
Parfois on peut ouvrir sans remettre le mot de passe ou bien comme je viens d'en faire l'expérience, ca a mis près de 2 minutes après avoir validé le mot de passe à déverrouiller !
 
Je parle pas au démarrage de la machine, mais bien lorsque je m'absente du poste et que je fais la touche SUPER+L


---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°1437903
Mobilis In​ Mobile
Posté le 12-09-2019 à 21:29:52  profilanswer
 

Pourquoi la touche SUPER + L ?  :??:
 
edit : je viens de tester je ne connaissais pas cette combinaison merci
Aucun souci pour ré-ouvrir ma session avec mon mot de passe.

Message cité 1 fois
Message édité par Mobilis In Mobile le 12-09-2019 à 21:31:11
n°1437912
mailiya
Posté le 13-09-2019 à 02:13:46  profilanswer
 

Ranbaz a écrit :

Je pense que quelque soit la distribution, Gnome sera toujours trop lourd pour un k6-II 400. Sur mon portable (pentium II 400 donc plus puissant qu'un K6) même avec XFCE je trouve que ça rame (bon ça doit aussi venir du driver de la carte vidéo en plus de X qui est vraiment trop lourd). Du coup je préfère largement utiliser Win2k sur celui-ci.


A l'installation seule la carte PCI a été détectée pour la configuration de X. Je n'avais donc pas d'affichage au lancement de X. J'ai donc du éditer mon XF86Config-4. j'ai un peu perdu du temps car je ne connaissais pas "sudo" et je cherchais désespérement le password de root :)

n°1437917
jeep05
Posté le 13-09-2019 à 08:34:37  profilanswer
 

Mobilis In Mobile a écrit :

Pourquoi la touche SUPER + L ?  :??:
 
edit : je viens de tester je ne connaissais pas cette combinaison merci
Aucun souci pour ré-ouvrir ma session avec mon mot de passe.


dans la grande majorité des cas ca fonctionne bien, mais parfois j'ai constaté les bugs décrits


---------------
"Finalement, quand on est riche, ça ne s'arrête jamais ? - Rassurez-vous, c'est pareil quand on est pauvre !" -Film "Ah ! si j'étais riche, 2002"
n°1437982
phœnix
Posté le 14-09-2019 à 20:04:47  profilanswer
 

J'ai encore un souci les gens, excusez mon incompétence.
 
J'ai 3 disques durs interne : celui avec ubuntu et deux de stockage. Ils sont bien monté avec fstab mais n'apparaissent pas dans les disques disponible. Une idée, jamais eu ce soucis avant.
 

Code :
  1. blkid
  2. /dev/sda1: UUID="A0C8-77D4" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="373018cf-5584-4df3-a3b1-1644be9e23e8"
  3. /dev/sda2: UUID="a867819e-122b-484b-9d19-f44fc08c39d7" TYPE="ext4" PARTUUID="e747cea4-e39d-4245-9780-8e2b39d8d110"
  4. /dev/sdb1: LABEL="storage" UUID="32338b6f-da7a-4fbe-b6a5-696d497a9c11" TYPE="ext4" PARTUUID="46907cca-fb09-421e-b3dd-8c4bf110a736"
  5. /dev/sdc1: LABEL="archives" UUID="f7b9b6ae-bef5-4b97-9c8a-76a7bb2456d3" TYPE="ext4" PARTUUID="62ba6775-11f0-4d0c-9f73-ed01927c9450"


D'ailleurs qu'est-ce partuuid dont je n'ai pas souvenirs auparavant.
Je suis étonné aussi de la partition efi bien que je comprenne ce que c'est.
 

Code :
  1. nano /etc/fstab
  2. UUID=a867819e-122b-484b-9d19-f44fc08c39d7       /                       ext4    errors=remount-ro       0       1
  3. UUID=32338b6f-da7a-4fbe-b6a5-696d497a9c11       /dev/storage            ext4    defaults                0       2
  4. UUID=f7b9b6ae-bef5-4b97-9c8a-76a7bb2456d3       /dev/archives           ext4    defaults                0       2
  5. /swapfile                                       none                    swap    sw                      0       0


 

Code :
  1. cd /dev
  2. ...
  3. drwx------  5 monnom monnom      4096 sept.  2 09:52 archives
  4. ...
  5. drwx------  5 monnom monnom      4096 sept.  9 18:48 storage
  6. ...


 
https://reho.st/self/848ee84308b89d5c211067722ac444991f3f059e.jpg
 
edit : Je me demande si avant je ne les montais pas dans /media, vu que j'ai refait mon script post install. Ca peut changer quelque chose ?


Message édité par phœnix le 14-09-2019 à 20:19:05
n°1437983
Elbarto
Posté le 14-09-2019 à 20:23:12  profilanswer
 

Est-ce que les disques sont visibles dans le logiciel gparted ?
ils sont formatés dans quel type de format de fichiers ?

 

le problème est arrivé juste après une mise à jour des paquets ?
si oui alors essaie de démarrer sur un autre noyau linux, comme le noyau LTS, au cas où ça viendrait d'un bug du dernier noyau linux, concernant certains systèmes de fichiers.
 
Enfin la consultation des fichiers log peut aider à mieux diagnostiquer le problème (dmesg, journalctl) et taper la commande "systemctl --failed --all" pour voir si un service a planté au démarrage.

Message cité 1 fois
Message édité par Elbarto le 14-09-2019 à 20:34:47
n°1437985
phœnix
Posté le 14-09-2019 à 21:12:38  profilanswer
 

Elbarto a écrit :

Est-ce que les disques sont visibles dans le logiciel gparted ?
ils sont formatés dans quel type de format de fichiers ?
 
le problème est arrivé juste après une mise à jour des paquets ?  
si oui alors essaie de démarrer sur un autre noyau linux, comme le noyau LTS, au cas où ça viendrait d'un bug du dernier noyau linux, concernant certains systèmes de fichiers.
 
Enfin la consultation des fichiers log peut aider à mieux diagnostiquer le problème (dmesg, journalctl) et taper la commande "systemctl --failed --all" pour voir si un service a planté au démarrage.


gparted c'est disques sur ubuntu ? Si jamais oui.
 
Formaté en ext4 :
type de partition : Linux Filesystem
Contenu : Ext4 (version 1.0) Monté sur /dev/storage
 
Je ne peux pas dire quand le problème est arrivé, je n'ai pas vraiment fait attention. Je tenterais.
 
Je ne vois rien dans les journaux mais pour dmesg il y a tellement de ligne que je ne suis pas sûr il est vrai. Je veux bien les mettre ici mais ça fait beaucoup de ligne, je ne sais pas si c'est judicieux.
 

Code :
  1. systemctl --failed --all
  2. 0 loaded units listed.
  3. To show all installed unit files use 'systemctl list-unit-files'.

n°1437986
phœnix
Posté le 14-09-2019 à 21:22:46  profilanswer
 

Bon en fait c'est ce que j'avais précisé dans mon premier message en éditant. En les montant dans /media ils apparaissent bien.

 

Je ne sais pas si c'est un bug ou si c'est incohérent de les monter dans /dev et pourquoi j'avais fait ça.

 

Merci pour ton aide Elbarto, pardon pour le dérangement.

 

edit : sur ubuntu-fr ils mettent : /media    Contient les points de montages pour les médias amovibles, du coup est-ce la bonne façon de faire, ils ne sont pas amovibles.

Message cité 1 fois
Message édité par phœnix le 14-09-2019 à 21:27:41
n°1437987
bailiyat
Posté le 14-09-2019 à 21:48:02  profilanswer
 

mailiya a écrit :


A l'installation seule la carte PCI a été détectée pour la configuration de X. Je n'avais donc pas d'affichage au lancement de X. J'ai donc du éditer mon XF86Config-4. j'ai un peu perdu du temps car je ne connaissais pas "sudo audacit et je cherchais désespérement le password de root :)


Je pense que quelque soit la distribution, Gnome sera toujours trop lourd pour un k6-II 400. Sur mon portable (pentium II 400 donc plus puissant qu'un K6) même avec XFCE je trouve que ça rame (bon ça doit aussi venir du driver de la carte vidéo en plus de X qui est vraiment trop lourd). Du coup je préfère largement utiliser Win2k sur celui-ci.

 

=============================
edit par BL : suppression des liens de spam


Message édité par black_lord le 20-09-2019 à 10:32:33
n°1437988
minux
On Linux ...
Posté le 14-09-2019 à 22:00:36  profilanswer
 

phœnix a écrit :

Bon en fait c'est ce que j'avais précisé dans mon premier message en éditant. En les montant dans /media ils apparaissent bien.
 
Je ne sais pas si c'est un bug ou si c'est incohérent de les monter dans /dev et pourquoi j'avais fait ça.
 
Merci pour ton aide Elbarto, pardon pour le dérangement.
 
edit : sur ubuntu-fr ils mettent : /media    Contient les points de montages pour les médias amovibles, du coup est-ce la bonne façon de faire, ils ne sont pas amovibles.


En fait /dev est un répertoire système qui contient des fichiers et répertoires qui représentent le matériel (dont les disques), donc c'est incohérent de monter des disques dans cette partition, ce pourquoi ça ne fonctionnait pas.
 
Et oui monter les disques dans /media est une bonne méthode (pas la seule, on peut les monter dans n'importe quel répertoire non utilisé par le système), que les disques soient amovibles ou non (d'ailleurs linux monte les clés usb dans /run/media/user habituellement et pas dans /media, en tout cas sur ma distrub, Archlinux)


---------------
Mes linux : 2002: Mandrake -> 2005: Ubuntu -> 2010: Arch | Roms MinuxBuild | Mes tutos pour root les Oneplus 5 et 6, Xiaomi Mi9 et SE
n°1437993
kajoux
Posté le 15-09-2019 à 01:21:09  profilanswer
 

Sous Ubuntu c'est dans /media/user.
D'où l'intérêt de privilégier les chemins relatifs dans les liens symboliques sur une partition de données, quand on passe d'une distribution à l'autre.

n°1438140
cacatomiqu​e
la base et le sommet
Posté le 20-09-2019 à 08:09:07  profilanswer
 

bonjour
je suis bloqué lors de l'install de l'émulateur de tilem pour émuler une ti83, j'ai des paquets manquant mais je n'arrive pas à les installer

Code :
  1. ~/Downloads/tilem-2.0$ ./configure
  2. checking for gcc... gcc
  3. checking whether the C compiler works... yes
  4. checking for C compiler default output file name... a.out
  5. checking for suffix of executables...
  6. checking whether we are cross compiling... no
  7. checking for suffix of object files... o
  8. checking whether we are using the GNU C compiler... yes
  9. checking whether gcc accepts -g... yes
  10. checking for gcc option to accept ISO C89... none needed
  11. checking how to run the C preprocessor... gcc -E
  12. checking for ar... ar
  13. checking for ranlib... ranlib
  14. checking for a BSD-compatible install... /usr/bin/install -c
  15. checking whether make sets $(MAKE)... yes
  16. checking for update-desktop-database... update-desktop-database
  17. checking for update-mime-database... update-mime-database
  18. checking for pkg-config... /usr/bin/pkg-config
  19. checking pkg-config is at least version 0.9.0... yes
  20. checking for GTK... yes
  21. checking for gtk_init... yes
  22. checking for TICALCS... no
  23. configure: error: libticalcs2 not found or not usable.
  24. No package 'ticalcs2' found
  25. No package 'ticables2' found
  26. No package 'tifiles2' found
  27. No package 'ticonv' found
  28. You must install libticalcs2, libticables2, libtifiles2, and libticonv
  29. (including the -dev/-devel packages if appropriate.)  These libraries
  30. are available from <http://lpg.ticalc.org/prj_tilp/>.
  31. If you have installed the libraries in a non-standard location (or if
  32. you're cross-compiling), you will need to add the location of
  33. ticalcs2.pc to your PKG_CONFIG_PATH environment variable, or set the
  34. TICALCS_CFLAGS and TICALCS_LIBS environment variables by hand.


une solution?  [:cacatomique:10]

n°1438143
rat de com​bat
attention rongeur méchant!
Posté le 20-09-2019 à 10:11:25  profilanswer
 

sudo apt install libticalcs2 libticables2 libtifiles2 libticonv ? (+dev eventuellement) :o
J'ai regardé chez Debian, les paquets sont tous dispo, vu que Ubuntu est basé dessus je suppose que la situation est pareille.

n°1438146
cacatomiqu​e
la base et le sommet
Posté le 20-09-2019 à 10:56:40  profilanswer
 

:jap:  
maintenant que j'ai toutes les dépendances, la phase "make" me renvoie une nouvelle erreur  [:kzimir]  

Code :
  1. ~/Downloads/tilem-2.0$ make
  2. cd emu && make
  3. make[1]: Entering directory '/home/cacatomique/Downloads/tilem-2.0/emu'
  4. make[1]: Nothing to be done for 'all'.
  5. make[1]: Leaving directory '/home/cacatomique/Downloads/tilem-2.0/emu'
  6. cd db && make
  7. make[1]: Entering directory '/home/cacatomique/Downloads/tilem-2.0/db'
  8. make[1]: Nothing to be done for 'all'.
  9. make[1]: Leaving directory '/home/cacatomique/Downloads/tilem-2.0/db'
  10. cd gui && make
  11. make[1]: Entering directory '/home/cacatomique/Downloads/tilem-2.0/gui'
  12. gcc -g -O2 -W -Wall -Wwrite-strings    -o tilem2 tilem2.o address.o animatedgif.o animation.o breakpoints.o config.o charmap.o debugger.o disasmview.o emulator.o emucore.o emuwin.o event.o filedlg.o files.o fixedtreeview.o gifencod.o icons.o keybindings.o keypaddlg.o link.o macro.o memmodel.o memview.o memory.o pbar.o preferences.o sendfile.o screenshot.o skinops.o ti81prg.o menu.o rcvmenu.o tool.o  -L../db -ltilemdb -L../emu -ltilemcore -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lfontconfig -lfreetype -lgthread-2.0 -pthread -lglib-2.0 -lticalcs2 -lticables2 -ltifiles2 -lticonv -lglib-2.0
  13. /usr/bin/ld: ../emu/libtilemcore.a(graycolor.o): undefined reference to symbol 'pow@@GLIBC_2.2.5'
  14. //lib/x86_64-linux-gnu/libm.so.6: error adding symbols: DSO missing from command line
  15. collect2: error: ld returned 1 exit status
  16. Makefile:96: recipe for target 'tilem2' failed
  17. make[1]: *** [tilem2] Error 1
  18. make[1]: Leaving directory '/home/cacatomique/Downloads/tilem-2.0/gui'
  19. Makefile:38: recipe for target 'all' failed
  20. make: *** [all] Error 2

n°1438147
rat de com​bat
attention rongeur méchant!
Posté le 20-09-2019 à 12:39:15  profilanswer
 

Dans /home/cacatomique/Downloads/tilem-2.0/gui tu dois avoir un fichier Makefile qui est généré par ./configure. Tu peux poster ce fichier (ou sur pastebin si c'est trop long)?

 

Tu peux aussi, après avoir fait une copie, essayer de modifier /home/cacatomique/Downloads/tilem-2.0/gui/Makefile.in puis refaire ./configure et ./make dans GUI. Il faut rajouter "-lm" (sans guillemets, -LM en minuscules) à la fin de la ligne LIBS = @LIBS@, soit

Code :
  1. LIBS = @LIBS@ -lm

.

 

Sans garantie. :o

Message cité 1 fois
Message édité par rat de combat le 20-09-2019 à 12:41:48
n°1438163
PetitJean
Manuela Nicolosi Gang
Posté le 20-09-2019 à 16:20:16  profilanswer
 

démarrage de session en 1~2 secondes avec le dernier noyau [:kaio]


---------------
BONJOUR AMIS CITOYENS PATRIOTES !
n°1438171
cacatomiqu​e
la base et le sommet
Posté le 20-09-2019 à 19:37:10  profilanswer
 

rat de combat a écrit :

Dans /home/cacatomique/Downloads/tilem-2.0/gui tu dois avoir un fichier Makefile qui est généré par ./configure. Tu peux poster ce fichier (ou sur pastebin si c'est trop long)?
 
Tu peux aussi, après avoir fait une copie, essayer de modifier /home/cacatomique/Downloads/tilem-2.0/gui/Makefile.in puis refaire ./configure et ./make dans GUI. Il faut rajouter "-lm" (sans guillemets, -LM en minuscules) à la fin de la ligne LIBS = @LIBS@, soit

Code :
  1. LIBS = @LIBS@ -lm

.
 
Sans garantie. :o


https://pastebin.com/RmyymyKG

n°1438172
rat de com​bat
attention rongeur méchant!
Posté le 20-09-2019 à 20:03:21  profilanswer
 

Je pense que c'est pas le bon fichier. Ca doit être tilem-2.0/Makefile, pas tilem-2.0/gui/Makefile?
 
Essaye la modif dont je parlais en prenant soin de bien choisir le bon fichier.

n°1438173
cacatomiqu​e
la base et le sommet
Posté le 20-09-2019 à 20:05:40  profilanswer
 

rat de combat a écrit :

Je pense que c'est pas le bon fichier. Ca doit être tilem-2.0/Makefile, pas tilem-2.0/gui/Makefile?
 
Essaye la modif dont je parlais en prenant soin de bien choisir le bon fichier.


en effet, il y en avait deux  
https://pastebin.com/4FKFmgLJ
je vais essayer ta manip

n°1438176
Elbarto
Posté le 20-09-2019 à 21:41:17  profilanswer
 

cacatomique a écrit :


une solution?  [:cacatomique:10]

 

Contourner l'obstacle,

 

apparemment il existe déjà un paquet pour ubuntu 19.04 :
https://www.ubuntuupdates.org/packa [...] base/tilem

 

et pour ubuntu 18.04 :
https://www.ubuntuupdates.org/packa [...] base/tilem

 

tu télécharges le paquet deb 64 bits et tu l'installes avec la commande "sudo dpkg -i <paquet.deb>"

 

mais il y aura peut-être des dépendances à installer, car dpkg ne gère pas les dépendances contrairement à apt,
https://www.ubuntuupdates.org/packa [...] tilem-data

 

autre moyen de contournement : télécharger le binaire windows, et le faire tourner avec wine, c'est ce que j'utilise parfois pour des émulateurs de vieux ordis 8 bits et de consoles de jeu, la version linux étant parfois indisponible ou trop compliquée à compiler.

 

Un rappel important : il est fortement déconseillé d'installer des applications en root avec des commandes de type "make install" (pas bon pour la sécurité, et risque d'écraser des fichiers présents dans la racine système si le bazar ne s'installe pas dans /usr/local), il est préférable de créer le paquet (via l'outil de création de paquet de sa distribution, lire le wiki), ou de télécharger un paquet déjà fait, afin de l'installer avec apt.


Message édité par Elbarto le 20-09-2019 à 21:56:54
n°1438177
PetitJean
Manuela Nicolosi Gang
Posté le 20-09-2019 à 21:44:58  profilanswer
 

J'ai téléchargé tilem 2.0. il faut ajouter -lm dans le makefile.in du dossier gui


---------------
BONJOUR AMIS CITOYENS PATRIOTES !
n°1438198
rat de com​bat
attention rongeur méchant!
Posté le 21-09-2019 à 18:26:36  profilanswer
 

PetitJean a écrit :

J'ai téléchargé tilem 2.0. il faut ajouter -lm dans le makefile.in du dossier gui

Oui, c'est ce que j'essayais de lui dire. :o

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  1420  1421  1422  1423  1424  1425

Aller à :
Ajouter une réponse
 

Sujets relatifs
encore un topic sur les températures[RESOLU] mount_data version 1919251317 is not supported
linux version disquetteLa version 10 de la mandrake dispo en magazine?
Topic Modifier les partitions sous Linux ("Partition Magic")Reiser 4 -- Version finale out - Faq : " Montre moi tes FS"
[Topic Unique] ROX-Filer[hébergement] serveur dédié
[Topic unique] Rox (-Filer) + X Files Explorer[Linux] Je recherche la version de Woody sur DVD
Plus de sujets relatifs à : [UBUNTU] 19.10 'Eoan Ermine' - Topic dédié


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR