Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
467 connectés 

 



Quelle(s) branche(s) de Gentoo utilisez-vous ?




Attention si vous cliquez sur "voir les résultats" vous ne pourrez plus voter
Les invités peuvent voter

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  136  137  138  139  140  141
Page Suivante
Auteur Sujet :

[Gentoo] Le topic (Profils en cours : 13.0, LiveDVD : 20160514)

n°1415805
j_c_p
Linux user
Posté le 11-03-2018 à 12:34:27  profilanswer
 

Reprise du message précédent :
Je suis en ~amd64 (profil 17.1 desktop/plasma) ;).
Sinon, ça arrive (rarement) que des petites choses soient cassées (ça peut être gênant, mais, au pire avec un livdCD en chrootant, on refait tout).
À priori, Gentoo est faite pour durer.


Message édité par j_c_p le 11-03-2018 à 12:34:56
mood
Publicité
Posté le 11-03-2018 à 12:34:27  profilanswer
 

n°1415825
odelpasso
Posté le 11-03-2018 à 18:06:50  profilanswer
 

Au faite j_c_p, est-ce qu'il t'arrive de te faire un overlay privé pour y mettre des ebuilds "officiels" plus à jour ?
 
Pour exemple, Mate est sorti en 1.20 et le derniers ebuilds officiels en date sont en 1.18. Si dans l'exemple tu utiliserais ce DE, est-ce que tu ferais une MAJ des différents ebuilds de Mate ?

n°1415828
j_c_p
Linux user
Posté le 11-03-2018 à 18:58:15  profilanswer
 

Non, plus actuellement, car j'ai ce qu'il me faut via portage.
Sinon, oui, c'est possible, mais ça peut demander pas mal de manipulations si tu veux incorporer des paquets conséquents.
 
nb : Fab-Del, le mieux pour commencer est de prendre amd64 classiquement, ensuite, on peut personnaliser par paquets via ~, c'est la force de Gentoo, pas la peine de partir directement en ~amd64.


Message édité par j_c_p le 11-03-2018 à 18:59:03
n°1415834
malikg
Posté le 11-03-2018 à 19:22:51  profilanswer
 

odelpasso a écrit :

Et ensuite, pensez-vous que Gentoo a encore de belles années devant elle par rapport aux autres distributions ?


Gentoo se meurt, enfin ça fait plus de 10 ans que des articles/blogs annoncent la mort de cette distro (exemple de 2009: https://makuro.wordpress.com/2009/0 [...] oo-dying/) mais force est de constater qu'elle est bien en vie, donc pas de souci à ce niveau.

n°1416186
Tom_
Posté le 18-03-2018 à 18:48:09  profilanswer
 

Gentoo est une belle distrib mais elle manque de main d'oeuvre.  
 
Perso, j'utilise un système amd64 avec un certain nombre d'ebuilds ~amd64 (dont KDE). C'est plutôt un bon compromis même si parfois ce mix complique la vie avec une gestion un compliquée des dépendances, keywords...  
 
Ca fait quelques années que je pense à quitter Gentoo pour réduire le temps de maintenance ... La réalité est que je suis resté parce que j'apprécie la flexibilité offerte par cette distribution et sa robustesse. Cette automne, j'ai fait de grosses mises à jour après quelques mois sans véritable maintenance et un bordel innommable dans les dépendances : gcc 4.x vers 5.4 puis 6.x puis 7.x avec mise à jour de l'ensemble du système (dont toolchain et kde ~amd64). Mon système est toujours en vie et même pleinement fonctionnel :)  
 
En tout cas, c'est bien d'avoir un peu de vie sur ce topic :)


Message édité par Tom_ le 18-03-2018 à 18:53:14
n°1416482
odelpasso
Posté le 25-03-2018 à 10:15:16  profilanswer
 

Suis bien embêté avec Gentoo car ça me fait cela uniquement avec cet OS, je n'ai jamais eu ce soucis avec une Arch ou Debian.
 
A savoir que le système freeze lorsqu'il reste allumé très longtemps sans être utilisé. Exemple, j'ai laissé un très gros téléchargement durant la nuit et ce matin même, le système avait freezé. Obligé de hard reboot.
 
Savez-vous ou je peux trouver les logs pré-redémarrage ?
D'ou cela peut-il venir ?

n°1416491
Mysterieus​eX
Chieuse
Posté le 25-03-2018 à 22:09:33  profilanswer
 

Gestion de l'énergie.
 
Faut que tu vérifie comment est compilé ton kernel par rapport au CPU que tu as, c'est un GRAND classique du freeze (le système qui ne supporte pas l'hibernation, ou le suspend, ou la mise en veille.)
 
Essaye des patchset différents, (zen ou ck) et n'oublie pas de toujours mettre à jour les derniers linuxfirmware (osef de l'opensource, vraiment) qui peuvent aider pour ce genre de soucis.
 
La dernière solution est carrément de mettre un no-suspend et no-hibernation dans le lancement de ton kernel. (ligne de commande grub ou lilo)
 
Edit : ne fait pas confiance aux interfaces de configuration pour la désactivation de l'hibernation ou suspend, elles peuvent te dire que c'est désactivé (et effectivement dans le /proc/machinchose c'est bien désactivé) mais pas côté kernel (et soit disant que la configuration binaire est plus sûre  :sarcastic: )


Message édité par MysterieuseX le 25-03-2018 à 22:11:57
n°1416509
odelpasso
Posté le 26-03-2018 à 11:55:20  profilanswer
 

Ce qui est bizarre c'est que je n'ai aucun soucis de redémarrage / freeze sur debian... Et j'ai compilé un noyau custom comme su gentoo

n°1416520
Mysterieus​eX
Chieuse
Posté le 26-03-2018 à 18:24:35  profilanswer
 

odelpasso a écrit :

Ce qui est bizarre c'est que je n'ai aucun soucis de redémarrage / freeze sur debian... Et j'ai compilé un noyau custom comme su gentoo


Et bah importe ton kernel debian sur ta gentoo, tu veux que je te dise quoi ?
Les patchset sont différents, les paquets firmware pour certains sont intégrés sous debian (alors qu'il faut le faire à la main sous gentoo hein)
Bref, non, ce n'est pas bizarre, mais ça, tu le saurais si tu t'intéressais un minimum un peu plus à se qui se passe en interne. C'est même cette bizarrerie qui te donnera la solution à ton problème : au lieu de trouver ça bizarre, ai un esprit critique et trouve les différences entre ta gentoo et la debian.

n°1416522
odelpasso
Posté le 26-03-2018 à 18:41:57  profilanswer
 

Vache, t'es aussi aimable qu'une pierre tombale ...
Faudrait que tu rajoutes "agressive" avec "chieuse", ça t'irait comme un gant.

Message cité 1 fois
Message édité par odelpasso le 26-03-2018 à 18:42:12
mood
Publicité
Posté le 26-03-2018 à 18:41:57  profilanswer
 

n°1416598
Mysterieus​eX
Chieuse
Posté le 28-03-2018 à 03:08:19  profilanswer
 

odelpasso a écrit :

Vache, t'es aussi aimable qu'une pierre tombale ...
Faudrait que tu rajoutes "agressive" avec "chieuse", ça t'irait comme un gant.


 
Nonobstant que je t'ai donné une réponse, tu répond, toi même par une attaque totalement personnelle. Je ne sais pas si tu as bien lu ma réponse. Elle est certes sèche, mais n'en est pas moins exacte : je n'ai pas à plaire ou à faire de l'éloquence ici, juste te fournir une information qui est : si ça fonctionne sous debian, compare les deux distro, notamment au niveau de la configuration du kernel, et des patch appliqués par les administrateurs de debian (puisque sous gentoo, tu es ton propre administrateur de distro). La pseudo politesse (de façade) et les codes sociaux nuisent au transfert d'informations justes, précises et concises.
 
Remarque que j'aurais tout aussi bien pu te dire STFF ou STFW puisque la réponse à ton interrogation est déjà disponible et revient régulièrement : certains CPU dépendamment du kernel et des patchs appliqués ne supportent pas S2/S3, les économies d'énergie, soit parce que le bios/uefi est compilé orienté windows (asus et ses tables ACPI foireuses, les IOAPIC et S2/S3 microsoft style) soit parce qu'il faut charger un firmware non libre, non inclus de base dans les distro (GNU GPL V2 interdisant le chargement de blobs binaires non libre sans information préalable de l'utilisateur) très courant depuis sandy bridge sur intel. Commence donc par rechercher de ce côté et reviens nous voir quand tu aura déjà vérifié ces points précis : tu en as pléthore à explorer. Et si la forme de la réponse ne te conviens pas, ben j'y peut rien.

n°1416609
O'Gure
Modérateur
Multi grognon de B_L
Posté le 28-03-2018 à 09:06:46  profilanswer
 

MysterieuseX, met de l'eau dans ton vin, s'il te plait.


---------------
Ton Antoine commence à me les briser menus !
n°1416610
Mysterieus​eX
Chieuse
Posté le 28-03-2018 à 09:08:41  profilanswer
 

[:vizera]
 
D'accord.

n°1416656
odelpasso
Posté le 28-03-2018 à 17:25:11  profilanswer
 

L'accident est clos. Bon, j'ai fait un tour sur Google et j'ai trouvé diverses topics ayant les mêmes soucis que moi, à savoir que le PC freeze sans raison et qu'il y ait des reboot aléatoire.
 
D'après ce que j'ai trouvé comme possible solution, c'est :
1- Augmenter le SoC voltage pour une meilleure stabilité de la RAM.
-> J'ai fait la manip mais je ne sais pas si ça sert à quelques choses pour ma part.
2- Pour les problèmes de reboot, cela viendrait de C-State, des personnes l'ayant désactivé dans le BIOS ou via le kernel n'ont plus de problème.  
-> Manip faite également, à voir sur la durée pour ma part.

n°1416657
Kaari
Fuck Yeah !
Posté le 28-03-2018 à 18:06:37  profilanswer
 

odelpasso a écrit :

2- Pour les problèmes de reboot, cela viendrait de C-State, des personnes l'ayant désactivé dans le BIOS ou via le kernel n'ont plus de problème.


Oui, c'est souvent çà, y'a moyen de patcher cela dit.


---------------
Mon topic ventes ;)
n°1421952
odelpasso
Posté le 12-08-2018 à 02:00:00  profilanswer
 

Hello,
 
Petit soucis sur Gentoo quand j'essaye de modifier un ebuild pour rajouter un USE flag. Pour remettre dans le contexte, il s'agit de l'ebuild "wine-any" dans laquel j'ai rajouté un USE flag (esync).
Ce nouvel USE flag apporte avec lui un certain nombre de patches à appliquer au source de Wine.
 
En plus d'avoir rajouter "esync" comme USE dans l'ebuild, j'ai également rajouté ces quelques lignes de code :

if use esync; then
  cd "${S}"
  for P in "${ESYNC_DIR}"/*.patch; do
   git apply -C1 --verbose < ${P}
  done
  if use staging; then
   patch -Np1 < "${FILESDIR}"/'esync-no_alloc_handle.patch'
  fi
 fi


 
Le problème survient lorsque "emerge" arrive au moment d'appliquer les patches via la commande "git apply -C1 --verbose < ${P}" (Je suis obligé d'utiliser cette commande spécifique et non passer par la commande patch ...). J'ai énormément d'échec lorsque les patches tentent d'être appliqué alors que d'autre réussissent.
Mais ce que je comprends pas, c'est lorsque je lance la commande manuellement, tout s'applique correctement.
 
J'ai beau me triturer le cerveau, je n'arrive pas à comprendre d'ou vient le soucis.
Est-ce que Emerge n'aime pas les commandes de ce genre pour appliquer des patches ?

n°1421953
Mysterieus​eX
Chieuse
Posté le 12-08-2018 à 03:19:57  profilanswer
 

Le problème ne vient pas d'emerge (qui est un outil plutôt idiot à la base et sert à faire des raccourcis usuels aux fonctions portage les plus utiles) mais de portage lui même qui fait des tests de régression sur l'arbre git en court, et le suivant, et donc tu en rajoute un autre, et portage ne sait pas gérer 3 niveau de patch git (en fait, quel builder ou packager saurait ?)
 
Il faut introduire des tempos pour laisser le temps à l'arbre git de se mettre à jour entre chaque patch, ou introduire un check dans ta boucle de patch si une autre action git est déjà en court.
 
Le plus simple si tu veux intégrer tes propres patchs, ou une ligne de patchs complète sur tes propres builds est de monter un overlay local. (Vérifie aussi que tes paquets systèmes sont bien build avec le use flag git) pistes à creuser : emaint, layman, eix

n°1423563
petitjean
-0.46€ sur les chocos BN
Posté le 21-09-2018 à 07:18:03  profilanswer
 

Cocorico ! [:moonzoid:2]  
 

https://reho.st/preview/self/65a37575404c3ff860d0ce3981fcf8b0e0387ae7.png ANSSI [:yoann riou:9] (@ANSSI_FR) :

Participez aux développement de la dernière version de CLIP OS !
Le système d'exploitation sécurisé de l'ANSSI, basé sur un noyau #Linux, est maintenant disponible en open-source pour initier un nouveau projet collaboratif #CLIPOS
 
https://www.ssi.gouv.fr/actualite/contribuez-au-developpement-de-clip-os-le-systeme-dexploitation-durci-concu-par-lanssi/
 
https://reho.st/thumb/https://pbs.twimg.com/media/Dnh48GWXgAE3qSz.jpg


---------------
SERGE PETITDEMANGE, BONJOUR !
n°1423567
Fork Bomb
Obsédé textuel
Posté le 21-09-2018 à 08:15:46  profilanswer
 

petitjean a écrit :

Cocorico ! [:moonzoid:2]  
 


Si c’est de l’Open Source, j’en veux pas.


---------------
Décentralisons Internet-Bépo-Troll Bingo - Ta mère est tellement conne qu’elle passe pas le test de Turing.
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  136  137  138  139  140  141
Page Suivante

Aller à :
Ajouter une réponse
 

Sujets relatifs
Combien de temps pour installer Gentoo?gentoo ? quelqu' un a essayé ?
Gnome 2 rc1 dispoGentoo 1.2 Released
Gentoo impressionPure-FTPd 1.0.12 est enfin dispo!
GENTOO help please[Help me] Gentoo
Gentoo 1.3a Released[gentoo & vmware] Probleme a l'installe pour la carte reseau C resolu
Plus de sujets relatifs à : [Gentoo] Le topic (Profils en cours : 13.0, LiveDVD : 20160514)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR