Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1966 connectés 

 



Quelle(s) branche(s) de Gentoo utilisez-vous ?




Attention si vous cliquez sur "voir les résultats" vous ne pourrez plus voter
Les invités peuvent voter

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  136  137  138  139  140  141
Page Suivante
Auteur Sujet :

[Gentoo] Le topic (Profils en cours : 13.0, LiveDVD : 20160514)

n°1416509
odelpasso
Posté le 26-03-2018 à 11:55:20  profilanswer
 

Reprise du message précédent :
Ce qui est bizarre c'est que je n'ai aucun soucis de redémarrage / freeze sur debian... Et j'ai compilé un noyau custom comme su gentoo

mood
Publicité
Posté le 26-03-2018 à 11:55:20  profilanswer
 

n°1416520
Mysterieus​eX
Chieuse
Posté le 26-03-2018 à 18:24:35  profilanswer
 

odelpasso a écrit :

Ce qui est bizarre c'est que je n'ai aucun soucis de redémarrage / freeze sur debian... Et j'ai compilé un noyau custom comme su gentoo


Et bah importe ton kernel debian sur ta gentoo, tu veux que je te dise quoi ?
Les patchset sont différents, les paquets firmware pour certains sont intégrés sous debian (alors qu'il faut le faire à la main sous gentoo hein)
Bref, non, ce n'est pas bizarre, mais ça, tu le saurais si tu t'intéressais un minimum un peu plus à se qui se passe en interne. C'est même cette bizarrerie qui te donnera la solution à ton problème : au lieu de trouver ça bizarre, ai un esprit critique et trouve les différences entre ta gentoo et la debian.

n°1416522
odelpasso
Posté le 26-03-2018 à 18:41:57  profilanswer
 

Vache, t'es aussi aimable qu'une pierre tombale ...
Faudrait que tu rajoutes "agressive" avec "chieuse", ça t'irait comme un gant.

Message cité 1 fois
Message édité par odelpasso le 26-03-2018 à 18:42:12
n°1416598
Mysterieus​eX
Chieuse
Posté le 28-03-2018 à 03:08:19  profilanswer
 

odelpasso a écrit :

Vache, t'es aussi aimable qu'une pierre tombale ...
Faudrait que tu rajoutes "agressive" avec "chieuse", ça t'irait comme un gant.


 
Nonobstant que je t'ai donné une réponse, tu répond, toi même par une attaque totalement personnelle. Je ne sais pas si tu as bien lu ma réponse. Elle est certes sèche, mais n'en est pas moins exacte : je n'ai pas à plaire ou à faire de l'éloquence ici, juste te fournir une information qui est : si ça fonctionne sous debian, compare les deux distro, notamment au niveau de la configuration du kernel, et des patch appliqués par les administrateurs de debian (puisque sous gentoo, tu es ton propre administrateur de distro). La pseudo politesse (de façade) et les codes sociaux nuisent au transfert d'informations justes, précises et concises.
 
Remarque que j'aurais tout aussi bien pu te dire STFF ou STFW puisque la réponse à ton interrogation est déjà disponible et revient régulièrement : certains CPU dépendamment du kernel et des patchs appliqués ne supportent pas S2/S3, les économies d'énergie, soit parce que le bios/uefi est compilé orienté windows (asus et ses tables ACPI foireuses, les IOAPIC et S2/S3 microsoft style) soit parce qu'il faut charger un firmware non libre, non inclus de base dans les distro (GNU GPL V2 interdisant le chargement de blobs binaires non libre sans information préalable de l'utilisateur) très courant depuis sandy bridge sur intel. Commence donc par rechercher de ce côté et reviens nous voir quand tu aura déjà vérifié ces points précis : tu en as pléthore à explorer. Et si la forme de la réponse ne te conviens pas, ben j'y peut rien.

n°1416609
o'gure
Modérateur
Multi grognon de B_L
Posté le 28-03-2018 à 09:06:46  profilanswer
 

MysterieuseX, met de l'eau dans ton vin, s'il te plait.


---------------
Ton Antoine commence à me les briser menus !
n°1416610
Mysterieus​eX
Chieuse
Posté le 28-03-2018 à 09:08:41  profilanswer
 

[:vizera]
 
D'accord.

n°1416656
odelpasso
Posté le 28-03-2018 à 17:25:11  profilanswer
 

L'accident est clos. Bon, j'ai fait un tour sur Google et j'ai trouvé diverses topics ayant les mêmes soucis que moi, à savoir que le PC freeze sans raison et qu'il y ait des reboot aléatoire.
 
D'après ce que j'ai trouvé comme possible solution, c'est :
1- Augmenter le SoC voltage pour une meilleure stabilité de la RAM.
-> J'ai fait la manip mais je ne sais pas si ça sert à quelques choses pour ma part.
2- Pour les problèmes de reboot, cela viendrait de C-State, des personnes l'ayant désactivé dans le BIOS ou via le kernel n'ont plus de problème.  
-> Manip faite également, à voir sur la durée pour ma part.

n°1416657
Kaari
Fuck Yeah !
Posté le 28-03-2018 à 18:06:37  profilanswer
 

odelpasso a écrit :

2- Pour les problèmes de reboot, cela viendrait de C-State, des personnes l'ayant désactivé dans le BIOS ou via le kernel n'ont plus de problème.


Oui, c'est souvent çà, y'a moyen de patcher cela dit.


---------------
Mon topic ventes ;)
n°1421952
odelpasso
Posté le 12-08-2018 à 02:00:00  profilanswer
 

Hello,
 
Petit soucis sur Gentoo quand j'essaye de modifier un ebuild pour rajouter un USE flag. Pour remettre dans le contexte, il s'agit de l'ebuild "wine-any" dans laquel j'ai rajouté un USE flag (esync).
Ce nouvel USE flag apporte avec lui un certain nombre de patches à appliquer au source de Wine.
 
En plus d'avoir rajouter "esync" comme USE dans l'ebuild, j'ai également rajouté ces quelques lignes de code :

if use esync; then
  cd "${S}"
  for P in "${ESYNC_DIR}"/*.patch; do
   git apply -C1 --verbose < ${P}
  done
  if use staging; then
   patch -Np1 < "${FILESDIR}"/'esync-no_alloc_handle.patch'
  fi
 fi


 
Le problème survient lorsque "emerge" arrive au moment d'appliquer les patches via la commande "git apply -C1 --verbose < ${P}" (Je suis obligé d'utiliser cette commande spécifique et non passer par la commande patch ...). J'ai énormément d'échec lorsque les patches tentent d'être appliqué alors que d'autre réussissent.
Mais ce que je comprends pas, c'est lorsque je lance la commande manuellement, tout s'applique correctement.
 
J'ai beau me triturer le cerveau, je n'arrive pas à comprendre d'ou vient le soucis.
Est-ce que Emerge n'aime pas les commandes de ce genre pour appliquer des patches ?

n°1421953
Mysterieus​eX
Chieuse
Posté le 12-08-2018 à 03:19:57  profilanswer
 

Le problème ne vient pas d'emerge (qui est un outil plutôt idiot à la base et sert à faire des raccourcis usuels aux fonctions portage les plus utiles) mais de portage lui même qui fait des tests de régression sur l'arbre git en court, et le suivant, et donc tu en rajoute un autre, et portage ne sait pas gérer 3 niveau de patch git (en fait, quel builder ou packager saurait ?)
 
Il faut introduire des tempos pour laisser le temps à l'arbre git de se mettre à jour entre chaque patch, ou introduire un check dans ta boucle de patch si une autre action git est déjà en court.
 
Le plus simple si tu veux intégrer tes propres patchs, ou une ligne de patchs complète sur tes propres builds est de monter un overlay local. (Vérifie aussi que tes paquets systèmes sont bien build avec le use flag git) pistes à creuser : emaint, layman, eix

mood
Publicité
Posté le 12-08-2018 à 03:19:57  profilanswer
 

n°1423563
PetitJean
#Nicolle2022
Posté le 21-09-2018 à 07:18:03  profilanswer
 

Cocorico ! [:moonzoid:2]  
 

https://reho.st/preview/self/65a37575404c3ff860d0ce3981fcf8b0e0387ae7.png ANSSI [:yoann riou:9] (@ANSSI_FR) :

Participez aux développement de la dernière version de CLIP OS !
Le système d'exploitation sécurisé de l'ANSSI, basé sur un noyau #Linux, est maintenant disponible en open-source pour initier un nouveau projet collaboratif #CLIPOS
 
https://www.ssi.gouv.fr/actualite/contribuez-au-developpement-de-clip-os-le-systeme-dexploitation-durci-concu-par-lanssi/
 
https://reho.st/thumb/https://pbs.twimg.com/media/Dnh48GWXgAE3qSz.jpg


---------------
SERGE PETITDEMANGE, BONJOUR !
n°1423567
Fork Bomb
Obsédé textuel
Posté le 21-09-2018 à 08:15:46  profilanswer
 

PetitJean a écrit :

Cocorico ! [:moonzoid:2]  
 


Si c’est de l’Open Source, j’en veux pas.


---------------
Décentralisons Internet-Bépo-Troll Bingo - Ta mère est tellement conne qu’elle passe pas le test de Turing.
n°1433908
odelpasso
Posté le 11-05-2019 à 08:39:45  profilanswer
 

@j_c_p, j'ai fait un test genlop mais les seuls paquets assez long à compiler sont GCC et LLVM. J'utilise pas Libreoffice et j'utilise la version binaire de Firefox :

* sys-devel/llvm
 
     Sat May 11 01:10:07 2019 >>> sys-devel/llvm-9999
       merge time: 27 minutes and 58 seconds.
 
 * sys-devel/gcc
 
     Wed May  8 13:02:06 2019 >>> sys-devel/gcc-9.1.0
       merge time: 44 minutes and 47 seconds.


Message édité par odelpasso le 11-05-2019 à 08:41:03
n°1433910
Kaari
Fuck Yeah !
Posté le 11-05-2019 à 09:11:46  profilanswer
 

Toi tu connais pas boost :o


---------------
Mon topic ventes ;)
n°1433911
PetitJean
#Nicolle2022
Posté le 11-05-2019 à 09:29:33  profilanswer
 

ceci ? https://www.boost.org/


---------------
SERGE PETITDEMANGE, BONJOUR !
n°1433914
odelpasso
Posté le 11-05-2019 à 10:22:41  profilanswer
 

Kaari a écrit :

Toi tu connais pas boost :o


 
Bah non, mais je t'en prie, explique moi  :o

n°1433926
j_c_p
Linux user
Posté le 11-05-2019 à 16:11:11  profilanswer
 

Merci odelpasso pour ton retour ;).
 
Sur ma configuration, j'ai cela :

Mon Apr  8 16:03:50 2019 >>> sys-devel/llvm-8.0.0
       merge time: 35 minutes and 48 seconds
 
Mon Apr  8 14:21:15 2019 >>> sys-devel/gcc-8.3.0-r1
       merge time: 47 minutes and 27 seconds.
 
Sat May  4 16:27:59 2019 >>> sys-devel/gcc-9.1.0
       merge time: 1 hour, 4 minutes and 5 seconds


 
Tu as tout compilé en gcc-9 ?

n°1433928
odelpasso
Posté le 11-05-2019 à 16:19:19  profilanswer
 

Lorsque je fais une nouvelle installation, suite au choix du profil je lance une première mise à jour du système via 'emerge -avuDN --with-bdeps=y @world'. C'est via cette update que s'installe gcc-9 donc du coup, toutes les maj se font via gcc-8.
 
C'est pour la suite de l'installation qui se fait uniquement en gcc-9

n°1433929
j_c_p
Linux user
Posté le 11-05-2019 à 16:26:56  profilanswer
 

Ok,
 
tiens, pour info :

jcp@phoenix64 ~ $ emerge --info
Portage 2.3.66 (python 3.6.8-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-8.3.0, glibc-2.29-r2, 5.1.1 x86_64)
=================================================================
System uname: Linux-5.1.1-x86_64-AMD_FX-tm-8300_Eight-Core_Processor-with-gentoo-2.6
KiB Mem:    16423812 total,  13683316 free
KiB Swap:     361456 total,    361456 free
Timestamp of repository gentoo: Sat, 11 May 2019 12:30:01 +0000
Head commit of repository gentoo: ee8272767fc844e42d178758e40fd5e93ad0dfb9
sh bash 5.0_p7
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          5.0_p7::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.8::gentoo, 3.7.3::gentoo
dev-util/cmake:           3.14.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.17::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.64-r1::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.14.1-r2::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            6.4.0-r5::gentoo, 8.3.0-r1::gentoo, 9.1.0::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.0-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo

n°1433950
odelpasso
Posté le 11-05-2019 à 20:56:14  profilanswer
 

Pour ma part, j'ai :

odelpasso@gentoo-desktop ~/Bureau $ emerge --info
Portage 2.3.66 (python 3.6.8-final-0, default/linux/amd64/17.0/desktop, gcc-9.1.0, glibc-2.29-r2, 5.1.0-gentoo x86_64)
=================================================================
System uname: Linux-5.1.0-gentoo-x86_64-AMD_Ryzen_5_1600_Six-Core_Processor-with-gentoo-2.6
KiB Mem:    16357048 total,   1827136 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 10 May 2019 22:00:01 +0000
Head commit of repository gentoo: c54b137b51007e99c897c74b75c14803f504a59b
sh bash 5.0_p7
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          5.0_p7::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.8::gentoo
dev-util/cmake:           3.14.3::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.17::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.1.0::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.0-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo


 
Par contre, fait du ménage dans tes versions de paquets... Surtout pour gcc, ca bouffe pas mal de place et tu as 2 versions qui ne sont plus utilisés.

n°1433981
j_c_p
Linux user
Posté le 12-05-2019 à 15:56:22  profilanswer
 

En fait, je suis en gcc-8 (gcc-9 venant d'être intégré) et je n'ai pas un besoin de gcc-9 pour le moment.

phoenix64 /home/jcp # gcc-config -l
 [1] x86_64-pc-linux-gnu-6.4.0
 [2] x86_64-pc-linux-gnu-8.3.0 *
 [3] x86_64-pc-linux-gnu-9.1.0


 
Pour la version 6, il me semblait que ça venait de Cuda, enfin, c'était le cas quand je suis passé de gcc-7 à gcc-8 :

phoenix64 /home/jcp # equery depends =sys-devel/gcc-6.4.0-r5
 * These packages depend on sys-devel/gcc-6.4.0-r5:
dev-db/mariadb-10.3.13 (>=sys-devel/gcc-3.4.6)
dev-lang/ruby-2.6.3 (jit ? sys-devel/gcc)
dev-util/nvidia-cuda-toolkit-10.1.105-r1 (<sys-devel/gcc-9[cxx])
media-libs/libmypaint-1.3.0-r2 (openmp ? sys-devel/gcc[openmp])
media-libs/mesa-19.1.0_rc1 (opencl ? >=sys-devel/gcc-4.6)
net-misc/dropbox-58.3.88-r1 (>=sys-devel/gcc-4.2.0)
sci-libs/fftw-3.3.8 (quad ? sys-devel/gcc[fortran])
sys-devel/llvm-8.0.0 (>=sys-devel/gcc-3.0)
sys-libs/glibc-2.29-r2 (>=sys-devel/gcc-6)
virtual/fortran-0 (sys-devel/gcc[fortran,openmp?])


 
 
Bref, je passerai à l'occasion en version 9.

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  136  137  138  139  140  141
Page Suivante

Aller à :
Ajouter une réponse
 

Sujets relatifs
Combien de temps pour installer Gentoo?gentoo ? quelqu' un a essayé ?
Gnome 2 rc1 dispoGentoo 1.2 Released
Gentoo impressionPure-FTPd 1.0.12 est enfin dispo!
GENTOO help please[Help me] Gentoo
Gentoo 1.3a Released[gentoo & vmware] Probleme a l'installe pour la carte reseau C resolu
Plus de sujets relatifs à : [Gentoo] Le topic (Profils en cours : 13.0, LiveDVD : 20160514)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR