Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1245 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Debian : apt-get dist-upgrade (problème de conflits)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Debian : apt-get dist-upgrade (problème de conflits)

n°383773
sneakz
Posté le 03-01-2004 à 12:51:23  profilanswer
 

J'ai installé une knoppix sur mon HD. J'ai modifié /etc/apt/sources.list et /etc/apt/apt.conf afin de "basculer" sur une SID Quand j'essaye de lancer "apt-get update && apt-get dist-upgrade", j'obtiens un problème de conflit en décompressant sysv-rc (sysv-rc_2.85-9-all.deb).
 
? Error proceeding /var/cache/apt/archives/sysv-rc_2.85-9_all.deb  
(--unpack): trying to overwrite "/etc/init.d/rc" which is also in packet  
sysvinit.
Errors occured while proceeding  
/var/cache/apt/archives/sysv-rc_2.85-9_all.deb (--unpack)
 
De fait, je ne peux installer les autres paquets.
 
La raison du conflit est évidente mais comment pourrais-je faire pour passer outre proprement ?
 
Une idée ?
 
Merci beaucoup

mood
Publicité
Posté le 03-01-2004 à 12:51:23  profilanswer
 

n°383779
Klaimant
?
Posté le 03-01-2004 à 12:59:31  profilanswer
 

apt-get -f install :??:


Message édité par Klaimant le 03-01-2004 à 12:59:40

---------------
Fais le ou ne le fais pas, mais il n'y a pas d'essai !!!
n°383801
GUG
Posté le 03-01-2004 à 13:42:56  profilanswer
 

tu peux :  
-le deinstaller, installer les autres packages et voir celui ci en dernier
-faire un dpkg -i --force-overwrite lapckage.deb
-desinstaller sysvinit  
-faire gaffe car ce sont les scripts d'init [:ddr555]
-installer une debian

n°383803
sneakz
Posté le 03-01-2004 à 13:47:53  profilanswer
 

apt-get -f install --> ne solutionne pas le pb
desinstaller sysvinit/faire gaffe car ce sont les scripts d'init --> oui c coton
installer une debian --> oui ms la knoppix construit autour d'une debian est assez bien conçue. J'avais installé précédement une Debian. La version était peut-être buggé mais l'install fut très incomplète avec paquetages non installés pour des pbs de dépendances non résolues.
 
 

n°383805
GUG
Posté le 03-01-2004 à 13:49:34  profilanswer
 

faire un mv lefichier lefichier.old ...

n°383926
sneakz
Posté le 03-01-2004 à 19:00:33  profilanswer
 

Je v essayé le mv mais g peur que le fichier en question soit mémorisé et que apt-get considère encore qu'il est présent et me refuse l'install


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Debian : apt-get dist-upgrade (problème de conflits)

 

Sujets relatifs
[Debian] installation F@st 800 et Sourie USB [RESOLU]Probleme de fenetre avec un programme Motif
Ou trouver une net-install de la "sarge" debian?[WindowMaker] Problème de résolution
Debian net install Bug de la config reseau[DEBIAN/SID] Upgrader les packages non buggués?
Installation debian sur disque USB ?debian xfree4.3 pre5 : installation de xlibs pour i386
[wifi on debian sid] problème dans la recompilation du kernel [help] 
Plus de sujets relatifs à : Debian : apt-get dist-upgrade (problème de conflits)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR