Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2072 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  KDE disque dur externe NTFS avec ntfs-3g et ntfs-config

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

KDE disque dur externe NTFS avec ntfs-3g et ntfs-config

n°987537
filochard
gardarem lou moral
Posté le 04-12-2007 à 17:48:34  profilanswer
 

Petit probleme avec un disque dur externe NTFS :
ntfs-3g et ntfs-config permettent de le monter avec une possibilité d'écriture :
ça marche au poil !
Mais il est impossible d'écrire des dossiers ou fichiers comportant des caractères accentués!
 
Pour les disques durs internes en NTFS il suffit d'écrire cette ligne dans le /etc/fstab :
/dev/<votre partition> /media/<point de montage> ntfs-3g silent,umask=0,locale=fr_FR.UTF-8 0 0
pour que les caractères accentués soient acceptés  
(dans mon cas ce serait  /dev/sda1 /media/FreeAgent ntfs-3g silent,umask=0,locale=fr_FR.UTF-8 0 0)
 
Mais je ne veux pas modifier mon fstab (cette ligne s'appliquerait à tout media externe et causerait des problèmes s'il n'est pas en NTFS)
 
 
 
Parmi les fichiers du paquetage ntfs-config se trouve celui-ci : /usr/share/ntfs-config/write-policy.fdi
 
 
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
 
<deviceinfo version="0.2">
 
<!-- file created by ntfs-config -->
<!-- mount ntfs volume with the ntfs-3g driver to enable write support -->
 
    <device>
        <match key="volume.fstype" string="ntfs">
      <match key="@block.storage_device:storage.hotpluggable" bool="true">
       <merge key="volume.fstype" type="string">ntfs-3g</merge>
                <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
       <append key="volume.mount.valid_options" type="strlist">locale=</append>
         </match>
     </match>
    </device>
 
</deviceinfo>
 
il est relié à /etc/hal/fdi/policy/20-ntfs-config-write-policy.fdi
 
et induit la création de cete ligne dans mtab
/dev/sda1 /media/FreeAgent\040Drive fuseblk rw,nosuid,nodev,sync,noatime,allow_other,default_permissions,blksize=4096 0 0
 
est-il concevable de modifier ainsi ce fichier
 
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
 
<deviceinfo version="0.2">
 
<!-- file created by ntfs-config -->
<!-- mount ntfs volume with the ntfs-3g driver to enable write support -->
 
    <device>
        <match key="volume.fstype" string="ntfs">
      <match key="@block.storage_device:storage.hotpluggable" bool="true">
       <merge key="volume.fstype" type="string">ntfs-3g</merge>
                <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
       <append key="volume.mount.valid_options" type="strlist">locale=fr_FR.UTF-8</append>
         </match>
     </match>
    </device>
 
</deviceinfo>
 
afin d'obtenir l'écriture des caractères accentués après le montage automatique d'un disque ntfs


Message édité par filochard le 10-12-2007 à 22:13:19
mood
Publicité
Posté le 04-12-2007 à 17:48:34  profilanswer
 

n°987553
filochard
gardarem lou moral
Posté le 04-12-2007 à 19:04:27  profilanswer
 

J'ai essayé ça n'a rien changé !
quelqu'un a une idée ?

n°987656
filochard
gardarem lou moral
Posté le 05-12-2007 à 02:17:38  profilanswer
 

J'y comprend rien !
 
Si je fonctionne sous Gnome, le disque dur externe NTFS est monté à la demande et lisible et inscriptible, après avoir modifié /home/monnom/.gconf/system/storage/default_options/ntfs-3g/%gconf.xml ainsi :
 
<gconf>

 <entry name="mount_options" mtime="1196813198" type="list" ltype="string">

 <li type="string">
<stringvalue>locale=fr_FR.UTF-8</stringvalue>
</li>
</entry>
</gconf>
 
Je peux écrire et lire des dossiers et fichiers avec des noms comportant des caractères accentués.
 
Si je fonctionne sous KDE et que je monte ce disque amovible, les dossiers et fichiers que j'ai écrits sous gnome sont invisibles ... et je ne peux écrire de nom avec des caractères accentués.
 
Cela ne vient donc pas seulement de la configuration de hal,  il y a quelque chose à faire dans KDE. Mais quoi?

n°987966
filochard
gardarem lou moral
Posté le 05-12-2007 à 19:32:33  profilanswer
 

J'ai modifié le titre :
Le problème se limite à KDE : et pour le montage de disque à chaud
 
1)
Si je mentionne /dev/dans fstab le disque ainsi :
/dev/sda1 /mnt/Disqueexterne ntfs-3g rw,user,users,umask=0,locale=fr_FR.UTF-8 0 0
Le disque est correctement monté, il est possible d'écrire ou de lire des noms de dossiers ou de fichiers comportant des caractères accentués sous Gnome ou KDE.
 
2)
Si je ne mentionne pas le disque dans fstab : (pour éviter des erreurs lors de l'utilisation d'une clé branchée à la place du disque, qui s'appelerait /dev/sda1 comme lui!)
Quand je le branche, ill est détecté par hal et une icône apparaît sur le bureau.
Je choisis de le monter et là ça se gâte :
 
a)
Sous Gnome le disque ne semble plus contenir les fichiers dont le nom comporte des caractères accentués (même s'ils ont été écrits en suivant la procédure précédente...
ce problème est contournable par le procédé mentionné dans le post précédent (une procédure simple pour la modification du fichier consiste à utiliser le menu de Gnome Système/Préférences/Avancé
ouvrir le dossier system  
puis les sous-dossiers storage
puis default_options
puis ntfs-3g
Dans ce dernier choisir d'éditer la clé "locale=" en ajoutant "fr_FR.UTF-8" (cela est valable pour Mandriva mais l'écriture varie selon les distributions : cela peut être fr_FR.utf8... pour le savoir taper dans une console "locale -a" cela donnera la liste des options possibles avec leur casse à respecter)
 
b)  
avec KDE l'icône du disque comporte un possiblité d'options (bouton droit puis propriétés, onglet montage : un bouton à cocher jeu de caractères UTF 8)
Le montage du disque crée le dossier /media/nomcommercialdudisque
Il est impossible de voir les fichiers dont le nom comporte un caractère accentué! (comme s'ils avaient disparu de l'arborescence) et impossible d'en écrire.
 
 
Questions
Y a-t-il un possibilité de modifier le media manager de KDE pour qu'il propose d'utiliser le jeu de caractère fr_FR.UTF-8 pour les disques en ntfs-3g (pour les disques en FAT32 pas de problème avec les caractères accentués le jeu de caractères UTF 8 suffit !) ?
 
Ou alors faut-il éditer le fstab en utilisant l'uuid du disque au lieu de /dev/sda1 pour éviter les confusions?
 

n°988296
l4nkou
Dr House Fan
Posté le 06-12-2007 à 15:43:26  profilanswer
 

Lien
 
Il n'est pas actuellement possible d'utiliser ntfs-3g pour les lecteurs amovibles sous KDE
 
 


---------------
Les avis, c'est comme les anus, tout le monde en a un.
n°988313
l4nkou
Dr House Fan
Posté le 06-12-2007 à 15:54:48  profilanswer
 

je viens de tomber sur un lien qui disait décocher l'option "Mount as user" sur le périphérique pour que ça fonctionne :/
je te conseille aussi, de rebooter sous windows, de faire un scan disk de ton dd externe, et de deconnecter ton disque dur externe comme tu le ferais pour une clé usb:
 
http://www.howtoforge.com/ntfs_3g_ [...] _spring_p3
 


Message édité par l4nkou le 06-12-2007 à 15:56:54

---------------
Les avis, c'est comme les anus, tout le monde en a un.
n°988422
filochard
gardarem lou moral
Posté le 06-12-2007 à 19:32:52  profilanswer
 

Merci l4nkou
Je n'ai pas eu de problème pour utiliser le lecteur amovible ntfs sous KDE : l'icône s'affiche comme pour  un support amovible vfat et le disque  peut être monté ou démonté, et l'écriture est possible....
(  les mises à jour par le backport repository de mandriva ont certainement corrigé le problème initial que signalait le lien que tu indiques et que j'avais déjà lu).
 
Le problème qui me préoccupe existe en fait sous Gnome et KDE : il est possible de voir les caractères accentués si le disque est utilisé comme un disque fixe déclaré dans fstab avec la précision du jeu de caractères fr_FR.UTF-8 (ce qui n'est pas nécessaire pour les partitions vfat : utf8 suffit)
 
Si le disque n'est pas déclaré dans fstab, il est décelé par hald, une icône apparait, permettant de le monter (ça marche pour Gnome et KDE)
Mais là, ça coince... les noms avec des caractères accentués disparaissent totalement de l'arborescence.......
J'ai pu contourner le problème dans Gnome en utilisant la procédure que j'indique  et il m'est possible de voir et d'écrire des noms de fichiers avec des caractères accentués.
 
Sous KDE je n'ai pas trouvé où se trouve le fichier qui est à l'origine de l'icône qui apparait... ce qui me permettrait de modifier  l'option proposée : jeu de caractères "UTF 8" en "fr_FR.UTF-8"
le seul fichier approchant est /usr/share/mimelnk/media/removable_unmounted.desktop... mais il n'est que la base sur laquelle se construit l'icône
Je n'ai pas trouvé non plus dans le dossier/home/mon_nom/.kde de trace de fichier correspondant à l'icône affichée sur mon bureau quand le disque est branché (c'est un fichier "dynamique" créé à l'issue du branchement du disque mais je ne sais pas où... peut être dans /var ? mais sur quelles bases?)
je n'ai pas trouvé

n°988424
filochard
gardarem lou moral
Posté le 06-12-2007 à 19:36:43  profilanswer
 

PS je n'ai plus windows et le problème ne vient pas d'une erreur de débranchement "à la cosaque". j'ai conservé le NTFS sur le disque dur amovible pour pouvoir proposer les fichiers à des utilisateurs de Windows (il en reste....) et écrire des images de dvd (plus de 4 Go non gérés par Fat 32)


Message édité par filochard le 06-12-2007 à 20:10:15
n°988433
filochard
gardarem lou moral
Posté le 06-12-2007 à 20:06:48  profilanswer
 

je viens de trouver quelques choses :
 
/usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
comporte ces lignes
 <!-- allow these mount options for ntfs -->
      <match key="volume.fstype" string="ntfs">
 <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
   <append key="volume.mount.valid_options" type="strlist">uid=</append>
   <append key="volume.mount.valid_options" type="strlist">gid=</append>
   <append key="volume.mount.valid_options" type="strlist">umask=</append>
   <append key="volume.mount.valid_options" type="strlist">locale=</append>
   <append key="volume.mount.valid_options" type="strlist">utf8</append>
 </match>
Peut-être cela pourait être modifié ..... en remplaçant utf8 par fr_FR.UTF-8
 
usr/share/hal/fdi/policy/10osvendor/30-locale-policy.fdi
et /usr/share/hal/fdi/30osvendor/30-locale-policy.fdi
comportent chacun ces lignes :
<match key="volume.fstype" string="ntfs">
  <merge key="volume.policy.mount_option.iocharset=utf8" type="bool">true</merge>
  <merge key="volume.policy.mount_option.utf8" type="bool">true</merge>
 </match>
peut-être faudrait-il les transformer en :
<match key="volume.fstype" string="ntfs">
  <merge key="volume.policy.mount_option.locale=fr_FR.UTF-8" type="bool">true</merge>
  <merge key="volume.policy.mount_option.fr_FR.UTF-8" type="bool">true</merge>
 </match>
 
ça devient peut-être trop pointu ....... je devrais peut-être essayer auprès des développeurs de hal et KDE !
 
Mais je voulais savoir si ce problème de caractères accentués concernait d'autres personnes (j'ai déjà vu sur un forum que les fichiers avec des noms accentués disparaissent de l'arborescence sous linux mais existent sous windows!!!) et si l'information à faire remonter était pertinente ou spécifique à Mandriva 2007.1

n°989512
enfoiro
a nickname is just a nickname
Posté le 10-12-2007 à 12:01:11  profilanswer
 

je pense que ce problème est du à l'utilisation du codage UTF8, debian a recemment basculé vers ce codage et ca provoque des soucis avec les anciens fichiers. Essaie fr_FR sans utf8 ca devrait marcher. D'autre part tu n'est pas le seul à avoir ce souci bien au contraire, très répandu sur le web. Si tu pouvais récapituler tes manips et le expliquer ca serait utile à tous. Utilise les balises [ fixed ] pour avoir quelque chose de propre pour les scripts/codes

mood
Publicité
Posté le 10-12-2007 à 12:01:11  profilanswer
 

n°989733
filochard
gardarem lou moral
Posté le 10-12-2007 à 22:43:50  profilanswer
 

je n'ai pas trouvé de solution pour KDE !  
Les tentatives de modification des fichiers .fdi n'ont rien changé....
 
Pour Enfoiro :
J'utilise Mandriva 2007.1, la locale fr_FR est, chez moi, liée à fr_FR.ISO-8859-15 ... ta proposition ne peut marcher !
 
Résumé :  
1)
on peut utiliser sans problème un disque externe en ntfs avec ntfs-3g s'il ne comporte aucun caractère accentué dans les noms de dossiers ou de fichier... sans procédure particulière
 
2)
Si l'on compte utiliser les caractères accentués il est nécessaire :
 
a)
soit de le déclarer dans fstab et de créer un point de montage avec des droits de lecture et d'écriture pour tous les utilisateurs
(/dev/sda1 /mnt/mondisk ntfs-3g rw,user,users,umask=0,locale=fr_FR.UTF-8 0 0)
 
 il est alors utilisable... qu'il soit branché ou non au démarrage, sous Gnome ou KDE :
 dans un cas il est monté automatiquement
dans l'autre il est reconnu comme disque amovible et monté à la demande dans le dossier prévu dans le fstab
 
b)
soit de ne pas toucher au fstab et de modifier un des fichiers de configuration de Gnome  
/home/monnom/.gconf/system/storage/default_options/ntfs-3g/%gconf.xml  
<gconf>

 <entry name="mount_options" mtime="1196813198" type="list" ltype="string">

 <li type="string">
<stringvalue>locale=fr_FR.UTF-8</stringvalue>
</li>
</entry>
</gconf>  
ce qui résoud le problème pour Gnome
 mais dans ce cas les noms comportant des caractères accentués disparaissent totalement pour KDE (comme si ces dossiers et fichiers avaient été effacés!)

n°1000902
florut
Posté le 11-01-2008 à 23:51:35  profilanswer
 

Salut Filochard,
 
J'ai exactement le même problème (les fichiers qui contiennent un caractère accentué ne s'affichent pas quand je monte un volume ntfs externe avec hal) et je me prends la tête dessus depuis un certain temps. Si tu as une solution, je suis très très preneur et je t'en ferai part également si je finis par trouver !!

n°1000903
florut
Posté le 12-01-2008 à 00:03:45  profilanswer
 

Finalement j'ai fini par trouver... la réponse est là :  
http://wiki.archlinux.org/index.ph [...] figuration
Ca marche !!

n°1001056
filochard
gardarem lou moral
Posté le 12-01-2008 à 13:08:14  profilanswer
 

salut florut
 
J'avais déjà trouvé cet astuce mais elle n'avait pas marché pour moi...... j'avais tenté de modifier la position des variables dans ce bash : /bin/ntfs-3g $1 $2 -o locale=fr_FR.UTF-8 en l'écrivant ainsi
/bin/ntfs-3g  -o locale=fr_FR.UTF-8 $1 $2
mais cela n'avait pas amélioré les choses.
 
Je me suis limité à modifier le fstab en remplaçant le début de la ligne de mon disque externe (mes disques internes étant baptisés hda et hdb)
dev/sda1 /mnt/blabla en  
dev/disk/by-uuid/CA8C309B8C30844B /mnt/Seagate ntfs-3g rw,user,users,umask=0,locale=fr_FR.UTF-8 0 0
(il suffit de rechercher dans le dossier /dev/disk/by-uuid/ quel "nom" est lié au disque externe)
ainsi ce réglage n'affectera aucun autre support de stockage externe en particulier s'ils ont un autre système de fichier! et pour ce disque tout baigne.
 
PS
Je n'ai pas encore  upgradé de mandriva 2007.1 à 2008, (j'attends toujours deux ou trois mois après la sortie d'une nouvelle version.... que les derniers bugs soient corrigés)
Je ne sais pas si le problème existe toujours avec Mandriva 2008 !


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  KDE disque dur externe NTFS avec ntfs-3g et ntfs-config

 

Sujets relatifs
Disque dur externe français sur télé anglaise ?Dev C++/KDE
[AIX 4.3] config carte réseau volatile et Simplex/Duplex[Resolu]Arret du disque dur répété sur hp 8510p
Probleme partage Disque en reseau [XP]disque dur sata seagate
disque en lecture seuleInstallation nouvelle config
[KDE] - Problème de taille de polices 
Plus de sujets relatifs à : KDE disque dur externe NTFS avec ntfs-3g et ntfs-config


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR