Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
553 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Question serveur DNS sur réseau local

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Question serveur DNS sur réseau local

n°146130
chapeaupoi​ntu
Posté le 20-04-2017 à 10:39:31  profilanswer
 

Bonjour,  
Je cherche à comprendre le fonctionnement d'un réseau avec un serveur Windows server 2008 (serveur de fichier, DHCP et DNS).  
La navigation internet sur les postes du réseau est lente, il se passe entre 1 et 2s entre le clic et le début d'apparition de la page (sur une connexion fibre !) et je soupçonne le serveur DNS d'être la cause.  
Les postes du réseau obtiennent leur adresse IP, DNS et passerelle par le DHCP du serveur. Le DNS du serveur est paramétré avec les redirecteurs d'Orange.  
Quand on navigue sur le net, c'est donc le DNS du serveur 2008 qui répond à nos requêtes. Si je remplace dans les propriétés de la carte réseau le DNS par ceux de Google par exemple (8.8.8.8), la navigation devient instantanée après le clic.  
 
J'aimerais savoir si je peux indiquer, sur chaque poste (ou dans le DHCP du serveur) le DNS de Google pour améliorer la réactivité de la navigation, mais surtout sans que cela perturbe la navigation "locale" vers les autres postes du réseau, imprimantes, NAS etc...  
 
Merci de vos réponses.

mood
Publicité
Posté le 20-04-2017 à 10:39:31  profilanswer
 

n°146131
ShonGail
En phase de calmitude ...
Posté le 20-04-2017 à 10:48:53  profilanswer
 

Et si au niveau de tes redirecteurs, tu paramètres les serveurs DNS de google à la place de ceux d'Orange ?
Les PCs sont sur domaine ?

n°146132
chapeaupoi​ntu
Posté le 20-04-2017 à 10:57:06  profilanswer
 

Oui les PC sont sur le domaine. Je n'ai pas voulu changer la configuration du serveur pour l'instant, je ne veux pas tout "casser", j'ai supposé que les DNS d'Orange sont réactifs :)
J'ai oublié de préciser que le serveur DHCP, DNS se trouve sur un site distant relié au site sur lequel j'ai ces lenteurs par un VPN SDSL 2Mo.
Je suppose que les lenteurs viennent de là, même si le SDSL a une bonne réputation côté réactivité....

n°146133
ShonGail
En phase de calmitude ...
Posté le 20-04-2017 à 11:02:52  profilanswer
 

Le mieux serait de placer sur site un serveur DNS qui contient la zone AD.

n°146134
ShonGail
En phase de calmitude ...
Posté le 20-04-2017 à 11:04:07  profilanswer
 

Mais il ne faut pas placer sur les PCs de serveurs DNS qui ne contiennent pas ta zone AD.

n°146135
chapeaupoi​ntu
Posté le 20-04-2017 à 11:13:20  profilanswer
 

Voilà je m'en doutais qu'il ne fallait pas toucher aux DNS des postes du site distant. Donc comme il n'y a qu'un serveur DNS pour les deux sites, je suis "baisé".
Quelle solution aurais-je pour améliorer la navigation sur le site distant ?


Message édité par chapeaupointu le 20-04-2017 à 11:13:49
n°146136
ShonGail
En phase de calmitude ...
Posté le 20-04-2017 à 11:40:34  profilanswer
 

Il faudrait déjà s'assurer que c'est bien un problème de latence entre le PC et le serveur DNS via la SDSL 2Mbits.
 
Si sur un PC qui a le problème, tu fais un nslookup et que tu tentes de résoudre des noms de domaine, as-tu une latence ?
Que donnent des pings entre ce même PC et le serveur DNS ?

n°146138
chapeaupoi​ntu
Posté le 20-04-2017 à 12:28:04  profilanswer
 

Je vais tester dès que je suis sur le site. Je te tiens au courant, merci pour tes conseils.

n°146139
dims
if it ain't brocken, mod it !
Posté le 20-04-2017 à 12:38:37  profilanswer
 

sans remettre un serveur AD complet sur ton second site, tu peux aussi y mettre un serveur DNS avec un replica de ta zone AD ou juste des forwarder bien configurés (pour ton domaine local forward vers le serveur DNS interne et 8.8.8.8 pour le reste)
 
certains routeur un peu avancé le font sans problème ;)

n°146326
borntokiff
Posté le 30-04-2017 à 00:47:55  profilanswer
 

attention aussi a la récursivité de ton DNS, par défaut sur le DNS w2008 les requêtes sont accepté même sur les postes hors domaine .... vérifier aussi l,activité de ton serveur DNS

mood
Publicité
Posté le 30-04-2017 à 00:47:55  profilanswer
 

n°146700
chapeaupoi​ntu
Posté le 22-05-2017 à 14:14:18  profilanswer
 

ShonGail a écrit :

Il faudrait déjà s'assurer que c'est bien un problème de latence entre le PC et le serveur DNS via la SDSL 2Mbits.
 
Si sur un PC qui a le problème, tu fais un nslookup et que tu tentes de résoudre des noms de domaine, as-tu une latence ?
Que donnent des pings entre ce même PC et le serveur DNS ?


 
Bonjour,
J'ai enfin pu me rendre sur site pour faire mes tests.
nslookup pas de latence, j'ai un affichage quasi instantané des adresses résolues
un ping du serveur DNS me donne 36ms en moyenne via la liaison SDSL, c'est plutôt pas mal non ?
 

n°146703
chapeaupoi​ntu
Posté le 22-05-2017 à 15:20:34  profilanswer
 

Bon finalement, contrairement à ce que j'avais cru au départ en faisant des tests vite faits, changer les DNS pour ceux de Google n'améliore pas la situation.
J'en viens maintenant à soupçonner le firewall situé après la connexion fibre.  
Là j'ai des sites qui mettent 20s !! à s'afficher après avoir tapé leur adresse. C'est le cas de clubic.com, lesnumeriques.com, lequipe.fr...
 
Pour lequipe.fr, le navigateur indique en bas "en attente de lequipe.fr","en attente de pq-direct.revsci.net" puis en "attente de medias.lequipe.fr"... avant que la page ne s'affiche...
 
Qu'en pensez vous ?

n°146705
Je@nb
Modérateur
In ze cloud
Posté le 22-05-2017 à 15:27:26  profilanswer
 

utilise le debugging de ton navigateur voir où ça bloque.
Sinon l'equipe comme site pro ...

n°146707
skoizer
tripoux et tête de veau
Posté le 22-05-2017 à 15:30:50  profilanswer
 

si tu es sur Internet explorer
essaye de désactiver "detecter automatiquement les paramétres de connexion" dans les paramétrés du reseau local  
 
cela peu aussi être ton firewall ou ton modem sdsl est en surcharge.
J'avais ce probléme sur mon ancien firmware qui n’était pas assez puissant.


---------------
Plus tu essaies de rentrer dans le moule, plus tu ressembles à une tarte.
n°146708
ShonGail
En phase de calmitude ...
Posté le 22-05-2017 à 15:32:22  profilanswer
 

chapeaupointu a écrit :


 
Bonjour,
J'ai enfin pu me rendre sur site pour faire mes tests.
nslookup pas de latence, j'ai un affichage quasi instantané des adresses résolues
un ping du serveur DNS me donne 36ms en moyenne via la liaison SDSL, c'est plutôt pas mal non ?
 


 
C'est correct sans être au top.
Enfin le problème n'est pas là.
 
Les PCs ont donc en DNS primaire ce serveur DNS ?

Message cité 1 fois
Message édité par ShonGail le 22-05-2017 à 15:33:16
n°146709
chapeaupoi​ntu
Posté le 22-05-2017 à 15:32:42  profilanswer
 

Je@nb a écrit :

utilise le debugging de ton navigateur voir où ça bloque.
Sinon l'equipe comme site pro ...


 
Je fais des tests, n'importe quel site fait l'affaire !


Message édité par chapeaupointu le 22-05-2017 à 15:34:03
n°146710
skoizer
tripoux et tête de veau
Posté le 22-05-2017 à 15:33:43  profilanswer
 

utilise tu un proxy ?
essaye ceci
enléve
"detecter automatiquement les paramétres de connexion"
une maj windows peu avoir posé probléme.


---------------
Plus tu essaies de rentrer dans le moule, plus tu ressembles à une tarte.
n°146711
chapeaupoi​ntu
Posté le 22-05-2017 à 15:38:08  profilanswer
 

non pas de proxy

n°146712
chapeaupoi​ntu
Posté le 22-05-2017 à 15:38:28  profilanswer
 

ShonGail a écrit :


 
C'est correct sans être au top.
Enfin le problème n'est pas là.
 
Les PCs ont donc en DNS primaire ce serveur DNS ?


 
oui

n°146714
ShonGail
En phase de calmitude ...
Posté le 22-05-2017 à 16:04:26  profilanswer
 


 
Bon donc a priori ce n'est pas un problème DNS.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Question serveur DNS sur réseau local

 

Sujets relatifs
hote vmware, carte reseau ethernet vs carte sfp+Question serveurs d'occasion
réseau + vpn derrière deux boxtraffic réseau et blocage adresse MAC
mon serveur est hacké !!!Montage NFS qui deconne sur un serveur HPUX
Refonte réseau MPLSMon PC principal ne voit plus tous les autres ordis du réseau
Serveur de connexion distant remplacement NAS 
Plus de sujets relatifs à : Question serveur DNS sur réseau local



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR