Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1919 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  [novice] Problème remonté d'inventaire OCS NG Inventory

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[novice] Problème remonté d'inventaire OCS NG Inventory

n°149797
dandyz
Posté le 09-11-2017 à 10:19:19  profilanswer
 

Salut,

 

Je viens sur le forum aujourd'hui car j'ai un problème de remonté d'inventaire, je m'explique.
J'ai installé OCS NG Inventory sur un serveur Hyper-V puis installé sur un poste client le OCS Inventory NG Agent. Malheureusement je n'ai aucune remontée de données sur le server OCS. J'arrive à ping le serveur et vice versa.
Je suis allé dans ocsinventory.log et j'ai remarqué qu'il y a une erreur : Failed to send Prolog. Avez-vous une idée ?
Merci d'avance  :wahoo:

 

PS (le contenu du fichier ocsinventory.log) :

 

Starting OCS Inventory NG Agent on Wednesday, November 08, 2017 13:55:02.
AGENT => Running OCS Inventory NG Agent Version 2.3.1.1
AGENT => Using OCS Inventory NG FrameWork Version 2.3.1.1
AGENT => Loading plug-in(s)
 DLL PLUGIN => Searching for Plug-in DLL(s) in folder <C:\Program Files (x86)\OCS Inventory Agent\plugins>
 DLL PLUGIN => 0 DLL Plug-in(s) successfully loaded on 0 DLL(s) found
AGENT => Using network connection with Communication Server
 COM PROVIDER => Loading Communication Provider <C:\Program Files (x86)\OCS Inventory Agent\ComHTTP.dll>
AGENT => Using Communication Provider <OCS Inventory NG cURL Communication Provider> Version <2.3.1.1>
AGENT => Sending Prolog
 DID_CHECK => Read DeviceID <DEV38-2017-11-08-09-01-58> and MACs <A4:5D:36:59:8E:076C:88:14:9E:30:1C6C:88:14:9E:30:1C6C:88:14:9E:30:1C6C:88:14:9E:30:1C6C:88:14:9E:30:1C00:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:00> in file <ocsinventory.dat>
DID_CHECK => MAC Address changed new:<A4:5D:36:59:8E:076C:88:14:9E:30:1C00:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:00> old:<A4:5D:36:59:8E:076C:88:14:9E:30:1C6C:88:14:9E:30:1C6C:88:14:9E:30:1C6C:88:14:9E:30:1C6C:88:14:9E:30:1C00:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:00>
DID_CHECK => Generating new unique ID for device <DEV38>
 DID_CHECK => writing DeviceID <DEV38-2017-11-08-13-55-02> and MACs <A4:5D:36:59:8E:076C:88:14:9E:30:1C00:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:0000:00:00:00:00:00> in file <C:\ProgramData\OCS Inventory NG\Agent\ocsinventory.dat>
 COM SERVER => Initializing cURL library for sendRequest
 COM SERVER => Using cURL with server authentication
 COM SERVER => Disabling cURL proxy support
 COM SERVER => Disabling cURL SSL server validation support
 COM SERVER => Sending HTTP Post request to URL <http://192.168.1.10/ocsinventory>
 WARNING *** COM SERVER => Failed to send HTTP Post request <Couldn't connect to server>
 COM SERVER => Cleaning cURL library
ERROR *** AGENT => Failed to send Prolog <Couldn't connect to server>
AGENT => Unloading communication provider
AGENT => Unloading plug-in(s)
AGENT => Execution duration: 00:00:22.


Message édité par dandyz le 09-11-2017 à 10:23:37
mood
Publicité
Posté le 09-11-2017 à 10:19:19  profilanswer
 

n°149798
matsu92
Be Water My Friend
Posté le 09-11-2017 à 10:28:53  profilanswer
 

Quel genre de test tu as fait avant de poster?
 
Firewall? ping?  
"Couldn't connect to server" ...

n°149802
dandyz
Posté le 09-11-2017 à 11:03:51  profilanswer
 

J'ai fais des ping et ils arrivent à se ping.
Je viens de désactiver le firewall et la il me met un nouveau message à la place de Couldn't connect to server.
 
ERROR *** AGENT => Failed to send Prolog <HTTP Status Code #404>

n°149803
matsu92
Be Water My Friend
Posté le 09-11-2017 à 11:07:55  profilanswer
 

https://wiki.ocsinventory-ng.org/in [...] Windows/fr
 
d'après cette doc, à l'install de l'agent tu dois renseigner ton serveur avec le port.
Tu es certain de bien avoir renseigné les champs?


Message édité par matsu92 le 09-11-2017 à 11:08:42
n°149804
matsu92
Be Water My Friend
Posté le 09-11-2017 à 11:15:49  profilanswer
 

http://www.laintimes.com/installat [...] et-client/
 
En cas d’erreur 404, il s’agit d’une mauvaise configuration de votre Vhost APACHE, OCS importe lui même son virtualhost. Vérifiez bien que votre URL(IP) pointe vers la racine du répertoire OCS. Pour compléter cela je vous fournis un exemple de Vhost, afin de faire pointer directement vers OCS votre serveur Web.

n°149810
dandyz
Posté le 09-11-2017 à 11:45:24  profilanswer
 

Pour l'installation j'avais pas exactement le même installer que dans la docs mais je pense l'avoir bien fait.
Pour l'erreur 404, ou est-ce que je vérifie que l'URL(IP) point vers la racine du répertoire OCS ?
Je viens de voir sur mon OCS Inventory côté server que la version, celle qui est marquée en haut à droite est : Ver. 2.1.2. Est ce que cela peut poser problème sachant que mon agent est en 2.3.1.1. Faudrait il plutôt que je le mette sur un serveur Linux avec une version non obsolète ?
 

n°149814
matsu92
Be Water My Friend
Posté le 09-11-2017 à 13:19:55  profilanswer
 

Je n'ai pas mentionné de changement de version.
Je t'ai dit de checker, à travers le lien que je t'ai donné, la conf de ton virtual host.
De plus, il est mentionné aussi que ton serveur doit être accessible en HTTPS et non pas en HTTP via les dernières versions d'OCS.
Ce sont des pistes.

n°149852
dandyz
Posté le 10-11-2017 à 09:04:59  profilanswer
 

Je suis arrivé à faire fonctionner le logiciel sans firewall.
Est il possible de le faire avec ? J'ai essayé en ouvrant les ports 80 et en changeant le ocsinventory.ini coté client. Mais pas de remonté, une idée ?

n°149854
matsu92
Be Water My Friend
Posté le 10-11-2017 à 13:48:18  profilanswer
 

Précise de quel firewall tu parles.

n°149855
dandyz
Posté le 10-11-2017 à 13:52:29  profilanswer
 

Le Firewall Windows

mood
Publicité
Posté le 10-11-2017 à 13:52:29  profilanswer
 

n°149859
matsu92
Be Water My Friend
Posté le 10-11-2017 à 14:08:52  profilanswer
 

OK
Précise encore.  
Le firewall Windows de ton client ou de ton serveur?

n°149870
dandyz
Posté le 10-11-2017 à 15:40:27  profilanswer
 

J'aimerais le faire fonctionner avec le pare feu activé sur mon serveur et sur mon/mes client(s).

n°149875
matsu92
Be Water My Friend
Posté le 10-11-2017 à 16:49:53  profilanswer
 

t'es censé pouvoir créer des exceptions dans ces parefeux normalement..


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  [novice] Problème remonté d'inventaire OCS NG Inventory

 

Sujets relatifs
Problème de connexion serveurs distantsNettoyage des TAG OCS
OPENVPN - Problème de routageProblème de sauvegarde d'une VM avec Veeam
NVR Airvision - problèmecomment eliminer le probleme connect a smart card
Création certificat pour OCS InventoryProblème pour joindre un 2° QNAP au domaine LDAP
Probleme reseau/bureau a distance 
Plus de sujets relatifs à : [novice] Problème remonté d'inventaire OCS NG Inventory



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR