Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2046 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  [WIN2008R2] Affichage Office bugé en TSE avec multi screen

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[WIN2008R2] Affichage Office bugé en TSE avec multi screen

n°148468
ankou2000
Pseudo alacon
Posté le 21-08-2017 à 11:07:46  profilanswer
 

Bonjour hfr,
 
J'ai un problème très bizarre dans un environnement TSE sous Windows 2008 R2 Standard 64 bits. Ce serveur est virtualisé sous ESX 6.
Mes utilisateurs se connectent en TSE sur ce serveur pour travailler sur leurs logiciels, et notamment sur Office.
Ils travaillent en double écrans sur le rdp, un logiciel métier a droite, et un produit office à gauche.
 
Depuis une semaine ils ont tous un problème d'affichage sur les produits Office lorsqu’ils basculent l’application sur le 2eme écran : La fenêtre est complétement buguée, des carrés bleus empêchent l'utilisation des produits. Pourtant ça reste "clickable" mais on ne voit pas ce qu'il se passe, je vous laisse quelques screenshot plus bas.
 
Ce qui a été fait coté serveur : Réparation d'Office complète. Recherche de mise a jour RAS, recherche de malwares RAS. Scan SFC RAS. Création de nouveaux profils RDP toujours pareil.
 
Et coté client :  Recherche de mise a jour RAS, recherche de malwares RAS. Scan SFC RAS, mise a jour pilote graphique RAS.
 
Je ne trouve pas la solution à ce problème, qui s'est pointé du jour au lendemain alors qu'ils bossent comme ça depuis des années.
 
Si vous avez des pistes je suis fortement preneur.
 
Merci à tous.
 
http://reho.st/self/222f6f6436c18eb499cb5db234596129fd70d2ba.png
http://reho.st/self/297c3b112854da148c0a9228ed5c506533e2f9fc.png
http://reho.st/self/76fb67b5733062d19c57720f21830886e07102c9.png


---------------
Achats-Ventes
mood
Publicité
Posté le 21-08-2017 à 11:07:46  profilanswer
 

n°148470
brutax
Posté le 21-08-2017 à 11:20:20  profilanswer
 

Yop,
Côté client, essaye de désactiver le cache des bitmap.
 
Le TSE est en réseau local ?
 
Vérifie aussi les versions du client RDP. Normalement, sous windows 7/8/8.1, tu dois être en 6.3 (clic droit sur l'en-tête de la fenêtre au moment de rentrer le nom de l'ordinateur quand tu lances une connexion bureau à distance, puis "à propos de..." ).
 
Sur ton serveur RDP, dans la configuration d'hôte, tu dois normalement être en 7.1 sur du 2008R2.
 
Au niveau du client, tu peux essayer de modifier les paramètres d'affichage pour réduire le nombre de couleurs. Idem : essaye de jouer sur les paramètres d'expérience.
 
Voilà.
a+

n°148471
ankou2000
Pseudo alacon
Posté le 21-08-2017 à 11:26:27  profilanswer
 

brutax a écrit :

Yop,
Côté client, essaye de désactiver le cache des bitmap.
 
Le TSE est en réseau local ?
 
Vérifie aussi les versions du client RDP. Normalement, sous windows 7/8/8.1, tu dois être en 6.3 (clic droit sur l'en-tête de la fenêtre au moment de rentrer le nom de l'ordinateur quand tu lances une connexion bureau à distance, puis "à propos de..." ).
 
Sur ton serveur RDP, dans la configuration d'hôte, tu dois normalement être en 7.1 sur du 2008R2.
 
Au niveau du client, tu peux essayer de modifier les paramètres d'affichage pour réduire le nombre de couleurs. Idem : essaye de jouer sur les paramètres d'expérience.
 
Voilà.
a+


 
Merci Vincent.
 
Coté version de rdp, j'avais déjà vérifié, je suis bien sur les dernières que se soit sur client et sur serveur.
Le tse est en local pour eux.
Je regarde pour bitmap et expérience utilisateur.  


---------------
Achats-Ventes
n°148472
brutax
Posté le 21-08-2017 à 11:57:06  profilanswer
 

Hmmm.
Ca te le fait quel que soit le TSE ? Ou même simplement en RDP sur un serveur non TSE ?
 
Tu peux aussi essayer de supprimer l'expérience utilisateur du serveur ou de l'activer si elle ne l'est pas.
 
Côté clients, vérifie l'espace de stockage dispo et l'utilisation de la RAM, j'ai déjà eu ce cas.
 
L'ultime test serait de supprimer le rôle RDS du TSE, de voir si ça fonctionne avec une seule session puis et de le remettre.

n°148473
ankou2000
Pseudo alacon
Posté le 21-08-2017 à 12:06:24  profilanswer
 

Je peux virer l’expérience utilisateur j'essaye en début d'aprem.
Coté client les pc sont vides ils ne bossent que en rdp, et la ram aussi ca va il ne font rien sur les pc.
Virer le role rds je peux pas il est en production.
Pour le test sur un autre serveur c'est difficile aussi ya qu'un seul tse


---------------
Achats-Ventes
n°148474
brutax
Posté le 21-08-2017 à 13:33:23  profilanswer
 

Oui mais tu peux ouvrir une session RDP sur un serveur non TSE.
Un contrôleur de domaine en 2008R2 par exemple.

n°148475
ankou2000
Pseudo alacon
Posté le 21-08-2017 à 13:39:47  profilanswer
 

Y'a pas office installé dessus  [:cmshadow]


---------------
Achats-Ventes
n°148476
brutax
Posté le 21-08-2017 à 13:48:03  profilanswer
 

Hé bé installe-le. Y'a pas besoin de reboot et tu as 60j d'essai (ou 30 ?)
Ca va pas te flinguer le serveur, hein :o

n°148477
Av3k
Posté le 21-08-2017 à 14:17:49  profilanswer
 

Si c'est arrivé du jour au lendemain sans intervention particulière commence peut etre à regarder du coté des MAJ Windows/Office... :)

n°148496
ankou2000
Pseudo alacon
Posté le 22-08-2017 à 13:16:22  profilanswer
 

brutax a écrit :

Hé bé installe-le. Y'a pas besoin de reboot et tu as 60j d'essai (ou 30 ?)
Ça va pas te flinguer le serveur, hein :o


Bon c'est fait, et ras sur un autre serveur, cela ne vient donc pas des postes de travail, mais bien du serveur.
Évidemment vla l'infra de merde du client : Il est DC, serveur de fichier, serveur TSE, serveur de sauvegarde, et d'applis metier. Du coup bah c'est pas facile  [:ankou2000:2]


---------------
Achats-Ventes
mood
Publicité
Posté le 22-08-2017 à 13:16:22  profilanswer
 

n°148499
webmail-75​000
Posté le 22-08-2017 à 15:38:17  profilanswer
 

ouille manque plus que l'exchange et on a la totale :/
 
laisse moi deviné c'est une PME?


---------------
pas grand chose pour le moment  Un jour Dieu a demandé à Goo de parler plus fort...Et depuis Google
n°148500
brutax
Posté le 22-08-2017 à 16:07:30  profilanswer
 

Ah ouais le truc bien crade !
Tant qu'on y est, y'a pas un switch 10M au milieu de tout ça ? [:s@ms:2]  
 
Bon, visiblement, le serveur galère à envoyer les images au client. Tu peux essayer d'installer les dernières versions du .Net framework (4.6.2 je crois...).
 
Il y a aussi une fonctionnalité nommée "Expérience audio-vidéo haute qualité Windows". Peut-être qu'en jouant là-dessus...  [:transparency]  
 
Un truc à tenter mais qui est bien hard-core : désinstaller tout ce qui est .Net Framework. Ca supprime également l'interface graphique. Le plus simple pour réinstaller tout ça c'est d'administrer ce serveur via un AUTRE serveur. A tester sur des serveurs hors prod avant quoi...  [:chapi]  
 
Par contre, au niveau de tous les autres rôles de ton serveur, je ne sais pas ce que ça implique. T'as intérêt à faire une sauvegarde avant tout ça.  [:faluja:5]

n°148502
Je@nb
Modérateur
In ze cloud
Posté le 22-08-2017 à 18:51:15  profilanswer
 

non fait pas ça, worst conseil ever !

n°148503
ankou2000
Pseudo alacon
Posté le 22-08-2017 à 18:55:09  profilanswer
 

Je@nb a écrit :

non fait pas ça, worst conseil ever !


Ne pas faire quoi ? Desinstaller NET Framwork ? Je m'apprete a le faire la


---------------
Achats-Ventes
n°148504
Je@nb
Modérateur
In ze cloud
Posté le 22-08-2017 à 19:01:28  profilanswer
 

oui

n°148505
ankou2000
Pseudo alacon
Posté le 22-08-2017 à 19:10:55  profilanswer
 

Tu peux developper ?


---------------
Achats-Ventes
n°148506
Je@nb
Modérateur
In ze cloud
Posté le 22-08-2017 à 19:17:31  profilanswer
 

1/ ça n'a aucun lien
2/ si tu veux planter les applications qui en dépendent va y c'est le meilleur moyen
 
On fait pas ce genre d'opération en prod en mode rien à foutre on verra bien si ça marche Yallah

n°148507
ankou2000
Pseudo alacon
Posté le 22-08-2017 à 19:22:22  profilanswer
 

Bah la je suis hors prod et j'ai un replica VEAM qui a 2 minutes...
Je viens de balancer un coup de setup de net framework... A suivre


---------------
Achats-Ventes
n°148511
brutax
Posté le 23-08-2017 à 08:15:54  profilanswer
 

C'est bien ce que je disais : a tester sur des serveurs hors prod. Un réplica comme le dit Ankou, c'est encore mieux !

 

Ces gens qui lisent en diagonale  [:baragor]

 

Edit : Mais c'est vrai qu'il peut-être intéressant de tenter la réinstallation du rôle RDS avant tout.


Message édité par brutax le 23-08-2017 à 08:36:19
n°148514
ankou2000
Pseudo alacon
Posté le 23-08-2017 à 08:39:55  profilanswer
 

Ca ne change rien


---------------
Achats-Ventes
n°148515
brutax
Posté le 23-08-2017 à 08:42:53  profilanswer
 

ankou2000 a écrit :

Ca ne change rien


La réinstallation du RDS ?
Ou du .NET ?

n°148517
ankou2000
Pseudo alacon
Posté le 23-08-2017 à 09:06:19  profilanswer
 

du .NET le rds j'ai pas l'autorisation du client. Il est en prod de 5h du mat a 19h30 et j'ai aussi une vie


---------------
Achats-Ventes
n°148518
brutax
Posté le 23-08-2017 à 09:09:15  profilanswer
 

Ah ouais OK...
Et c'est pas envisageable de les faire travailler sur un TSE à côté ? Genre pas sur un serveur qui héberge 700K rôles/services ?
 
Ouais mais il vont pas vouloir payer la licence...

n°148519
webmail-75​000
Posté le 23-08-2017 à 09:11:39  profilanswer
 

tu ne sais pas monter le réplica sur une autre machine? ou en vm?


---------------
pas grand chose pour le moment  Un jour Dieu a demandé à Goo de parler plus fort...Et depuis Google
n°148520
Je@nb
Modérateur
In ze cloud
Posté le 23-08-2017 à 09:24:38  profilanswer
 

Arrête de faire toutes tes manips, c'est un bug du patch tuesday d'aout:
https://social.technet.microsoft.co [...] inserverTS
https://www.neunbeere.de/blog/2017/ [...] y-updates/
 
C'est même expliqué sur la page de l'update que tu aurais du lire avant d'appliquer des updates au hasard : KB4034664

n°148526
brutax
Posté le 23-08-2017 à 09:51:03  profilanswer
 

Je@nb a écrit :

Arrête de faire toutes tes manips, c'est un bug du patch tuesday d'aout:
https://social.technet.microsoft.co [...] inserverTS
https://www.neunbeere.de/blog/2017/ [...] y-updates/
 
C'est même expliqué sur la page de l'update que tu aurais du lire avant d'appliquer des updates au hasard : KB4034664


Bien vu !
 
Mais tu en connais beaucoup des entreprises qui ont un admin réseau ayant le temps de tout lire sur chaque update qui sort ?
Ou d'avoir un serveur dans un coin sur le quel il teste toutes les maj dans toutes les conditions possibles de son entreprise ?
 
Franchement la plupart, moi compris, installent tout et se cassent la tête quand ça plante. C'est quand même rare d'avoir une MaJ foireuse.

n°148527
ShonGail
En phase de calmitude ...
Posté le 23-08-2017 à 09:59:41  profilanswer
 

brutax a écrit :


Bien vu !
 
Mais tu en connais beaucoup des entreprises qui ont un admin réseau ayant le temps de tout lire sur chaque update qui sort ?
Ou d'avoir un serveur dans un coin sur le quel il teste toutes les maj dans toutes les conditions possibles de son entreprise ?
 
Franchement la plupart, moi compris, installent tout et se cassent la tête quand ça plante. C'est quand même rare d'avoir une MaJ foireuse.


 
Par contre quand y'a un problème suite à des MAJ, c'est de bon sens le premier axe de recherche.
Et puis sur un tel serveur, il peut être utile de ne pas appliquer les MAJ dès leurs sorties mais après un délai afin que la MAJ foireuse soit retirée ou que le bug soit découvert/expliqué.
Autant ne pas jouer les beta testeurs chez des clients dont l'infra est déjà en dessous de l'admissible.

n°148529
ankou2000
Pseudo alacon
Posté le 23-08-2017 à 10:04:19  profilanswer
 

Les gars je recentre :
 
Je suis en info gérance, je ne gère pas ce serveur de merde ni cette infra qui pue, je me contente d'intervenir avec mon équipe quand ils sont dépassés.
Je n'ai rien configuré du tout, si ces cons ont monté leur infra comme ca et installent les MAJ chaque nuit sans rien tester, je m'en bas limites les couilles, ca nous fait travailler au ticket.
Bref je viens de désinstaller le kb foireux, je reboot entre midi et 2 et vous fais un retour.
Merci pour votre aide :jap:


---------------
Achats-Ventes
n°148534
Je@nb
Modérateur
In ze cloud
Posté le 23-08-2017 à 10:46:28  profilanswer
 

brutax a écrit :


Bien vu !
 
Mais tu en connais beaucoup des entreprises qui ont un admin réseau ayant le temps de tout lire sur chaque update qui sort ?
Ou d'avoir un serveur dans un coin sur le quel il teste toutes les maj dans toutes les conditions possibles de son entreprise ?
 
Franchement la plupart, moi compris, installent tout et se cassent la tête quand ça plante. C'est quand même rare d'avoir une MaJ foireuse.


 
Oui, toutes les entreprises que je cotoie en fait ... Ca s'appelle le processus de patch management.
Si tu fais de la merde c'est ton problème mais dans la vrai vie on fait ça bien.
Et les maj foireuse il y en a tous les mois et de plus en plus malheureusement (la qualité des patchs review est en nette baisse chez MS ces dernières années). Suffit de regarder le nb de known issue sur chaque patchs, le nombre de patchs qui sortent et qui sont retirés dans la foulée chaque mois, le nb de patchs qui corrigent des problèmes sortis dans les patchs précédents et qui des fois ne le corrigent même pas en entier (voir le cas d'outlook depuis mai/juin qui a connu 4 ou 5 tentatives de patchs pour résoudre le pb)

n°148535
Av3k
Posté le 23-08-2017 à 10:57:05  profilanswer
 

Av3k a écrit :

Si c'est arrivé du jour au lendemain sans intervention particulière commence peut etre à regarder du coté des MAJ Windows/Office... :)


 
 
Je dis ca je dis rien....

n°148539
brutax
Posté le 23-08-2017 à 11:28:37  profilanswer
 

Je@nb a écrit :

 

Oui, toutes les entreprises que je cotoie en fait ... Ca s'appelle le processus de patch management.
Si tu fais de la merde c'est ton problème mais dans la vrai vie on fait ça bien.
Et les maj foireuse il y en a tous les mois et de plus en plus malheureusement (la qualité des patchs review est en nette baisse chez MS ces dernières années). Suffit de regarder le nb de known issue sur chaque patchs, le nombre de patchs qui sortent et qui sont retirés dans la foulée chaque mois, le nb de patchs qui corrigent des problèmes sortis dans les patchs précédents et qui des fois ne le corrigent même pas en entier (voir le cas d'outlook depuis mai/juin qui a connu 4 ou 5 tentatives de patchs pour résoudre le pb)


Je suis d'accord sur le principe, mais dans la vraie vie (mais nous n'avons pas tous la même vraie vie), comme tu dis, on ne peut pas tous avoir une personne qui passe du temps à tester les MàJ. si encore, y avait que Windows (Server et client, précisons)...
Oui mais y a aussi Office, SQL server, les applications métiers, Adobe, java et je passe le reste. Heureusement que SharePoint et Excahnge je les ai en Cloud...
Je travaille dans l'éducation, tu n'imagines pas le nombre de logiciels et d'outils qu'on utilise. Rien que pour la compta/paye, on a Ciel, Cegid, EBP et Sage. Pas le choix, c'est comme ça.

 

Je préfère me prendre la tête, quitte à restaurer une sauvegarde de temps en temps plutôt que de passer des heures à tester les MàJ de tout ça dans toutes les configurations possibles.

 

Mon dernier problème suite à une MàJ foireuse remonte à... Pfff.... je ne sais même plus. Début 2016, au pif.

 

J'aimerai bien pouvoir faire comme toi, tu as 100% raison et ce que tu fais est parfaitement pro. Mais les ressources et les moyens, on n'a pas tous les mêmes.

Message cité 1 fois
Message édité par brutax le 23-08-2017 à 11:33:31
n°148570
ankou2000
Pseudo alacon
Posté le 23-08-2017 à 14:14:39  profilanswer
 

Suppression du KB4034664 a résolu le problème  [:obvious]


---------------
Achats-Ventes
n°148583
smarechal3
Posté le 24-08-2017 à 09:34:03  profilanswer
 

brutax a écrit :


Je suis d'accord sur le principe, mais dans la vraie vie (mais nous n'avons pas tous la même vraie vie), comme tu dis, on ne peut pas tous avoir une personne qui passe du temps à tester les MàJ. si encore, y avait que Windows (Server et client, précisons)...
Oui mais y a aussi Office, SQL server, les applications métiers, Adobe, java et je passe le reste. Heureusement que SharePoint et Excahnge je les ai en Cloud...
Je travaille dans l'éducation, tu n'imagines pas le nombre de logiciels et d'outils qu'on utilise. Rien que pour la compta/paye, on a Ciel, Cegid, EBP et Sage. Pas le choix, c'est comme ça.
 
Je préfère me prendre la tête, quitte à restaurer une sauvegarde de temps en temps plutôt que de passer des heures à tester les MàJ de tout ça dans toutes les configurations possibles.
 
Mon dernier problème suite à une MàJ foireuse remonte à... Pfff.... je ne sais même plus. Début 2016, au pif.
 
J'aimerai bien pouvoir faire comme toi, tu as 100% raison et ce que tu fais est parfaitement pro. Mais les ressources et les moyens, on n'a pas tous les mêmes.


+1 C'est pas gérable dans une entreprise ou on est juste au niveau personnel dans le SI.

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  [WIN2008R2] Affichage Office bugé en TSE avec multi screen

 

Sujets relatifs
Office 365 / OneDrive / volume et partageVPS Docker Lamp Wordpress et Multi Site
Clé de registre TSEconnexion LDAP pour copieur multi fonction
Office 365filrtage URL / P2P en multi sites VPN MPLS
Office 365 - MAJ ?Office 2016 volume ou retail
Migration exchange 2007 vers Office 365Désinstallation du pack office en réseau avec un script
Plus de sujets relatifs à : [WIN2008R2] Affichage Office bugé en TSE avec multi screen



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR