Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
801 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Formule avec 2 Condition s sous EXCEL

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Formule avec 2 Condition s sous EXCEL

n°1475757
neoffyz
Le vrai artiste est celui à qu
Posté le 03-03-2004 à 09:08:22  profilanswer
 

Salut tlm :d
j'ai un petit blocage avec une formule excel.
je souhaite concillier 2 conditions (SI) dans une formule mais je n'arrive pas.
 
voici mes 2 formules :
=SI(G:G="MB";33%;25%)
=SI(F:F="SFCR04";19%;25%)
 
je souhaite les rassembler dans la meme cellule.
Mais je ne sais pas comment !
 
merci par avance :d

mood
Publicité
Posté le 03-03-2004 à 09:08:22  profilanswer
 

n°1475795
neoffyz
Le vrai artiste est celui à qu
Posté le 03-03-2004 à 09:38:42  profilanswer
 

UP
ca doit pas etre bien difficile... :d

n°1475804
TheDoors
Posté le 03-03-2004 à 09:43:14  profilanswer
 

=SI(G:G="MB";33%;SI(F:F="SFCR04";19%;25%))

n°1475807
flash_gord​on
Posté le 03-03-2004 à 09:44:23  profilanswer
 

c plus simple avec un AND

n°1475819
neoffyz
Le vrai artiste est celui à qu
Posté le 03-03-2004 à 09:49:50  profilanswer
 

merci thedoors, je test :)

n°1475825
neoffyz
Le vrai artiste est celui à qu
Posté le 03-03-2004 à 09:54:31  profilanswer
 

oui ca marche, merci.
mais dans le cas ou d'autres conditions apparaissent....

n°1475836
TheDoors
Posté le 03-03-2004 à 10:00:08  profilanswer
 

Tu fais pareil
 
La formule si donne ça :
 
=si(condition;résultat si condition remplie; résultat si condition pas remplie)
 
Donc en cas de plusieurs conditions imbriquées, tu remplaces "résultat si condition pas remplie" par une autre formule si.
 
Je ne sais pas si j'ai été assez clair

n°1475864
minikissko​ol
C Frais Mais C Pas Grave
Posté le 03-03-2004 à 10:19:41  profilanswer
 

attention, il me semble qu'il y a un plafond d'imbrication à 6 conditions avec cette méthode...

n°1475891
neoffyz
Le vrai artiste est celui à qu
Posté le 03-03-2004 à 10:37:27  profilanswer
 

ok merci :d
en quoi le AND serait utile dans ce cas comme l'a souligné flashgordon ?

n°1475899
TheDoors
Posté le 03-03-2004 à 10:41:42  profilanswer
 

minikisskool a écrit :

attention, il me semble qu'il y a un plafond d'imbrication à 6 conditions avec cette méthode...


 
Effectivement il y a un plafond.
 
Dans excel 2000 :  
 

Citation :

Il est possible d'imbriquer jusqu'à sept fonctions SI comme arguments valeur_si_vrai et valeur_si_faux


 
Ce qui fait 8 si (avec le premier)

mood
Publicité
Posté le 03-03-2004 à 10:41:42  profilanswer
 

n°1476015
minikissko​ol
C Frais Mais C Pas Grave
Posté le 03-03-2004 à 11:53:40  profilanswer
 

je ne sais pas si c plus simple, ça doit faire un truc du genre
 
SI(ET(G:G<>"MB";F:F<>"SFCR04" );25%;SI(G:G="MB";33%;19%))
 
:/

n°2926159
coulabdeng
Posté le 28-01-2010 à 15:53:51  profilanswer
 

TheDoors a écrit :

=SI(G:G="MB";33%;SI(F:F="SFCR04";19%;25%))


 
Bonjour à tous,
 
j'aurais également une question pour une formule mais avec plusieurs conditions sous excel.
Voilà ce que je souhaiterais faire :
SI J16=1 alors on affiche 7,48
si J16=2 alors on affiche 15,36
si J16=3 alors on affiche 23,24  
si J16=4 alors on affiche 31,12
si J16=4 alors on affiche 39
si J16=6 alors on affiche 46,48
 
Quelqu'un aurait-il une solution à me proposer ?
Merci d'avance.

n°2926164
elecman
Posté le 28-01-2010 à 16:24:32  profilanswer
 

C'est expliquer plus haut, tu imbrique les SI mais bon, a mon avis, tu attend une réponse avec la formule toute faite lol
 
SI(J16=1;7.48;SI(j16=2;15.36;SI(j16=3;23.46; SI(j16=4;31.12; ETC....))))


---------------
Perso FFXI : Buldom Galka MNK75/WAR75/NIN75/SMN75/DRG75/SAM75/DRK75/THF75
n°2926200
benoit6363
Posté le 28-01-2010 à 18:29:32  profilanswer
 

La formule toute faite:
 
=CHOISIR(J16;7,48;15,36;23,24;31,12;39;46,48)

n°2926345
elecman
Posté le 29-01-2010 à 15:20:50  profilanswer
 

Ah c'Est super, je connaisait pas cette fonction cool


---------------
Perso FFXI : Buldom Galka MNK75/WAR75/NIN75/SMN75/DRG75/SAM75/DRK75/THF75
n°3108251
treze 23
Posté le 12-12-2013 à 16:13:17  profilanswer
 

benoit6363 a écrit :

La formule toute faite:
 
=CHOISIR(J16;7,48;15,36;23,24;31,12;39;46,48)


Bonjour,  
 
Moi j'ai essayé les formules proposées mais je n'y arrive pas. Mes 2 formules donnent séparement: NB.SI(A1:A20;"=x" ) et NB.SI(B1:B20;"=y" ). Comment les fusionner?
 
Merci de votre aide.

n°3108277
benoit6363
Posté le 12-12-2013 à 18:22:47  profilanswer
 

Bonjour,
 
En supposant que l'on veille savoir le nombre de fois que l'on a "x" en colonne A et en même temps "y" en colonne B.
"x" et "y" sont sur la même ligne.
 
=SOMMEPROD((A1:A20="x" )*1;(B1:B20="y" )*1)


Message édité par benoit6363 le 12-12-2013 à 18:23:14
n°3108330
pupu1503
Posté le 13-12-2013 à 10:29:06  profilanswer
 

Bonjour tous,
 
J'ai également un prob avec une formule. Et comme ici vous avez l'air d'être des pros...
 
J'aimerais que mon tableau prenne en compte deux choses:
Si dans la case de C7 à C40 il y a "2" et que dans la case K7 à N40 il y a "Eric" comptabiliser "1"
Mais quand je tape cela j'ai rien... Pouvez vous me venir en aide.
 
Merci beaucoup

n°3108334
pupu1503
Posté le 13-12-2013 à 11:07:47  profilanswer
 

Je suis parvenu a faire en colonne simple mais pas sur plusieur.
C'est à dire de C7 à C40 avec K7 à K40 mais pas pour K7 à N40

n°3108335
pupu1503
Posté le 13-12-2013 à 11:10:33  profilanswer
 

=NB.SI.ENS(C7:C41;"2";N7:N41;"Eric" ) La ca marche dans la case de calcul il fais le total du nombre de présence des deux réunis  
=NB.SI.ENS(C7:C41;"2";N7:O41;"Eric" ) La ca marche pas

n°3108336
MaybeEijOr​Not
but someone at least
Posté le 13-12-2013 à 11:22:49  profilanswer
 

Code :
  1. =SI(ET(NB.SI(C7:C41;2);NB.SI(K7:N40;"e" ));1;0)


 
Renvoie 1 si il y a au moins un 2 dans la plage C7 à C40 et si il y a au moins un e dans la plage K7 à N40.
 
 
EDIT : avec NB.SI.ENS tes plages sont associées, elles doivent donc être de même taille.


Message édité par MaybeEijOrNot le 13-12-2013 à 11:31:11
n°3108355
benoit6363
Posté le 13-12-2013 à 14:11:03  profilanswer
 

Bonjour,
 
Pour faire cela, il faut préalablement créer une nouvelle Colonne O,
qui contient la formule suivante
 
=RECHERCHE("Eric";K7:N7)
 
Il faut utiliser la poignée de recopie pour dérouler la formule jusqu'à la ligne 40.
 
Ensuite il suffit d'utiliser la formule que vous avez proposé:
 
=NB.SI.ENS(C7:C40;"2";O7:O40;"Eric" )
 
Cela devrait fonctionner.

n°3150392
clem0612
Posté le 08-12-2014 à 18:01:43  profilanswer
 

Bonjour,
 
Etant un peu novice avec les formules EXCEL, je me tourne vers les Pro pour un petit coup de pouce:
 
Voilà, j'ai 2 conditions pour une même cellule avec des formules, soit :
 
Dans la 1ère condition le résultat doit être entre 1et 8 et dans la 2ème le résultat doit être 0 =SI((SOMME(J41+V41+AH41+AT41+BF41+BR41+CD41)-35)>=8;8;(SOMME(J41+V41+AH41+AT41+BF41+BR41+CD41)-35)<=0;0))))
 
Avec celle-ci, si aucun chiffre dans les cellules le résultat est -35 et j'aimerai plutôt 0 : =SI((SOMME(J42+V42+AH42+AT42+BF42+BR42+CD42)-35)>=8;8;(SOMME(J42+V42+AH42+AT42+BF42+BR42+CD42)-35))
 
Pouvez-vous m'aider ? Merci d'avance.
 
Clem
 

n°3287408
Domino16
Posté le 23-10-2017 à 17:21:33  profilanswer
 

Bonjour ; je ne sais pas si le site est toujours actif (pas de sujet depuis 2014) ou si tout le monde est devenu bon, mais je pose ma question quand même :
En A2, j'ai "DOMINO (F)"
en A3, j'ai "BEBERT"
(pas de "(F)" car une seule personne, le "(F)" indique au moins une seconde personne de la même famille)
en B2 et B3, j'ai un paiement soit par "CHQ" soit en "ESP"
La personne en A2 paie 20,00 et la personne en A3 paie 25,00.
J'aurai aimé que dans la cellule C2, C3, etc, le montant soit mis automatiquement en conséquence de "(F)" ou pas.
De plus (sinon, c'est trop facile lol), si la personne n'a pas payé sa cotisation, que la cellule C correspondante soit vide
J'ai essayé plusieurs solutions, celle acceptée par Excel est :
=SI(B2="CHQ""ESP";"25";SI(A2="!(F)!";"20";" " ))
or, ça me laisse toujours une cellule vide :
BIROT Carole "KYOU"    
BOUCHERIT Albéric "ALBE"    
CAILLEUX Olivier "TITAN"    
DE ALMEIDA Patrick "PDA"    
GOUJON Lydia "LY" (F)    
GUERY Dominique "BOUFTOUT"    
JOUGIER Bertrand "BEBER"    
JOUGIER Mathis "?" (F)  
MERCIER Sébastien  25,00
MUSSEAU Jean-Louis "GREMLINS"  25,00
Désolé, le tableau ne s'est pas dessiné
Merci de votre aide par avance
Dom

n°3287413
djidji5943​0
Posté le 23-10-2017 à 17:55:07  profilanswer
 

Bonjour,
 
Un essai :  
 http://www.cjoint.com/c/GJxp2Cg6jfO
 
Cdlmnt

n°3287463
Domino16
Posté le 24-10-2017 à 09:15:13  profilanswer
 

Bonjour ; wahou, super, merci beaucoup, j'ai galéré là-dessus. En fait, il fallait combiner ET et OU.
Par contre, dans la solution proposée, après "=", il y a "D15", ce doit être une erreur, je l'ai supprimé et ça va bien.
Merci encore
 :bounce:  :love:

n°3289175
ovrefoss
Posté le 09-11-2017 à 12:59:49  profilanswer
 

TheDoors a écrit :

=SI(G:G="MB";33%;SI(F:F="SFCR04";19%;25%))


 
Merci pour ton aide.........
 
Ca va bien, depuis le temps ?  :lol:  


---------------
Le terrorisme gauchiste et le terrorisme étatique sont les deux mâchoires d’un même piège à cons »© JP. Manchette - Super site français en rade, dommage !
n°3289194
ovrefoss
Posté le 09-11-2017 à 14:12:23  profilanswer
 


 
En fait il s'agissait pour moi de supprimer les doublons dans une liste alpha sous deux conditions, la première condition de nom peut être remplie mais pas la deuxième qui est un n° de code, ce qui doit me permettre de les conserver et ne pas éliminer la deuxième différente :
 
Ma formule donc (à conserver)
 

Citation :


 
=SI(A1=A2;SI(B1=B2;"DOUBLON";" " );" " )
 


 
Si DOUBLON est affiché, plus qu'à effacer la ligne
 
 
 :hello:  
 


---------------
Le terrorisme gauchiste et le terrorisme étatique sont les deux mâchoires d’un même piège à cons »© JP. Manchette - Super site français en rade, dommage !
n°3290956
Domino16
Posté le 20-11-2017 à 11:46:27  profilanswer
 

Bonjour ;  
j'aurais une autre demande à faire !
Voilà, j'ai en B3 une chaîne de caractère contenant soit "hôtel" soit "camping" soit "restaurant",
en C3 et E3 des paiements en chq ou esp,
en P3, la fameuse formule qui me mettrait la somme C3+E3
J'ai essayé plusieurs possibilités avec des imbrication de SI, OU, ET, SI.NB, mais galère.
Exemples :
P3=SI(OU(B3="restaurant";B3="hôtel";B3="camping" )C3+E3;" " ) .... pas bon car le mot recherché doit être seul dans B3
P3=SI(OU(B3="*restaurant*";B3="*hôtel*";B3="*camping*" )C3+E3;" " ) .... pas mieux malgré l'astérisque qui oblige à chercher un mot dans une chaîne de caractères
P3=SI(SI.NB(OU(B3="*restaurant*" );(B3="*hôtel*" );(B3="*camping*" ))C3+E3;" " ) .... toujours pas
P3=SI((OU(B3;"*restaurant*" );(B3;"*hôtel*" );(B3;"*camping*" ))C3+E3;" " ) .... encore non, avec ou sans astérisque
Merci de votre aide

n°3290957
Domino16
Posté le 20-11-2017 à 11:49:16  profilanswer
 

Bonjour ;  
j'aurais une autre demande à faire !
Voilà, j'ai en B3 une chaîne de caractère contenant soit "hôtel" soit "camping" soit "restaurant",
en C3 et E3 des paiements en chq ou esp,
en P3, la fameuse formule qui me mettrait la somme C3+E3
J'ai essayé plusieurs possibilités avec des imbrication de SI, OU, ET, SI.NB, mais galère.
Exemples :
P3=SI(OU(B3="restaurant";B3="hôtel";B3="camping" )C3+E3;" " ) .... pas bon car le mot recherché doit être seul dans B3
P3=SI(OU(B3="*restaurant*";B3="*hôtel*";B3="*camping*" )C3+E3;" " ) .... pas mieux malgré l'astérisque qui oblige à chercher un mot dans une chaîne de caractères
P3=SI(SI.NB(OU(B3="*restaurant*" );(B3="*hôtel*" );(B3="*camping*" ))C3+E3;" " ) .... toujours pas
P3=SI((OU(B3;"*restaurant*" );(B3;"*hôtel*" );(B3;"*camping*" ))C3+E3;" " ) .... encore non, avec ou sans astérisque
Merci de votre aide

n°3291004
djidji5943​0
Posté le 20-11-2017 à 18:26:49  profilanswer
 

Re
 
essaye
 
=SI(SOMME(SIERREUR(CHERCHE("restaurant";B3)>1;0)+SIERREUR(CHERCHE("hotel";B3)>1;0)+SIERREUR(CHERCHE("camping";B3)>1;0))=1;C3+E3;"" )
 
pour une seul des trois propositions en B
 
Cdlmnt

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Formule avec 2 Condition s sous EXCEL

 

Sujets relatifs
[RÉSOLU] Excel 2000 refuse de se lancer du jour au lendemain[Excel] Comment synchroniser 2 fichiers ?
urgent : requete simple sur excel: virer les doubons : thx for helpComment afficher toujours la ligne de titres sous Excel ?
[EXCEL] "Erreur: risque de perte de donnees" avec fichiers japonais...Voir qui a utilisé un fichier excel ?
word, excel, ... ne repondent pas[Powerpoint XP] condition d'affichage
[excel] graphique "conditionnel"[excel] somme et produit
Plus de sujets relatifs à : Formule avec 2 Condition s sous EXCEL



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR