Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1921 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Probleme version de Wamp : SQL, PHP, et surtout de moi

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme version de Wamp : SQL, PHP, et surtout de moi

n°2291050
fscalda
Gaaaaaazzzz
Posté le 03-11-2016 à 10:23:20  profilanswer
 

Bonjour,
j'ai un soucis avec Wamp, et moi surtout, puisque j'ai dev sous Php5.5...  :pt1cable:  
 
Je développais un truc en php en local (adaptation d'un script et rajout de fonctionnalité à ma sauce) que je renvoyais sur mon serveur chez Ovh dès que c'était bon, et depuis que j'ai changé de machine, j'ai mis la nouvelle version de Wamp. Et c'est la que tout est parti en sucette.  :whistle:  
 
En local, les modifications sur le script de base ne fonctionne plus, seul ce que j'ai rajouté par la suite fonctionne encore.
 
Pour vous donner une idée, si je veux supprimer une ligne d'une table sous Phpmyadmin, j'ai ce message d'erreur :
 
Incorrect date value: '0000-00-00' for column 'signup_date'
 
Je vais avoir besoin d'un coup de main pour raffraichir tout ça. Je cherche dans la docs, mais  :pfff:  
 
 
 

mood
Publicité
Posté le 03-11-2016 à 10:23:20  profilanswer
 

n°2291052
fscalda
Gaaaaaazzzz
Posté le 03-11-2016 à 10:26:24  profilanswer
 

A force, je viens de trouver qu'il faut désactiver stric trans table
Bonne idée ou pas ? Faut encore que je trouve ou, car j'ai rien qui correspond dans mon wamp 64 serveur.
 
Edit : Tout les chemins possibles.
 
/etc/my.cnf, /etc/mysql/my.cnf, SYSCONFDIR/my.cnf, $MYSQL_HOME/my.cnf, and ~/my.cnf. ~/.my.cnf
 
Mais j'en ai aucun....


Message édité par fscalda le 03-11-2016 à 10:30:39
n°2291055
fscalda
Gaaaaaazzzz
Posté le 03-11-2016 à 10:40:26  profilanswer
 

J'ai donc depuis l'icone Wamp été dans Mysql > Myini, j'ai ouvert le bloc note et commenté la ligne :
;sql-mode="STRICT_ALL_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_ZERO_DATE,NO_ZERO_IN_DATE,NO_AUTO_CREATE_USER"
redemarrer les services, ça n'a pas marché.
J'ai carrement supprimer la ligne, et idem..

n°2291057
fscalda
Gaaaaaazzzz
Posté le 03-11-2016 à 11:15:55  profilanswer
 

Bon, ça me prend tellement la tête de tout modifier. Que je vais voir comment régler Wamp avec les mêmes versions que sur le serveur. Ou installer une ancienne.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Probleme version de Wamp : SQL, PHP, et surtout de moi

 

Sujets relatifs
HTTP POST problèmeFormulaire PHP réponse mail accent
Problème encodageproblème invalid syntaxe
Recrutement développeur PHPPHP MSSQL Query qui fonctionne pas toujours
Problème de schéma de BDD[PHP/PostGres] fetch_object ne fonctionne pas
Sql server un champ avec 3 choixProblème avec boucle foreach powershell
Plus de sujets relatifs à : Probleme version de Wamp : SQL, PHP, et surtout de moi



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR