Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2339 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Problème PHP (pour GLPI) après MAJ firmware Qnap

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème PHP (pour GLPI) après MAJ firmware Qnap

n°2292840
jocodis
Posté le 27-11-2016 à 20:28:18  profilanswer
 

Bonjour,
 
 
 
j'ai mis à mon firmware sur mon TS219PII (vers 4.2.2).
 
Depuis je rencontre un gros problème :
 
 
 
une erreur 500 apparaît après un login correct sur GLPI (je reçois bien un rejet lorsque je rentre un login faux).
 
J'ai désinstallé/réinstallé GLPI, restauré la configuration php.ini, désactivé/réactivé le serveur web du NAS mais rien y fait.
 
Je n'y connais pas grand chose en programmation pour apache.
 
 
 
Quelqu'un aurait-il une piste?
 
 
 
Merci!


Message édité par jocodis le 27-11-2016 à 20:34:11
mood
Publicité
Posté le 27-11-2016 à 20:28:18  profilanswer
 

n°2292858
rufo
Pas me confondre avec Lycos!
Posté le 28-11-2016 à 10:46:06  profilanswer
 

Ben commence déjà par faire afficher tous les msgs d'erreur de PHP pour qu'on sache précisément ce qui ne va pas. C'est quelle version de GLPI ?
 
Il est en effet fort probable que ça vienne d'un pb du modèle objet de PHP qui a pas mal évolué en 5.6 puis 7.0 et que du coup, le code source de GLPI est incompatible avec ces versions.
 
PS : ça n'a donc rien à voir avec la programmation "apache".


---------------
Astres, outil de help-desk GPL : http://sourceforge.net/projects/astres, ICARE, gestion de conf : http://sourceforge.net/projects/icare, Outil Cantine Calandreta : http://sourceforge.net/projects/canteen-calandreta
n°2292879
jocodis
Posté le 28-11-2016 à 13:10:26  profilanswer
 

Concernant la version de GLPI : 0.85.3 (pas de version plus récente disponbile sur l'App Center, peut être peut-on forcer une installation plus récente autrement?)
 
Pour les messages d'erreur de php, je ne sais pas où les trouver.
Y a-t-il un log quelque part? Ou faut il activer un log dans un fichier de configuration?
J'ai parcouru quelques arborescences avec WinSCP mais je ne trouve rien.
 
Si ça peut aider, les pages en php affichent "erreur 500" sur chrome, et une page blanche sous IE.
 
Merci
 
PS : il n'y que les pages php de GLPI qui posent problème actuellement (essai avec un autre site hébergé réussi)


Message édité par jocodis le 28-11-2016 à 13:12:01
n°2292880
rufo
Pas me confondre avec Lycos!
Posté le 28-11-2016 à 13:24:05  profilanswer
 

http://php.net/manual/fr/function.error-reporting.php
 
Activation à faire dans le fichier de conf de GLPI.


---------------
Astres, outil de help-desk GPL : http://sourceforge.net/projects/astres, ICARE, gestion de conf : http://sourceforge.net/projects/icare, Outil Cantine Calandreta : http://sourceforge.net/projects/canteen-calandreta
n°2292908
jocodis
Posté le 28-11-2016 à 22:04:04  profilanswer
 

Bonsoir,
 
mille merci pour tes conseils.
Je n'ai pas réussi à trouver quelque chose dans le log :(.
MAIS, j'ai réussi à forcer l'installation de la dernière version de GLPI, récupéré la BDD et ça fonctionne nickel!

n°2292912
rufo
Pas me confondre avec Lycos!
Posté le 29-11-2016 à 09:49:02  profilanswer
 

Y'a pas de log en PHP. Les erreurs s'affichent direct sur les pages web. Après, rien n'empêche de les rediriger dans un fichier de log. Après, y'a les logs Apache.


---------------
Astres, outil de help-desk GPL : http://sourceforge.net/projects/astres, ICARE, gestion de conf : http://sourceforge.net/projects/icare, Outil Cantine Calandreta : http://sourceforge.net/projects/canteen-calandreta

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Problème PHP (pour GLPI) après MAJ firmware Qnap

 

Sujets relatifs
Urgent / PHP / StagePetit Problème
Problème Menu Jquery SuperFishProblème lors de l'installation de PHPmyAdmin sur Raspberry
Problème jointureProbleme version de Wamp : SQL, PHP, et surtout de moi
HTTP POST problèmeFormulaire PHP réponse mail accent
Problème encodage 
Plus de sujets relatifs à : Problème PHP (pour GLPI) après MAJ firmware Qnap



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR