Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
926 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Multimédia

  [DEBIAN] Impossible de lire de gros fichiers avec MPlayer

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[DEBIAN] Impossible de lire de gros fichiers avec MPlayer

n°932651
moute
Posté le 10-07-2007 à 12:43:58  profilanswer
 

Bonjour,
 
    Je viens d'installer MPlayer sur ma debian etch. J'utilise Mplayer uniquement en ligne de commande.  
    J'arrive à lire les vidéos de moins de 700 Mo quel que soit leur format d'encodage, par contre je ne peux pas lire les vidéos HD de 4Go. En fait, tout semble se passer bien sauf que mplayer s'arrête avant d'avoir commencer la lecture :
 

Citation :

debian:/disque2/matrixhd# mplayer -vo svga cf-matrixhd.avi  
MPlayer 1.0rc1-4.1.2-DFSG-free (C) 2000-2006 MPlayer Team  
CPU: Intel(R) Pentium(R) D  CPU 2.66GHz (Family: 15, Model: 4, Stepping: 7)  
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1  
Compiled with runtime CPU detection.  
mplayer: could not connect to socket  
mplayer: No such file or directory  
Failed to open LIRC support. You will not be able to use your remote control.  
 
Playing cf-matrixhd.avi.  
AVI file format detected.  
AVI: ODML: Building ODML index (2 superindexchunks).  
VIDEO:  [XVID]  1280x720  12bpp  25.000 fps  4095.4 kbps (499.9 kbyte/s)  
Clip info:  
 Software: VirtualDubMod 1.5.10.2 Fr | www.trad-fr.com ||  (build 2540/release)  
[svgalib: allocated virtual console #7]  
debian:/disque2/matrixhd#  


 
Est-ce que quelqu'un aurais une idée pour résoudre mon problème ?
 
Moute
 

mood
Publicité
Posté le 10-07-2007 à 12:43:58  profilanswer
 

n°932654
wedgeant
Da penguin inside
Posté le 10-07-2007 à 12:51:55  profilanswer
 

Question bête: pourquoi utiliser -vo svga ? :gratgrat:
 
Sinon, spa bien de lire des vidéos ripées si on a pas les originaux :o


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°932836
moute
Posté le 10-07-2007 à 21:32:32  profilanswer
 

Parce que tu utilises comment mplayer ?
J'avais essayer sans options, mais ca ne fonctionnait pas. Avec -vo svga ca fonctionne. Par contre, je n'ai pas essayé les autres.
 
J'ai bien  évidemment l'original, mais pas en HD. Je voulais voir la différence ...
 
Moute

n°932837
Xavier_OM
Talking seagull lawyer, bitch
Posté le 10-07-2007 à 21:40:40  profilanswer
 

par défaut mplayer <=> "mplayer -vo xv", ce qui marche très bien (à moins que tu n'ai une config spécial genre framebuffer ou X over ssh :o)


---------------
Lorsque la liberté aura déserté le monde, il restera toujours un homme pour en rêver. (Le dernier civil, Ernst Glaeser)
n°932907
wedgeant
Da penguin inside
Posté le 11-07-2007 à 08:05:59  profilanswer
 

mplayer -vo xv
mplayer -vo xover
mplayer -vo x11
mplayer -vo gl
mplayer -vo gl2
 
:spamafote:
 
T'en as forcément 1 qui marche dans l'tas ...
Et laisses tomber -vo svga, caÿtoupouritte :o


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°933217
moute
Posté le 11-07-2007 à 20:17:46  profilanswer
 

J'ai fait l'essai avec xv, x11, gl, gl2 et à chaque fois il me dit qu'il ne peut pas trouver l'affichage x11. Xover ne marche pas non plus.
 
En fait, je n'ai pas de serveur X. Je ne souhaite pas l'installer car je n'en ai pas vraiment l'utilité. Donc c'est sans doute pour cela que xv, x11, gl, gl2 et xover ne marche pas, non ?
 
Moute

n°933349
wedgeant
Da penguin inside
Posté le 12-07-2007 à 10:07:26  profilanswer
 

moute a écrit :

J'ai fait l'essai avec xv, x11, gl, gl2 et à chaque fois il me dit qu'il ne peut pas trouver l'affichage x11. Xover ne marche pas non plus.

 

En fait, je n'ai pas de serveur X. Je ne souhaite pas l'installer car je n'en ai pas vraiment l'utilité. Donc c'est sans doute pour cela que xv, x11, gl, gl2 et xover ne marche pas, non ?

 

Moute

 

[:sovxx]

 

[:thierry3] [:tuffgong]
[:fatidik972]

 

[:cupra]

Message cité 1 fois
Message édité par wedgeant le 12-07-2007 à 14:14:24

---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°933360
zecrazytux
Posté le 12-07-2007 à 10:20:57  profilanswer
 

:D


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°933377
wedgeant
Da penguin inside
Posté le 12-07-2007 à 10:41:59  profilanswer
 

Dans ce cas:
mplayer -vo caca film.avi
 
Non, je me fous pas de ta gueule, caca correspond à la libcaca, tout à fait sérieuse :o


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°933382
Riot
Buy me a riot
Posté le 12-07-2007 à 10:57:03  profilanswer
 

En gros, tu fais un  
mplayer -vo help
pour voir les sorties vidéo dispo, et tu les testes toutes jusqu'à ce que ça marche [:o_doc]


---------------
Be the one with the flames.
mood
Publicité
Posté le 12-07-2007 à 10:57:03  profilanswer
 

n°933385
Tomate
Posté le 12-07-2007 à 11:00:20  profilanswer
 

apt-get install libaa1 [:dawa]


Message édité par Tomate le 12-07-2007 à 11:00:42

---------------
:: Light is Right ::
n°933398
nErIkI
oenologue
Posté le 12-07-2007 à 11:22:49  profilanswer
 

Sans serveur X, et si le frame buffer est activé, il y a aussi moyen de passer par lui ( mplayer -vo fbdev )
 

wedgeant a écrit :

 
 
 
 
 :o
 


 
Depuis quand X est obligatoire :mouais:
Un reste de Windows peut être, vous êtes tout perdu sans votre mulot.  :whistle:


---------------
C'est pas bon, Neriki, tu recommences à glander, là. :o
n°933403
wedgeant
Da penguin inside
Posté le 12-07-2007 à 11:27:09  profilanswer
 

nErIkI a écrit :

Sans serveur X, et si le frame buffer est activé, il y a aussi moyen de passer par lui ( mplayer -vo fbdev )
 
Depuis quand X est obligatoire :mouais:
Un reste de Windows peut être, vous êtes tout perdu sans votre mulot.  :whistle:


 
Euh, j'ai pas dit que c'était obligatoire, mais c'est mieux quand même quoi :spamafote:
mplayer gère beaucoup mieux quand un serveur X est activé :o


---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°933437
skateinmar​s
Posté le 12-07-2007 à 13:20:26  profilanswer
 

Avec -vo fbdev et le framebuffer ca devrait passer

n°933565
gee
Bon ben hon
Posté le 12-07-2007 à 19:25:22  profilanswer
 

cvidix si tu peux c'est le top.


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°933601
moute
Posté le 12-07-2007 à 21:44:02  profilanswer
 

Alors tout d'abord merci pour l'effervescence de vos réponses.
 
WedgeAnt : c'est kler qu'en mode caca ca marche (j'ai fait le test), mais lire un film hd en ASCII sur une TV LCD 90 cm c'est un peu moyen ...
 
J'ai tout essayé, seul l'option svga fonctionne pour l'instant, mais je préfèrerais effectivement utiliser fbdev.
 
Avec cvidix ca semble marché mais en fait je n'ai qu'un tout petit morceau de l'image en transparence dans la console au milieu de mes lignes de commande.
 
Avec fbdev, il me sort l'erreur :

Citation :


MPlayer 1.0rc1-4.1.2-DFSG-free (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) D  CPU 2.66GHz (Family: 15, Model: 4, Stepping: 7)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
 
Playing myfilm.avi.
AVI file format detected.
VIDEO:  [XVID]  640x272  24bpp  25.000 fps  710.8 kbps (86.8 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.2 Fr | www.trad-fr.com ||  (build 2540/release)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 640 x 272 (preferred colorspace: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.40:1 - prescaling to correct movie aspect.
SwScaler: using unscaled yuv420p -> bgr24 special converter
VO: [fbdev] 640x272 => 652x272 BGR 24-bit
Can't put VSCREENINFO: Invalid argument
FATAL: Cannot initialize video driver.
 
FATAL: Could not initialize video filters (-vf) or video output (-vo).
 
 
Exiting... (End of file)


 
Quelqu'un aurait-il une piste que je puisse faire fonctionner fbdev ?
 
Moute
 

n°933614
skateinmar​s
Posté le 12-07-2007 à 22:24:51  profilanswer
 

Il te faut activer le framebuffer, regarde dans les options de grub dans ton menu.lst

n°933617
Riot
Buy me a riot
Posté le 12-07-2007 à 22:35:34  profilanswer
 

Tu mets un vga=791 dans ton grub et basta :o


---------------
Be the one with the flames.
n°933650
skateinmar​s
Posté le 12-07-2007 à 23:30:56  profilanswer
 

C'est ce que j'ai dit quoi :o

n°933651
Riot
Buy me a riot
Posté le 12-07-2007 à 23:32:39  profilanswer
 

Oui, mais je l'aidais un poil plus. Je le sens un peu perdu le garçon :D


---------------
Be the one with the flames.
n°933668
gee
Bon ben hon
Posté le 13-07-2007 à 00:25:48  profilanswer
 

moute a écrit :

Alors tout d'abord merci pour l'effervescence de vos réponses.
 
WedgeAnt : c'est kler qu'en mode caca ca marche (j'ai fait le test), mais lire un film hd en ASCII sur une TV LCD 90 cm c'est un peu moyen ...
 
J'ai tout essayé, seul l'option svga fonctionne pour l'instant, mais je préfèrerais effectivement utiliser fbdev.
 
Avec cvidix ca semble marché mais en fait je n'ai qu'un tout petit morceau de l'image en transparence dans la console au milieu de mes lignes de commande.
 
Avec fbdev, il me sort l'erreur :


Quand le cvidix est bon, tente le fullscreen avec la touche 'f'.
Ca et la résolution donnée par les 2 lascars devraient pouvoir t'aider.


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°933669
skateinmar​s
Posté le 13-07-2007 à 00:31:44  profilanswer
 

C'est comme ca qu'on progresse, la tête dans un man à rien comprendre :whistle:

n°933949
moute
Posté le 13-07-2007 à 23:02:19  profilanswer
 

Juste une question, je n'ai pas grub, mais lilo. J'ai mis vga=791 dans mon lilo.conf et relancer lilo puis redémarrer mais ca ne fonctionne toujour pas. Suis-je obligé d'installer grub ?
 
Moute

n°933950
Riot
Buy me a riot
Posté le 13-07-2007 à 23:05:45  profilanswer
 

Non non.


---------------
Be the one with the flames.
n°933961
skateinmar​s
Posté le 14-07-2007 à 01:14:51  profilanswer
 

Mais la conf est certainement pas pareille avec lilo

n°934264
moute
Posté le 15-07-2007 à 16:50:28  profilanswer
 

Oui, effectivement j'avais une ligne vga=normal que j'ai changer en vga=791. Par contre ca ne fonctionne toujours pas. Il me sort toujours la même erreur.

Citation :


Can't put VSCREENINFO: Invalid argument
FATAL: Cannot initialize video driver.
 
FATAL: Could not initialize video filters (-vf) or video output (-vo).  


Moute


Message édité par moute le 15-07-2007 à 16:50:48
n°934354
gui42
Posté le 15-07-2007 à 20:46:31  profilanswer
 

Bonsoir
il me semble bien que dans les options de compilation de mplayer y'a un truc à propos des gros fichiers.
Donc je serais bien tenté de dire que d'origine il ne sait pas lire un fichier si gros.
Télécharges des sources et fait un ./configure --help ça devrait te mettre sur la piste.

n°934366
Nonor_
Ubuntu c'est supaire
Posté le 15-07-2007 à 21:20:32  profilanswer
 

Il peut aussi essayer vga=0x318 (ou autres codes, voir /usr/src/linux-XX/Documentation/fb/vesafb.txt ou autres)

n°934611
moute
Posté le 16-07-2007 à 15:57:41  profilanswer
 

gui42 : Ca veut dire que je ne pourrais pas utiliser le package debian ? Y a-t-il un moyen d'utiliser ses options de compilation en utilisant apt-get ?
 
Nonor_ : Je vais essayer vga=0x318 pour voir.
 
Merci de votre aide ?
 
Moute

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Multimédia

  [DEBIAN] Impossible de lire de gros fichiers avec MPlayer

 

Sujets relatifs
Debian Etch, X et NvidiaDebian Etch + pure-ftpd et lien symbolique
raid 5 logiciel sous debianmsn: impossible de s'authentifier: .NET Messenger Service sous Debian
installation de windows xp impossible[Résolu] Installation de Java SDK sur Debian PPC
Debian : Raid 0 a l'install...gros problème avec kate et du nfs
Comment creer une sauvegarde quotidienne d'un dossier? (debian) 
Plus de sujets relatifs à : [DEBIAN] Impossible de lire de gros fichiers avec MPlayer



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR