Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2082 connectés 

 

 

Proxmox c'est ?




Attention si vous cliquez sur "voir les résultats" vous ne pourrez plus voter

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  49  50  51  52  53  54
Page Suivante
Auteur Sujet :

[TOPIKUNIK] Proxmox, une solution de virtualisation kellébien !

n°1401704
Deadlock
Feck off, cup !
Posté le 15-03-2017 à 09:16:02  profilanswer
 

Reprise du message précédent :
Hello :hello:

 

Question CEPH;

 

J'ai pendant un temps eu un cluster Proxmox basé sur deux nœuds physiques et une VM sur un NAS (pour le quorum). Le storage étant basé sur NFS sur deux NAS (en croisant disk images et backups). J'ai remplacé un des mes NAS par un HP Gen8 avec OMV3 puis, alors que je bataillais pour faire tourner VBox sous OMV, pour déplacer mon nœud virtuel. F'ai finalement fini par installer Proxmox sur le Gen8 et virtualiser OMV dessus.

 

Du coup j'ai maintenant 3 nœuds physiques auxquels j'ai attaché un disque de 500Go, j'ai installé/configuré CEPH, ajouté les 3 disques comme OSDs et maintenant je me pose la question de la confguration du pool. Je ne cherche pas la performance, c'est juste du @home mais comme les VMs ont toutes une utilité, je veux pouvoir avoir un "HA" fonctionnel et donc perdre un nœud (voire deux) sans perte.

 

J'ai largement de quoi héberger toutes mes VMs sur 500Go, j'hésite entre du 3/2, 3/1 et du 2/1. Je sais que le 3/2 n'est pas compatible avec le "voire deux" de la phrase précédente mais quelle configuration retiendriez-vous ?

 

Merci :jap:


Message édité par Deadlock le 15-03-2017 à 09:18:44

---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
mood
Publicité
Posté le 15-03-2017 à 09:16:02  profilanswer
 

n°1401834
Titprem
Posté le 19-03-2017 à 14:31:25  profilanswer
 

:hello:
 
Note : il s'agit de mon installation personnelle, il n'y a aucun enjeu ! :o
 
J'ai mis à jour le Grub de mon Proxmox (4.1), et j'ai perdu le boot de ma machine.
 
Ne connaissant pas bien Grub, j'ai opté pour une solution de facilité, en l'occurrence, Boot repair disk. Ce dernier m'a créé une sorte de nouveau boot, intitulé "proxmox", qui apparait dans le BIOS de mon serveur (alors qu'avant je bootais sur mon SSD Crucial). Mais ce dernier lance un OS qui s'appelle "system setup"... et qui reboot le PC ! :( Si j'édite la commande, j'ai simplement :  

setparams 'System setup'
          fwsetup


 
Bref, je suis parti pour tout réinstaller, mais j'aurais souhaité récupérer mes VM ! :)
 
En bootant sur une distribution Linux en liveUSB, j'arrive à récupérer les LVM Proxmox (pve-root et pve-data), et à les monter. J'ai donc accès à tous les fichiers. :)  
 
J'ai trouvé les VMs, qui sont stockées sur le LVM "pve-data", dans le répertoire : /images/<id>/vm-<id>-disk-1.raw
 
Par contre, il me semblait qu'il y avait des fichiers de configuration pour chaque VM, dans /etc/pve/, mais je ne retrouve rien...
 
Y a-t-il moyen de récupérer mes VM avec juste le fichier image raw, dans le "pve-data" ? :??:
 
:jap:

Message cité 1 fois
Message édité par Titprem le 19-03-2017 à 16:05:54
n°1401835
Deadlock
Feck off, cup !
Posté le 19-03-2017 à 15:53:50  profilanswer
 

Salut,

 

J'ai un gros problème d'I/O sur une VM.
J'utilise un HP µserver G8 (i3/8Go) comme host Proxmox 4 (pvetest à jour) sur lequel j'ai créé un R5 de 4x2To.
Si je fais des tests de copie depuis le SSD de boot vers le R5 directement sur le host, j'arrive en écriture à environ 250Mo/s. Si je fais des tests depuis le réseau (cifs/nfs/scp/rsync) je sature la connexion Gigabit avec ~110Mo/s stables.

 

J'ai créé une VM avec deux disques (Virtio/qcow2) sur le R5 qui est monté en storage local sur /var/lib/vz. Le premier de 16Go pour l'OS (Openmediavault 3.0.65) et un autre de 4.5To pour les datas.
J'ai activé le Qemu Agent dans les options de la VM, installé qemu-guest-agent sur le guest et quand je fais des copies sur cette VM, quelque soit le protocol, ça commence quelques secondes à 80Mo/s puis le débit chute secondes après seconde jusqu'à stopper (stalled) puis reprendre dans les 5-15Mo/s erratiquement jusqu'à la fin du transfert. Les test sont faits avec un fichier de 2Go.

 

Je ne vois pas d'où peut venir ce problème ... J'ai testé plusieurs configs et là même avec 6Go et 4 vCPU ça change rien ...

 

Une idée ? :jap:

 

PS: Le réseau est aussi de type Virtio.


Message édité par Deadlock le 19-03-2017 à 15:56:10

---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
n°1401961
Titprem
Posté le 23-03-2017 à 09:33:42  profilanswer
 

Titprem a écrit :

:hello:
 
Note : il s'agit de mon installation personnelle, il n'y a aucun enjeu ! :o
 
J'ai mis à jour le Grub de mon Proxmox (4.1), et j'ai perdu le boot de ma machine.
 
Ne connaissant pas bien Grub, j'ai opté pour une solution de facilité, en l'occurrence, Boot repair disk. Ce dernier m'a créé une sorte de nouveau boot, intitulé "proxmox", qui apparait dans le BIOS de mon serveur (alors qu'avant je bootais sur mon SSD Crucial). Mais ce dernier lance un OS qui s'appelle "system setup"... et qui reboot le PC ! :( Si j'édite la commande, j'ai simplement :  

setparams 'System setup'
          fwsetup


 
Bref, je suis parti pour tout réinstaller, mais j'aurais souhaité récupérer mes VM ! :)
 
En bootant sur une distribution Linux en liveUSB, j'arrive à récupérer les LVM Proxmox (pve-root et pve-data), et à les monter. J'ai donc accès à tous les fichiers. :)  
 
J'ai trouvé les VMs, qui sont stockées sur le LVM "pve-data", dans le répertoire : /images/<id>/vm-<id>-disk-1.raw
 
Par contre, il me semblait qu'il y avait des fichiers de configuration pour chaque VM, dans /etc/pve/, mais je ne retrouve rien...
 
Y a-t-il moyen de récupérer mes VM avec juste le fichier image raw, dans le "pve-data" ? :??:
 
:jap:


Je me réponds à moi-même : oui, c'est possible !
 
Après réinstallation de Proxmox, il suffit de créer une VM "vide", puis de remplacer le fichier raw dans /var/lib/vz/images/vm-<id>-....raw par l'ancien fichier.
 
Par contre, entre Proxmox 4.1 et 4.2 et supérieur, ils ont changé le LVM en thin LVM (avec provisionning), et c'est donc pas aussi simple. (J'ai laissé tomber. :o)


Message édité par Titprem le 23-03-2017 à 09:35:32
n°1402223
matteu
Posté le 02-04-2017 à 10:34:38  profilanswer
 

Question très bête, je voudrais changer le disque système de mon proxmox qui est en 80Go par un 500Go.
Est ce que la meilleure solution consiste à cloner mon disque 80 -> 500 ?
Si oui, avez vous un utilitaire à me conseiller ?

 

Je suppose qu'il me faudra éteindre la machine, mais ce n'est pas un soucis. Si je prends un utilitaire de clonage sous windows et que je branche mes 2 disques dans une machine windows est ce que ca fonctionnera ?

 

Autre question, je suis en train de m'apercevoir que je fais les backup de mes vm sur mon disque système. Bref, pas la bonne solution. J'ai un raid 5 à coté mais les disque sont monté directement dans ma VM OMV. Si mon proxmox est client NFS d'un share fourni par OMV, est ce que ca fonctionnerait ? parce que je me dis que si l'hote reboot, il va tenter de monter le partage NFS, mais il ne pourra pas car la vm ne sera pas démarrée... Existe t'il une solution dans mon cas ?

 

Merci par avance !


Message édité par matteu le 02-04-2017 à 10:42:47

---------------
Mon Feedback---Mes ventes
n°1402224
l0g4n
Proxmox&Beer
Posté le 02-04-2017 à 10:42:22  profilanswer
 

Tu tiens vraiment à changer le disque, rajouter le 500 et y déplacer les vms ne convient pas ?


---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
n°1402227
matteu
Posté le 02-04-2017 à 10:51:57  profilanswer
 

oui ^^
le 80 est vieux je ne lui fais pas confiance puis plus la place sans investir pour ajouter un disque ^^. donc je voudrai le remplacer le 500 est neuf.


---------------
Mon Feedback---Mes ventes
n°1402228
l0g4n
Proxmox&Beer
Posté le 02-04-2017 à 10:56:09  profilanswer
 

Boot sur un clonezilla en usb :jap:


---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
n°1402229
matteu
Posté le 02-04-2017 à 11:01:16  profilanswer
 

ok je boot sur le clonezilla, je mets l'image sur le raid 5 et je restaure sur le 500Go c'est ca?  
Ou on peut brancher le 500 sur l'ODD le temps de la manip ?
 
Et ensuite je sais pas si tu as vu ma seconde question concernant les sauvegardes ?


---------------
Mon Feedback---Mes ventes
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  49  50  51  52  53  54
Page Suivante

Aller à :
Ajouter une réponse
 

Sujets relatifs
Choix Hyperviseur pour Xeon [Box de test]Routage vm Proxmox
Questionnement sur un hyperviseur[Topikunik] Personnalisation des interfaces graphiques
Plus de sujets relatifs à : [TOPIKUNIK] Proxmox, une solution de virtualisation kellébien !



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR