Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1523 connectés 

 

 

Proxmox c'est ?




Attention si vous cliquez sur "voir les résultats" vous ne pourrez plus voter

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  51  52  53  54  55  56
Auteur Sujet :

[TOPIKUNIK] Proxmox, une solution de virtualisation kellébien !

n°1401704
Deadlock
Feck off, cup !
Posté le 15-03-2017 à 09:16:02  profilanswer
 

Reprise du message précédent :
Hello :hello:

 

Question CEPH;

 

J'ai pendant un temps eu un cluster Proxmox basé sur deux nœuds physiques et une VM sur un NAS (pour le quorum). Le storage étant basé sur NFS sur deux NAS (en croisant disk images et backups). J'ai remplacé un des mes NAS par un HP Gen8 avec OMV3 puis, alors que je bataillais pour faire tourner VBox sous OMV, pour déplacer mon nœud virtuel. F'ai finalement fini par installer Proxmox sur le Gen8 et virtualiser OMV dessus.

 

Du coup j'ai maintenant 3 nœuds physiques auxquels j'ai attaché un disque de 500Go, j'ai installé/configuré CEPH, ajouté les 3 disques comme OSDs et maintenant je me pose la question de la confguration du pool. Je ne cherche pas la performance, c'est juste du @home mais comme les VMs ont toutes une utilité, je veux pouvoir avoir un "HA" fonctionnel et donc perdre un nœud (voire deux) sans perte.

 

J'ai largement de quoi héberger toutes mes VMs sur 500Go, j'hésite entre du 3/2, 3/1 et du 2/1. Je sais que le 3/2 n'est pas compatible avec le "voire deux" de la phrase précédente mais quelle configuration retiendriez-vous ?

 

Merci :jap:


Message édité par Deadlock le 15-03-2017 à 09:18:44

---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
mood
Publicité
Posté le 15-03-2017 à 09:16:02  profilanswer
 

n°1401834
Titprem
Posté le 19-03-2017 à 14:31:25  profilanswer
 

:hello:
 
Note : il s'agit de mon installation personnelle, il n'y a aucun enjeu ! :o
 
J'ai mis à jour le Grub de mon Proxmox (4.1), et j'ai perdu le boot de ma machine.
 
Ne connaissant pas bien Grub, j'ai opté pour une solution de facilité, en l'occurrence, Boot repair disk. Ce dernier m'a créé une sorte de nouveau boot, intitulé "proxmox", qui apparait dans le BIOS de mon serveur (alors qu'avant je bootais sur mon SSD Crucial). Mais ce dernier lance un OS qui s'appelle "system setup"... et qui reboot le PC ! :( Si j'édite la commande, j'ai simplement :  

setparams 'System setup'
          fwsetup


 
Bref, je suis parti pour tout réinstaller, mais j'aurais souhaité récupérer mes VM ! :)
 
En bootant sur une distribution Linux en liveUSB, j'arrive à récupérer les LVM Proxmox (pve-root et pve-data), et à les monter. J'ai donc accès à tous les fichiers. :)  
 
J'ai trouvé les VMs, qui sont stockées sur le LVM "pve-data", dans le répertoire : /images/<id>/vm-<id>-disk-1.raw
 
Par contre, il me semblait qu'il y avait des fichiers de configuration pour chaque VM, dans /etc/pve/, mais je ne retrouve rien...
 
Y a-t-il moyen de récupérer mes VM avec juste le fichier image raw, dans le "pve-data" ? :??:
 
:jap:

Message cité 1 fois
Message édité par Titprem le 19-03-2017 à 16:05:54
n°1401835
Deadlock
Feck off, cup !
Posté le 19-03-2017 à 15:53:50  profilanswer
 

Salut,

 

J'ai un gros problème d'I/O sur une VM.
J'utilise un HP µserver G8 (i3/8Go) comme host Proxmox 4 (pvetest à jour) sur lequel j'ai créé un R5 de 4x2To.
Si je fais des tests de copie depuis le SSD de boot vers le R5 directement sur le host, j'arrive en écriture à environ 250Mo/s. Si je fais des tests depuis le réseau (cifs/nfs/scp/rsync) je sature la connexion Gigabit avec ~110Mo/s stables.

 

J'ai créé une VM avec deux disques (Virtio/qcow2) sur le R5 qui est monté en storage local sur /var/lib/vz. Le premier de 16Go pour l'OS (Openmediavault 3.0.65) et un autre de 4.5To pour les datas.
J'ai activé le Qemu Agent dans les options de la VM, installé qemu-guest-agent sur le guest et quand je fais des copies sur cette VM, quelque soit le protocol, ça commence quelques secondes à 80Mo/s puis le débit chute secondes après seconde jusqu'à stopper (stalled) puis reprendre dans les 5-15Mo/s erratiquement jusqu'à la fin du transfert. Les test sont faits avec un fichier de 2Go.

 

Je ne vois pas d'où peut venir ce problème ... J'ai testé plusieurs configs et là même avec 6Go et 4 vCPU ça change rien ...

 

Une idée ? :jap:

 

PS: Le réseau est aussi de type Virtio.


Message édité par Deadlock le 19-03-2017 à 15:56:10

---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
n°1401961
Titprem
Posté le 23-03-2017 à 09:33:42  profilanswer
 

Titprem a écrit :

:hello:
 
Note : il s'agit de mon installation personnelle, il n'y a aucun enjeu ! :o
 
J'ai mis à jour le Grub de mon Proxmox (4.1), et j'ai perdu le boot de ma machine.
 
Ne connaissant pas bien Grub, j'ai opté pour une solution de facilité, en l'occurrence, Boot repair disk. Ce dernier m'a créé une sorte de nouveau boot, intitulé "proxmox", qui apparait dans le BIOS de mon serveur (alors qu'avant je bootais sur mon SSD Crucial). Mais ce dernier lance un OS qui s'appelle "system setup"... et qui reboot le PC ! :( Si j'édite la commande, j'ai simplement :  

setparams 'System setup'
          fwsetup


 
Bref, je suis parti pour tout réinstaller, mais j'aurais souhaité récupérer mes VM ! :)
 
En bootant sur une distribution Linux en liveUSB, j'arrive à récupérer les LVM Proxmox (pve-root et pve-data), et à les monter. J'ai donc accès à tous les fichiers. :)  
 
J'ai trouvé les VMs, qui sont stockées sur le LVM "pve-data", dans le répertoire : /images/<id>/vm-<id>-disk-1.raw
 
Par contre, il me semblait qu'il y avait des fichiers de configuration pour chaque VM, dans /etc/pve/, mais je ne retrouve rien...
 
Y a-t-il moyen de récupérer mes VM avec juste le fichier image raw, dans le "pve-data" ? :??:
 
:jap:


Je me réponds à moi-même : oui, c'est possible !
 
Après réinstallation de Proxmox, il suffit de créer une VM "vide", puis de remplacer le fichier raw dans /var/lib/vz/images/vm-<id>-....raw par l'ancien fichier.
 
Par contre, entre Proxmox 4.1 et 4.2 et supérieur, ils ont changé le LVM en thin LVM (avec provisionning), et c'est donc pas aussi simple. (J'ai laissé tomber. :o)


Message édité par Titprem le 23-03-2017 à 09:35:32
n°1402223
matteu
Posté le 02-04-2017 à 10:34:38  profilanswer
 

Question très bête, je voudrais changer le disque système de mon proxmox qui est en 80Go par un 500Go.
Est ce que la meilleure solution consiste à cloner mon disque 80 -> 500 ?
Si oui, avez vous un utilitaire à me conseiller ?

 

Je suppose qu'il me faudra éteindre la machine, mais ce n'est pas un soucis. Si je prends un utilitaire de clonage sous windows et que je branche mes 2 disques dans une machine windows est ce que ca fonctionnera ?

 

Autre question, je suis en train de m'apercevoir que je fais les backup de mes vm sur mon disque système. Bref, pas la bonne solution. J'ai un raid 5 à coté mais les disque sont monté directement dans ma VM OMV. Si mon proxmox est client NFS d'un share fourni par OMV, est ce que ca fonctionnerait ? parce que je me dis que si l'hote reboot, il va tenter de monter le partage NFS, mais il ne pourra pas car la vm ne sera pas démarrée... Existe t'il une solution dans mon cas ?

 

Merci par avance !


Message édité par matteu le 02-04-2017 à 10:42:47

---------------
Mon Feedback---Mes ventes
n°1402224
l0g4n
Proxmox&Beer
Posté le 02-04-2017 à 10:42:22  profilanswer
 

Tu tiens vraiment à changer le disque, rajouter le 500 et y déplacer les vms ne convient pas ?


---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
n°1402227
matteu
Posté le 02-04-2017 à 10:51:57  profilanswer
 

oui ^^
le 80 est vieux je ne lui fais pas confiance puis plus la place sans investir pour ajouter un disque ^^. donc je voudrai le remplacer le 500 est neuf.


---------------
Mon Feedback---Mes ventes
n°1402228
l0g4n
Proxmox&Beer
Posté le 02-04-2017 à 10:56:09  profilanswer
 

Boot sur un clonezilla en usb :jap:


---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
n°1402229
matteu
Posté le 02-04-2017 à 11:01:16  profilanswer
 

ok je boot sur le clonezilla, je mets l'image sur le raid 5 et je restaure sur le 500Go c'est ca?  
Ou on peut brancher le 500 sur l'ODD le temps de la manip ?
 
Et ensuite je sais pas si tu as vu ma seconde question concernant les sauvegardes ?


---------------
Mon Feedback---Mes ventes
n°1405065
eliohan
Posté le 20-06-2017 à 14:53:29  profilanswer
 

Bonjour,
 
J'entends pas mal parler de proxmox ces temps-ci et comme j'avais envie de tester, je me suis monté un petit lab dans 1 des ESX de ma boite.
 
J'ai donc :
- 1 VM proxmox installé
- Dans ce proxmox, une VM centos 7
 
Toutes les options ont été laissé par défaut à l'install des 2.
Et je ne comprends pas un truc :
Ma VM centos est en bridge, via vmbr0, et elle obtient une IP de mon DHCP. Ce qui veut dire que le bridge fonctionne à priori. Mais elle ne peut pinger que elle-même et l'hôte proxmox, aucune machine du LAN, ni 8.8.8.8
Proxmox lui même peut pinger lui, la VM et tout le LAN de l'agence, et 8.8.8.8, aucun problème.
 
Pour mes tests, j'ai besoin que cette VM centos 7 soit accessible sur le réseau de l'agence... et j'y arrive pas.
 
J'ai oublié quoi ?


---------------
---------------
mood
Publicité
Posté le 20-06-2017 à 14:53:29  profilanswer
 

n°1405626
jean-blagu​in
Posté le 05-07-2017 à 13:50:32  profilanswer
 

Avec la sortie de Proxmox 5  
[:ill nino]


---------------
Vieux motard que jamais :)
n°1405627
tybobab
Posté le 05-07-2017 à 13:57:31  profilanswer
 
n°1405628
lestat67se​l
:-)
Posté le 05-07-2017 à 13:58:59  profilanswer
 

J'allais poser la question, j'ai rien vu asser en faisant un update.
On peut upgrade en debian 9 aussi ? :p
 
Edit: Ah bah oui :)


Message édité par lestat67sel le 05-07-2017 à 13:59:39
n°1405634
XaTriX
Now we are all sons of bitches
Posté le 05-07-2017 à 14:53:50  profilanswer
 

On attends vos retours :o
Et screens :love:
 
XaT


---------------
eargasm § • Topics JV Rage Nostalgie • Discu Expatriés Toulouse Ryanair
n°1405639
Koshi_n
Posté le 05-07-2017 à 16:12:43  profilanswer
 

Maj à l'instant, premier truc le NoVNC qui propose du fullscreen et une interface dépliable sur la gauche.
Le PVE Manager n'a pas changer (pas besoin en même temps).
La maj ma pris 5min environ  
 
(les maj de Debian 8 -> 9 on été les moins douloureuses je trouve).
 
 
EDIT : Pour supprimer le message d'averstissement de Proxmox lors de la connection sur l'inteface PVE l'élément à supprimer ce trouve ligne 815 ici /usr/share/pve-manager/js/pvemanagerlib.js  


Message édité par Koshi_n le 05-07-2017 à 16:25:45
n°1405640
Deadlock
Feck off, cup !
Posté le 05-07-2017 à 17:53:58  profilanswer
 

Je dois attendre un peu pour ceph 12.2 moi. Mais bon, y'a aucune urgence.


---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
n°1405645
bocal83
Posté le 05-07-2017 à 19:50:46  profilanswer
 

J'patiente un peu moi aussi :o


---------------
Steam : John_Matrix PSN : John_Matrix GT : JohnM4trix
n°1405740
jean-blagu​in
Posté le 07-07-2017 à 13:43:00  profilanswer
 

Ayé.
J'ai loué un nouveau serveur sur Kimsufi pour me mettre enfin à Proxmox.
Installé par dessus une Debian Stretch. Bah c'est vrai kellebien :lol:
Quelques soucis encore avec VNC et le mappage du clavier : c'est à dire que pour les lettre je suis bien en azerty mais alors les caractères spéciaux, c'est même pas du Qwerty [:dams86]
 
Mais sinon c'est vraiment génial !


---------------
Vieux motard que jamais :)
n°1405742
Plam
:o
Posté le 07-07-2017 à 13:52:41  profilanswer
 

raw key > keysyms
 
Je sais pas si les mecs de ProXmoX vont faire le switch un jour mais depuis que fait dans XO ça m'a changé la vie d'avoir des consoles qui merdent pas avec le layout :love:


---------------
Xen-orchestra.com // NodeJS c'est le bien :o // Ossifié, comme fusionné dans son cockpit
n°1405763
gizmo15
Posté le 08-07-2017 à 17:23:39  profilanswer
 

upgrade faite de mon coté aussi de 4 à 5.
 
sympa de pouvoir avoir le novnc en fullscreen et le scroll quand la console est plus grande que ton écran c'est cool aussi.

n°1405796
matteu
Posté le 09-07-2017 à 22:26:03  profilanswer
 

Bon, bé je suis super heureux...
J'ai fais l'upgrade 4.4 vers 5 en éteignant les vms et tout niquel tout à l'air de s'être bien passé.
Sauf que j'ai plus accés à la webinterface...
Et je me souviens plus comment j'avais configuré mon proxmox, mais je pense que j'avais mes vms qui tournaient en local -> et paf je pense qu'il a tout dégagé.
Donc je suis bon pour remonter mes sauvegardes et restaurer le backup je pense.
Je suis pas content du tout quand tu vois upgrade tu t'attends pas à ce que ce soit le merdier pareil

 

PS : je vois que j'ai bien mes Vms dans /dev/pve en ssh donc à priori mes données sont toujours la !
Maintenant, faut que je comprenne comment récupérer l'interface web dans un premier temps...
Et ensuite, comment faire en sorte que mes vms soient vues dans l'interface web.
Encore des heures de recherches très probablement dans mon cas :(
Puisqu'à priori c'est pas qm pour démarrer les vm^^


Message édité par matteu le 09-07-2017 à 22:35:21

---------------
Mon Feedback---Mes ventes
n°1405805
snipereyes
Posté le 10-07-2017 à 07:57:54  profilanswer
 

L'interface web proxmox est complètement indépendante du coeur de proxmox. Elle sert juste de gui et n'est pas importante. Si tu fais un qm start vmxx et que ça marche c'est que l'upgrade s'est bien passée.


---------------
-- Topic de vente -- FeedBack --
n°1405806
matteu
Posté le 10-07-2017 à 09:43:16  profilanswer
 

qm commande non reconnu.
-_-
la ca sent mauvais.


---------------
Mon Feedback---Mes ventes
n°1405807
l0g4n
Proxmox&Beer
Posté le 10-07-2017 à 09:45:58  profilanswer
 

De toutes façons, tes qcow2/raw sont pas perdus, et t'a les correspondances noms de vm/id/mac dans les fichiers de conf :jap:


---------------
Le mieux n'est pas de savoir, c'est que les autres pensent que tu saches, après tu peux enfin apprendre !
n°1405809
matteu
Posté le 10-07-2017 à 09:57:56  profilanswer
 

je veux bien, mais actuellement tout est éteint et ca me va pas... J'ai accés à rien la :) et vu que j'ai une vm qui me sert de nas....
bref concrétement, qu'est ce qu'il faut que je fasse la ^^
Dans quel ordre commencer !
A force de toucher le sources.list j'ai des problème maintenant...

 

root@proxmox:~# apt-get update
Hit:1 http://download.proxmox.com/debian/pve stretch InRelease
Ign:2 http://ftp.debian.org/debian stretch InRelease
Get:3 http://download.proxmox.com/debian stretch InRelease [3,058 B]
Hit:4 http://ftp.debian.org/debian stretch Release
Hit:5 http://security.debian.org stretch/updates InRelease
Ign:6 https://enterprise.proxmox.com/debian stretch InRelease
Get:7 http://download.proxmox.com/debian stretch/pve-no-subscription amd64 Packages [75.3 kB]
Ign:8 https://enterprise.proxmox.com/debian stretch Release
Ign:10 https://enterprise.proxmox.com/debian stretch/pve-enterprise all Packages
Ign:11 https://enterprise.proxmox.com/debian stretch/pve-enterprise amd64 Packages
Ign:12 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en_US
Ign:13 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en
Ign:10 https://enterprise.proxmox.com/debian stretch/pve-enterprise all Packages
Ign:11 https://enterprise.proxmox.com/debian stretch/pve-enterprise amd64 Packages
Ign:12 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en_US
Ign:13 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en
Ign:10 https://enterprise.proxmox.com/debian stretch/pve-enterprise all Packages
Ign:11 https://enterprise.proxmox.com/debian stretch/pve-enterprise amd64 Packages
Ign:12 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en_US
Ign:13 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en
Ign:10 https://enterprise.proxmox.com/debian stretch/pve-enterprise all Packages
Ign:11 https://enterprise.proxmox.com/debian stretch/pve-enterprise amd64 Packages
Ign:12 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en_US
Ign:13 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en
Ign:10 https://enterprise.proxmox.com/debian stretch/pve-enterprise all Packages
Ign:11 https://enterprise.proxmox.com/debian stretch/pve-enterprise amd64 Packages
Ign:12 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en_US
Ign:13 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en
Ign:10 https://enterprise.proxmox.com/debian stretch/pve-enterprise all Packages
Err:11 https://enterprise.proxmox.com/debian stretch/pve-enterprise amd64 Packages
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Ign:12 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en_US
Ign:13 https://enterprise.proxmox.com/debian stretch/pve-enterprise Translation-en
Fetched 78.4 kB in 5s (15.0 kB/s)
Reading package lists... Done
W: The repository 'https://enterprise.proxmox.com/debian stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://enterprise.proxmox.com/debi [...] 4/Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
E: Some index files failed to download. They have been ignored, or old ones used instead.


Message édité par matteu le 10-07-2017 à 09:59:45

---------------
Mon Feedback---Mes ventes
n°1405811
decamerone
Posté le 10-07-2017 à 10:22:24  profilanswer
 

On dirait que ton update a échoué car tu n'as pas commenté le repo entreprise. Mets un # devant, apt update puis apt dist-upgrade, ça devrait déjà t'avancer un peu.

n°1405812
snipereyes
Posté le 10-07-2017 à 10:57:12  profilanswer
 

exact, as tu une raison d'avoir le repo entreprise ?


---------------
-- Topic de vente -- FeedBack --
n°1405814
matteu
Posté le 10-07-2017 à 11:15:47  profilanswer
 

je comprends pas ou il est justement...
voici mon sources.list
je n'ai pas de contrat chez proxmox.

 

Je pense qu'il faut revoir les bases dans ma config en effet car il doit bien y avoir un soucis à ce niveau la déjà.

 

deb http://ftp.debian.org/debian stretch main contrib

 

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

 

# security updates
deb http://security.debian.org stretch/updates main contrib

 

j'ai essayé quelque manip trouvées ici mais pas de changement : https://forum.proxmox.com/threads/4 [...] ues.35495/


Message édité par matteu le 10-07-2017 à 11:25:35

---------------
Mon Feedback---Mes ventes
n°1405815
snipereyes
Posté le 10-07-2017 à 11:25:18  profilanswer
 

il est dans /etc/apt/source.list.d/source.list


---------------
-- Topic de vente -- FeedBack --
n°1405816
matteu
Posté le 10-07-2017 à 11:39:09  profilanswer
 

je n'ai que ca dans ce répertoire
root@proxmox:~# ls -al /etc/apt/sources.list.d/
total 20
drwxr-xr-x 2 root root 4096 Jul 10 11:43 .
drwxr-xr-x 6 root root 4096 Jul 10 11:15 ..
-rw-r--r-- 1 root root   66 Jul 10 11:40 pve-enterprise.list
-rw-r--r-- 1 root root   65 Jul 10 09:07 pve-enterprise.list.bak
-rw-r--r-- 1 root root   67 Jul 10 09:28 pve-no-sub.list

 

alors j'ai commenté la ligne du repo dans pve-entreprise.list et depuis j'ai ça :
root@proxmox:~# apt-get update
Hit:1 http://download.proxmox.com/debian/pve stretch InRelease
Hit:2 http://security.debian.org stretch/updates InRelease
Hit:3 http://download.proxmox.com/debian stretch InRelease
Ign:4 http://ftp.debian.org/debian stretch InRelease
Hit:5 http://ftp.debian.org/debian stretch Release
Reading package lists... Done

 

ca fait pas beaucoup de ligne par rapport à ce que j'avais avant.

 

et le contenu de mon pve-no-sub.list
deb http://download.proxmox.com/debian stretch pve-no-subscription

 

et toujours pas d'interface web :) (même si je suppose qu'entre les repositories et l'interface web il n'y a aucun lien)

 

root@proxmox:~# qm start 100
-bash: qm: command not found

 

root@proxmox:~# pveversion
-bash: pveversion: command not found

 

J'ai l'impression que je suis pas en dernière version en fait :
root@proxmox:~# dpkg -l | grep pve
ii  corosync                             2.4.2-pve3                     amd64        clu                                                                                                                       ster engine daemon and utilities
ii  corosync-pve                         2.4.2-pve3                     all          Tra                                                                                                                       nsitional package.
ii  dmeventd                             2:1.02.137-pve2                amd64        Lin                                                                                                                       ux Kernel Device Mapper event daemon
ii  dmsetup                              2:1.02.137-pve2                amd64        Lin                                                                                                                       ux Kernel Device Mapper userspace library
ii  grub-common                          2.02-pve6                      amd64        GRa                                                                                                                       nd Unified Bootloader (common files)
ii  grub-efi-amd64-bin                   2.02-pve6                      amd64        GRa                                                                                                                       nd Unified Bootloader, version 2 (EFI-AMD64 binaries)
ii  grub-efi-ia32-bin                    2.02-pve6                      amd64        GRa                                                                                                                       nd Unified Bootloader, version 2 (EFI-IA32 binaries)
ii  grub-pc                              2.02-pve6                      amd64        GRa                                                                                                                       nd Unified Bootloader, version 2 (PC/BIOS version)
ii  grub-pc-bin                          2.02-pve6                      amd64        GRa                                                                                                                       nd Unified Bootloader, version 2 (PC/BIOS binaries)
ii  grub2-common                         2.02-pve6                      amd64        GRa                                                                                                                       nd Unified Bootloader (common files for version 2)
ii  libcfg6:amd64                        2.4.2-pve3                     amd64        clu                                                                                                                       ster engine CFG library
ii  libcmap4:amd64                       2.4.2-pve3                     amd64        clu                                                                                                                       ster engine CMAP library
ii  libcorosync-common4:amd64            2.4.2-pve3                     amd64        clu                                                                                                                       ster engine common library
ii  libcorosync4-pve                     2.4.2-pve3                     all          Tra                                                                                                                       nsitional package.
ii  libcpg4:amd64                        2.4.2-pve3                     amd64        clu                                                                                                                       ster engine CPG library
ii  libdevmapper-event1.02.1:amd64       2:1.02.137-pve2                amd64        Lin                                                                                                                       ux Kernel Device Mapper event support library
ii  libdevmapper1.02.1:amd64             2:1.02.137-pve2                amd64        Lin                                                                                                                       ux Kernel Device Mapper userspace library
ii  liblvm2app2.2:amd64                  2.02.168-pve2                  amd64        LVM                                                                                                                       2 application library
ii  liblvm2cmd2.02:amd64                 2.02.168-pve2                  amd64        LVM                                                                                                                       2 command library
ii  libnvpair1linux                      0.6.5.9-pve16~bpo90            amd64        Sol                                                                                                                       aris name-value library for Linux
ii  libpve-common-perl                   5.0-16                         all          Pro                                                                                                                       xmox VE base library
ii  libpve-storage-perl                  5.0-12                         all          Pro                                                                                                                       xmox VE storage management library
ii  libquorum5:amd64                     2.4.2-pve3                     amd64        clu                                                                                                                       ster engine Quorum library
ii  libtotem-pg5:amd64                   2.4.2-pve3                     amd64        clu                                                                                                                       ster engine Totem library
ii  libuutil1linux                       0.6.5.9-pve16~bpo90            amd64        Sol                                                                                                                       aris userland utility library for Linux
ii  libvotequorum8:amd64                 2.4.2-pve3                     amd64        clu                                                                                                                       ster engine Votequorum library
ii  libzfs2linux                         0.6.5.9-pve16~bpo90            amd64        Ope                                                                                                                       nZFS filesystem library for Linux
ii  libzpool2linux                       0.6.5.9-pve16~bpo90            amd64        Ope                                                                                                                       nZFS pool library for Linux
ii  lvm2                                 2.02.168-pve2                  amd64        Lin                                                                                                                       ux Logical Volume Manager
ii  lxc-pve                              2.0.8-3                        amd64        Lin                                                                                                                       ux containers usersapce tools
ii  lxcfs                                2.0.7-pve2                     amd64        LXC                                                                                                                        userspace filesystem
ii  novnc-pve                            0.6-4                          amd64        HTM                                                                                                                       L5 VNC client
rc  pve-cluster                          4.0-48                         amd64        Clu                                                                                                                       ster Infrastructure for Proxmox Virtual Environment
ii  pve-docs                             5.0-8                          all          Pro                                                                                                                       xmox VE Documentation
rc  pve-firewall                         2.0-33                         amd64        Pro                                                                                                                       xmox VE Firewall
ii  pve-firmware                         2.0-2                          all          Bin                                                                                                                       ary firmware code for the pve-kernel
rc  pve-ha-manager                       1.0-38                         amd64        Pro                                                                                                                       xmox VE HA Manager
ii  pve-kernel-4.4.35-1-pve              4.4.35-77                      amd64        The                                                                                                                        Proxmox PVE Kernel Image
ii  pve-libspice-server1                 0.12.8-3                       amd64        SPI                                                                                                                       CE remote display system server library
rc  pve-manager                          4.4-1                          amd64        The                                                                                                                        Proxmox Virtual Environment
ii  pve-qemu-kvm                         2.9.0-2                        amd64        Ful                                                                                                                       l virtualization on x86 hardware
ii  spl                                  0.6.5.9-pve9~bpo90             amd64        Sol                                                                                                                       aris Porting Layer user-space utilities for Linux
ii  zfs-initramfs                        0.6.5.9-pve16~bpo90            all          Ope                                                                                                                       nZFS root filesystem capabilities for Linux - initramfs
ii  zfs-zed                              0.6.5.9-pve16~bpo90            amd64        Ope                                                                                                                       nZFS Event Daemon
ii  zfsutils                             0.6.5.9-pve15~bpo80            all          tra                                                                                                                       nsitional package
ii  zfsutils-linux                       0.6.5.9-pve16~bpo90            amd64        com                                                                                                                       mand-line tools to manage OpenZFS filesystems

 


ouais en fait c'est même sur, à force de faire des manipulations peut être je vois que je suis en 4.4

 

Linux proxmox 4.4.35-1-pve #1 SMP Thu Dec 22 14:58:39 CET 2016 x86_64

 

Et je peux pas installer la 5 lorsque je retente la migration il me dis pas de mise à jour disponible.

 

root@proxmox:~# pvesm
Can't locate PVE/Cluster.pm in @INC (you may need to install the PVE::Cluster module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/share/perl5/PVE/CLI/pvesm.pm line 11.
BEGIN failed--compilation aborted at /usr/share/perl5/PVE/CLI/pvesm.pm line 11.
Compilation failed in require at /usr/sbin/pvesm line 6.
BEGIN failed--compilation aborted at /usr/sbin/pvesm line 6.

 



Message édité par matteu le 10-07-2017 à 12:32:12

---------------
Mon Feedback---Mes ventes
n°1405817
Deadlock
Feck off, cup !
Posté le 10-07-2017 à 12:32:14  profilanswer
 

Restore ton OS et retente la migration alors. Essaie aussi d'utiliser pastebin pour alléger ce genre de post.


---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
n°1405818
matteu
Posté le 10-07-2017 à 12:37:57  profilanswer
 

Merci pour ta réponse.

 

L'OS est trop en vrac pour tenter de le réparer c'est ça ?

 

j'ai pas de backup de mon hote je sais même pas comment on backup un linux en fait ^^ (oui je sais, c'est pas bien...)
Par contre, j'ai des backup de mes vms normalement (non testés) qui sont sur mon raid gérer via une vm donc je n'ai pas accés à ce stockage actuellement...
Je voudrais juste que ca évite de finir comme d'hab l'histoire c'est à dire reconstruction de tout mais si je pouvais éviter de perdre 2 jours ca m'aurait bien arrangé ^^

 

Et je suis en train de capter que je ne suis pas certain de pouvoir restaurer mes vms en fait...
Puisque une des vm me sert de nas. Donc en gros, faut que je crée une vm identique pour remonter le raid sur lequel j'ai mes data et faire la restauration ! super !!!!

 

Pour faire simple :
j'ai sur mon hote proxmox + client nfs
1 vm qui fait nas avec 3 disque mappés dans la vm en raid 5
1 vm qui fait nextcloud via les disque de la vm nas

 

Donc si j'installe un nouveau proxmox j'ai pas accés a la vm nas mais je peux en crée une nouvelle sur laquelle je monte le raid et je peux faire un serveur nfs pour que le proxmox aie accés au stockage et puisse me restaurer mes vms ! ca devrait fonctionner ca non ?

 

OU alors j'installe mdadm sur l hote pour gérer le raid et je peux restaurer sur l'hote directement (ça doit fonctionner ça non? ) puis je fait regérer le raid via la vm


Message édité par matteu le 10-07-2017 à 13:11:08

---------------
Mon Feedback---Mes ventes
n°1405820
snipereyes
Posté le 10-07-2017 à 13:30:16  profilanswer
 

Pour moi tu as merdé sur l'upgrade, le kernel doit etre en 4.10 logiquement sur la 5.
 
as tu bien fait un dist-upgrade ?
 
Les upgrades ne se font que par ce biais.
 
Tente un apt update
Puis un apt dist-upgrade


Message édité par snipereyes le 10-07-2017 à 13:31:31

---------------
-- Topic de vente -- FeedBack --
n°1405822
matteu
Posté le 10-07-2017 à 14:08:58  profilanswer
 

La premiere fois j'ai bien fait ca oui.
Car j'ai pris le lien officiel et fait un copier coller des étapes (sauf celle ceph)
https://pve.proxmox.com/wiki/Upgrade_from_4.x_to_5.0

 

Par contre, après cou j'ai fais quelque manipulation dont certaines m'ont proposer d'installer un kernel 4.4.
Je peux installer le kernel 4.10 quand je fais apt-cache search pve je vois bien le kernel
root@proxmox:~# apt-cache search pve-kernel
pve-firmware - Binary firmware code for the pve-kernel
pve-kernel-4.10.11-1-pve - The Proxmox PVE Kernel Image
pve-kernel-4.10.15-1-pve - The Proxmox PVE Kernel Image
pve-kernel-4.10.8-1-pve - The Proxmox PVE Kernel Image
pve-kernel-4.10.5-1-pve - The Proxmox PVE Kernel Image
pve-kernel-4.10.1-2-pve - The Proxmox PVE Kernel Image
pve-kernel-4.4.35-1-pve - The Proxmox PVE Kernel Image

 

Je peux donc installer le dernier non ?

 

Si je fais un apt-get install pve-kernel-4.10.15-1-pve

 

ce que j'aime pas sous linux (oui je suis plutot windows ^^) c'est que sur le net tu trouves toujours des infos différentes. Et au niveau officiel proxmox c'es tun peu le néant concernant les soucis de migration. Mais bon, c'est surement pour prendre le support ^^.

 

Bref, en tous cas, merci à ceux qui tentent de m'aider, j'apprécie ça parce que je me sens moins seul et je me dis que peut être le problème peut se régler sans devoir tout refaire !.

 

Le serveur est un g7 donc pas d'ilo ce qui veut dire que si des manip sont à réaliser au démarrage de la machine, je pourrai regarder ca que ce soir en rebranchant un écran sur le serveur.


Message édité par matteu le 10-07-2017 à 14:12:04

---------------
Mon Feedback---Mes ventes
n°1405823
snipereyes
Posté le 10-07-2017 à 14:30:27  profilanswer
 

le support Proxmox tu peux l'avoir sur le forum ils répondent rapidement et efficacement. Mais si tu veux un meilleur support, payer est un bon moyen.
 
J'ai passé une certification Proxmox il y a preque un an, le formateur lui même ne nous encourageait pas à prendre la maintenance pour juste 2 ou 3 serveur proxmox. Par contre quand on tape dans le ceph ou les grosses infra c'est un plus quand même.
 
Pour en revenir à ton sujet, oui tente une install du pve-kernel et du pve-manager également.


---------------
-- Topic de vente -- FeedBack --
n°1405824
Deadlock
Feck off, cup !
Posté le 10-07-2017 à 14:45:25  profilanswer
 

snipereyes a écrit :

le support Proxmox tu peux l'avoir sur le forum ils répondent rapidement et efficacement. Mais si tu veux un meilleur support, payer est un bon moyen.

 

J'ai passé une certification Proxmox il y a preque un an, le formateur lui même ne nous encourageait pas à prendre la maintenance pour juste 2 ou 3 serveur proxmox. Par contre quand on tape dans le ceph ou les grosses infra c'est un plus quand même.

 

Pour en revenir à ton sujet, oui tente une install du pve-kernel et du pve-manager également.


Ou alors backup de /etc/pve et réinstallation propre d'une 4.4 (ou éventuellement directement une 5.0).


---------------
"Les Doigts sont nos dieux!" - Année 100.000.667, 23ème, rebelle déiste.
n°1405825
matteu
Posté le 10-07-2017 à 14:45:58  profilanswer
 

j'ai laissé un message sur leur forum mais bon, vu que je suis pas super fort en anglais, et encore moins en linux, c'est pas garanti que ca donne quelque chose raison pour laquelle j'ai aussi posté ici :)
ok je tente l'install du kernel.
kernel ok
je reboote et je tente l'install du pve manager et c'est la qu'on a trouvé le problème je pense :)

 

Setting up pve-firewall (3.0-1) ...
Failed to reload-or-restart pve-firewall.service: Unit pve-firewall.service is masked.
dpkg: error processing package pve-firewall (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of qemu-server:
 qemu-server depends on pve-firewall; however:
  Package pve-firewall is not configured yet.

 

je tente alors apt-get install pve-firewall
dpkg: error processing package pve-container (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pve-firewall
 qemu-server
 pve-manager
 pve-ha-manager
 pve-container
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

EDIT : ok super en fouillant un peu j'ai fais

 

systemctl list-unit-files

 

et on voit bien que pve-firewall est en masked

 

j'ai donc fait
systemctl unmask pve-firewall.service

 

ensuite apt-get install qemu-server
et la il m'a demandé ce qu'il devait faire du fichier sources.list (et c'est la ou ca m'a fait tilt et ou j'avais mis entreprise edition lors de la migration !!!! -> c'est peut être à cause de cela que la migration à foirée :)  ) alors que la j'ai laissé le choix par défaut qui est de conserver la configuration actuelle.
Et à partir de la tout est revenu et je vois bien via
netstat -a | grep 8006
que c'est à l'écoute et mon interface web fonctionne !!!

 

Je vois donc mes vms et je suis bien en version 5 !
Est ce que les anciens kernels sont automatiquement désinstallés ou pas du cou ?
Bon bé la tout est fonctionnel on dirait bien :) Je suis content ^^ Merci à toi snipereyes qui m'a bien mis sur la piste avec le pve-manager

 


Par contre, est ce que c'est normal d'avoir uniquement 5 url lors d'un apt-get update ?

  


Message édité par matteu le 10-07-2017 à 15:15:48

---------------
Mon Feedback---Mes ventes
n°1405826
snipereyes
Posté le 10-07-2017 à 15:41:33  profilanswer
 

peux tu poster un pveversion -v juste pour voir si c'est correct ?
 
Pour les anciens kernels faut les enlever à la main, mais gardes en quand meme dans le doute.
 
Pour le apt poste ton sources.list mais de mémoire oui ca doit être ca.
 
Edit : Je ferais quand même un apt dist-upgrade histoire de sur que tout est ok.


Message édité par snipereyes le 10-07-2017 à 15:42:49

---------------
-- Topic de vente -- FeedBack --
n°1405827
matteu
Posté le 10-07-2017 à 15:47:59  profilanswer
 

root@proxmox:~# pveversion -v
proxmox-ve: not correctly installed (running kernel: 4.10.15-1-pve)
pve-manager: 5.0-23 (running version: 5.0-23/af4267bf)
pve-kernel-4.10.15-1-pve: 4.10.15-15
pve-kernel-4.4.35-1-pve: 4.4.35-77
libpve-http-server-perl: 2.0-5
lvm2: 2.02.168-pve2
corosync: 2.4.2-pve3
libqb0: 1.0.1-1
pve-cluster: 5.0-10
qemu-server: 5.0-12
pve-firmware: 2.0-2
libpve-common-perl: 5.0-16
libpve-guest-common-perl: 2.0-11
libpve-access-control: 5.0-5
libpve-storage-perl: 5.0-12
pve-libspice-server1: 0.12.8-3
vncterm: 1.5-2
pve-docs: 5.0-8
pve-qemu-kvm: 2.9.0-2
pve-container: 2.0-14
pve-firewall: 3.0-1
pve-ha-manager: 2.0-2
ksm-control-daemon: 1.2-2
glusterfs-client: 3.8.8-1
lxc-pve: 2.0.8-3
lxcfs: 2.0.7-pve2
criu: 2.11.1-1~bpo90
novnc-pve: 0.6-4
smartmontools: 6.5+svn4324-1
zfsutils-linux: 0.6.5.9-pve16~bpo90

 

sources.list

 

deb http://ftp.debian.org/debian stretch main contrib

 

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

 

# security updates
deb http://security.debian.org stretch/updates main contrib

 


Et du cou, le sources.list est utilisé si jamais le fichier /etc/apt/sources.list.d/pve-enterprise.list est vide ou tout est commenté c'est ça ?

 

Déjà fait l'apt-get dist-upgrade et rien de dispo


Message édité par matteu le 10-07-2017 à 15:50:11

---------------
Mon Feedback---Mes ventes
n°1405830
snipereyes
Posté le 10-07-2017 à 17:53:01  profilanswer
 

tu sembles avoir encore un problème, il faudrait voir sur le forum, sinon solution de Deadlock sauvegarde /etc/pve et réinstall


---------------
-- Topic de vente -- FeedBack --
n°1405834
lestat67se​l
:-)
Posté le 10-07-2017 à 22:09:24  profilanswer
 

Bon perso j'avais aussi le repos entreprise activé.
Ptet parce que c'est pas une install ISO mais proxmox sur debian ?
 
Du coup je l'ai viré avant de lancer l'update :o
 
Ca mouline
 
Edit: Terminé, no problem  :bounce:


Message édité par lestat67sel le 10-07-2017 à 22:58:06
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  51  52  53  54  55  56

Aller à :
Ajouter une réponse
 

Sujets relatifs
Choix Hyperviseur pour Xeon [Box de test]Routage vm Proxmox
Questionnement sur un hyperviseur[Topikunik] Personnalisation des interfaces graphiques
Plus de sujets relatifs à : [TOPIKUNIK] Proxmox, une solution de virtualisation kellébien !



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR