Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide Recherche
384 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  wide screen (16/10) sur portable et linux

 


 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

wide screen (16/10) sur portable et linux

n°359789
Biff Tanne​n
tampis
Posté le 17-11-2003 à 20:11:23  profilanswer
 

j'aimerais savoir pour ceux qui ont ce type de dalle si vous etes arrivé a config XF86config de maniere a ne pas avoir un affichage étiré , si c'est le cas, comment , avec kel GPU ? et si je pouvais avoir le contenu de vos XF86config egalmeent :jap:

mood
Publicité
Posté le 17-11-2003 à 20:11:23  profilanswer
 

n°359799
fl0ups
東京 - パリ - SLP
Posté le 17-11-2003 à 20:18:13  profilanswer
 

Doit juste suffire de se faire une modeline adéquate
 
Par ex en utilisant ce site: http://koala.ilog.fr/cgi-bin/nph-colas-modelines
et en lui disant que tu veux du 16/10ieme.
 
D'ailleurs ca m'étonnerait pas que ca marche sans modeline
 
Faut savoir qu'avec Xfree tu peux avoir quasiment toutes les résolutions que tu veux et que tu n'es pas limité aux habituels 640x480 800x600 1024x768 etc.
 
Par ex moi j'utilise du 768x576 (résolution max de ma carte TV pour avoir du plein écran sans interpolation), et du 1136x852 qui est la résolution max que mon moniteur pourrave supporte à 75Hz (en 1152 il passe à 72Hz).
 
Donc faire marcher un écran wide 16/10ieme sous linux avec xfree je pense que c'est vraiment fingerz in ze nose, et ce quelquesoit  le GPU.

n°359801
Biff Tanne​n
tampis
Posté le 17-11-2003 à 20:19:58  profilanswer
 

g pas encore installé les drivers nvidia , j'ai essayé de lui donner la resolution max supporté par l ecran , a savoir 1280*800 , mais il m'envoie chier :/ , pareil pour 1024*640 , mais je vais regarder ton url maintenant

n°359808
Biff Tanne​n
tampis
Posté le 17-11-2003 à 20:32:47  profilanswer
 

hmmm , c embettant , il y a des info dont je ne dispose pas :/ et rien dans le manuel du laptop :/

n°359840
Zaib3k
Posté le 17-11-2003 à 21:22:31  profilanswer
 

courage. j'ai bloqué sur ce genre de probleme aussi. (15'4 wide,r9200)
 
je m'y remet des que possible
 
 
 
(et je flag [:drapo] )

n°359853
Biff Tanne​n
tampis
Posté le 17-11-2003 à 21:34:48  profilanswer
 

grace a l url de fl0ups g pu obtenir des modeline
apres avoir cherché les carac technique dont j'avais besoin
bon , je sais ou il faut les mettre dans le XF86Config-4 (debian inside)
 
mais apres ?? ya rien d'autre a faire ? rien d'autre a modfifier ?

n°359862
fl0ups
東京 - パリ - SLP
Posté le 17-11-2003 à 22:01:38  profilanswer
 

bah tu lui dit d'utiliser ta nouvelle modeline comme résolution par défaut (tout en bas du XF86Config-4, dans la section qui correspond à la color depth que tu utilises, tu mets en tête la résolution spéciale du portable (1280x800 ou un truc comme ca) pour laquelle tu viens de créer une modeline.

n°360049
matafan
Posté le 18-11-2003 à 04:16:58  profilanswer
 

C'est quoi comme portable ? Sur mon inspiron 8500, écran 1920x1200, j'utilise ça :

Modeline "1920x1200" 246.59 1920 2064 2272 2624 1200 1201 1204 1253 -HSync +Vsync

n°360070
Biff Tanne​n
tampis
Posté le 18-11-2003 à 08:29:26  profilanswer
 

toshiba M30-104  
le -HSync +Vsync , sert a koi , g généré aucune ligne contenant cela

n°360083
Biff Tanne​n
tampis
Posté le 18-11-2003 à 09:18:27  profilanswer
 

de plus , avec les ligne que j'ai rajouté , j'arrive a avoir les bonnes proportion a priori , mais c trop grand , cad que si je bouge la sourie vers les extrémité , j'ai l'affichage qui défile jusqu'a arriver au bord de l'affichage [:ddr555]

mood
Publicité
Posté le 18-11-2003 à 09:18:27  profilanswer
 

n°360086
bobuse
Posté le 18-11-2003 à 09:37:11  profilanswer
 

[ [:drapo] ]

n°360270
Biff Tanne​n
tampis
Posté le 18-11-2003 à 12:35:03  profilanswer
 

Biff Tannen a écrit :

de plus , avec les ligne que j'ai rajouté , j'arrive a avoir les bonnes proportion a priori , mais c trop grand , cad que si je bouge la sourie vers les extrémité , j'ai l'affichage qui défile jusqu'a arriver au bord de l'affichage [:ddr555]


 
un ptit UP fera pas de mal je pense :)

n°360360
fl0ups
東京 - パリ - SLP
Posté le 18-11-2003 à 14:31:20  profilanswer
 

comme je l'ai déja dit plus haut, dans la section display qui correspond à ta colordepth il faut que tu rajoutes ta résolution et que tu la mettes en tête.


        SubSection "Display"
                Depth           24
                Modes           "1280x800" "1024x768" "800x600"
         EndSubSection


n°360362
Biff Tanne​n
tampis
Posté le 18-11-2003 à 14:32:45  profilanswer
 

c ce que j'ai fait [:spamafote]

n°360388
fl0ups
東京 - パリ - SLP
Posté le 18-11-2003 à 14:55:38  profilanswer
 

Bein tu t'es forcément gourré quelquepart si t'es en mode 'virtual desktop'
 
il accepte bien ta modeline? Dans /var/log/XFree86.0.log (ou quelquechose comme ca)

n°360392
Biff Tanne​n
tampis
Posté le 18-11-2003 à 15:01:02  profilanswer
 

je regarderais ce soir


Message édité par Biff Tannen le 18-11-2003 à 15:57:37
n°365532
Biff Tanne​n
tampis
Posté le 26-11-2003 à 07:44:23  profilanswer
 

fl0ups a écrit :

Bein tu t'es forcément gourré quelquepart si t'es en mode 'virtual desktop'
 
il accepte bien ta modeline? Dans /var/log/XFree86.0.log (ou quelquechose comme ca)


 
en gros ça me dit k il en veut pas de mon 1280*800 , et idem pour 1024*640 ... genre , out of range  
 
UP par la mme occasion , j'aimerais arriver a kkchose ...


Message édité par Biff Tannen le 26-11-2003 à 07:44:43
n°366097
fl0ups
東京 - パリ - SLP
Posté le 27-11-2003 à 14:54:59  profilanswer
 

bah ca ca veut dire qu'il faut que tu baiosses de quelques chouillas les valeurs (sur la bande passante etc) quand tu remplis sur le site qui te génère la modeline.
 
Mais comme je te l'ai indiqué sur l'autre topic, avec le XF86Config exemple, il ne semble pas nécessaire de créer une modeline spécifique.
 
T'as essayé d'utiliser son fichier tel quel en changeant juste pour les fonts / clavier / souris?

n°366158
Biff Tanne​n
tampis
Posté le 27-11-2003 à 18:00:32  profilanswer
 

non je ne l'ai pas essayé ... en y allant a taton je suis pas vraimetn certain d'y arriver, surtout si en plus sans modline ça peut marcher
 
de plus sur la conf que tu ma montré , c avec des drivers ati me semble t il , or j'ai un chip nvidia , et ils n'ont pas vraimetn l'air de gerer cette resolution ...

n°366159
fl0ups
東京 - パリ - SLP
Posté le 27-11-2003 à 18:02:31  profilanswer
 

Ca n'a absolument rien à voir avec le chipset, tous les chips peuvent gérer n'importe quelle résolution (dans la limite de la mémoire dont ils disposent etc).
 
Je te sens intéressé mais pas super motivaide sur cette histoire :D
Si ca te soule de faire des tests le plus simple est de lancer ton serveur X normalement dans le mode 'étiré', de faire les modifs dans le XF86Config-4 et de lancer un 2ieme server X à partir de la console avec startx -- :1
 
Comme ca meme si il plante tu auras toujours un environnement graphique avec ton premier server X qui te permettre de googler pour trouver la solution ;)


Message édité par fl0ups le 27-11-2003 à 18:06:02
n°366162
Biff Tanne​n
tampis
Posté le 27-11-2003 à 18:05:17  profilanswer
 

bon dans ce cas je ne vois pas pourquoi si il n'y a pas besoin des modeline , comme sur l'exemple , ça ne fonctionne pas ...

n°366163
fl0ups
東京 - パリ - SLP
Posté le 27-11-2003 à 18:06:23  profilanswer
 

(j'ai rajouté du texte au dessus ;))

n°366164
Biff Tanne​n
tampis
Posté le 27-11-2003 à 18:09:08  profilanswer
 

le pb n'est pas de faire ça a partir de X ou non, je me demerde tres bien sans , c'est pas que je suis pas motivé , mais un peu flémard :D
et surtout je ne comprend pas pourquoi ça ne fonctionnerais pas comme je viens de le dire précédement, ya pas vraiment de raison ... sinon , faut me la donner parceque je la vois pas :D


Message édité par Biff Tannen le 27-11-2003 à 18:09:28
n°366165
fl0ups
東京 - パリ - SLP
Posté le 27-11-2003 à 18:10:24  profilanswer
 

bein ravale ta flemmardise et explique en long en large et en travers ce que 'ca marche pas' peut bien vouloir dire

n°366167
fl0ups
東京 - パリ - SLP
Posté le 27-11-2003 à 18:11:45  profilanswer
 

tu pourrais par ex poster un lien vers ton XF86Config et ton fichier de log d'xfree (les copie colle pas directement sur le thread c'est illisible...)

n°366168
Biff Tanne​n
tampis
Posté le 27-11-2003 à 18:14:29  profilanswer
 

bon,  sparti , on va faire ça si free fonctionne today , sachant que je mettrais un XF86config avec seulement le mode 1280*800 ...

n°366170
Biff Tanne​n
tampis
Posté le 27-11-2003 à 18:20:32  profilanswer
 
n°366178
fl0ups
東京 - パリ - SLP
Posté le 27-11-2003 à 18:33:29  profilanswer
 

t'as essayé de refaire une modeline et de modifier les valeurs de ton xf86config en fonction des messages qu'il te met?
 
(WW) NVIDIA(0): The user specified HorizSync "31.500-80.500" has been adjusted
(WW) NVIDIA(0):      to "31.500-49.000" (the intersection with EDID-specified
(WW) NVIDIA(0):      HorizSync "29.000-49.000" )
(WW) NVIDIA(0): The user specified VertRefresh "60.000-75.000" has been
(WW) NVIDIA(0):      adjusted to "60.000" (the intersection with
(WW) NVIDIA(0):      EDID-specified VertRefresh "0.000-60.000"
(II) NVIDIA(0): Monitor0: Using hsync range of 31.50-49.00 kHz
(II) NVIDIA(0): Monitor0: Using vrefresh value of 60.00 Hz

n°366180
Biff Tanne​n
tampis
Posté le 27-11-2003 à 18:40:30  profilanswer
 

ouep j'ai deja essayé ça sans succes :/
la version de XF86Config que j'ai posté a été faite apres en fonction de l'exmeple que t'avais donné sur l'autre topic

n°623041
fifi85
Posté le 19-01-2005 à 19:54:26  profilanswer
 

j'ai eu le même problème avec un écran Proview 16:10 15"4 TFT
les générateurs de modeline que j'ai essayé sont tous plus pourris les uns que les autres, aucun ne donnait de modes valables
et non, les drivers NVIDIA n'y sont pour rien, c'est juste que XFree arrive pas a récuperer les modes par défaut du moniteur
 
(je tourne sous Debian Sid)
 
en tatonnant et en lisant la doc des VideoModes sur xfree.org, j'ai réussi à trouver un réglage qui marche bien pour ce type d'écran
 
voilà ma section Monitor dans XF86Config-4
 
Section "Monitor"
 Identifier "Proview Monitor"
 HorizSync 29-52
 VertRefresh 59.0-61.0
 DisplaySize 332 207
 Modeline "1280x800@60" 71.47 1280 1288 1312 1400 800 802 804 842
 Option  "DPMS"
EndSection
 
et après il suffit de rajouter "1280x800@60" quelque part dans la section screen...

n°693759
psykokwak
Posté le 15-06-2005 à 16:25:55  profilanswer
 

hum, je flag, je testerai ca se soir

n°693769
_darkalt3_
Proctopathe
Posté le 15-06-2005 à 16:40:18  profilanswer
 

[:drapal]


---------------
Top of the plop - Eternity4Life - Putain ça craint... Je crache du sang et c'est pas le mien.
n°693783
korben31
Posté le 15-06-2005 à 16:52:49  profilanswer
 

topic interessent
:D

n°693789
psykokwak
Posté le 15-06-2005 à 16:58:17  profilanswer
 

bon et bien j'ai reussi :
 
jai demarré (Whoppix) en 1024*768 etiré!
 
jai modifié mon XF86Config-4 pour que la section "monitor" et "screen" ressemblent a ceci :


Section "Monitor"
 Identifier "Monitor0"
 Option "DPMS" "true"
 HorizSync    28.0 - 96.0
 VertRefresh  50.0 - 75.0
 Modeline "1280x800" 71.47 1280 1288 1312 1400 800 802 804 842  
EndSection
 
Section "Screen"
 Identifier "Screen0"
 Device     "Card0"
 Monitor    "Monitor0"
 DefaultColorDepth 16
 SubSection "Display"
  Depth     1
  Modes "1280x800"
 EndSubSection
 SubSection "Display"
  Depth     4
  Modes "1280x800"
 EndSubSection
 SubSection "Display"
  Depth     8
  Modes "1280x800"
 EndSubSection
 SubSection "Display"
  Depth     15
  Modes "1280x800"
 EndSubSection
 SubSection "Display"
  Depth     16
  Modes "1280x800"
 EndSubSection
 SubSection "Display"
  Depth     24
  Modes "1280x800"
 EndSubSection
 SubSection "Display"
  Depth     32
  Modes "1280x800"
 EndSubSection
EndSection


 
ensuite je lance un 2eme X sur un autre terminal par la commande :  

startx --:1


 
 
et là  :love:  :D  
 
 
pour info : je suis sur un Toshiba M30 avec un ecran 16/10 15"4

n°693795
korben31
Posté le 15-06-2005 à 17:05:13  profilanswer
 

me tarde d'avoir mon ptit portable hihi

n°693796
deather2
Posté le 15-06-2005 à 17:06:53  profilanswer
 

Perso, Ubuntu m'a configure mon portable sans que je n'ai rien a faire, en 1280x800.
Je peux poster mon XF86Config-4 si besoin :)

n°693941
kzimir
-
Posté le 15-06-2005 à 22:14:42  profilanswer
 

deather2 a écrit :

Perso, Ubuntu m'a configure mon portable sans que je n'ai rien a faire, en 1280x800.
Je peux poster mon XF86Config-4 si besoin :)


 
Pareil sous ubuntu, c'était pareil sous Mandrake 10.0, mais l'installation des drivers ATI (fglrxconfig) fout le dawa, il faut corriger le xorg.conf/XF86Config-4 après coup (faire une sauvegarde de l'ancien :p)


Message édité par kzimir le 15-06-2005 à 22:14:58

---------------
Serre les fesses jusqu'en 2012...
n°765693
hatnux
Posté le 25-12-2005 à 22:36:38  profilanswer
 

:bounce:  up sur ce topic intéressant !
 
Dailleur j'ai aussi un 16:10 et mon linux ne le détect pas, enfin dès que je passe en graphique j'ai rien. A ce moment là ça ma pas étonné vu ce qui est dis ici, donc directe je m'apprete à editer mon xorg.conf et là stupéfaction j'en ai pas  :ouch:  
 
Ni de dossier X11 d'ailleur :heink:  
Et ça c'est pas normale nan ? Ou il pourrait bien être ?
 
edit : j'étais en rescue, c'est pour ça que je le voyais pas  :whistle:  
Bon sinon le nouveau modeline il faut le mettre à la place de l'ancien ou l'ajouter seulement ? Et c'est le seul changement à faire ? Car perso ça marche pas :( mais je continu à tester

Message cité 1 fois
Message édité par hatnux le 25-12-2005 à 23:00:33
n°765697
deather2
Posté le 25-12-2005 à 22:55:41  profilanswer
 

Personellement, j'ai un portable Asus avec un ecran 1280x800, 16/10 donc.
Il marche parfaitement sous Debian avec Xorg, de meme sous Solaris et NetBSD, et ce sans ModeLine.
La carte graphique est une ATI Radeon 9700 Mobility. Ca marche aussi bien avec les pilotes libres et les pilotes proprio (sous Linux).
J'ai simplement mit Modes "1280x800", et ca marchait.

n°765698
hatnux
Posté le 25-12-2005 à 23:02:48  profilanswer
 

deather2 a écrit :

Personellement, j'ai un portable Asus avec un ecran 1280x800, 16/10 donc.
Il marche parfaitement sous Debian avec Xorg, de meme sous Solaris et NetBSD, et ce sans ModeLine.
La carte graphique est une ATI Radeon 9700 Mobility. Ca marche aussi bien avec les pilotes libres et les pilotes proprio (sous Linux).
J'ai simplement mit Modes "1280x800", et ca marchait.


T'as du bol ! ça doit venir de ta carte qui doit avoir de bon driver.
Perso c'est une intel intégrée, alors ça vien peut être de là :(, mais je pense plutot que c'est vraiment mon écran qu'il n'aime pas  
 
 

hatnux a écrit :


edit : j'étais en rescue, c'est pour ça que je le voyais pas  :whistle:  
Bon sinon le nouveau modeline il faut le mettre à la place de l'ancien ou l'ajouter seulement ? Et c'est le seul changement à faire ? Car perso ça marche pas :( mais je continu à tester


mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  wide screen (16/10) sur portable et linux

 

Sujets relatifs
Mode graphique qu'en 640x480 et souris folle (portable sous Debian)serveur IIS sous vmware en Linux ? (c'est pas mon choix !)
Linux sur un vieux PCAssociation Linux
Ce que vous n'aimez pas de windows et n'aimez pas de linux :)[HD Linux] Prob reconnaissance
Serveur ftp sous linux et qui donne acces au pc du rezo on fé comment?Pb d'extinction PC portable
clé usb sous linuxLinux RedHat 9, oint a lapalce de la virgule, clavier num ...
Plus de sujets relatifs à : wide screen (16/10) sur portable et linux



Copyright © 1997-2014 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Avis LDLC / LesNumeriques.com