Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
539 connectés 

  FORUM HardWare.fr
  Hardware - Périphériques
  Scanner

  [Résolu] CANON rmslantc.dll (Impossible d’ouvrir la source Twain)

 

 

 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] CANON rmslantc.dll (Impossible d’ouvrir la source Twain)

n°404050
WareFr
Posté le 15-06-2007 à 01:02:33  profilanswer
 

Bonsoir les lecteurs en mal de solutions,
 
Apres quelques heures (de nombreuses heures, ma fois) sous Windows XP Service Pack 2...
Dans mon cas, le scanner (Lide 80) fonctionnait parfaitement bien jusqu'au moment fatidique ou un logiciel
fraichement installe lui a chuchote de boycotter le boulot pour lequel il etait nourri a grands coups d'USB.
Enfin ! Reprenons !
 
Vous installez Scangear par le Cd ou plus simplement juste par les pilotes et la !
Grande surprise votre logiciel d'acquisition prefere (PSP, Photoshop, Paint, Photostudio...) vous
salue par "Impossible d’ouvrir la source Twain" ou "Scanner non detecte", "Source Twain introuvable",
"Cette application n’a pas pu démarrer car rmslantc.dll est introuvable"...etc.
 
La solution en pratique pour bon nombre de scanners Canon :
 
Acte I : Installation propre
- Debranchez le cable USB entre votre ordinateur PC et votre scanner.
- Inserez le CD-ROM du logiciel et cliquez sur parcourir le CD pour en afficher le contenu.  
- Ouvrez le répertoire "Bin" puis cliquez deux fois sur Deldrv (cette opération permet de
supprimer le driver actuel).  
- Redemarrez votre ordinateur. (lol)
Acte II : Reinstallation propre
- Allez donc chercher par la (rubrique scanners:) le dernier ScanGear pour votre materiel.
- Vous vous deplacez dans C:\WINDOWS\twain_32 et notez les dossiers existants.
- Vous lancez (pas trop fort !) l'execution de l'installation des pilotes
- Une fois l'installation terminee, vous branchez votre scanner sur un port USB (pas un HUB de preference).
- Vous testez l'acquisition avec un de vos logiciels favoris (Paint ?) :-)
- Si cela fonctionne, alors bonne continuation vous n'aviez pas besoin de lire ce post
- Si cela ne fonctionne pas...
Acte III : En route vers la numerisation
- Deplacez-vous dans C:\WINDOWS\twain_32 et descendez d'un niveau dans le dossier cree lors de  
l'installation des pilotes, recopiez ce chemin (cette arborescence) pour une utilisation ulterieure.
- bouton droit (de la souris) sur "poste de travail" > Proprietes (ou Windows/Pause pour les pros).
- Onglet "Avance", tout en bas a gauche "Variables d'environnement"
- "Variables systeme" selectionner "Path";"Modifier", ne pas effacer la ligne !!!!
- Deplacer vous avec le curseur (fleche droite) a l'extremite droite de la ligne
- A la fin de cette ligne ajouter un point virgule si il n'existe pas (;)
- Derriere ce ";" Recopiez a l'identique le chemin vers le TWAIN de votre scanner
(dans mon cas C:\WINDOWS\twain_32\CNQL80)
- Votre Path modifie devrait ressembler a quelque chose du genre
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\Microsoft SQL Server\80;C:\Program Files\Fichiers communs\Adobe\AGL;C:\WINDOWS\twain_32\CNQL80
- Cliquez sur "OK" trois fois
 
J'ai essaye (dans la mesure du possible) que ce post soit techniquement accessible si
la realisation des manipulations vous parait trop complexe, posez vos questions ici, les
FoRhum'eurs vous repondront specifiquement sur ce sujet et sa mise en pratique.
 
(Cette manipulation fonctionne egalement pour Windows Vista.)
 
Schussssssssssssssssssssssss...................[FEEDBACK]
 
Nb : Pour ceux qui ne trouvent pas Deldrv, ne pas debrancher le
scanner et destination /bouton droit /poste de travail/Proprietes/Materiel/Gestionnaire de
peripheriques/Peripheriques d'images a deployer (+) et bouton droit sur Canoscan XXXX
desactiver et ensuite desinstaller, a ce moment si Windows demande quoique ce soit cliquer
sur annuler. Reprendre ensuite Acte II...
 

Citation :

Reflexion par la lecture et Action par la souris, dedicace pour Justine et les autres


Message édité par WareFr le 17-06-2007 à 00:31:45
mood
Publicité
Posté le 15-06-2007 à 01:02:33  profilanswer
 

n°425398
viiz
Bad motherfucker
Posté le 05-09-2007 à 00:53:50  profilanswer
 

Le fait de mettre le répertoire Twain dans le path a effectivement suffit.
Très fort merci bcp pour l'info en lisant j'y croyais pas une seconde ;)

n°480712
tafkap
Posté le 13-04-2008 à 10:37:38  profilanswer
 

Exactement ce que je cherchais... je vais essayer de suite...

n°480717
tafkap
Posté le 13-04-2008 à 11:02:41  profilanswer
 

Un grand merci à WareFr, ça fonctionne  :pt1cable:  
 
 :jap:  :jap:

n°491518
Groswilly
Posté le 08-06-2008 à 20:58:42  profilanswer
 

parfait pour moi aussi !
merci

n°510702
stravinski
Posté le 11-09-2008 à 10:31:21  profilanswer
 

bonjour, j'ai enfin trouvé une solution à ce problème, mais malgré les corrections indiquées, la source twain n'est pas trouvé lorsque je lance la numérisation.
 
j'ai regardé par rapport au path indiqué par WareFr  et je n'ai pas cette partie : "C:\Program Files\Microsoft SQL Server\80;C:\Program Files\Fichiers communs\Adobe\AGL" sachant que j'ai un canon lide 35 et que j'ai partitionné mon disque dur. (en règle générale je mets les applications sur E:
 
Merci de m'aider pour enfin réutiliser mon scanner.
 
Merci

n°514293
Gluonk
Kopin
Posté le 01-10-2008 à 10:48:45  profilanswer
 

Salut,

 

moi j'ai eu une série de problèmes avec mon scanner CANON LIDE 20.

 

n°1 - Dès que je le branchais, il se mettait à scanner tout seul, et arrivé au bout il ne revenait pas à sa position normale, d'où un bruit atroce :( . Obligé de le débrancher.
n°2 - Une fois ce problème réglé je ne sais plus comment (à force de débrancher/rebrancher/taper dessus), dès que je lançais un scan avec CanoScan Toolbox, il m'affichait deux messages l'un derrière l'autre : l'un pour me dire de "débloquer, puis déconnecter et reconnecter le cordon USB", et l'autre "Source TWAIN introuvable[...]".

 

- j'ai désinstallé/réinstallé dans tous les sens, rien à faire.
- j'ai même réalisé cette manip : http://forum.hardware.fr/hfr/Hardw [...] 3400_1.htm
- je viens de tomber sur votre thread, mais votre astuce ne change rien.

 

J'ai fini par comprendre que le premier message d'erreur signifiait en substance que le verrour de blocage de mon scanner était enclenché sur la position "bloqué" (cadena fermé). Hors, j'ai vérifié, il était sur la position ouvert.
J'ai secoué le scanner comme un prunier, et je l'ai débloqué (l'ergot devait déconner)!

 

Mais maintenant, j'ai de nouveau le problème n°1 !  :o
J'en ai un peu ras le ***, et j'aimerais bien qu'il arrête de faire son zinzin. Comment le maîtriser?  [:agla]
J'voudrais pouvoir relancer un scan "normal" ^^, et vérifier si votre astuce fonctionne :)


Message édité par Gluonk le 01-10-2008 à 10:51:37

---------------
Feedback | Zappateers Radio [Bully's Streams] (http://zappateers.oblivion-software:8000)
n°514437
Gluonk
Kopin
Posté le 01-10-2008 à 21:07:36  profilanswer
 

Up, pour mon scanner-fou !
Lien connexe : http://www.commentcamarche.net/for [...] m-de-twain


Message édité par Gluonk le 01-10-2008 à 22:13:34

---------------
Feedback | Zappateers Radio [Bully's Streams] (http://zappateers.oblivion-software:8000)
n°541863
gobite
Posté le 15-02-2009 à 03:07:50  profilanswer
 

alors moi j'ai exactement le même souci que décrit plus haut, a savoir un soft (mise a jour de ma webcam a priori) fait que mon cannoscan lide 30 a eu ce même souci de source twain (je suis sous xp edition familliale).
je suis vraiment pas une lumiére en informatique mais j'en ai vraiment besoin pour mon taf, en particulier tout ce qui touche a l'image et en particulier mon scan, donc je passe trois heures comme un forcené dans le gestionnaire de peripheriques ou on me dit bien que le peripherique fonctionne mal (comme cette foutue webcam d'ailleurs), je desinstalle je reinstalle sans succes bref....
la je tombe sur la soluce de ware, j'essaie, et je sais pas si je suis maudit ou quoi mais non content de pas solutionner le problême , mon scan a completement disparu de la circulation, je le trouve plus dans le gestionnaire de peripheriques et quand je tente un scan sous photoshop, image twain n'est même plus proposé dans le menu importation.
donc la le desespoir me submerge, j'ai un peu l'impression d'avoir empiré le truc bref......si mon probleme inspire quelqu'un lachez vous !!!

n°590495
padevaux
Posté le 03-02-2010 à 22:48:45  profilanswer
 

j'ai le même problème avec mon scanner canon lide 20
j'ai installé windows 7 et les drivers fournit par Canon
mais il est toujours indiqué " Tawain absent "
 
merci de votre aide

mood
Publicité
Posté le 03-02-2010 à 22:48:45  profilanswer
 

n°590536
Sacripot
Alien in this country.
Posté le 04-02-2010 à 11:37:44  profilanswer
 

padevaux a écrit :

j'ai le même problème avec mon scanner canon lide 20
j'ai installé windows 7 et les drivers fournit par Canon
mais il est toujours indiqué " Tawain absent "
merci de votre aide


 
Bonjour Padevaux,
 
Je suppose que vous installé votre scanner "comme il faut" selon la procédure? (comme pour les modem et box, il faut souvent installer le logiciel avant de brancher le matériel et ne brancher ce dernier qu'à un moment précis. :sweat:  
 
Depuis combien de temps avez-vous le scanner?
Vous est-il possible de l'installer sur un autre PC chez vous? chez un ami? un voisin? quelqu'un qui a Windows Seven?
Dans ce cas, fonctionne-t-il? (pour isoler le problème - scanner? - PC?)
 
Je vous pose la question parce que je trouve que les messages d'erreurs sont peu compréhensibles.
Dans mon ancien cas de scanner en panne, après moult recherches sur les forums, il semblerait que le coupable soit le cordon/boîtier d'alimentation qui ait perdu son ampérage avec l'age. Le prix d'un cordon compatible étant presque l'équivalent du scanner en panne... On ne perd pas plus de temps.
 
Avez-vous essayé la procédure de WareFr?
 
Sinon que faut-il faire?
Désinstaller complètement le logiciel, avec Ccleaner et son option registre?
Réinstaller selon la procédure. (si le mode d'emploi en français traduit de l'anglais traduit du roumain traduit du russe traduit de l'allemand traduit du chinois vous aide. Maîtriser quelques langues étrangères aide. Je me rappelle ma motocyclette et le guide d'entretien "en français" :lol:  :lol: ) ou selon le contraire de la procédure?
 
Cela pourrait confirmer ce que je pense de l'adaptation précipitée des fabricants de logiciels et matériels aux nouveaux systèmes d'exploitation: :D  
On attend le retour SAV pour corriger.
 
Comment dit-on bug en français? fonctionnalité?  :D  
 
Désolé pour la longueur de mon blabla, mais à part essayer votre scanner sur un autre PC, ou un autre scanner sur votre PC - ce qui permet de réduire la liste des causes de pannes), je ne vois pas trop d'où vient le problème qui est peut-être tout simplement électrique. (trop de périphériques branchés, un port USB défaillant, etc.)
 
Bon courage. :sweat:  
 
S.


---------------
Windows XP Home, Windows XP Pro, until...
n°757259
newinc
Posté le 14-01-2014 à 20:36:22  profilanswer
 

Extra cette info ;) , je commençais à m'arracher les cheveux avec mon CanoScan 4200F qui ne voulait plus scanner sur mon PC (windows7 64) mais fonctionnait parfaitement sur mon portable (windows 7 64), malgré nettoyage du registre, suppression complète des drivers et réinstallation ensuite.
Merci  :jap:

n°791014
Perfect007
What else ?
Posté le 19-10-2014 à 14:14:12  profilanswer
 

Idem qu'au dessus avec donc un 4200F sous win7 64
 
Première fois qu'il me faisait cette erreur :D


---------------
Bash.Pseudo.Culture.Stats
n°817913
cisiorc
Posté le 29-03-2015 à 19:24:18  profilanswer
 

Après avoir essayer toute les solutions ci-dessus et dispo sur le web, j'ai réussi (Scanner 4200F sur Windows 7 - 64) en allant sur Canon US, en téléchargeant le pilote du 4200F ET SURTOUT la version 4.6 de la toolbox.
Avec la dernière version de la toolbox 5.0 ca ne marche pas, il ne trouvait pas le dossier Twain 32.
Espérons que ça aide!

n°840059
judasbrico​t
Posté le 01-09-2015 à 20:12:30  profilanswer
 

Bonsoir à tous,
 
ma solution (sous entendu celle qui a fonctionné chez moi...) :
donc sur un PC portable ASUS X72J de 2010 qui était sous W7, je viens de le migrer en W10
et bien sur mon Scanner Canoscan LIDE60 n'était plus reconnu, j'ai essayé la procédure signalée
en début de ce fil, échec, mais peut être ai-je foiré une étape, toujours est il que j'ai eu l'idée de  
récupérer sur le site de Canon le driver W7-64 bits et après installation et redémarrage du PC
miracle le Scan a émis son petit bzzzzzzzzziiiiiii à l'initialisation et la numérisation refonctionne.
le fichier porte le nom suivant : lide60vst6411111a_64.fr
 
Voilà c'était ma petite contrib à ce message bien énervant :
 "Impossible d'ouvrir la source TWAIN vérifiez la connection et réessayez"
 
Bonne soirée
 
JB

n°917494
coqquiimpr​ime
Posté le 09-03-2017 à 08:57:15  profilanswer
 

Bonjour  
j'adapte la solution de WareFr à Windows 10 et à mon souci de Twain avec mon CanoScan 4400F
 
Après quelques heures (de nombreuses heures, ma fois) sous Windows 10 votre logiciel d'acquisition préféré (PSP, Photoshop, Paint, Photostudio...) vous  
salue par "Impossible d’ouvrir la source Twain" ou "Scanner non détecté", "Source Twain introuvable", "Cette application n’a pas pu démarrer car rmslantc.dll est introuvable"...etc.  
 
La solution est
- Déplacez-vous dans C:\WINDOWS\twain_32 et descendez d'un niveau dans le dossier cree lors de l'installation des pilotes, recopiez ce chemin (cette arborescence) pour une utilisation ultérieure.  
- bouton droit (de la souris) sur "poste de travail" > Propriétés (ou Windows/Pause pour les pros ... pas mon cas).  
- Onglet "Avance", tout en bas a gauche "Variables d'environnement"  
- "Variables système" sélectionner "Path";"Modifier", ne pas effacer la ligne !!!!  
- Déplacez-vous avec le curseur (flèche vers le bas) au bas de la liste
- Cliquez sur "Nouveau" et dans l'espace qui apparaît:

- Recopiez a l'identique le chemin vers le TWAIN de votre scanner  
(dans mon cas C:\WINDOWS\twain_32\CNQ4803)  
- Cliquez sur "OK" trois fois  
 
et voilà que mon numériseur fonctionne comme il y a 10 ans.
 


Message édité par coqquiimprime le 09-03-2017 à 08:59:52

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware - Périphériques
  Scanner

  [Résolu] CANON rmslantc.dll (Impossible d’ouvrir la source Twain)

 

Sujets relatifs
LASER Canon LBP-2900 : Vos avis (Toner dans le carton ?)Probleme de couleurs avec une canon MP180
maintenance CANON IR 1600Canon LBP3000, impression réseau via une commande dos copy
icone "retirer le périph en tte sécurité" disparu (résolu)[résolu]Controleur Ethernet...
WIFI sur Canon MP600RCanon i6500 A3 - problème de décalage
Canon MP600 - Cartouche bleue mal reconnueGraveur HS ? [Résolu]
Plus de sujets relatifs à : [Résolu] CANON rmslantc.dll (Impossible d’ouvrir la source Twain)



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR