Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2188 connectés 

  FORUM HardWare.fr
  Hardware
  Disque SSD

  [Résolu] Booter sur un SSD NVMe

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] Booter sur un SSD NVMe

n°10184051
zatowa
Posté le 10-07-2017 à 15:16:12  profilanswer
 

Bonjour à tous,
 
J'ai acheté dernièrement un SSD NVMe 960 EVO 250Go de chez SAMSUNG mais je n’ai aucun moyen de booter dessus (il n'est pas reconnu en UEFI/EFI) hormis de régler le 'Boot mode' de mon BIOS sur 'Legacy support', mais cela implique un démarrage plus long ..
Pourtant avant d'acheter ce SSD j'avais un SSD M2 avec le 'Boot mode' de mon BIOS réglé sur UEFI et cela ne posait aucun problème.
De plus j'ai des blue screen de temps en temps (que je n'avais jamais eu auparavant) avec l'erreur : DRIVER_POWER_STATE_FAILURE, d'après WhoCrashed 'ntoskrnl.exe' (NT Kernel & System) et 'ntkrnlmp.exe' seraient en cause.  
Est-ce que c'est lié au Legacy support ? je ne sais pas ..
 
Selon vous, est-ce que c'est la particularité NVMe du SSD qui pose problème ou un réglage du BIOS est à modifier ? (J'ai pourtant fait le tour de mon BIOS je l'ai même mis à jour).
 
N'hésiter pas à me demander des infos supplémentaires si j'en ai oublié, ou même des screen de mon BIOS.
 
PS : La référence de mon ordinateur est LENOVO Y700-17ISK
 
Merci d'avance !


Message édité par zatowa le 11-07-2017 à 03:08:18
mood
Publicité
Posté le 10-07-2017 à 15:16:12  profilanswer
 

n°10184063
zerist
Posté le 10-07-2017 à 15:21:35  profilanswer
 

:hello:
 
C'est quel OS ?  
 
Tu as fait une installation propre sur ton nouveau SSD, ou un clonage ?


---------------
Asus Z170-A - intel core i5-7600k @4.6GHz/1.24V - 16 Go DDR4@3000MHz G.Skill - MSI GTX1070 Quick Silver - firestrike - time-spy
n°10184064
Zonka
x58 forever!
Posté le 10-07-2017 à 15:21:38  profilanswer
 

Hello.

 

Le format physique "M2" ne veut pas dire que c'est compatible NVMe.

 

Ton OS c'est W10 je suppose? normalement nativement compatible NVMe. Mais encore faut-il que le BIOS/UEFI le soit (le fait que le SSD NVMe soit vu par le BIOS ne veut rien dire).

 

Pas bien compris sinon : tu as tenté une reinstallation complète sur le NVMe? un clonage?

 

EDIT: grilled by Zerist :p


Message édité par Zonka le 10-07-2017 à 15:21:57

---------------
Feedback - Guide d'achat de config
n°10184086
zatowa
Posté le 10-07-2017 à 15:39:50  profilanswer
 

Bonjour à vous 2 et merci de votre réactivité !
 
Oui mon OS est bien Windows 10.
 
@zerist & @zonka
J'ai essayer de faire un clonage via Acronis mais lui aussi ne reconnaissait pas mon SSD NVMe du coup j'ai du faire une installation propre à partir de 0.
 
Petite info supplémentaire, j'ai un disque dur SSD en SATA (oui oui ça existe encore), qui comme le SSD NVMe est reconnu uniquement en Legacy support (juste pour info ce SSD SATA est bien reconnu par Acronis)
 
 
 

n°10184107
nono0000
Posté le 10-07-2017 à 16:05:29  profilanswer
 

Pourtant d’après ce document, le Y700-17ISK supporte les SSD PCIE NVME: (p79)
https://download.lenovo.com/consume [...] 201510.pdf

 

Pour pouvoir booter sur un périphérique PCIE (qu'il soit NVME ou AHCI), il faut absolument être en UEFI (donc pas en Legacy).
Les CSM sont sur quel mode dans le bios?

 

Sur le DVD ou la clef USB, il faut obligatoirement booter en UEFI (généralement appelé "UEFI:<nom de periperique>" dans le boot menu)


Message édité par nono0000 le 10-07-2017 à 16:32:22

---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10184113
zatowa
Posté le 10-07-2017 à 16:21:24  profilanswer
 

Salut nono,
 
Effectivement, je n'avais pas trouvé cette doc.
 
Quand j'active le 'Boot mode' UEFI, j'ai uniquement une partie EFI qui apparaît avec le mode de boot PXE juste en dessous.
Je ne trouve pas d'option CMS dans mon BIOS, cette option sert à quoi exactement ?
 
Mes infos ne sont peut-être pas très claire car je ne connais pas trop la différence entre UEFI et EFI (si il y en a une).

n°10184117
nono0000
Posté le 10-07-2017 à 16:28:57  profilanswer
 

UEFI c'est l’implémentation de l'EFI fait par Intel ;)
C'est devenu maintenant un standard.

 

L'installateur Windows se trouve où ? sur une clef USB ou un DVD?

 

Le CSM est une couche d’émulation pour les OS anciens comme Windows 7 qui ne peuvent se servir directement d'un bios purement EFI.
Avec Windows 10 pas besoin de l'activer, c'est pour ça que sur "Auto" normalement cela détecte l'OS utilisé et s'active au besoin.
Mais si tu n'as pas l'option ce n'est pas grave...


Message édité par nono0000 le 10-07-2017 à 16:33:52

---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10184124
zatowa
Posté le 10-07-2017 à 16:47:51  profilanswer
 

D'accord merci pour l'info ;)
 
J'ai installé Windows à partir d'un CD
L'option qui se rapproche le plus de ta description de CMS est 'OS Optimized Defaults' qui est sur Enable
 
Quand j'ai vu qu'Acronis ne voyait pas mon SSD NVMe j'ai décidé de le formater avec DISKPART et je me demande si ça ne joue pas sur le fait qu'il n'est pas reconnu en UEFI

n°10184192
nono0000
Posté le 10-07-2017 à 18:28:27  profilanswer
 

Le type de partition ou de fichier n'a pas d'importance à ce niveau là.

 

Je ne connais pas les logiciels de transfert de système. Personnellement je préfère repartir d'une base propre quand je change de disque.

 

Je te conseille de partir de l'iso disponible sur le site de Microsoft qui est basé sur la version 1703:
https://www.microsoft.com/fr-fr/sof [...] /windows10

 

Tu peux demander à l'outil de le mettre sur une clef USB (toute la clef sera effacée).

 

Quand tu lances le menu de boot (généralement touche F8) tu devrais avoir quelque chose qui ressemble à çà:
https://www.tenforums.com/attachments/installation-upgrade/37251d1485951837t-problem-windows-10-installing-asus-boot-menu.png

 

Comme tu peux le voir le même périphérique est présent deux fois (ici une clef USB)... l'un pour le mode legacy et l'autre pour le mode UEFI.
Il faut bien sélectionner le second...


Message édité par nono0000 le 10-07-2017 à 18:29:16

---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10184409
zatowa
Posté le 10-07-2017 à 23:27:40  profilanswer
 

ahh, je t'avoue que je n'ai absolument pas fait attention à cela.
 
Je vais faire une clé bootable et réinstaller Windows par la suite, je te tiens au courant.

mood
Publicité
Posté le 10-07-2017 à 23:27:40  profilanswer
 

n°10184450
zatowa
Posté le 11-07-2017 à 03:07:25  profilanswer
 

Bon bah, tu avais raison, lors de mon installation j'ai dû démarrer sur mon lecteur CD en Legacy, ce qui explique que mon disque n'était pas visible en UEFI.
J'ai installé l'ISO de Windows 10 sur une clé et j'ai démarré sur celle-ci en UEFI, maintenant mon SSD NVMe est bien reconnu en UEFI.
 
Merci beaucoup pour ton aide et les informations que tu m'as apportées, c'est un plaisir d'être aidé par des personnes comme toi :)

n°10184474
nono0000
Posté le 11-07-2017 à 08:25:17  profilanswer
 

Bonne nouvelle ;)


---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10212632
ulises3131
Posté le 17-08-2017 à 23:08:08  profilanswer
 

Bonjour,
 
J'ai acheté le disque dur SSD SSD 960 EVO M.2 250GB.
J'ai acheté un adaptateur PCI Express 4x à M Clé M.2 SSD Slot Adaptateur Pour M.2 PCI-E SSD (NGFF) SSD 2230 2242 2260 2280 Carte Touche M PCI-E X4 NG
 
Je possède une carte mère gigabyte x58a-ud4p, sorti il y a bien 7 ans.
 
Le disque dur est reconnu par windows 7 x64 et windows 10 X64 ,quand je boote sur un autre disque dur classique méchanique ,comme disque de stockage mais impossible de lancer windows 7 et windows 10 une fois installés sur le SSD ( j peux les installer surle ssd)  Dans le bios le disque n'est pas reconnu mais il est reconnu par windows pour seulement "stockage".  Je sais que ma carte mère ne possède pas de port M.2, c'est pourquoi j'ai acheté un adaptateur pci dont je vous donne le lien:
 
https://fr.aliexpress.com/item/PCI- [...] 79188.html
 
J'ai tout modifié dansle bios mais le ssd comme système ne fonctionne pas. Windows ne se lance pas, ni 7 ni 10.
Normalement même si la carte mère n'est pas compatible  ( pci 2.0 avec un adaptateur pci  le ssd de samsung devrait être reconnu puis je devrais pouvoir booter sur le ssd.  
 
Quand je suis sur mon disque dur classique avec windows 7 ou 10 , dans gestionnaire de disque , le ssd apparaît.
 
Que puis-je faire?
 
 
Merci

n°10212636
nono0000
Posté le 17-08-2017 à 23:12:00  profilanswer
 

Salut,
 
Non le ssd ne sera pas reconnu par le bios car il utilise le protocole NVME et non AHCI. Le seul moyen de pouvoir booter dessus, serait de modifier le bios pour y injecter un pilote NVME. Cela est très risqué et sans garantie que cela marche au final...


---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10212708
Zonka
x58 forever!
Posté le 18-08-2017 à 01:49:48  profilanswer
 

ulises3131 a écrit :

Je possède une carte mère gigabyte x58a-ud4p, sorti il y a bien 7 ans.
 


 
J'ai un SSD NVMe sur une carte-mère en x58, sur une carte PCI-E 4x, comme toi :
 
- D'une part, ça ne fonctionnera qu'à demi-vitesse (déja pas si mal, certes) par rapport à du PCI-E 3.0 pour lequel c'est prévu (là c'est du 2.0)  
 
- le SSD ne sera utilisable qu'en disque de STOCKAGE (pas de boot possible), avec Windows 10 nativement, ou même windows 7/8.1 si tu peux installer le pilote/hotfix fourni par Microsoft. Je te conseille Win10 sur ce coup là.
 
Je connaissais les contraintes avant d'investir et j'ai essayé de bricoler pour booter dessus = c'est possible mais TRES COMPLIQUE = je passais par un "faux boot" simulant une surcouche UEFI, sur une clé USB = ça marchait, mais temps de boot de 1min30 entre le BIOS et la 2e sequence de boot sur la clé = j'ai arreté les frais.
 
Ces SSD ne fonctionnent "bien" que sur les carte-mères ultra-récentes.


---------------
Feedback - Guide d'achat de config
n°10213476
ulises3131
Posté le 19-08-2017 à 00:33:38  profilanswer
 

merci de vos réponses

n°10213673
ulises3131
Posté le 19-08-2017 à 12:22:07  profilanswer
 

et s'il s'agit d'un disue ssd SSD AHCI, ma carte en est compatible?  fonctionnerai-t-elle?

n°10213681
Zonka
x58 forever!
Posté le 19-08-2017 à 12:32:57  profilanswer
 

ulises3131 a écrit :

et s'il s'agit d'un disue ssd SSD AHCI, ma carte en est compatible?  fonctionnerai-t-elle?


 
Si tu parles toujours de la carte-mère en x58 et d'un SSD SATA en format 2.5' (on ne parle plus de M2), oui c'est parfaitement compatible, mais tu seras limité en SATA2 (environ 250 Mo/sec) au lieu du SATA3 (environ 500 Mo/sec) ce qui ne fait aucune différence à l'usage pratique.
 
Tu peux éventuellement acheter une (bonne) carte SATA3 en PCI-E, ça peut être bootable (j'en ai une sur x58 :p) mais ça coute 70-80 euro et ça n'apporte rien de plus au final à part la satisfaction d'avoir essayé de s'en sortir :)
 
=> un SSD 2.5' branché sur les ports SATA2 Intel de ta CM x58, bootable et fonctionnel sans souci.


---------------
Feedback - Guide d'achat de config
n°10213683
nono0000
Posté le 19-08-2017 à 12:35:48  profilanswer
 

Par ssd AHCI, tu entends PCIE AHCI ou Sata AHCI ?
 
Pour le Sata AHCI, il n'y aura aucun problème mais tu ne peux pas le mettre sur un port PCIE.
En fait si mais via un adaptateur un peu spécial que l'on branche sur une prise Sata classique.
http://m.materiel.net/catalogue/ca [...] ata-121138
 
S'il s'agit d'un SSD PCIE AHCI, alors cela va dépendre du niveau de ton UEFI. Mais sur une CM x58 cela risque d'être  une version bêta au mieux et pas sûr que le niveau soit suffisant pour booter sur un périphérique PCIE... A tester.
Peut être que Zonka peut donner des précisions sur x58...


---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10213713
Zonka
x58 forever!
Posté le 19-08-2017 à 13:00:14  profilanswer
 

@Nono0000 : vu le prix des cartes et les perfs, comme je le disais, la solution la plus raisonnable me semble un bête SSD SATA en 2.5' sans s'embêter avec une carte PCI-E SATA3 (qui passe sans souci, c'est une simple carte contrôleur prise en charge par le BIOS)


---------------
Feedback - Guide d'achat de config
n°10213891
ulises3131
Posté le 19-08-2017 à 16:54:03  profilanswer
 

Bonjour,
 
J'ai bien compris ce que vus avez dit et je savais déjà.
 
Je pensais qu'il existaitl a possibilité d'installer un ssd m2 sur une carte mère incompatible m.2 à l'aide d'une carte pci x  nvme( mvne).
 
Cela semble impossible donc ( besoin d'un bios uefi).
 
Après j'ai vu que ma carte mère  étant compatible ACHI dans le bios, il y a des ssd  à la norme ACHI ( samsung) .
 
 
La solution comme vous dites,  une carte pci E avec du sata 6 sur laquelle on ajute un ssd.  J'ai la fameuse asus U3S6 sauf que cette carte est bridée à 1x  et non pas 4x, la honte.

n°10213898
ulises3131
Posté le 19-08-2017 à 17:06:18  profilanswer
 

il faut que je trouve une carte pci avec un ou deux ports sata 6 pour lui brancher un ssd mais est-ce que je peux trouver ce pci car ce n'est pas donné en prix ? merci

n°10213912
Zonka
x58 forever!
Posté le 19-08-2017 à 17:19:38  profilanswer
 

Si tu as compris ce qui a été expliqué : POURQUOI NE PAS SIMPLEMENT BRANCHER UN SSD 2.5' SATA sur LES PORTS SATA2 DE LA CARTE MERE?
 
Si tu tiens absolument à une carte PCI-E, j'ai celle-ci qui marche très bien.... https://www.amazon.fr/gp/product/B00B2N0AU4 ; c'est une PCI-E x2, c'est suffisant pour 1 voire 2 SSD en bande passante. Mais tu ne verras pas la différence à l'usage, comme déja dit x fois.
 
j'ai aussi une Asus U3S6, c'est vraiment une carte 2x mais le souci est le contrôleur, pas seulement le câblage.


---------------
Feedback - Guide d'achat de config
n°10213916
ulises3131
Posté le 19-08-2017 à 17:24:34  profilanswer
 

parce que sur un sata 2, on est limité en vitesse ,non,? si le ssd tourne en écriture/lecture 400/500, on est bridé, non? merci

n°10213920
Zonka
x58 forever!
Posté le 19-08-2017 à 17:32:28  profilanswer
 


Citation :


Si tu parles toujours de la carte-mère en x58 et d'un SSD SATA en format 2.5' (on ne parle plus de M2), oui c'est parfaitement compatible, mais tu seras limité en SATA2 (environ 250 Mo/sec) au lieu du SATA3 (environ 500 Mo/sec) ce qui ne fait aucune différence à l'usage pratique.
 


 
Bridé au kikimeter, pas bridé en utilisation réelle.


---------------
Feedback - Guide d'achat de config
n°10214073
ulises3131
Posté le 19-08-2017 à 21:24:42  profilanswer
 

entendu......
 
merci
 
Je viens de faire la demande  du renvoi du ssd samsung 960evo. Je vais voir ce queje trouve en ssd classique en 512 voir 1To mais jepense qu'un 512 c'est suffisant. Après je lui ajoute un 4to classiqueour du stockage

n°10214298
ulises3131
Posté le 20-08-2017 à 11:56:51  profilanswer
 

Une dernière question. L'idée c'est de partitionner le ssd . Une partition de 100go pour le système et le reste pour du stockage et traitement. Par exemple lorsque j'utilise dxo pour traiter les photos, cela me permet de les traiter plus vite en les passant d'abord dur la deuxième parition du ssd lors du traitement, puis tranquillement sur un disque dur classique pour les conserver.  
 
Soir je prends un samsung 850 evo ou bien un raid 0 pour augmenter la vitesse de compression et décompression des fichiers que j'utilise beaucoup, traitement photo, etc.     un bien 2X ssd 256 ou 1 seul 512.
 

n°10214342
nono0000
Posté le 20-08-2017 à 12:52:37  profilanswer
 

Je te recommande un seul disque.
Avec un raid 0 semi hw du chipset x58, il y a de grandes chances que le trim ne marche pas.
Il faut mettre un bios modifié avec le support du trim pour l'Orom.
 
En raid SW sous windows je ne sais pas si le trim marche...


---------------
CPU: 5960X 4.4Ghz (Uncore: 4.0Ghz) WC HM -- Mem: 4x4Go 3200Mhz 15-16-16-32-2T -- Mobo: Asus X99 Deluxe -- GPU: 1080Ti (GPU: 2000Mhz, VRAM: 5900Mhz) -- Carte Son: X-Fi Titanium Fatal1ty Professional -- SSD: M.2 PCIE XP941 -- Ecran: Asus ROG Swift PG278Q
n°10214401
Zonka
x58 forever!
Posté le 20-08-2017 à 14:04:37  profilanswer
 

Sur l'ICH Intel, le trim ne fonctionnera effectivement pas en raid

 

Maintenant qu'on comprend mieux la problématique (besoin de gros débits pour données lourdes), la question de la carte PCI-E peut se discuter.

 

Tu peux aussi simplement avoir un SSD de 250 Go pour l'OS sur port SATA 2 Intel, et garder la carte PCI-E M2 pour le SSD NVMe juste pour stockage/tampon/manipulation de données.


Message édité par Zonka le 20-08-2017 à 14:13:38

---------------
Feedback - Guide d'achat de config
n°10214761
ulises3131
Posté le 20-08-2017 à 22:23:15  profilanswer
 

Je pense qu'un 250go ssd c'est suffisant pour le système, en effet. Unn mvme pour du stockage c'est vraiment trop cher pour seulement du stockage.  
 
Avec la différence de prix entre un ssd 250 et 500 je peux me prendre un disque dur classique externe de presque 3to .
  Puis j'ai trouvé une carte pci  X1 avec 2 ports sata 6 pour 7€

n°10214772
Zonka
x58 forever!
Posté le 20-08-2017 à 22:34:05  profilanswer
 

ulises3131 a écrit :

 Puis j'ai trouvé une carte pci  X1 avec 2 ports sata 6 pour 7€


 
Ca tiendra à peine un seul SSD à débit maximal ; pas cher, mais perfs probablement pas terribles ; ça se tente pour le prix.
 
Quand je parle de "stockage" pour le NVMe, c'est plus dans l'idée "workspace", si tu utilises des fichiers très lourds, un NVMe sur une carte PCI-E 4x même 2.0 peut faire une différence par rapport à un SSD en SATA3.
 
Tu as les différents éléments, fais nous un retour quand tu auras testé le matériel que tu auras choisi ;)


---------------
Feedback - Guide d'achat de config
n°10215135
ulises3131
Posté le 21-08-2017 à 10:59:10  profilanswer
 

'avais compris pour le "workspace". Je vous dirai quoi  mais pas avant, je pense, un mois.  Le temps queje commande le tout.    merci

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Disque SSD

  [Résolu] Booter sur un SSD NVMe

 

Sujets relatifs
Clonage SSD vers RAID1 - Journal applications saturé ?[SSD] Oui, un SSD M2 NVME ne vaut pas le coup en upgrade d'un SSD SATA
SSD M.2 sur Asus Z170 DeluxeSSD et/ou HDD
SSD M2 - Mémoire virtuellePin SSD cassé
SSD tueur de Carte mère ?Demande d’aide pour installation M2 NVMe
[HFR] Actu : Apacer lance un SSD au design... original ! 
Plus de sujets relatifs à : [Résolu] Booter sur un SSD NVMe



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR