Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide Recherche
2796 connectés 

  FORUM HardWare.fr
  Hardware
  Disque dur

  Disque SATA plus lent en AHCI !?

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Disque SATA plus lent en AHCI !?

n°6559860
zezette
"Allez hop, au revoir"
Posté le 25-08-2008 à 11:42:50  profilanswer
 

Bonsoir à tous,
 
J'ai une carte mère Gigabyte GA-P35-S3 et en disque dur en SATA. En XP, le mode AHCI était désactivé dans le bios. Comme j'ai voulu (re)tenter Vista, j'ai activé AHCI et lancé l'installation. Après 3 heures, la 2e étape (décompression) en était seulement à 60% ! J'ai réessayé plusieurs fois et c'était toujours pareil... J'ai arreté et tout recommencé en désactivant l'AHCI et là, après 1/2h, l'installation était terminée... En mode AHCI, ce n'est pas censé être plus rapide ?
 


---------------
"Par moment j'me d'mande si chui pas con" G. de Suresnes
mood
Publicité
Posté le 25-08-2008 à 11:42:50  profilanswer
 

n°6559877
ph75
Posté le 25-08-2008 à 11:52:55  profilanswer
 

L'activation du AHCI amène le NCQ qui n' "accélère" qu'en cas de multi-accès au disque (donc pas lors de l'installe)  
Sinon même préco que pour tout, il faut utiliser un driver pas trop vieux lors de l'installe j'imagine ...

n°6559911
freduche
Posté le 25-08-2008 à 12:22:20  profilanswer
 

En ce qui me concerne, ASUS P5K Premium + XP sp2.
Passage en mode AHCI m'a fait stabiliser mon débit, plus soutenue et continue.

 

Je met au passage la procédure pour passer du mode non AHCI à celui-ci (c'est possible !)

 
Citation :

J'ai proceder de la façon suivante: (sur XP, Vista je sais pas, je ne connais pas encore cet OS)
 
1: télécharger la dernère version des Drivers Intel Matrix Storage Manager ICH7ICH8ICH9 version 7.6.0.1011 WHQL chez Intel, récuperer les drivers AHCI de l'executable téléchargé, les stocker dans un répertoire que vous créerez "ahci".
 
2: Aller dans le gestionnaire de périphériques / contrôleurs ATA/ATAPI/IDE, double-cliquer sur Intel(R) port Serial ATA Storage Controller / mettre à jour le pilote / installer à partir d'une liste / suivant / "je vais choisir le pilote à installer" / disque fourni / parcourir > C:\ ahci \ driver \ cliquer sur "iaahci.inf" et dans la liste, sélectionner "Intel(R) ICH9 SATA AHCI Controller"  >> valider,  
   
Puis très important: rebooter, passer par le bios pour mettre le contrôleur SATA sur AHCI (si on le laisse sur IDE, c'est le crash assuré au boot), rebooter > une fois sous Windows, le pilote souhaité se chargera automatiquement et demandera un reboot pour finaliser l'installation.  


Message édité par freduche le 25-08-2008 à 12:24:25
n°6585854
zezette
"Allez hop, au revoir"
Posté le 08-09-2008 à 22:48:05  profilanswer
 

Bon ben tout cela ne m'aide guère... Le AHCI est pris en charge directement par Vista donc pas besoin de trafiquer comme ci-dessus (meme avec des drivers récents). Mon probleme c'est qu'en AHCI, c'est 20 fois plus lent (sans exagérer) que sans... alors que ça devrait être plus rapide...


---------------
"Par moment j'me d'mande si chui pas con" G. de Suresnes
n°6585868
Profil sup​primé
Posté le 08-09-2008 à 22:53:08  answer
 

Salut,  
 
Ton lecteur CD aussi est S-ATA ?
 
As-tu un périphérique IDE de branché dans ta tour ?

n°6585880
zezette
"Allez hop, au revoir"
Posté le 08-09-2008 à 22:56:50  profilanswer
 

Tout est en SATA : HDD, DVD et graveur (mais je n'en suis plus à la phase installation; j'ai installé en mode IDE et j'ai mis a jour les driver et rebooté en mode AHCI pour me rendre compte que c'était toujours aussi lent (comme expliqué par freduche ; ca marche aussi avec Vista))


---------------
"Par moment j'me d'mande si chui pas con" G. de Suresnes
n°6585899
Profil sup​primé
Posté le 08-09-2008 à 23:02:57  answer
 

zezette a écrit :

Tout est en SATA : HDD, DVD et graveur (mais je n'en suis plus à la phase installation; j'ai installé en mode IDE et j'ai mis a jour les driver et rebooté en mode AHCI pour me rendre compte que c'était toujours aussi lent (comme expliqué par freduche ; ca marche aussi avec Vista))


 
Essai de désactiver complètement le contrôleur IDE dans le BIOS, sur une carte mère, ça à fonctionner pour moi (avant l'installation de windows).
 
Sinon voir ici :  
 
http://fr.wikipedia.org/wiki/Advan [...] _Interface
 

Citation :

Activer l'AHCI dans le BIOS sur un système où Windows Vista est déjà installé provoque un écran bleu de la mort si le disque dur SATA a été utilisé en mode IDE pendant l'installation de Vista. Avant d'activer l'AHCI dans le BIOS, les utilisateurs doivent d'abord suivre les instructions situées ici : Microsoft Knowledge Base article 922976


 
http://support.microsoft.com/kb/922976


Message édité par Profil supprimé le 08-09-2008 à 23:04:53
n°6607578
killerboxe​r
Posté le 22-09-2008 à 16:55:45  profilanswer
 

Je suis dans ton cas aussi zezette, j'avais mon disque en SATA (un Raptor 150 pour etre précis). J'ai voulu activer le AHCI, pour voir si je pouvais gagner du temps.
La réponse est non.
Pas de gain au démarrage d'XP, et encore moins à la copie de fichiers. J'ai effectué un test sur un mélange de documents divers de 1Ko à 200Mo, et je faisait le tout en 3min avec le disque en SATA normal, et maintenant en AHCI, je le fais en 3min42, j'ai essayé de recréer les memes conditions (juste après le démarrage de la machine) et le même type de déplacement (couper-coller) d'un dossier à un autre sur la même partition...
 
Ce serait bien de savoir si c'est le cas pour d'autres personnes (si le AHCI ralentit vraiment les perfs). D'autant plus que je n'ai absloument pas gagné en bruit de grattage mais bon fallait pas s'attendre à un miracle non plus ^^

n°6607598
ph75
Posté le 22-09-2008 à 17:06:53  profilanswer
 

killerboxer a écrit :

Je suis dans ton cas aussi zezette, j'avais mon disque en SATA (un Raptor 150 pour etre précis). J'ai voulu activer le AHCI, pour voir si je pouvais gagner du temps.
La réponse est non.

Encore une fois, le NCQ est conçu pour optimiser les accès concurrents à un même disques, donc ce sont des conditions très particulières que l'on rencontre finalement assez rarement sur un PC personnel.
Cela n'accélérera certainement pas une simple copie de fichiers. Il faudrait lancer simultanément plusieurs copies de fichiers pour espérer voir une différence.

n°6607929
killerboxe​r
Posté le 22-09-2008 à 19:53:30  profilanswer
 

hmm, je pense voir ce que tu veux dire, et j'avais mal interprété les accès conccurents... en gros tu veux dire une fois qu'on a saturé la pile de requêtes pour accéder au disque quand plusieurs personnes accèdent à un disque partagé en réseau par exemple ?
Un OS seul ne peut pas effectuer de requetes concurrentes à priori ?

mood
Publicité
Posté le 22-09-2008 à 19:53:30  profilanswer
 

n°6607943
ph75
Posté le 22-09-2008 à 20:00:17  profilanswer
 

Non, un OS moderne n'a pas en soi de problème pour gérer les accès concurrents, mais le NCQ permet d'optimiser les accès en réordonnant les requêtes, et comme c'est géré par le disque c'est plus efficace car lui seul sait où se trouve la tête de lecture ...

n°6607955
zezette
"Allez hop, au revoir"
Posté le 22-09-2008 à 20:03:41  profilanswer
 

J'ai trouvé d'où venait le problème... Apparemment c'est le disque dur qui n'aimait pas trop le mode AHCI (un Maxtor DiamondMax 10). J'ai maintenant un Seagate 7200.11 et ça fonctionne très bien...


---------------
"Par moment j'me d'mande si chui pas con" G. de Suresnes
n°6619694
morgani
Posté le 30-09-2008 à 09:22:22  profilanswer
 

Bonjour.
 
Je souhaite activer le ncq sur mon ordi mais je n'arrive aps à trouver els drivers nécessaire, j'ai un chipset G33, à chaque fois que je télécharge un drivers il me dit que le systéme n'est pas supporté.
 
Je suis sous XP
 
C'est bon j'ai réussis avec ce tuto: http://www.tt-hardware.com/modules [...] &sid=11513
 
@++


Message édité par morgani le 30-09-2008 à 10:03:06

---------------
-=Mon topic ventes=-
n°6619911
killerboxe​r
Posté le 30-09-2008 à 12:21:20  profilanswer
 

Oui j'ai suivi ce tuto aussi.
 
Je suis désolé d'insister ph75, mais je veux bien à la limite que ça n'accélère pas une copie... Mais comment ça se fait qu'elle soit ralentie et que, sur certains tests qu'on peut trouver sur le Net, on voit que les débits ne sont plus aussi élevés que sans le AHCI ?  
Au final j'ai du mal à me dire le NCQ c'est bien/c'est pas bien, du moins pour l'utilisation que j'en fais. Je pense que ça ne sert à rien de l'activer, les gains de temps ne sont pas suffisament siginificatifs pour se compliquer la vie...

n°6803764
zezette
"Allez hop, au revoir"
Posté le 19-01-2009 à 22:31:56  profilanswer
 

Quand j'ai dit que ca fonctionnait très bien, j'ai parlé un peu vite, j'ai des tas de problèmes avec le lecteur DVD et le graveur...


---------------
"Par moment j'me d'mande si chui pas con" G. de Suresnes

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Disque dur

  Disque SATA plus lent en AHCI !?

 

Sujets relatifs
Erreur sur disque dur :/Disque non reconnue suite a un scandisk
Disque dur illisibleDisque dur Samsung SATA 2
Port USB beaucoup trop lent ASUS P5B-EplusDisque dur non détecté lors du boot mais détecté dans le bios
Espace disque restant bizarre...Récupérer les données de mon disque dur
Disque dur Samsung neuf fait des bruit bizare 
Plus de sujets relatifs à : Disque SATA plus lent en AHCI !?



Copyright © 1997-2014 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC